From: Steven Rostedt <rostedt@goodmis.org>
To: linux-kernel@vger.kernel.org
Cc: Ingo Molnar <mingo@kernel.org>,
Andrew Morton <akpm@linux-foundation.org>
Subject: [for-next][PATCH 06/30] tracing: Fix TRACING_MAP Kconfig
Date: Wed, 20 Apr 2016 15:29:44 -0400 [thread overview]
Message-ID: <20160420193026.951454203@goodmis.org> (raw)
In-Reply-To: <20160420192938.515326341@goodmis.org>
[-- Attachment #1: 0006-tracing-Fix-TRACING_MAP-Kconfig.patch --]
[-- Type: text/plain, Size: 1989 bytes --]
From: "Steven Rostedt (Red Hat)" <rostedt@goodmis.org>
The config option for TRACING_MAP has "default n", which is not needed
because the default of configs is 'n'.
Also, since the TRACING_MAP has no config prompt, there's no reason to
include "If in doubt, say N" in the help text.
Fixed a typo in the comments of tracing_map.h.
Signed-off-by: Steven Rostedt <rostedt@goodmis.org>
---
kernel/trace/Kconfig | 3 ---
kernel/trace/tracing_map.h | 2 +-
2 files changed, 1 insertion(+), 4 deletions(-)
diff --git a/kernel/trace/Kconfig b/kernel/trace/Kconfig
index 48b732943e0e..d39556fd863a 100644
--- a/kernel/trace/Kconfig
+++ b/kernel/trace/Kconfig
@@ -531,7 +531,6 @@ config MMIOTRACE
config TRACING_MAP
bool
depends on ARCH_HAVE_NMI_SAFE_CMPXCHG
- default n
help
tracing_map is a special-purpose lock-free map for tracing,
separated out as a stand-alone facility in order to allow it
@@ -539,8 +538,6 @@ config TRACING_MAP
generally used outside of that context, and is normally
selected by tracers that use it.
- If in doubt, say N.
-
config MMIOTRACE_TEST
tristate "Test module for mmiotrace"
depends on MMIOTRACE && m
diff --git a/kernel/trace/tracing_map.h b/kernel/trace/tracing_map.h
index 75718255a8ad..1f7eda548787 100644
--- a/kernel/trace/tracing_map.h
+++ b/kernel/trace/tracing_map.h
@@ -46,7 +46,7 @@ typedef int (*tracing_map_cmp_fn_t) (void *val_a, void *val_b);
* That unique element now in the tracing_map_entry's 'val' field is
* an instance of tracing_map_elt, where 'elt' in the latter part of
* that variable name is short for 'element'. The purpose of a
- * tracing_map_elt is to hold values specific to the the particular
+ * tracing_map_elt is to hold values specific to the particular
* 32-bit hashed key it's assocated with. Things such as the unique
* set of aggregated sums associated with the 32-bit hashed key, along
* with a copy of the full key associated with the entry, and which
--
2.8.0.rc3
next prev parent reply other threads:[~2016-04-20 19:36 UTC|newest]
Thread overview: 31+ messages / expand[flat|nested] mbox.gz Atom feed top
2016-04-20 19:29 [for-next][PATCH 00/30] tracing: Add features for event-fork and histograms Steven Rostedt
2016-04-20 19:29 ` [for-next][PATCH 01/30] tracing: Rename check_ignore_pid() to ignore_this_task() Steven Rostedt
2016-04-20 19:29 ` [for-next][PATCH 02/30] tracing: Use pid bitmap instead of a pid array for set_event_pid Steven Rostedt
2016-04-20 19:29 ` [for-next][PATCH 03/30] tracing: Add infrastructure to allow set_event_pid to follow children Steven Rostedt
2016-04-20 19:29 ` [for-next][PATCH 04/30] tracing: Update the documentation to describe "event-fork" option Steven Rostedt
2016-04-20 19:29 ` [for-next][PATCH 05/30] tracing: Add lock-free tracing_map Steven Rostedt
2016-04-20 19:29 ` Steven Rostedt [this message]
2016-04-20 19:29 ` [for-next][PATCH 07/30] tracing: Update some tracing_map constants and comments Steven Rostedt
2016-04-20 19:29 ` [for-next][PATCH 08/30] tracing: Add hist event trigger command Steven Rostedt
2016-04-20 19:29 ` [for-next][PATCH 09/30] tracing: Add hist trigger support for multiple values (vals= param) Steven Rostedt
2016-04-20 19:29 ` [for-next][PATCH 10/30] tracing: Add hist trigger support for compound keys Steven Rostedt
2016-04-20 19:29 ` [for-next][PATCH 11/30] tracing: Add hist trigger support for user-defined sorting (sort= param) Steven Rostedt
2016-04-20 19:29 ` [for-next][PATCH 12/30] tracing: Add hist trigger support for pausing and continuing a trace Steven Rostedt
2016-04-20 19:29 ` [for-next][PATCH 13/30] tracing: Add hist trigger support for clearing " Steven Rostedt
2016-04-20 19:29 ` [for-next][PATCH 14/30] tracing: Add hist trigger hex modifier for displaying numeric fields Steven Rostedt
2016-04-20 19:29 ` [for-next][PATCH 15/30] tracing: Add hist trigger sym and sym-offset modifiers Steven Rostedt
2016-04-20 19:29 ` [for-next][PATCH 16/30] tracing: Add hist trigger execname modifier Steven Rostedt
2016-04-20 19:29 ` [for-next][PATCH 17/30] tracing: Add hist trigger syscall modifier Steven Rostedt
2016-04-20 19:29 ` [for-next][PATCH 18/30] tracing: Add hist trigger support for stacktraces as keys Steven Rostedt
2016-04-20 19:29 ` [for-next][PATCH 19/30] tracing: Support string type key properly Steven Rostedt
2016-04-20 19:29 ` [for-next][PATCH 20/30] tracing: Remove restriction on string position in hist trigger keys Steven Rostedt
2016-04-20 19:29 ` [for-next][PATCH 21/30] tracing: Add enable_hist/disable_hist triggers Steven Rostedt
2016-04-20 19:30 ` [for-next][PATCH 22/30] tracing: Add hist trigger Documentation Steven Rostedt
2016-04-20 19:30 ` [for-next][PATCH 23/30] tracing: Add support for multiple hist triggers per event Steven Rostedt
2016-04-20 19:30 ` [for-next][PATCH 24/30] tracing: Add support for named triggers Steven Rostedt
2016-04-20 19:30 ` [for-next][PATCH 25/30] tracing: Add support for named hist triggers Steven Rostedt
2016-04-20 19:30 ` [for-next][PATCH 26/30] kselftests/ftrace : Add event trigger testcases Steven Rostedt
2016-04-20 19:30 ` [for-next][PATCH 27/30] kselftests/ftrace: Add hist " Steven Rostedt
2016-04-20 19:30 ` [for-next][PATCH 28/30] tracing: Add hist trigger log2 modifier Steven Rostedt
2016-04-20 19:30 ` [for-next][PATCH 29/30] kselftests/ftrace: Add a test for log2 modifier of hist trigger Steven Rostedt
2016-04-20 19:30 ` [for-next][PATCH 30/30] tracing: Fix unsigned comparison to zero in hist trigger code Steven Rostedt
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20160420193026.951454203@goodmis.org \
--to=rostedt@goodmis.org \
--cc=akpm@linux-foundation.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome