mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH 0142/1285] Replace numeric parameter like 0444 with macro
@ 2016-08-02 10:44 Baole Ni
  0 siblings, 0 replies; only message in thread
From: Baole Ni @ 2016-08-02 10:44 UTC (permalink / raw)
  To: mchehab, maurochehab, mchehab, mchehab, m.chehab, dougthompson, bp
  Cc: linux-edac, linux-kernel, chuansheng.liu, baolex.ni, lee.jones

I find that the developers often just specified the numeric value
when calling a macro which is defined with a parameter for access permission.
As we know, these numeric value for access permission have had the corresponding macro,
and that using macro can improve the robustness and readability of the code,
thus, I suggest replacing the numeric parameter with the macro.

Signed-off-by: Chuansheng Liu <chuansheng.liu@intel.com>
Signed-off-by: Baole Ni <baolex.ni@intel.com>
---
 drivers/edac/edac_mc_sysfs.c | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/drivers/edac/edac_mc_sysfs.c b/drivers/edac/edac_mc_sysfs.c
index 10c305b..1603b76 100644
--- a/drivers/edac/edac_mc_sysfs.c
+++ b/drivers/edac/edac_mc_sysfs.c
@@ -74,16 +74,16 @@ static int edac_set_poll_msec(const char *val, struct kernel_param *kp)
 }
 
 /* Parameter declarations for above */
-module_param(edac_mc_panic_on_ue, int, 0644);
+module_param(edac_mc_panic_on_ue, int, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);
 MODULE_PARM_DESC(edac_mc_panic_on_ue, "Panic on uncorrected error: 0=off 1=on");
-module_param(edac_mc_log_ue, int, 0644);
+module_param(edac_mc_log_ue, int, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);
 MODULE_PARM_DESC(edac_mc_log_ue,
 		 "Log uncorrectable error to console: 0=off 1=on");
-module_param(edac_mc_log_ce, int, 0644);
+module_param(edac_mc_log_ce, int, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);
 MODULE_PARM_DESC(edac_mc_log_ce,
 		 "Log correctable error to console: 0=off 1=on");
 module_param_call(edac_mc_poll_msec, edac_set_poll_msec, param_get_int,
-		  &edac_mc_poll_msec, 0644);
+		  &edac_mc_poll_msec, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);
 MODULE_PARM_DESC(edac_mc_poll_msec, "Polling period in milliseconds");
 
 static struct device *mci_pdev;
-- 
2.9.2

^ permalink raw reply	[flat|nested] only message in thread

only message in thread, other threads:[~2016-08-02 11:36 UTC | newest]

Thread overview: (only message) (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2016-08-02 10:44 [PATCH 0142/1285] Replace numeric parameter like 0444 with macro Baole Ni

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®