* [PATCH 1154/1285] Replace numeric parameter like 0444 with macro
@ 2016-08-02 12:21 Baole Ni
0 siblings, 0 replies; only message in thread
From: Baole Ni @ 2016-08-02 12:21 UTC (permalink / raw)
To: perex, tiwai, serge, davem, kadlec, m.szyprowski, kyungmin.park,
k.kozlowski
Cc: alsa-devel, linux-kernel, chuansheng.liu, baolex.ni, aryabinin
I find that the developers often just specified the numeric value
when calling a macro which is defined with a parameter for access permission.
As we know, these numeric value for access permission have had the corresponding macro,
and that using macro can improve the robustness and readability of the code,
thus, I suggest replacing the numeric parameter with the macro.
Signed-off-by: Chuansheng Liu <chuansheng.liu@intel.com>
Signed-off-by: Baole Ni <baolex.ni@intel.com>
---
sound/core/seq/seq_dummy.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/sound/core/seq/seq_dummy.c b/sound/core/seq/seq_dummy.c
index d3a2ec4..1b01fb6 100644
--- a/sound/core/seq/seq_dummy.c
+++ b/sound/core/seq/seq_dummy.c
@@ -67,9 +67,9 @@ MODULE_ALIAS("snd-seq-client-" __stringify(SNDRV_SEQ_CLIENT_DUMMY));
static int ports = 1;
static bool duplex;
-module_param(ports, int, 0444);
+module_param(ports, int, S_IRUSR | S_IRGRP | S_IROTH);
MODULE_PARM_DESC(ports, "number of ports to be created");
-module_param(duplex, bool, 0444);
+module_param(duplex, bool, S_IRUSR | S_IRGRP | S_IROTH);
MODULE_PARM_DESC(duplex, "create DUPLEX ports");
struct snd_seq_dummy_port {
--
2.9.2
^ permalink raw reply [flat|nested] only message in thread
only message in thread, other threads:[~2016-08-02 13:14 UTC | newest]
Thread overview: (only message) (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2016-08-02 12:21 [PATCH 1154/1285] Replace numeric parameter like 0444 with macro Baole Ni
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®