From: Andrew Morton <akpm@linux-foundation.org>
To: Andrey Konovalov <andreyknvl@google.com>
Cc: Dmitry Vyukov <dvyukov@google.com>,
Nicolai Stange <nicstange@gmail.com>,
Andrey Ryabinin <aryabinin@virtuozzo.com>,
Kees Cook <keescook@chromium.org>,
James Morse <james.morse@arm.com>,
linux-kernel@vger.kernel.org, vegard.nossum@oracle.com,
quentin.casasnovas@oracle.com, ryabinin.a.a@gmail.com,
Thomas Gleixner <tglx@linutronix.de>, Ingo Molnar <mingo@elte.hu>,
Peter Zijlstra <a.p.zijlstra@chello.nl>
Subject: Re: [PATCH] kcov: properly check if we are in an interrupt
Date: Mon, 26 Sep 2016 16:32:26 -0700 [thread overview]
Message-ID: <20160926163226.35cc76eb1a06083440cbb86d@linux-foundation.org> (raw)
In-Reply-To: <1474642273-112248-1-git-send-email-andreyknvl@google.com>
On Fri, 23 Sep 2016 16:51:13 +0200 Andrey Konovalov <andreyknvl@google.com> wrote:
> in_interrupt() returns a nonzero value when we are either in an
> interrupt or have bh disabled via local_bh_disable(). Since we are
> interested in only ignoring coverage from actual interrupts, do a
> proper check of whether we are really in an interrupt.
>
> Signed-off-by: Andrey Konovalov <andreyknvl@google.com>
> ---
> It would look totally better to reuse in_irq(), in_serving_softirq() and
> in_nmi() instead of checking flags manually, but that leads to slower
> generated code (three separate tests for each of the flags). Would it be
> better to add another macro to preempt.h that would check if we're actually
> in interrupt and use it?
Yes please. Is there anywhere else where such a macro can be used?
> --- a/kernel/kcov.c
> +++ b/kernel/kcov.c
> @@ -54,7 +54,8 @@ void notrace __sanitizer_cov_trace_pc(void)
> * We are interested in code coverage as a function of a syscall inputs,
> * so we ignore code executed in interrupts.
> */
> - if (!t || in_interrupt())
> + if (!t || (preempt_count() & (HARDIRQ_MASK | SOFTIRQ_OFFSET
> + | NMI_MASK)))
Or include a prominent and very apologetic comment here explaining why
it is open-coded. But I do agree that not open-coding it is better.
next prev parent reply other threads:[~2016-09-26 23:32 UTC|newest]
Thread overview: 9+ messages / expand[flat|nested] mbox.gz Atom feed top
2016-09-23 14:51 Andrey Konovalov
2016-09-26 23:32 ` Andrew Morton [this message]
2016-09-27 6:21 ` Dmitry Vyukov
2016-09-27 7:34 ` Peter Zijlstra
2016-09-27 7:50 ` Dmitry Vyukov
2016-09-27 10:59 ` Peter Zijlstra
2016-09-27 12:32 ` Dmitry Vyukov
2016-09-27 11:20 ` Vegard Nossum
2016-09-27 11:22 ` Vegard Nossum
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20160926163226.35cc76eb1a06083440cbb86d@linux-foundation.org \
--to=akpm@linux-foundation.org \
--cc=a.p.zijlstra@chello.nl \
--cc=andreyknvl@google.com \
--cc=aryabinin@virtuozzo.com \
--cc=dvyukov@google.com \
--cc=james.morse@arm.com \
--cc=keescook@chromium.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@elte.hu \
--cc=nicstange@gmail.com \
--cc=quentin.casasnovas@oracle.com \
--cc=ryabinin.a.a@gmail.com \
--cc=tglx@linutronix.de \
--cc=vegard.nossum@oracle.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®