mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH 00/12] trace: add the ability to parse sizeof()
@ 2017-05-31 21:56 Jeremy Linton
  2017-05-31 21:56 ` [PATCH 01/12] trace: rename kernel enum section to eval Jeremy Linton
                   ` (12 more replies)
  0 siblings, 13 replies; 19+ messages in thread
From: Jeremy Linton @ 2017-05-31 21:56 UTC (permalink / raw)
  To: linux-kernel
  Cc: linux-arch, rostedt, mingo, rusty, jeyu, kirill.shutemov,
	christoffer.dall, marc.zyngier, jcm

There are a few cases of sizeof() embedded in TRACE_EVENT()
macros. That is a problem because the sizeof(structure) gets
passed to userspace which doesn't know how to decode the
size of kernel data structures. This is a similar problem
to enums which were being passed in their symbolic form to
userspace.

Rather than recreating much of that infrastructure lets
simply extend it, and append additional symbols into the
enum_map that can translate string sizeof() calls into
values. Of course that means that much of the infrastructure
is now poorly named so we go through and replace instances
describing "enum" with "eval" to indicate a generic C
expression to numerical evaluation routine.

Jeremy Linton (12):
  trace: rename kernel enum section to eval
  trace: rename trace_enum_map to trace_eval_map
  trace: rename struct module entry for trace enums
  trace: rename trace enum data structures in trace.c
  trace: rename trace_enum_mutex to trace_eval_mutex
  trace: rename trace.c enum functions
  trace: rename enum_map functions
  tracing: Rename enum_replace to eval_replace
  tracing: define TRACE_DEFINE_SIZEOF() macro to map sizeof's to their
    values
  tracing: Update sample file to describe the new macro
  tracing: Add TRACE_DEFINE_SIZEOF() macros
  tracing: Rename update the enum_map file

 arch/arm64/kvm/trace.h                     |   2 +
 include/asm-generic/vmlinux.lds.h          |   6 +-
 include/linux/module.h                     |   4 +-
 include/linux/tracepoint.h                 |   7 +-
 include/trace/events/xen.h                 |  13 +-
 include/trace/trace_events.h               |  26 +++-
 kernel/module.c                            |   6 +-
 kernel/trace/Kconfig                       |  22 ++--
 kernel/trace/trace.c                       | 194 ++++++++++++++---------------
 kernel/trace/trace.h                       |   4 +-
 kernel/trace/trace_events.c                |  24 ++--
 samples/trace_events/trace-events-sample.h |   7 ++
 12 files changed, 175 insertions(+), 140 deletions(-)

-- 
2.9.4

^ permalink raw reply	[flat|nested] 19+ messages in thread

end of thread, other threads:[~2017-06-14 18:43 UTC | newest]

Thread overview: 19+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2017-05-31 21:56 [PATCH 00/12] trace: add the ability to parse sizeof() Jeremy Linton
2017-05-31 21:56 ` [PATCH 01/12] trace: rename kernel enum section to eval Jeremy Linton
2017-05-31 21:56 ` [PATCH 02/12] trace: rename trace_enum_map to trace_eval_map Jeremy Linton
2017-05-31 21:56 ` [PATCH 03/12] trace: rename struct module entry for trace enums Jeremy Linton
2017-05-31 21:56 ` [PATCH 04/12] trace: rename trace enum data structures in trace.c Jeremy Linton
2017-05-31 21:56 ` [PATCH 05/12] trace: rename trace_enum_mutex to trace_eval_mutex Jeremy Linton
2017-05-31 21:56 ` [PATCH 06/12] trace: rename trace.c enum functions Jeremy Linton
2017-05-31 21:56 ` [PATCH 07/12] trace: rename enum_map functions Jeremy Linton
2017-05-31 21:56 ` [PATCH 08/12] tracing: Rename enum_replace to eval_replace Jeremy Linton
2017-05-31 21:56 ` [PATCH 09/12] tracing: define TRACE_DEFINE_SIZEOF() macro to map sizeof's to their values Jeremy Linton
2017-05-31 21:56 ` [PATCH 10/12] tracing: Update sample file to describe the new macro Jeremy Linton
2017-06-13 21:07   ` Steven Rostedt
2017-05-31 21:56 ` [PATCH 11/12] tracing: Add TRACE_DEFINE_SIZEOF() macros Jeremy Linton
2017-05-31 21:56 ` [PATCH 12/12] tracing: Rename update the enum_map file Jeremy Linton
2017-06-13 21:12   ` Steven Rostedt
2017-06-13 21:21     ` Jeremy Linton
2017-06-14 17:06       ` Steven Rostedt
2017-06-14 18:43         ` Jeremy Linton
2017-06-01  1:11 ` [PATCH 00/12] trace: add the ability to parse sizeof() Steven Rostedt

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®