From: Matthias Kaehlcke <mka@chromium.org>
To: Masahiro Yamada <yamada.masahiro@socionext.com>
Cc: Arnd Bergmann <arnd@arndb.de>, Michal Marek <mmarek@suse.com>,
Thomas Gleixner <tglx@linutronix.de>,
Ingo Molnar <mingo@redhat.com>, "H . Peter Anvin" <hpa@zytor.com>,
"H . J . Lu" <hjl.tools@gmail.com>,
David Woodhouse <dwmw2@infradead.org>,
the arch/x86 maintainers <x86@kernel.org>,
Linux Kbuild mailing list <linux-kbuild@vger.kernel.org>,
Linux Kernel Mailing List <linux-kernel@vger.kernel.org>,
Michael Davidson <md@google.com>,
Greg Hackmann <ghackmann@google.com>,
Nick Desaulniers <ndesaulniers@google.com>,
Stephen Hines <srhines@google.com>,
Kees Cook <keescook@chromium.org>,
Bernhard.Rosenkranzer@linaro.org,
Peter Foley <pefoley2@pefoley.com>,
Behan Webster <behanw@converseincode.com>,
Douglas Anderson <dianders@chromium.org>
Subject: Re: [PATCH 1/3] kbuild: Add cc-option-no-kbuild macro
Date: Tue, 13 Jun 2017 09:45:52 -0700 [thread overview]
Message-ID: <20170613164552.GK141096@google.com> (raw)
In-Reply-To: <CAK7LNARhhp2cJw=yxJTdB0_Cs4mBkkeHmNp7B9RYne92WXBQyw@mail.gmail.com>
El Tue, Jun 13, 2017 at 07:13:55PM +0900 Masahiro Yamada ha dit:
> 2017-06-13 17:31 GMT+09:00 Arnd Bergmann <arnd@arndb.de>:
> > On Tue, Jun 13, 2017 at 9:49 AM, Michal Marek <mmarek@suse.com> wrote:
> >> On 2017-06-13 02:55, Matthias Kaehlcke wrote:
> >>> cc-option uses KBUILD_CFLAGS and KBUILD_CPPFLAGS when it determines
> >>> whether an option is supported or not. This is fine for options used to
> >>> build the kernel itself, however some components like the x86 boot code
> >>> use a different set of flags.
> >>>
> >>> Add the new macro cc-option-no-kbuild which does the same as cc-option
> >>> except that it has an additional parameter with the compiler options
> >>> which are used instead of KBUILD_CFLAGS and KBUILD_CPPFLAGS.
> >>>
> >>> Signed-off-by: Matthias Kaehlcke <mka@chromium.org>
> >>> ---
> >>> scripts/Kbuild.include | 5 +++++
> >>> 1 file changed, 5 insertions(+)
> >>>
> >>> diff --git a/scripts/Kbuild.include b/scripts/Kbuild.include
> >>> index 61f87a99bf0a..d9fdc740105f 100644
> >>> --- a/scripts/Kbuild.include
> >>> +++ b/scripts/Kbuild.include
> >>> @@ -128,6 +128,11 @@ cc-option-yn = $(call try-run,\
> >>> cc-option-align = $(subst -functions=0,,\
> >>> $(call cc-option,-falign-functions=0,-malign-functions=0))
> >>>
> >>> +# cc-option-no-kbuild
> >>> +# Usage: cflags-no-kbuild-y += $(call cc-option-no-kbuild,<other flags>,-march=winchip-c6,-march=i586)
> >>> +cc-option-no-kbuild = $(call try-run,\
> >>> + $(CC) -Werror $(filter-out $(GCC_PLUGINS_CFLAGS),$(1)) $(2) -c -x c /dev/null -o "$$TMP",$(2),$(3))
> >>
> >> As this is a version of cc-option with an extrra argument, how about
> >> implementing cc-option as a shorthand for cc-option-no-kbuild? It would
> >> make it more obvious what cc-option-no-kbuild does differently (it's
> >> probably just me, but I was unable to infer the semantics from its name).
> >
> > Agreed, also the hostcc-option could be based on the same I think, if we
> > also make the $(CC) an argument of the low-level helper.
> >
>
> Agree. One possible implementation:
>
> cc-option-raw = $(call try-run,\
> $(1) -Werror $(2) $(3) -c -x c /dev/null -o "$$TMP",$(3),$(4))
>
> cc-option = $(call cc-option-raw, $(CC), $(KBUILD_CPPFLAGS)
> $(CC_OPTION_CFLAGS),\
> $(1), $(2))
>
> This will allow us to do:
> hostcc-option = $(call cc-option-raw, $(HOSTCC), $(HOSTCFLAGS), $(1), $(2))
Looks good, thanks all for the suggestions.
> Suggestion for a better name is welcome...
Yeah, this tends to be the difficult part, I didn't like
the initial 'cc-option-no-kbuild' either ... 'cc-option-raw' seems
ok if nothing better pops up.
next prev parent reply other threads:[~2017-06-13 16:45 UTC|newest]
Thread overview: 11+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-06-13 0:55 [PATCH 0/3] x86: stack alignment for boot code and clang Matthias Kaehlcke
2017-06-13 0:55 ` [PATCH 1/3] kbuild: Add cc-option-no-kbuild macro Matthias Kaehlcke
2017-06-13 7:49 ` Michal Marek
2017-06-13 8:31 ` Arnd Bergmann
2017-06-13 10:13 ` Masahiro Yamada
2017-06-13 16:45 ` Matthias Kaehlcke [this message]
2017-06-13 0:55 ` [PATCH 2/3] x86/build: Use cc-option-no-kbuild for boot code compiler options Matthias Kaehlcke
2017-06-13 0:55 ` [PATCH 3/3] x86/build: Specify stack alignment for clang Matthias Kaehlcke
2017-06-13 6:38 ` Ingo Molnar
2017-06-13 17:25 ` Matthias Kaehlcke
2017-06-13 6:39 ` [PATCH 0/3] x86: stack alignment for boot code and clang Ingo Molnar
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20170613164552.GK141096@google.com \
--to=mka@chromium.org \
--cc=Bernhard.Rosenkranzer@linaro.org \
--cc=arnd@arndb.de \
--cc=behanw@converseincode.com \
--cc=dianders@chromium.org \
--cc=dwmw2@infradead.org \
--cc=ghackmann@google.com \
--cc=hjl.tools@gmail.com \
--cc=hpa@zytor.com \
--cc=keescook@chromium.org \
--cc=linux-kbuild@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=md@google.com \
--cc=mingo@redhat.com \
--cc=mmarek@suse.com \
--cc=ndesaulniers@google.com \
--cc=pefoley2@pefoley.com \
--cc=srhines@google.com \
--cc=tglx@linutronix.de \
--cc=x86@kernel.org \
--cc=yamada.masahiro@socionext.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome