mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Ingo Molnar <mingo@kernel.org>
To: Andi Kleen <andi@firstfloor.org>
Cc: x86@kernel.org, linux-kernel@vger.kernel.org,
	Andi Kleen <ak@linux.intel.com>,
	Thomas Gleixner <tglx@linutronix.de>
Subject: Re: [PATCH v9 3/5] x86/cpuid: Make clearcpuid an early param
Date: Thu, 12 Oct 2017 10:09:14 +0200	[thread overview]
Message-ID: <20171012080913.g2z6uxtoyqvfbdaz@gmail.com> (raw)
In-Reply-To: <20171007000328.12843-4-andi@firstfloor.org>


* Andi Kleen <andi@firstfloor.org> wrote:

> From: Andi Kleen <ak@linux.intel.com>
> 
> Make clearcpuid= an early param, to make sure it is parsed
> before the XSAVE initialization. This allows to modify
> XSAVE state by clearing specific CPUID bits.
> 
> Reviewed-by: Thomas Gleixner <tglx@linutronix.de>
> Signed-off-by: Andi Kleen <ak@linux.intel.com>
> ---
>  arch/x86/kernel/cpu/common.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/arch/x86/kernel/cpu/common.c b/arch/x86/kernel/cpu/common.c
> index fd47692e5ce9..ff51c61d2df0 100644
> --- a/arch/x86/kernel/cpu/common.c
> +++ b/arch/x86/kernel/cpu/common.c
> @@ -1310,7 +1310,7 @@ static __init int setup_disablecpuid(char *arg)
>  
>  	return 1;
>  }
> -__setup("clearcpuid=", setup_disablecpuid);
> +early_param("clearcpuid", setup_disablecpuid);

Yeah, so there's pre-existing bad naming here that should be fixed before we add 
new complexity to the code: why is the option named 'clearcpuid' while the 
function name is 'disablecpuid'?

Thanks,

	Ingo

  reply	other threads:[~2017-10-12  8:09 UTC|newest]

Thread overview: 20+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2017-10-07  0:03 Support generic disabling of all XSAVE features Andi Kleen
2017-10-07  0:03 ` [PATCH v9 1/5] x86/xsave: Move xsave initialization to after parsing early parameters Andi Kleen
2017-10-12  7:18   ` Ingo Molnar
2017-10-07  0:03 ` [PATCH v9 2/5] x86/cpuid: Add generic table for cpuid dependencies Andi Kleen
2017-10-08  8:35   ` Thomas Gleixner
2017-10-12  8:07   ` Ingo Molnar
2017-10-12  8:16     ` Ingo Molnar
2017-10-13 17:46       ` Andi Kleen
2017-10-12 15:13     ` Thomas Gleixner
2017-10-12 22:01       ` Andi Kleen
2017-10-13  5:30       ` Ingo Molnar
2017-10-13 16:36         ` Andi Kleen
2017-10-12 22:12     ` Andi Kleen
2017-10-07  0:03 ` [PATCH v9 3/5] x86/cpuid: Make clearcpuid an early param Andi Kleen
2017-10-12  8:09   ` Ingo Molnar [this message]
2017-10-07  0:03 ` [PATCH v9 4/5] x86/xsave: Make XSAVE check the base CPUID features before enabling Andi Kleen
2017-10-08  8:34   ` Thomas Gleixner
2017-10-12  8:11   ` Ingo Molnar
2017-10-13 17:48     ` Andi Kleen
2017-10-07  0:03 ` [PATCH v9 5/5] x86/xsave: Remove the explicit clearing of XSAVE dependend features Andi Kleen

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20171012080913.g2z6uxtoyqvfbdaz@gmail.com \
    --to=mingo@kernel.org \
    --cc=ak@linux.intel.com \
    --cc=andi@firstfloor.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=tglx@linutronix.de \
    --cc=x86@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome