mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH 1/3] net: core: export dev_alloc_name_ns
@ 2017-11-21  0:34 Rasmus Villemoes
  2017-11-21  0:34 ` [PATCH 2/3] net: use dev_alloc_name_ns instead of dev_get_valid_name Rasmus Villemoes
                   ` (2 more replies)
  0 siblings, 3 replies; 4+ messages in thread
From: Rasmus Villemoes @ 2017-11-21  0:34 UTC (permalink / raw)
  To: David S. Miller; +Cc: Rasmus Villemoes, netdev, linux-kernel

dev_alloc_name_ns and dev_get_valid_name now do exactly the same
thing. Let's expose this functionality as dev_alloc_name_ns
(obviously, a core function like this won't return an invalid
name...).

Signed-off-by: Rasmus Villemoes <linux@rasmusvillemoes.dk>
---
 include/linux/netdevice.h | 1 +
 net/core/dev.c            | 7 ++++---
 2 files changed, 5 insertions(+), 3 deletions(-)

diff --git a/include/linux/netdevice.h b/include/linux/netdevice.h
index 6b274bfe489f..e249d3d0ff85 100644
--- a/include/linux/netdevice.h
+++ b/include/linux/netdevice.h
@@ -2447,6 +2447,7 @@ struct net_device *dev_get_by_name(struct net *net, const char *name);
 struct net_device *dev_get_by_name_rcu(struct net *net, const char *name);
 struct net_device *__dev_get_by_name(struct net *net, const char *name);
 int dev_alloc_name(struct net_device *dev, const char *name);
+int dev_alloc_name_ns(struct net *net, struct net_device *dev, const char *name);
 int dev_open(struct net_device *dev);
 void dev_close(struct net_device *dev);
 void dev_close_many(struct list_head *head, bool unlink);
diff --git a/net/core/dev.c b/net/core/dev.c
index 8ee29f4f5fa9..9575e7329823 100644
--- a/net/core/dev.c
+++ b/net/core/dev.c
@@ -1109,9 +1109,9 @@ static int __dev_alloc_name(struct net *net, const char *name, char *buf)
 	return p ? -ENFILE : -EEXIST;
 }
 
-static int dev_alloc_name_ns(struct net *net,
-			     struct net_device *dev,
-			     const char *name)
+int dev_alloc_name_ns(struct net *net,
+		      struct net_device *dev,
+		      const char *name)
 {
 	char buf[IFNAMSIZ];
 	int ret;
@@ -1122,6 +1122,7 @@ static int dev_alloc_name_ns(struct net *net,
 		strlcpy(dev->name, buf, IFNAMSIZ);
 	return ret;
 }
+EXPORT_SYMBOL(dev_alloc_name_ns);
 
 /**
  *	dev_alloc_name - allocate a name for a device
-- 
2.11.0

^ permalink raw reply	[flat|nested] 4+ messages in thread

* [PATCH 2/3] net: use dev_alloc_name_ns instead of dev_get_valid_name
  2017-11-21  0:34 [PATCH 1/3] net: core: export dev_alloc_name_ns Rasmus Villemoes
@ 2017-11-21  0:34 ` Rasmus Villemoes
  2017-11-21  0:34 ` [PATCH 3/3] net: core: remove dev_get_valid_name Rasmus Villemoes
  2017-11-24 20:11 ` [PATCH 1/3] net: core: export dev_alloc_name_ns David Miller
  2 siblings, 0 replies; 4+ messages in thread
From: Rasmus Villemoes @ 2017-11-21  0:34 UTC (permalink / raw)
  To: David S. Miller; +Cc: Rasmus Villemoes, netdev, linux-kernel

The latter is simply a wrapper for the former; no need to keep both, so
call dev_alloc_name_ns directly.

Signed-off-by: Rasmus Villemoes <linux@rasmusvillemoes.dk>
---
 drivers/net/tun.c | 2 +-
 net/core/dev.c    | 6 +++---
 2 files changed, 4 insertions(+), 4 deletions(-)

diff --git a/drivers/net/tun.c b/drivers/net/tun.c
index 6bb1e604aadd..849a95505f80 100644
--- a/drivers/net/tun.c
+++ b/drivers/net/tun.c
@@ -2253,7 +2253,7 @@ static int tun_set_iff(struct net *net, struct file *file, struct ifreq *ifr)
 
 		if (!dev)
 			return -ENOMEM;
-		err = dev_get_valid_name(net, dev, name);
+		err = dev_alloc_name_ns(net, dev, name);
 		if (err < 0)
 			goto err_free_dev;
 
diff --git a/net/core/dev.c b/net/core/dev.c
index 9575e7329823..0de42f39d280 100644
--- a/net/core/dev.c
+++ b/net/core/dev.c
@@ -1183,7 +1183,7 @@ int dev_change_name(struct net_device *dev, const char *newname)
 
 	memcpy(oldname, dev->name, IFNAMSIZ);
 
-	err = dev_get_valid_name(net, dev, newname);
+	err = dev_alloc_name_ns(net, dev, newname);
 	if (err < 0) {
 		write_seqcount_end(&devnet_rename_seq);
 		return err;
@@ -7615,7 +7615,7 @@ int register_netdevice(struct net_device *dev)
 	spin_lock_init(&dev->addr_list_lock);
 	netdev_set_addr_lockdep_class(dev);
 
-	ret = dev_get_valid_name(net, dev, dev->name);
+	ret = dev_alloc_name_ns(net, dev, dev->name);
 	if (ret < 0)
 		goto out;
 
@@ -8354,7 +8354,7 @@ int dev_change_net_namespace(struct net_device *dev, struct net *net, const char
 		/* We get here if we can't use the current device name */
 		if (!pat)
 			goto out;
-		if (dev_get_valid_name(net, dev, pat) < 0)
+		if (dev_alloc_name_ns(net, dev, pat) < 0)
 			goto out;
 	}
 
-- 
2.11.0

^ permalink raw reply	[flat|nested] 4+ messages in thread

* [PATCH 3/3] net: core: remove dev_get_valid_name
  2017-11-21  0:34 [PATCH 1/3] net: core: export dev_alloc_name_ns Rasmus Villemoes
  2017-11-21  0:34 ` [PATCH 2/3] net: use dev_alloc_name_ns instead of dev_get_valid_name Rasmus Villemoes
@ 2017-11-21  0:34 ` Rasmus Villemoes
  2017-11-24 20:11 ` [PATCH 1/3] net: core: export dev_alloc_name_ns David Miller
  2 siblings, 0 replies; 4+ messages in thread
From: Rasmus Villemoes @ 2017-11-21  0:34 UTC (permalink / raw)
  To: David S. Miller; +Cc: Rasmus Villemoes, netdev, linux-kernel

No users left.

Signed-off-by: Rasmus Villemoes <linux@rasmusvillemoes.dk>
---
 include/linux/netdevice.h | 2 --
 net/core/dev.c            | 7 -------
 2 files changed, 9 deletions(-)

diff --git a/include/linux/netdevice.h b/include/linux/netdevice.h
index e249d3d0ff85..7b057ef42906 100644
--- a/include/linux/netdevice.h
+++ b/include/linux/netdevice.h
@@ -3732,8 +3732,6 @@ struct net_device *alloc_netdev_mqs(int sizeof_priv, const char *name,
 				    unsigned char name_assign_type,
 				    void (*setup)(struct net_device *),
 				    unsigned int txqs, unsigned int rxqs);
-int dev_get_valid_name(struct net *net, struct net_device *dev,
-		       const char *name);
 
 #define alloc_netdev(sizeof_priv, name, name_assign_type, setup) \
 	alloc_netdev_mqs(sizeof_priv, name, name_assign_type, setup, 1, 1)
diff --git a/net/core/dev.c b/net/core/dev.c
index 0de42f39d280..405598c27195 100644
--- a/net/core/dev.c
+++ b/net/core/dev.c
@@ -1144,13 +1144,6 @@ int dev_alloc_name(struct net_device *dev, const char *name)
 }
 EXPORT_SYMBOL(dev_alloc_name);
 
-int dev_get_valid_name(struct net *net, struct net_device *dev,
-		       const char *name)
-{
-	return dev_alloc_name_ns(net, dev, name);
-}
-EXPORT_SYMBOL(dev_get_valid_name);
-
 /**
  *	dev_change_name - change name of a device
  *	@dev: device
-- 
2.11.0

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCH 1/3] net: core: export dev_alloc_name_ns
  2017-11-21  0:34 [PATCH 1/3] net: core: export dev_alloc_name_ns Rasmus Villemoes
  2017-11-21  0:34 ` [PATCH 2/3] net: use dev_alloc_name_ns instead of dev_get_valid_name Rasmus Villemoes
  2017-11-21  0:34 ` [PATCH 3/3] net: core: remove dev_get_valid_name Rasmus Villemoes
@ 2017-11-24 20:11 ` David Miller
  2 siblings, 0 replies; 4+ messages in thread
From: David Miller @ 2017-11-24 20:11 UTC (permalink / raw)
  To: linux; +Cc: netdev, linux-kernel

From: Rasmus Villemoes <linux@rasmusvillemoes.dk>
Date: Tue, 21 Nov 2017 01:34:37 +0100

> dev_alloc_name_ns and dev_get_valid_name now do exactly the same
> thing. Let's expose this functionality as dev_alloc_name_ns
> (obviously, a core function like this won't return an invalid
> name...).
> 
> Signed-off-by: Rasmus Villemoes <linux@rasmusvillemoes.dk>

If you're going to keep one of the routines, keep the one with
the simpler and smaller name, "dev_get_valid_name".

^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2017-11-24 20:11 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2017-11-21  0:34 [PATCH 1/3] net: core: export dev_alloc_name_ns Rasmus Villemoes
2017-11-21  0:34 ` [PATCH 2/3] net: use dev_alloc_name_ns instead of dev_get_valid_name Rasmus Villemoes
2017-11-21  0:34 ` [PATCH 3/3] net: core: remove dev_get_valid_name Rasmus Villemoes
2017-11-24 20:11 ` [PATCH 1/3] net: core: export dev_alloc_name_ns David Miller

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®