From: "Vladislav Valtchev (VMware)" <vladislav.valtchev@gmail.com>
To: rostedt@goodmis.org
Cc: linux-kernel@vger.kernel.org, y.karadz@gmail.com,
"Vladislav Valtchev (VMware)" <vladislav.valtchev@gmail.com>
Subject: [PATCH 09/11] trace-cmd: Consolidate ARRAY_SIZE() in trace-cmd.h
Date: Thu, 23 Nov 2017 18:33:33 +0200 [thread overview]
Message-ID: <20171123163335.19078-10-vladislav.valtchev@gmail.com> (raw)
In-Reply-To: <20171123163335.19078-1-vladislav.valtchev@gmail.com>
Since ARRAY_SIZE() is a very useful macro, it makes sense to move it in a common
header file, in order to avoid several C files to re-define it.
Signed-off-by: Vladislav Valtchev (VMware) <vladislav.valtchev@gmail.com>
---
plugin_blk.c | 1 -
trace-cmd.c | 2 --
trace-cmd.h | 2 ++
3 files changed, 2 insertions(+), 3 deletions(-)
diff --git a/plugin_blk.c b/plugin_blk.c
index e87bebb..a1b5df0 100644
--- a/plugin_blk.c
+++ b/plugin_blk.c
@@ -30,7 +30,6 @@
#define MINORMASK ((1U << MINORBITS) - 1)
#define MAJOR(dev) ((unsigned int) ((dev) >> MINORBITS))
#define MINOR(dev) ((unsigned int) ((dev) & MINORMASK))
-#define ARRAY_SIZE(arr) (sizeof(arr) / sizeof((arr)[0]))
struct blk_data {
unsigned long long sector;
diff --git a/trace-cmd.c b/trace-cmd.c
index 7297756..6c2efa3 100644
--- a/trace-cmd.c
+++ b/trace-cmd.c
@@ -117,8 +117,6 @@ struct command commands[] = {
{"-h", trace_usage},
};
-#define ARRAY_SIZE(_a) (sizeof(_a) / sizeof(_a[0]))
-
int main (int argc, char **argv)
{
int i;
diff --git a/trace-cmd.h b/trace-cmd.h
index 485907f..3fb6aab 100644
--- a/trace-cmd.h
+++ b/trace-cmd.h
@@ -22,6 +22,8 @@
#include "event-parse.h"
+#define ARRAY_SIZE(_a) (sizeof(_a) / sizeof((_a)[0]))
+
#define TRACECMD_ERR_MSK ((unsigned long)(-1) & ~((1UL << 14) - 1))
#define TRACECMD_ISERR(ptr) ((unsigned long)(ptr) > TRACECMD_ERR_MSK)
#define TRACECMD_ERROR(ret) ((void *)((unsigned long)(ret) | TRACECMD_ERR_MSK))
--
2.14.1
next prev parent reply other threads:[~2017-11-23 16:34 UTC|newest]
Thread overview: 30+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-11-23 16:33 [PATCH 00/11] trace-cmd: Refactoring trace_record() Vladislav Valtchev (VMware)
2017-11-23 16:33 ` [PATCH 01/11] trace-cmd: Extract trace_stop() from trace_record() Vladislav Valtchev (VMware)
2017-11-23 16:33 ` [PATCH 02/11] trace-cmd: Extract trace_restart() " Vladislav Valtchev (VMware)
2017-11-23 16:33 ` [PATCH 03/11] trace-cmd: Extract trace_reset() " Vladislav Valtchev (VMware)
2017-11-23 16:33 ` [PATCH 04/11] trace-cmd: Extract parse_record_options() " Vladislav Valtchev (VMware)
2017-11-28 16:48 ` Steven Rostedt
2017-11-28 18:17 ` Vladislav Valtchev
2017-11-28 18:30 ` Steven Rostedt
2017-11-28 18:57 ` Vladislav Valtchev
2017-11-28 19:15 ` Steven Rostedt
2017-11-29 14:53 ` Steven Rostedt
2017-11-29 15:18 ` Vladislav Valtchev
2017-11-23 16:33 ` [PATCH 05/11] trace-cmd: Rename trace_profile() to trace_profile_int() Vladislav Valtchev (VMware)
2017-11-28 17:05 ` Steven Rostedt
2017-11-28 19:00 ` Vladislav Valtchev
2017-11-23 16:33 ` [PATCH 06/11] trace-cmd: Replacing cmd flags w/ a trace_cmd enum Vladislav Valtchev (VMware)
2017-11-23 16:33 ` [PATCH 07/11] trace-cmd: Extracting record_trace() Vladislav Valtchev (VMware)
2017-11-23 16:33 ` [PATCH 08/11] trace-cmd: Making start,extract,stream,profile separate funcs Vladislav Valtchev (VMware)
2017-11-28 17:14 ` Steven Rostedt
2017-11-28 18:34 ` Vladislav Valtchev
2017-11-28 19:35 ` Steven Rostedt
2017-11-29 10:03 ` Vladislav Valtchev
2017-11-29 12:48 ` Steven Rostedt
2017-11-23 16:33 ` Vladislav Valtchev (VMware) [this message]
2017-11-28 17:16 ` [PATCH 09/11] trace-cmd: Consolidate ARRAY_SIZE() in trace-cmd.h Steven Rostedt
2017-11-23 16:33 ` [PATCH 10/11] trace-cmd: Making the "die" functions noreturn Vladislav Valtchev (VMware)
2017-11-23 16:33 ` [PATCH 11/11] trace-cmd: Introducing get_trace_cmd_type() Vladislav Valtchev (VMware)
2017-11-28 17:17 ` Steven Rostedt
2017-11-28 18:32 ` Steven Rostedt
2017-11-28 19:04 ` Vladislav Valtchev
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20171123163335.19078-10-vladislav.valtchev@gmail.com \
--to=vladislav.valtchev@gmail.com \
--cc=linux-kernel@vger.kernel.org \
--cc=rostedt@goodmis.org \
--cc=y.karadz@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®