From: "Vladislav Valtchev (VMware)" <vladislav.valtchev@gmail.com>
To: rostedt@goodmis.org
Cc: linux-kernel@vger.kernel.org, y.karadz@gmail.com,
"Vladislav Valtchev (VMware)" <vladislav.valtchev@gmail.com>
Subject: [PATCH 05/11] trace-cmd: Rename trace_profile() to trace_profile_int()
Date: Thu, 23 Nov 2017 18:33:29 +0200 [thread overview]
Message-ID: <20171123163335.19078-6-vladislav.valtchev@gmail.com> (raw)
In-Reply-To: <20171123163335.19078-1-vladislav.valtchev@gmail.com>
The purpose of this renaming is to make room for a new trace_profile() function,
that will handle directly the 'profile' command, following the internal
convention COMMAND_NAME -> trace_{COMMAND_NAME}.
Clearly, in the next steps the top-level trace_profile() function will be made
to call trace_profile_int() after some initialization.
Signed-off-by: Vladislav Valtchev (VMware) <vladislav.valtchev@gmail.com>
---
trace-local.h | 2 +-
trace-profile.c | 2 +-
trace-read.c | 2 +-
trace-record.c | 2 +-
4 files changed, 4 insertions(+), 4 deletions(-)
diff --git a/trace-local.h b/trace-local.h
index 49e7635..83c794a 100644
--- a/trace-local.h
+++ b/trace-local.h
@@ -96,7 +96,7 @@ struct hook_list;
void trace_init_profile(struct tracecmd_input *handle, struct hook_list *hooks,
int global);
-int trace_profile(void);
+int trace_profile_int(void);
void trace_profile_set_merge_like_comms(void);
struct tracecmd_input *
diff --git a/trace-profile.c b/trace-profile.c
index 0af27cd..777c4f2 100644
--- a/trace-profile.c
+++ b/trace-profile.c
@@ -2452,7 +2452,7 @@ static void merge_tasks(struct handle_data *h)
}
}
-int trace_profile(void)
+int trace_profile_int(void)
{
struct handle_data *h;
diff --git a/trace-read.c b/trace-read.c
index 350a843..862455e 100644
--- a/trace-read.c
+++ b/trace-read.c
@@ -1227,7 +1227,7 @@ static void read_data_info(struct list_head *handle_list, enum output_type otype
} while (last_record);
if (profile)
- trace_profile();
+ trace_profile_int();
list_for_each_entry(handles, handle_list, list) {
free_filters(handles->event_filters);
diff --git a/trace-record.c b/trace-record.c
index 6dc828b..b75d209 100644
--- a/trace-record.c
+++ b/trace-record.c
@@ -4937,7 +4937,7 @@ void trace_record(int argc, char **argv)
tracecmd_output_close(network_handle);
if (ctx.profile)
- trace_profile();
+ trace_profile_int();
exit(0);
}
--
2.14.1
next prev parent reply other threads:[~2017-11-23 16:34 UTC|newest]
Thread overview: 30+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-11-23 16:33 [PATCH 00/11] trace-cmd: Refactoring trace_record() Vladislav Valtchev (VMware)
2017-11-23 16:33 ` [PATCH 01/11] trace-cmd: Extract trace_stop() from trace_record() Vladislav Valtchev (VMware)
2017-11-23 16:33 ` [PATCH 02/11] trace-cmd: Extract trace_restart() " Vladislav Valtchev (VMware)
2017-11-23 16:33 ` [PATCH 03/11] trace-cmd: Extract trace_reset() " Vladislav Valtchev (VMware)
2017-11-23 16:33 ` [PATCH 04/11] trace-cmd: Extract parse_record_options() " Vladislav Valtchev (VMware)
2017-11-28 16:48 ` Steven Rostedt
2017-11-28 18:17 ` Vladislav Valtchev
2017-11-28 18:30 ` Steven Rostedt
2017-11-28 18:57 ` Vladislav Valtchev
2017-11-28 19:15 ` Steven Rostedt
2017-11-29 14:53 ` Steven Rostedt
2017-11-29 15:18 ` Vladislav Valtchev
2017-11-23 16:33 ` Vladislav Valtchev (VMware) [this message]
2017-11-28 17:05 ` [PATCH 05/11] trace-cmd: Rename trace_profile() to trace_profile_int() Steven Rostedt
2017-11-28 19:00 ` Vladislav Valtchev
2017-11-23 16:33 ` [PATCH 06/11] trace-cmd: Replacing cmd flags w/ a trace_cmd enum Vladislav Valtchev (VMware)
2017-11-23 16:33 ` [PATCH 07/11] trace-cmd: Extracting record_trace() Vladislav Valtchev (VMware)
2017-11-23 16:33 ` [PATCH 08/11] trace-cmd: Making start,extract,stream,profile separate funcs Vladislav Valtchev (VMware)
2017-11-28 17:14 ` Steven Rostedt
2017-11-28 18:34 ` Vladislav Valtchev
2017-11-28 19:35 ` Steven Rostedt
2017-11-29 10:03 ` Vladislav Valtchev
2017-11-29 12:48 ` Steven Rostedt
2017-11-23 16:33 ` [PATCH 09/11] trace-cmd: Consolidate ARRAY_SIZE() in trace-cmd.h Vladislav Valtchev (VMware)
2017-11-28 17:16 ` Steven Rostedt
2017-11-23 16:33 ` [PATCH 10/11] trace-cmd: Making the "die" functions noreturn Vladislav Valtchev (VMware)
2017-11-23 16:33 ` [PATCH 11/11] trace-cmd: Introducing get_trace_cmd_type() Vladislav Valtchev (VMware)
2017-11-28 17:17 ` Steven Rostedt
2017-11-28 18:32 ` Steven Rostedt
2017-11-28 19:04 ` Vladislav Valtchev
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20171123163335.19078-6-vladislav.valtchev@gmail.com \
--to=vladislav.valtchev@gmail.com \
--cc=linux-kernel@vger.kernel.org \
--cc=rostedt@goodmis.org \
--cc=y.karadz@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®