From: Steven Rostedt <rostedt@goodmis.org>
To: Vladislav Valtchev <vladislav.valtchev@gmail.com>
Cc: linux-kernel@vger.kernel.org, y.karadz@gmail.com
Subject: Re: [PATCH 04/11] trace-cmd: Extract parse_record_options() from trace_record()
Date: Tue, 28 Nov 2017 14:15:29 -0500 [thread overview]
Message-ID: <20171128141529.4e6ce05e@gandalf.local.home> (raw)
In-Reply-To: <1511895433.1754.39.camel@gmail.com>
On Tue, 28 Nov 2017 20:57:13 +0200
Vladislav Valtchev <vladislav.valtchev@gmail.com> wrote:
> On Tue, 2017-11-28 at 13:30 -0500, Steven Rostedt wrote:
> > On Tue, 28 Nov 2017 20:17:46 +0200
> > Vladislav Valtchev <vladislav.valtchev@gmail.com> wrote:
> >
> > > Since that code was profile-specific, I put it in trace_profile(),
> > > without 'if' statements, clearly.
> >
> > This is all about balancing. You were able to remove one if statement,
> > but required two function calls by all others.
> >
>
> I totally agree that is all about balancing.
> I wrote exactly the same thing as part of my previous e-mail (before reading this message).
>
> Are you concerned by the cost the of function calls or by the "verbosity" in calling them?
No the cost is negligible. More about the complexity. Adding "paired"
calls can sometimes be more confusing than if logic.
>
> Otherwise, I believe that having those function calls that way just makes the code simpler
> for new contributors. Functions, among everything else, are also "labels" for pieces of code.
> Having two different labels there (init context and parse options) makes sense to me.
> But, again, I understand that is a trade-off based on my subjective value system and
> way of thinking, of course.
>
> Do you have a strong opinion?
Yes ;-)
I'll reply why in the other email.
-- Steve
next prev parent reply other threads:[~2017-11-28 19:15 UTC|newest]
Thread overview: 30+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-11-23 16:33 [PATCH 00/11] trace-cmd: Refactoring trace_record() Vladislav Valtchev (VMware)
2017-11-23 16:33 ` [PATCH 01/11] trace-cmd: Extract trace_stop() from trace_record() Vladislav Valtchev (VMware)
2017-11-23 16:33 ` [PATCH 02/11] trace-cmd: Extract trace_restart() " Vladislav Valtchev (VMware)
2017-11-23 16:33 ` [PATCH 03/11] trace-cmd: Extract trace_reset() " Vladislav Valtchev (VMware)
2017-11-23 16:33 ` [PATCH 04/11] trace-cmd: Extract parse_record_options() " Vladislav Valtchev (VMware)
2017-11-28 16:48 ` Steven Rostedt
2017-11-28 18:17 ` Vladislav Valtchev
2017-11-28 18:30 ` Steven Rostedt
2017-11-28 18:57 ` Vladislav Valtchev
2017-11-28 19:15 ` Steven Rostedt [this message]
2017-11-29 14:53 ` Steven Rostedt
2017-11-29 15:18 ` Vladislav Valtchev
2017-11-23 16:33 ` [PATCH 05/11] trace-cmd: Rename trace_profile() to trace_profile_int() Vladislav Valtchev (VMware)
2017-11-28 17:05 ` Steven Rostedt
2017-11-28 19:00 ` Vladislav Valtchev
2017-11-23 16:33 ` [PATCH 06/11] trace-cmd: Replacing cmd flags w/ a trace_cmd enum Vladislav Valtchev (VMware)
2017-11-23 16:33 ` [PATCH 07/11] trace-cmd: Extracting record_trace() Vladislav Valtchev (VMware)
2017-11-23 16:33 ` [PATCH 08/11] trace-cmd: Making start,extract,stream,profile separate funcs Vladislav Valtchev (VMware)
2017-11-28 17:14 ` Steven Rostedt
2017-11-28 18:34 ` Vladislav Valtchev
2017-11-28 19:35 ` Steven Rostedt
2017-11-29 10:03 ` Vladislav Valtchev
2017-11-29 12:48 ` Steven Rostedt
2017-11-23 16:33 ` [PATCH 09/11] trace-cmd: Consolidate ARRAY_SIZE() in trace-cmd.h Vladislav Valtchev (VMware)
2017-11-28 17:16 ` Steven Rostedt
2017-11-23 16:33 ` [PATCH 10/11] trace-cmd: Making the "die" functions noreturn Vladislav Valtchev (VMware)
2017-11-23 16:33 ` [PATCH 11/11] trace-cmd: Introducing get_trace_cmd_type() Vladislav Valtchev (VMware)
2017-11-28 17:17 ` Steven Rostedt
2017-11-28 18:32 ` Steven Rostedt
2017-11-28 19:04 ` Vladislav Valtchev
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20171128141529.4e6ce05e@gandalf.local.home \
--to=rostedt@goodmis.org \
--cc=linux-kernel@vger.kernel.org \
--cc=vladislav.valtchev@gmail.com \
--cc=y.karadz@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®