From: Borislav Petkov <bp@suse.de>
To: Andy Lutomirski <luto@kernel.org>
Cc: X86 ML <x86@kernel.org>,
"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
Brian Gerst <brgerst@gmail.com>,
Dave Hansen <dave.hansen@intel.com>,
Linus Torvalds <torvalds@linux-foundation.org>,
Josh Poimboeuf <jpoimboe@redhat.com>
Subject: Re: [PATCH v2 10/18] x86/asm: Remap the TSS into the cpu entry area
Date: Thu, 23 Nov 2017 20:55:55 +0100 [thread overview]
Message-ID: <20171123195555.ct72tiphayavkffq@pd.tnic> (raw)
In-Reply-To: <07895bbccbff01d5c6ba3b1a5bf48fab34b92eae.1511325444.git.luto@kernel.org>
On Tue, Nov 21, 2017 at 08:44:05PM -0800, Andy Lutomirski wrote:
> This has a secondary purpose: it puts the entry stack into a region
> with a well-controlled layout. A subsequent patch will take
> advantage of this to streamline the SYSCALL entry code to be able to
> find it more easily.
>
> Signed-off-by: Andy Lutomirski <luto@kernel.org>
> ---
> arch/x86/entry/entry_32.S | 6 ++++--
> arch/x86/include/asm/fixmap.h | 7 +++++++
> arch/x86/kernel/asm-offsets.c | 3 +++
> arch/x86/kernel/cpu/common.c | 40 ++++++++++++++++++++++++++++++++++------
> arch/x86/kernel/dumpstack.c | 3 ++-
> arch/x86/power/cpu.c | 11 ++++++-----
> 6 files changed, 56 insertions(+), 14 deletions(-)
>
> diff --git a/arch/x86/entry/entry_32.S b/arch/x86/entry/entry_32.S
> index 4838037f97f6..0ab316c46806 100644
> --- a/arch/x86/entry/entry_32.S
> +++ b/arch/x86/entry/entry_32.S
> @@ -941,7 +941,8 @@ ENTRY(debug)
> movl %esp, %eax # pt_regs pointer
>
> /* Are we currently on the SYSENTER stack? */
> - PER_CPU(cpu_tss + CPU_TSS_SYSENTER_stack + SIZEOF_SYSENTER_stack, %ecx)
> + movl PER_CPU_VAR(cpu_entry_area), %ecx
> + addl $CPU_ENTRY_AREA_tss + CPU_TSS_SYSENTER_stack + SIZEOF_SYSENTER_stack, %ecx
> subl %eax, %ecx /* ecx = (end of SYSENTER_stack) - esp */
Fixup that comment while you're at it to be either ontop or be of the
#-type. The cool thing about the # comments is that gas puts them in the
.s output too, so you can find them again.
> cmpl $SIZEOF_SYSENTER_stack, %ecx
> jb .Ldebug_from_sysenter_stack
> @@ -984,7 +985,8 @@ ENTRY(nmi)
> movl %esp, %eax # pt_regs pointer
>
> /* Are we currently on the SYSENTER stack? */
> - PER_CPU(cpu_tss + CPU_TSS_SYSENTER_stack + SIZEOF_SYSENTER_stack, %ecx)
> + movl PER_CPU_VAR(cpu_entry_area), %ecx
> + addl $CPU_ENTRY_AREA_tss + CPU_TSS_SYSENTER_stack + SIZEOF_SYSENTER_stack, %ecx
> subl %eax, %ecx /* ecx = (end of SYSENTER_stack) - esp */
Ditto.
> cmpl $SIZEOF_SYSENTER_stack, %ecx
> jb .Lnmi_from_sysenter_stack
...
> diff --git a/arch/x86/kernel/asm-offsets.c b/arch/x86/kernel/asm-offsets.c
> index b275863128eb..55858b277cf6 100644
> --- a/arch/x86/kernel/asm-offsets.c
> +++ b/arch/x86/kernel/asm-offsets.c
> @@ -98,4 +98,7 @@ void common(void) {
> OFFSET(CPU_TSS_SYSENTER_stack, tss_struct, SYSENTER_stack);
> /* Size of SYSENTER_stack */
> DEFINE(SIZEOF_SYSENTER_stack, sizeof(((struct tss_struct *)0)->SYSENTER_stack));
> +
> + /* Layout info for cpu_entry_area */
> + OFFSET(CPU_ENTRY_AREA_tss, cpu_entry_area, tss);
The naming convention of those looks really strange. The beginning is in
all caps and then small. Can we choose a convention pls.
And the comments are not really needed - the variable names already say
what they are.
...
> @@ -1281,7 +1304,8 @@ void enable_sep_cpu(void)
> wrmsr(MSR_IA32_SYSENTER_CS, tss->x86_tss.ss1, 0);
>
> wrmsr(MSR_IA32_SYSENTER_ESP,
> - (unsigned long)tss + offsetofend(struct tss_struct, SYSENTER_stack),
> + (unsigned long)&get_cpu_entry_area(cpu)->tss +
> + offsetofend(struct tss_struct, SYSENTER_stack),
> 0);
Use a local var:
unsigned long se_esp;
...
se_esp = (unsigned long)&get_cpu_entry_area(cpu)->tss + offsetofend(struct tss_struct, SYSENTER_stack);
wrmsr(MSR_IA32_SYSENTER_ESP, se_esp, 0);
>
> wrmsr(MSR_IA32_SYSENTER_EIP, (unsigned long)entry_SYSENTER_32, 0);
> @@ -1394,6 +1418,8 @@ static DEFINE_PER_CPU_PAGE_ALIGNED(char, exception_stacks
> /* May not be marked __init: used by software suspend */
> void syscall_init(void)
> {
> + int cpu = smp_processor_id();
> +
> wrmsr(MSR_STAR, 0, (__USER32_CS << 16) | __KERNEL_CS);
> wrmsrl(MSR_LSTAR, (unsigned long)entry_SYSCALL_64);
>
> @@ -1407,7 +1433,7 @@ void syscall_init(void)
> */
> wrmsrl_safe(MSR_IA32_SYSENTER_CS, (u64)__KERNEL_CS);
> wrmsrl_safe(MSR_IA32_SYSENTER_ESP,
> - (unsigned long)this_cpu_ptr(&cpu_tss) +
> + (unsigned long)&get_cpu_entry_area(cpu)->tss +
> offsetofend(struct tss_struct, SYSENTER_stack));
Ditto.
> wrmsrl_safe(MSR_IA32_SYSENTER_EIP, (u64)entry_SYSENTER_compat);
> #else
--
Regards/Gruss,
Boris.
SUSE Linux GmbH, GF: Felix Imendörffer, Jane Smithard, Graham Norton, HRB 21284 (AG Nürnberg)
--
next prev parent reply other threads:[~2017-11-23 19:56 UTC|newest]
Thread overview: 64+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-11-22 4:43 [PATCH v2 00/18] Entry stack switching Andy Lutomirski
2017-11-22 4:43 ` [PATCH v2 01/18] x86/entry/64: Fix entry_SYSCALL_64_after_hwframe IRQ tracing Andy Lutomirski
2017-11-22 5:35 ` Ingo Molnar
2017-11-22 7:45 ` [tip:x86/urgent] x86/entry/64: Fix entry_SYSCALL_64_after_hwframe() " tip-bot for Andy Lutomirski
2017-11-22 4:43 ` [PATCH v2 02/18] x86/asm/64: Allocate and enable the SYSENTER stack Andy Lutomirski
2017-11-22 4:43 ` [PATCH v2 03/18] x86/dumpstack: Add get_stack_info() support for " Andy Lutomirski
2017-11-22 12:10 ` Borislav Petkov
2017-11-22 4:43 ` [PATCH v2 04/18] x86/gdt: Put per-cpu GDT remaps in ascending order Andy Lutomirski
2017-11-22 11:05 ` Borislav Petkov
2017-11-22 15:26 ` Andy Lutomirski
2017-11-22 4:44 ` [PATCH v2 05/18] x86/fixmap: Generalize the GDT fixmap mechanism Andy Lutomirski
2017-11-22 15:33 ` Borislav Petkov
2017-11-22 17:16 ` Andy Lutomirski
2017-11-22 17:32 ` Borislav Petkov
2017-11-23 15:24 ` Andy Lutomirski
2017-11-23 19:24 ` Thomas Gleixner
2017-11-22 4:44 ` [PATCH v2 06/18] x86/kasan/64: Teach KASAN about the cpu_entry_area Andy Lutomirski
2017-11-22 6:19 ` Ingo Molnar
2017-11-22 9:05 ` Andrey Ryabinin
2017-11-22 15:22 ` Andy Lutomirski
2017-11-23 10:08 ` Andrey Ryabinin
2017-11-23 15:22 ` Andy Lutomirski
2017-11-22 4:44 ` [PATCH v2 07/18] x86/asm: Fix assumptions that the HW TSS is at the beginning of cpu_tss Andy Lutomirski
2017-11-22 19:06 ` Borislav Petkov
2017-11-22 4:44 ` [PATCH v2 08/18] x86/dumpstack: Handle stack overflow on all stacks Andy Lutomirski
2017-11-23 11:19 ` Borislav Petkov
2017-11-22 4:44 ` [PATCH v2 09/18] x86/asm: Move SYSENTER_stack to the beginning of struct tss_struct Andy Lutomirski
2017-11-23 12:00 ` Borislav Petkov
2017-11-23 13:16 ` Denys Vlasenko
2017-11-23 15:02 ` Andy Lutomirski
2017-11-23 19:30 ` Thomas Gleixner
2017-11-22 4:44 ` [PATCH v2 10/18] x86/asm: Remap the TSS into the cpu entry area Andy Lutomirski
2017-11-23 19:32 ` Thomas Gleixner
2017-11-23 19:55 ` Borislav Petkov [this message]
2017-11-23 20:15 ` Andy Lutomirski
2017-11-23 20:37 ` Borislav Petkov
2017-11-24 2:40 ` Andy Lutomirski
2017-11-24 4:17 ` Andy Lutomirski
2017-11-22 4:44 ` [PATCH v2 11/18] x86/asm/64: Separate cpu_current_top_of_stack from TSS.sp0 Andy Lutomirski
2017-11-23 19:34 ` Thomas Gleixner
2017-11-22 4:44 ` [PATCH v2 12/18] x86/espfix/64: Stop assuming that pt_regs is on the entry stack Andy Lutomirski
2017-11-23 19:36 ` Thomas Gleixner
2017-11-22 4:44 ` [PATCH v2 13/18] x86/asm/64: Use a percpu trampoline stack for IDT entries Andy Lutomirski
2017-11-23 23:44 ` Thomas Gleixner
2017-11-24 4:14 ` Andy Lutomirski
2017-11-22 4:44 ` [PATCH v2 14/18] x86/asm/64: Return to userspace from the trampoline stack Andy Lutomirski
2017-11-22 4:44 ` [PATCH v2 15/18] x86/entry/64: Create a percpu SYSCALL entry trampoline Andy Lutomirski
2017-11-22 4:44 ` [PATCH v2 16/18] x86/irq: Remove an old outdated comment about context tracking races Andy Lutomirski
2017-11-22 4:44 ` [PATCH v2 17/18] x86/irq/64: In the stack overflow warning, print the offending IP Andy Lutomirski
2017-11-22 4:44 ` [PATCH v2 18/18] x86/entry/64: Move the IST stacks into cpu_entry_area Andy Lutomirski
2017-11-22 6:22 ` [PATCH v2 00/18] Entry stack switching Ingo Molnar
2017-11-22 6:36 ` Ingo Molnar
2017-11-22 16:23 ` Andy Lutomirski
2017-11-23 6:21 ` Ingo Molnar
2017-11-23 6:44 ` Ingo Molnar
2017-11-23 6:58 ` Ingo Molnar
2017-11-23 15:29 ` Andy Lutomirski
2017-11-23 16:41 ` Thomas Gleixner
2017-11-22 7:39 ` WARNING: can't dereference registers at ffffc90004dfff60 for ip error_entry+0x7d/0xd0 (Re: [PATCH v2 00/18] Entry stack switching) Ingo Molnar
2017-11-22 7:43 ` Ingo Molnar
2017-11-22 13:55 ` Josh Poimboeuf
2017-11-22 15:19 ` Andy Lutomirski
2017-11-22 15:56 ` Ingo Molnar
2017-11-22 16:35 ` Andy Lutomirski
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20171123195555.ct72tiphayavkffq@pd.tnic \
--to=bp@suse.de \
--cc=brgerst@gmail.com \
--cc=dave.hansen@intel.com \
--cc=jpoimboe@redhat.com \
--cc=linux-kernel@vger.kernel.org \
--cc=luto@kernel.org \
--cc=torvalds@linux-foundation.org \
--cc=x86@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®