* [PATCH] drm/i915/guc: Fix doc reference to intel_guc_fw.c
@ 2017-11-28 6:50 Jonathan Neuschäfer
2017-11-28 8:51 ` Michal Wajdeczko
0 siblings, 1 reply; 3+ messages in thread
From: Jonathan Neuschäfer @ 2017-11-28 6:50 UTC (permalink / raw)
To: linux-doc
Cc: Jonathan Neuschäfer, Michal Wajdeczko, Jani Nikula,
Joonas Lahtinen, Rodrigo Vivi, Daniel Vetter, Sean Paul,
David Airlie, Jonathan Corbet, intel-gfx, dri-devel,
linux-kernel
Sphinx complains that it can't find intel_guc_loader.c, and rightly so:
The file has been renamed.
Fixes: e8668bbcb0f9 ("drm/i915/guc: Rename intel_guc_loader.c to intel_guc_fw.c")
Cc: Michal Wajdeczko <michal.wajdeczko@intel.com>
Signed-off-by: Jonathan Neuschäfer <j.neuschaefer@gmx.net>
---
Documentation/gpu/i915.rst | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/Documentation/gpu/i915.rst b/Documentation/gpu/i915.rst
index 2e7ee0313c1c..e21698e16534 100644
--- a/Documentation/gpu/i915.rst
+++ b/Documentation/gpu/i915.rst
@@ -341,10 +341,10 @@ GuC
GuC-specific firmware loader
----------------------------
-.. kernel-doc:: drivers/gpu/drm/i915/intel_guc_loader.c
+.. kernel-doc:: drivers/gpu/drm/i915/intel_guc_fw.c
:doc: GuC-specific firmware loader
-.. kernel-doc:: drivers/gpu/drm/i915/intel_guc_loader.c
+.. kernel-doc:: drivers/gpu/drm/i915/intel_guc_fw.c
:internal:
GuC-based command submission
--
2.15.0
^ permalink raw reply [flat|nested] 3+ messages in thread* Re: [PATCH] drm/i915/guc: Fix doc reference to intel_guc_fw.c 2017-11-28 6:50 [PATCH] drm/i915/guc: Fix doc reference to intel_guc_fw.c Jonathan Neuschäfer @ 2017-11-28 8:51 ` Michal Wajdeczko 2017-11-28 12:58 ` Jonathan Neuschäfer 0 siblings, 1 reply; 3+ messages in thread From: Michal Wajdeczko @ 2017-11-28 8:51 UTC (permalink / raw) To: linux-doc, Jonathan Neuschäfer Cc: Jani Nikula, Joonas Lahtinen, Rodrigo Vivi, Daniel Vetter, Sean Paul, David Airlie, Jonathan Corbet, intel-gfx, dri-devel, linux-kernel, Ville Syrjälä On Tue, 28 Nov 2017 07:50:52 +0100, Jonathan Neuschäfer <j.neuschaefer@gmx.net> wrote: > Sphinx complains that it can't find intel_guc_loader.c, and rightly so: > The file has been renamed. > > Fixes: e8668bbcb0f9 ("drm/i915/guc: Rename intel_guc_loader.c to > intel_guc_fw.c") > Cc: Michal Wajdeczko <michal.wajdeczko@intel.com> > Signed-off-by: Jonathan Neuschäfer <j.neuschaefer@gmx.net> > --- > Documentation/gpu/i915.rst | 4 ++-- > 1 file changed, 2 insertions(+), 2 deletions(-) > > diff --git a/Documentation/gpu/i915.rst b/Documentation/gpu/i915.rst > index 2e7ee0313c1c..e21698e16534 100644 > --- a/Documentation/gpu/i915.rst > +++ b/Documentation/gpu/i915.rst > @@ -341,10 +341,10 @@ GuC > GuC-specific firmware loader > ---------------------------- > -.. kernel-doc:: drivers/gpu/drm/i915/intel_guc_loader.c > +.. kernel-doc:: drivers/gpu/drm/i915/intel_guc_fw.c > :doc: GuC-specific firmware loader > -.. kernel-doc:: drivers/gpu/drm/i915/intel_guc_loader.c > +.. kernel-doc:: drivers/gpu/drm/i915/intel_guc_fw.c > :internal: > GuC-based command submission + Ville Well, this will fix sphinx error, but in my opinion it will not make i915 documentation any better. See my earlier patch/comments in [1]. So maybe better to wait for other comments which way to go. Thanks for the patch, Michal [1] https://patchwork.freedesktop.org/patch/188424/ ^ permalink raw reply [flat|nested] 3+ messages in thread
* Re: [PATCH] drm/i915/guc: Fix doc reference to intel_guc_fw.c 2017-11-28 8:51 ` Michal Wajdeczko @ 2017-11-28 12:58 ` Jonathan Neuschäfer 0 siblings, 0 replies; 3+ messages in thread From: Jonathan Neuschäfer @ 2017-11-28 12:58 UTC (permalink / raw) To: Michal Wajdeczko Cc: linux-doc, Jonathan Neuschäfer, Jani Nikula, Joonas Lahtinen, Rodrigo Vivi, Daniel Vetter, Sean Paul, David Airlie, Jonathan Corbet, intel-gfx, dri-devel, linux-kernel, Ville Syrjälä [-- Attachment #1: Type: text/plain, Size: 2644 bytes --] On Tue, Nov 28, 2017 at 09:51:13AM +0100, Michal Wajdeczko wrote: > On Tue, 28 Nov 2017 07:50:52 +0100, Jonathan Neuschäfer > <j.neuschaefer@gmx.net> wrote: > > > Sphinx complains that it can't find intel_guc_loader.c, and rightly so: > > The file has been renamed. > > > > Fixes: e8668bbcb0f9 ("drm/i915/guc: Rename intel_guc_loader.c to > > intel_guc_fw.c") > > Cc: Michal Wajdeczko <michal.wajdeczko@intel.com> > > Signed-off-by: Jonathan Neuschäfer <j.neuschaefer@gmx.net> > > --- > > Documentation/gpu/i915.rst | 4 ++-- > > 1 file changed, 2 insertions(+), 2 deletions(-) > > > > diff --git a/Documentation/gpu/i915.rst b/Documentation/gpu/i915.rst > > index 2e7ee0313c1c..e21698e16534 100644 > > --- a/Documentation/gpu/i915.rst > > +++ b/Documentation/gpu/i915.rst > > @@ -341,10 +341,10 @@ GuC > > GuC-specific firmware loader > > ---------------------------- > > -.. kernel-doc:: drivers/gpu/drm/i915/intel_guc_loader.c > > +.. kernel-doc:: drivers/gpu/drm/i915/intel_guc_fw.c > > :doc: GuC-specific firmware loader > > -.. kernel-doc:: drivers/gpu/drm/i915/intel_guc_loader.c > > +.. kernel-doc:: drivers/gpu/drm/i915/intel_guc_fw.c > > :internal: > > GuC-based command submission > > + Ville > > Well, this will fix sphinx error, but in my opinion it will not make > i915 documentation any better. See my earlier patch/comments in [1]. Thanks for the pointer. Hmm, right, given that there's no "DOC:" line in intel_guc_fw.c anymore, the ":doc:" directive above is not useful. As a tiny step towards more complete documentation (and to keep people from patching this spot again ;), IMHO it makes sense to do this (it's of course up to the maintainers whether they agree): ----------------------------------------------------------------------- diff --git a/Documentation/gpu/i915.rst b/Documentation/gpu/i915.rst index 2e7ee0313c1c..e94d3ac2bdd0 100644 --- a/Documentation/gpu/i915.rst +++ b/Documentation/gpu/i915.rst @@ -341,10 +341,7 @@ GuC GuC-specific firmware loader ---------------------------- -.. kernel-doc:: drivers/gpu/drm/i915/intel_guc_loader.c - :doc: GuC-specific firmware loader - -.. kernel-doc:: drivers/gpu/drm/i915/intel_guc_loader.c +.. kernel-doc:: drivers/gpu/drm/i915/intel_guc_fw.c :internal: GuC-based command submission ----------------------------------------------------------------------- > So maybe better to wait for other comments which way to go. Makes sense. Thanks, Jonathan Neuschäfer > > Thanks for the patch, > Michal > > [1] https://patchwork.freedesktop.org/patch/188424/ [-- Attachment #2: signature.asc --] [-- Type: application/pgp-signature, Size: 819 bytes --] ^ permalink raw reply [flat|nested] 3+ messages in thread
end of thread, other threads:[~2017-11-28 12:59 UTC | newest] Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed) -- links below jump to the message on this page -- 2017-11-28 6:50 [PATCH] drm/i915/guc: Fix doc reference to intel_guc_fw.c Jonathan Neuschäfer 2017-11-28 8:51 ` Michal Wajdeczko 2017-11-28 12:58 ` Jonathan Neuschäfer
This is a public inbox, see mirroring instructions for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®