From: Dan Carpenter <dan.carpenter@oracle.com>
To: "Simon Sandström" <simon@nikanor.nu>
Cc: devel@driverdev.osuosl.org, gregkh@linuxfoundation.org,
linux@Wolf-Entwicklungen.de, linux-kernel@vger.kernel.org
Subject: Re: [PATCH 4/6] staging: pi433: Rename enum optionOnOff in rf69_enum.h
Date: Mon, 4 Dec 2017 13:37:19 +0300 [thread overview]
Message-ID: <20171204103719.7talcb3dqu3yfns2@mwanda> (raw)
In-Reply-To: <20171204101737.xv4eyglsrbmiagtn@mwanda>
On Mon, Dec 04, 2017 at 01:17:37PM +0300, Dan Carpenter wrote:
> Perhaps choose different function names if you want? You could do it
> as several patches:
>
> patch 1: change types to bool
> patch 2: sed -e '/ == optionOn//'
> patch 3: split the functions into two functions
> patch 4: delete optionOnOff enum
>
> patches 1 and 2 could be merged together (your choice).
>
Markus says that optionOn is used by user space so my you won't be able
to remove these entirely. But as much as possible we should internally.
regards,
dan carpenter
next prev parent reply other threads:[~2017-12-04 10:37 UTC|newest]
Thread overview: 32+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-12-03 15:17 [PATCH 0/6] Fix indentation and CamelCase issues in staging/pi433 Simon Sandström
2017-12-03 15:17 ` [PATCH 1/6] staging: pi433: Fix indentation in rf69_enum.h Simon Sandström
2017-12-03 15:17 ` [PATCH 2/6] staging: pi433: Capitalize constant definitions Simon Sandström
2017-12-03 15:17 ` [PATCH 3/6] staging: pi433: Rename variable in struct pi433_rx_cfg Simon Sandström
2017-12-03 15:17 ` [PATCH 4/6] staging: pi433: Rename enum optionOnOff in rf69_enum.h Simon Sandström
2017-12-03 16:49 ` Marcus Wolf
2017-12-04 10:04 ` Simon Sandström
2017-12-04 10:17 ` Dan Carpenter
2017-12-04 10:37 ` Dan Carpenter [this message]
2017-12-04 18:37 ` Marcus Wolf
2017-12-04 19:15 ` Dan Carpenter
2017-12-04 19:22 ` Marcus Wolf
2017-12-04 19:42 ` Simon Sandström
2017-12-04 19:59 ` Marcus Wolf
2017-12-04 20:05 ` Simon Sandström
2017-12-05 12:06 ` Marcus Wolf
2017-12-05 12:16 ` Dan Carpenter
2017-12-05 12:40 ` Marcus Wolf
2017-12-05 13:03 ` Dan Carpenter
2017-12-03 15:17 ` [PATCH 5/6] staging: pi433: Rename enum dataMode " Simon Sandström
2017-12-04 10:24 ` Dan Carpenter
2017-12-04 19:12 ` Marcus Wolf
2017-12-04 19:21 ` Dan Carpenter
2017-12-04 19:31 ` Marcus Wolf
2017-12-04 19:56 ` Dan Carpenter
2017-12-04 20:21 ` Marcus Wolf
2017-12-03 15:17 ` [PATCH 6/6] staging: pi433: Rename enum modShaping " Simon Sandström
2017-12-04 10:33 ` Dan Carpenter
2017-12-04 18:59 ` Marcus Wolf
2017-12-04 19:18 ` Dan Carpenter
2017-12-04 19:41 ` Marcus Wolf
2017-12-17 17:13 ` Marcus Wolf
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20171204103719.7talcb3dqu3yfns2@mwanda \
--to=dan.carpenter@oracle.com \
--cc=devel@driverdev.osuosl.org \
--cc=gregkh@linuxfoundation.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux@Wolf-Entwicklungen.de \
--cc=simon@nikanor.nu \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®