mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Marcus Wolf <marcus.wolf@smarthome-wolf.de>
To: "Dan Carpenter" <dan.carpenter@oracle.com>,
	"Simon Sandström" <simon@nikanor.nu>
Cc: gregkh@linuxfoundation.org, devel@driverdev.osuosl.org,
	linux@Wolf-Entwicklungen.de, linux-kernel@vger.kernel.org
Subject: Re: [PATCH 5/6] staging: pi433: Rename enum dataMode in rf69_enum.h
Date: Mon, 4 Dec 2017 21:12:52 +0200	[thread overview]
Message-ID: <ab1d3ff4-e59d-d24f-7024-4c308738a281@smarthome-wolf.de> (raw)
In-Reply-To: <20171204102419.onpiyz2dpos4ooc5@mwanda>



Am 04.12.2017 um 12:24 schrieb Dan Carpenter:
> On Sun, Dec 03, 2017 at 04:17:25PM +0100, Simon Sandström wrote:
>> Renames enum dataMode and its values packet, continuous, continuousNoSync
>> to enum data_mode and PACKET, CONTINUOUS, CONTINUOUS_NO_SYNC. Fixes
>> checkpatch.pl warnings: "Avoid CamelCase: <dataMode>, <continuousNoSync>".
> 
> These names are too generic.  Delete them.  Use DATAMODUL_MODE_PACKET
> and friends directly.
> 
> int rf69_set_data_mode(struct spi_device *spi, u8 val)
> {
> 	return WRITE_REG(REG_DATAMODUL, (READ_REG(REG_DATAMODUL) & ~MASK_DATAMODUL_MODE) | val);
> }
> 
> Only DATAMODUL_MODE_PACKET is ever used.  There is no need to validate
> the parameters.
> 
> regards,
> dan carpenter
> 

Hi Dan, hi Simon,

like I wrote a few days ago to Marcin Ciupak, I see two disadvantages in 
doing so.

If you want to go that way, you - as far as I believe - need to alter 
the values in rf69_enum.h, so they carry the corresponding values from 
rf69_reg.h. To avoid confusion, you will need to remove the values from 
rf69_reg.h.
But then you have to keep track of two files (enum.h and reg.h), if you 
want to further develop register access stuff. I would prefer to keep 
all chip/register related values at the same place.

Second there might be the idea of supporting different chips in the 
future (I already thought about).
Then it might be, that DATAMODUL_MODE_PACKET might need an other value.
Therefore, I introduced the "double layer" - enums as labels for the 
user space and defines, containing the values, for the register access.

For closer details, pls. see my long answer to Marcin.

I am not sure, whether simplification of the code like proposed is more 
important, then the disadvatages, I mentioned.

Cheers,

Marcus

  reply	other threads:[~2017-12-04 19:13 UTC|newest]

Thread overview: 32+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2017-12-03 15:17 [PATCH 0/6] Fix indentation and CamelCase issues in staging/pi433 Simon Sandström
2017-12-03 15:17 ` [PATCH 1/6] staging: pi433: Fix indentation in rf69_enum.h Simon Sandström
2017-12-03 15:17 ` [PATCH 2/6] staging: pi433: Capitalize constant definitions Simon Sandström
2017-12-03 15:17 ` [PATCH 3/6] staging: pi433: Rename variable in struct pi433_rx_cfg Simon Sandström
2017-12-03 15:17 ` [PATCH 4/6] staging: pi433: Rename enum optionOnOff in rf69_enum.h Simon Sandström
2017-12-03 16:49   ` Marcus Wolf
2017-12-04 10:04     ` Simon Sandström
2017-12-04 10:17   ` Dan Carpenter
2017-12-04 10:37     ` Dan Carpenter
2017-12-04 18:37       ` Marcus Wolf
2017-12-04 19:15         ` Dan Carpenter
2017-12-04 19:22           ` Marcus Wolf
2017-12-04 19:42             ` Simon Sandström
2017-12-04 19:59               ` Marcus Wolf
2017-12-04 20:05                 ` Simon Sandström
2017-12-05 12:06                   ` Marcus Wolf
2017-12-05 12:16                 ` Dan Carpenter
2017-12-05 12:40                   ` Marcus Wolf
2017-12-05 13:03                     ` Dan Carpenter
2017-12-03 15:17 ` [PATCH 5/6] staging: pi433: Rename enum dataMode " Simon Sandström
2017-12-04 10:24   ` Dan Carpenter
2017-12-04 19:12     ` Marcus Wolf [this message]
2017-12-04 19:21       ` Dan Carpenter
2017-12-04 19:31         ` Marcus Wolf
2017-12-04 19:56           ` Dan Carpenter
2017-12-04 20:21             ` Marcus Wolf
2017-12-03 15:17 ` [PATCH 6/6] staging: pi433: Rename enum modShaping " Simon Sandström
2017-12-04 10:33   ` Dan Carpenter
2017-12-04 18:59     ` Marcus Wolf
2017-12-04 19:18       ` Dan Carpenter
2017-12-04 19:41         ` Marcus Wolf
2017-12-17 17:13         ` Marcus Wolf

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=ab1d3ff4-e59d-d24f-7024-4c308738a281@smarthome-wolf.de \
    --to=marcus.wolf@smarthome-wolf.de \
    --cc=dan.carpenter@oracle.com \
    --cc=devel@driverdev.osuosl.org \
    --cc=gregkh@linuxfoundation.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux@Wolf-Entwicklungen.de \
    --cc=simon@nikanor.nu \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®