From: Dan Carpenter <dan.carpenter@oracle.com>
To: Marcus Wolf <marcus.wolf@smarthome-wolf.de>
Cc: "Simon Sandström" <simon@nikanor.nu>,
devel@driverdev.osuosl.org, gregkh@linuxfoundation.org,
linux@Wolf-Entwicklungen.de, linux-kernel@vger.kernel.org
Subject: Re: [PATCH 4/6] staging: pi433: Rename enum optionOnOff in rf69_enum.h
Date: Tue, 5 Dec 2017 15:16:29 +0300 [thread overview]
Message-ID: <20171205103008.h7evql7onlaygczi@mwanda> (raw)
In-Reply-To: <b33f2952-f169-eeb2-f322-e6c4b22358db@smarthome-wolf.de>
On Mon, Dec 04, 2017 at 09:59:02PM +0200, Marcus Wolf wrote:
> Keep in mind, that if you split the functions, in the interface
> implementation you also need more code:
>
> SET_CHECKED(rf69_set_sync_enable(dev->spi, rx_cfg->enable_sync));
>
> will have to be converted in something like
>
> if (rx_cfg->enable_sync)
> SET_CHECKED(rf69_set_sync_enbable(dev->spi);
> else
> SET_CHECKED(rf69_set_sync_disable(dev->spi);
>
Here's what the code looks like right now:
198 /* packet config */
199 /* enable */
200 SET_CHECKED(rf69_set_sync_enable(dev->spi, rx_cfg->enable_sync));
201 if (rx_cfg->enable_sync == optionOn)
202 {
203 SET_CHECKED(rf69_set_fifo_fill_condition(dev->spi, afterSyncInterrupt));
204 }
205 else
206 {
207 SET_CHECKED(rf69_set_fifo_fill_condition(dev->spi, always));
208 }
That's for the rx_cfg. We have related but different code for the
tx_cfg. It's strange to me that we can enable sync for rx and not for
tx... How does that work when the setting ends up getting stored in the
same register?
The new code would look like this:
if (rx_cfg->enable_sync) {
ret = rf69_enable_sync(spi);
if (ret)
return ret;
ret = rf69_set_fifo_fill_condition(dev->spi, afterSyncInterrupt);
if (ret)
return ret;
} else {
ret = rf69_disable_sync(dev->spi);
if (ret)
return ret;
ret = rf69_set_fifo_fill_condition(dev->spi, always);
if (ret)
return ret;
}
It's not the greatest, but it's not the worst... The configuration for
->enable_sync is a bit spread out and it might be nice to move it all to
one function?
I liked Simon's naming scheme and I thought it was clear what the
rf69_set_sync(spi, false) function would do.
Simon, it seems like Marcus and I both are Ok with your style choices.
Do whatever seems best when you implement the code. If it's awkward to
break up the functions then don't.
regards,
dan carpenter
next prev parent reply other threads:[~2017-12-05 12:16 UTC|newest]
Thread overview: 32+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-12-03 15:17 [PATCH 0/6] Fix indentation and CamelCase issues in staging/pi433 Simon Sandström
2017-12-03 15:17 ` [PATCH 1/6] staging: pi433: Fix indentation in rf69_enum.h Simon Sandström
2017-12-03 15:17 ` [PATCH 2/6] staging: pi433: Capitalize constant definitions Simon Sandström
2017-12-03 15:17 ` [PATCH 3/6] staging: pi433: Rename variable in struct pi433_rx_cfg Simon Sandström
2017-12-03 15:17 ` [PATCH 4/6] staging: pi433: Rename enum optionOnOff in rf69_enum.h Simon Sandström
2017-12-03 16:49 ` Marcus Wolf
2017-12-04 10:04 ` Simon Sandström
2017-12-04 10:17 ` Dan Carpenter
2017-12-04 10:37 ` Dan Carpenter
2017-12-04 18:37 ` Marcus Wolf
2017-12-04 19:15 ` Dan Carpenter
2017-12-04 19:22 ` Marcus Wolf
2017-12-04 19:42 ` Simon Sandström
2017-12-04 19:59 ` Marcus Wolf
2017-12-04 20:05 ` Simon Sandström
2017-12-05 12:06 ` Marcus Wolf
2017-12-05 12:16 ` Dan Carpenter [this message]
2017-12-05 12:40 ` Marcus Wolf
2017-12-05 13:03 ` Dan Carpenter
2017-12-03 15:17 ` [PATCH 5/6] staging: pi433: Rename enum dataMode " Simon Sandström
2017-12-04 10:24 ` Dan Carpenter
2017-12-04 19:12 ` Marcus Wolf
2017-12-04 19:21 ` Dan Carpenter
2017-12-04 19:31 ` Marcus Wolf
2017-12-04 19:56 ` Dan Carpenter
2017-12-04 20:21 ` Marcus Wolf
2017-12-03 15:17 ` [PATCH 6/6] staging: pi433: Rename enum modShaping " Simon Sandström
2017-12-04 10:33 ` Dan Carpenter
2017-12-04 18:59 ` Marcus Wolf
2017-12-04 19:18 ` Dan Carpenter
2017-12-04 19:41 ` Marcus Wolf
2017-12-17 17:13 ` Marcus Wolf
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20171205103008.h7evql7onlaygczi@mwanda \
--to=dan.carpenter@oracle.com \
--cc=devel@driverdev.osuosl.org \
--cc=gregkh@linuxfoundation.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux@Wolf-Entwicklungen.de \
--cc=marcus.wolf@smarthome-wolf.de \
--cc=simon@nikanor.nu \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®