mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH] staging: olpc_dcon: Add Tabs to define-Macros
@ 2019-03-22  9:52 Emanuel Bennici
  2019-03-22 14:17 ` Greg Kroah-Hartman
  0 siblings, 1 reply; 2+ messages in thread
From: Emanuel Bennici @ 2019-03-22  9:52 UTC (permalink / raw)
  To: linux-kernel
  Cc: Jens Frederich, Daniel Drake, Jon Nettleton, Greg Kroah-Hartman,
	Joe Perches

Improve Code Readability by adding Tabs after #define-Macro
definition.

Signed-off-by: Emanuel Bennici <benniciemanuel78@gmail.com>
---
 drivers/staging/olpc_dcon/olpc_dcon.h        | 24 ++++++++++----------
 drivers/staging/olpc_dcon/olpc_dcon_xo_1_5.c |  8 +++----
 2 files changed, 16 insertions(+), 16 deletions(-)

diff --git a/drivers/staging/olpc_dcon/olpc_dcon.h b/drivers/staging/olpc_dcon/olpc_dcon.h
index c987aaf894e7..277b19967315 100644
--- a/drivers/staging/olpc_dcon/olpc_dcon.h
+++ b/drivers/staging/olpc_dcon/olpc_dcon.h
@@ -10,18 +10,18 @@
 #define DCON_REG_ID		 0
 #define DCON_REG_MODE		 1
 
-#define MODE_PASSTHRU	BIT(0)
-#define MODE_SLEEP	BIT(1)
-#define MODE_SLEEP_AUTO	BIT(2)
-#define MODE_BL_ENABLE	BIT(3)
-#define MODE_BLANK	BIT(4)
-#define MODE_CSWIZZLE	BIT(5)
-#define MODE_COL_AA	BIT(6)
-#define MODE_MONO_LUMA	BIT(7)
-#define MODE_SCAN_INT	BIT(8)
-#define MODE_CLOCKDIV	BIT(9)
-#define MODE_DEBUG	BIT(14)
-#define MODE_SELFTEST	BIT(15)
+#define MODE_PASSTHRU		BIT(0)
+#define MODE_SLEEP		BIT(1)
+#define MODE_SLEEP_AUTO		BIT(2)
+#define MODE_BL_ENABLE		BIT(3)
+#define MODE_BLANK		BIT(4)
+#define MODE_CSWIZZLE		BIT(5)
+#define MODE_COL_AA		BIT(6)
+#define MODE_MONO_LUMA		BIT(7)
+#define MODE_SCAN_INT		BIT(8)
+#define MODE_CLOCKDIV		BIT(9)
+#define MODE_DEBUG		BIT(14)
+#define MODE_SELFTEST		BIT(15)
 
 #define DCON_REG_HRES		0x2
 #define DCON_REG_HTOTAL		0x3
diff --git a/drivers/staging/olpc_dcon/olpc_dcon_xo_1_5.c b/drivers/staging/olpc_dcon/olpc_dcon_xo_1_5.c
index 838daa2be3ef..7972b591d1b8 100644
--- a/drivers/staging/olpc_dcon/olpc_dcon_xo_1_5.c
+++ b/drivers/staging/olpc_dcon/olpc_dcon_xo_1_5.c
@@ -31,10 +31,10 @@
  *	DCONSMBCLK connects to VX855 graphics CRTSPCLK
  */
 
-#define VX855_GENL_PURPOSE_OUTPUT 0x44c /* PMIO_Rx4c-4f */
-#define VX855_GPI_STATUS_CHG 0x450  /* PMIO_Rx50 */
-#define VX855_GPI_SCI_SMI 0x452  /* PMIO_Rx52 */
-#define BIT_GPIO12 0x40
+#define VX855_GENL_PURPOSE_OUTPUT	0x44c /* PMIO_Rx4c-4f */
+#define VX855_GPI_STATUS_CHG		0x450  /* PMIO_Rx50 */
+#define VX855_GPI_SCI_SMI		0x452  /* PMIO_Rx52 */
+#define BIT_GPIO12			0x40
 
 #define PREFIX "OLPC DCON:"
 
-- 
2.19.1


^ permalink raw reply	[flat|nested] 2+ messages in thread

* Re: [PATCH] staging: olpc_dcon: Add Tabs to define-Macros
  2019-03-22  9:52 [PATCH] staging: olpc_dcon: Add Tabs to define-Macros Emanuel Bennici
@ 2019-03-22 14:17 ` Greg Kroah-Hartman
  0 siblings, 0 replies; 2+ messages in thread
From: Greg Kroah-Hartman @ 2019-03-22 14:17 UTC (permalink / raw)
  To: Emanuel Bennici
  Cc: linux-kernel, Jens Frederich, Daniel Drake, Jon Nettleton, Joe Perches

On Fri, Mar 22, 2019 at 10:52:43AM +0100, Emanuel Bennici wrote:
> Improve Code Readability by adding Tabs after #define-Macro
> definition.
> 
> Signed-off-by: Emanuel Bennici <benniciemanuel78@gmail.com>
> ---
>  drivers/staging/olpc_dcon/olpc_dcon.h        | 24 ++++++++++----------
>  drivers/staging/olpc_dcon/olpc_dcon_xo_1_5.c |  8 +++----
>  2 files changed, 16 insertions(+), 16 deletions(-)
> 
> diff --git a/drivers/staging/olpc_dcon/olpc_dcon.h b/drivers/staging/olpc_dcon/olpc_dcon.h
> index c987aaf894e7..277b19967315 100644
> --- a/drivers/staging/olpc_dcon/olpc_dcon.h
> +++ b/drivers/staging/olpc_dcon/olpc_dcon.h
> @@ -10,18 +10,18 @@
>  #define DCON_REG_ID		 0
>  #define DCON_REG_MODE		 1
>  
> -#define MODE_PASSTHRU	BIT(0)
> -#define MODE_SLEEP	BIT(1)
> -#define MODE_SLEEP_AUTO	BIT(2)
> -#define MODE_BL_ENABLE	BIT(3)
> -#define MODE_BLANK	BIT(4)
> -#define MODE_CSWIZZLE	BIT(5)
> -#define MODE_COL_AA	BIT(6)
> -#define MODE_MONO_LUMA	BIT(7)
> -#define MODE_SCAN_INT	BIT(8)
> -#define MODE_CLOCKDIV	BIT(9)
> -#define MODE_DEBUG	BIT(14)
> -#define MODE_SELFTEST	BIT(15)
> +#define MODE_PASSTHRU		BIT(0)
> +#define MODE_SLEEP		BIT(1)
> +#define MODE_SLEEP_AUTO		BIT(2)
> +#define MODE_BL_ENABLE		BIT(3)
> +#define MODE_BLANK		BIT(4)
> +#define MODE_CSWIZZLE		BIT(5)
> +#define MODE_COL_AA		BIT(6)
> +#define MODE_MONO_LUMA		BIT(7)
> +#define MODE_SCAN_INT		BIT(8)
> +#define MODE_CLOCKDIV		BIT(9)
> +#define MODE_DEBUG		BIT(14)
> +#define MODE_SELFTEST		BIT(15)

These really did not have to be changed, did they?

>  
>  #define DCON_REG_HRES		0x2
>  #define DCON_REG_HTOTAL		0x3
> diff --git a/drivers/staging/olpc_dcon/olpc_dcon_xo_1_5.c b/drivers/staging/olpc_dcon/olpc_dcon_xo_1_5.c
> index 838daa2be3ef..7972b591d1b8 100644
> --- a/drivers/staging/olpc_dcon/olpc_dcon_xo_1_5.c
> +++ b/drivers/staging/olpc_dcon/olpc_dcon_xo_1_5.c
> @@ -31,10 +31,10 @@
>   *	DCONSMBCLK connects to VX855 graphics CRTSPCLK
>   */
>  
> -#define VX855_GENL_PURPOSE_OUTPUT 0x44c /* PMIO_Rx4c-4f */
> -#define VX855_GPI_STATUS_CHG 0x450  /* PMIO_Rx50 */
> -#define VX855_GPI_SCI_SMI 0x452  /* PMIO_Rx52 */
> -#define BIT_GPIO12 0x40
> +#define VX855_GENL_PURPOSE_OUTPUT	0x44c /* PMIO_Rx4c-4f */
> +#define VX855_GPI_STATUS_CHG		0x450  /* PMIO_Rx50 */
> +#define VX855_GPI_SCI_SMI		0x452  /* PMIO_Rx52 */
> +#define BIT_GPIO12			0x40

Also use a tab before the comment on these lines.

thanks,

greg k-h

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2019-03-22 14:17 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2019-03-22  9:52 [PATCH] staging: olpc_dcon: Add Tabs to define-Macros Emanuel Bennici
2019-03-22 14:17 ` Greg Kroah-Hartman

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®