mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Oscar Carter <oscar.carter@gmx.com>
To: Forest Bond <forest@alittletooquiet.net>,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Cc: Oscar Carter <oscar.carter@gmx.com>,
	Malcolm Priestley <tvboxspy@gmail.com>,
	Dan Carpenter <dan.carpenter@oracle.com>,
	Quentin Deslandes <quentin.deslandes@itdev.co.uk>,
	Amir Mahdi Ghorbanian <indigoomega021@gmail.com>,
	devel@driverdev.osuosl.org, linux-kernel@vger.kernel.org
Subject: [PATCH 2/2] staging: vt6656: Remove unnecessary local variable initialization
Date: Tue,  7 Apr 2020 18:29:59 +0200	[thread overview]
Message-ID: <20200407162959.7318-3-oscar.carter@gmx.com> (raw)
In-Reply-To: <20200407162959.7318-1-oscar.carter@gmx.com>

Don't initialize the rate variable as it is set a few lines later.

Reviewed-by: Dan Carpenter <dan.carpenter@oracle.com>
Signed-off-by: Oscar Carter <oscar.carter@gmx.com>
---
 drivers/staging/vt6656/baseband.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/staging/vt6656/baseband.c b/drivers/staging/vt6656/baseband.c
index 092e56668a09..5d9bc97916a5 100644
--- a/drivers/staging/vt6656/baseband.c
+++ b/drivers/staging/vt6656/baseband.c
@@ -135,7 +135,7 @@ unsigned int vnt_get_frame_time(u8 preamble_type, u8 pkt_type,
 {
 	unsigned int frame_time;
 	unsigned int preamble;
-	unsigned int rate = 0;
+	unsigned int rate;

 	if (tx_rate > RATE_54M)
 		return 0;
--
2.20.1


  parent reply	other threads:[~2020-04-07 16:31 UTC|newest]

Thread overview: 5+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-04-07 16:29 [PATCH v2 0/2] staging: vt6656: Cleanup of the vnt_get_frame_time function Oscar Carter
2020-04-07 16:29 ` [PATCH 1/2] staging: vt6656: Use define instead of magic number for tx_rate Oscar Carter
2020-04-07 16:29 ` Oscar Carter [this message]
2020-04-07 16:44 ` [PATCH v2 0/2] staging: vt6656: Cleanup of the vnt_get_frame_time function Oscar Carter
2020-04-11 12:51 [PATCH 0/2] staging: vt6656: Refactor the vnt_vt3184_init function Oscar Carter
2020-04-11 12:51 ` [PATCH 2/2] staging: vt6656: Remove unnecessary local variable initialization Oscar Carter

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200407162959.7318-3-oscar.carter@gmx.com \
    --to=oscar.carter@gmx.com \
    --cc=dan.carpenter@oracle.com \
    --cc=devel@driverdev.osuosl.org \
    --cc=forest@alittletooquiet.net \
    --cc=gregkh@linuxfoundation.org \
    --cc=indigoomega021@gmail.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=quentin.deslandes@itdev.co.uk \
    --cc=tvboxspy@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®