* [PATCH v2 0/2] staging: vt6656: Cleanup of the vnt_get_frame_time function
@ 2020-04-07 16:29 Oscar Carter
2020-04-07 16:29 ` [PATCH 1/2] staging: vt6656: Use define instead of magic number for tx_rate Oscar Carter
` (2 more replies)
0 siblings, 3 replies; 5+ messages in thread
From: Oscar Carter @ 2020-04-07 16:29 UTC (permalink / raw)
To: Forest Bond, Greg Kroah-Hartman
Cc: Oscar Carter, Malcolm Priestley, Dan Carpenter,
Quentin Deslandes, Amir Mahdi Ghorbanian, devel, linux-kernel
This patch series makes a cleanup of the vnt_get_frame_time function.
The first patch makes use of the define RATE_11M instead of a magic
number. The second patch remove unnecessary local variable initialization.
Changelog v1 -> v2
- Not use the ARRAY_SIZE macro to compare against the tx_rate variable.
Oscar Carter (2):
staging: vt6656: Use define instead of magic number for tx_rate
staging: vt6656: Remove unnecessary local variable initialization
drivers/staging/vt6656/baseband.c | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
--
2.20.1
^ permalink raw reply [flat|nested] 5+ messages in thread* [PATCH 1/2] staging: vt6656: Use define instead of magic number for tx_rate
2020-04-07 16:29 [PATCH v2 0/2] staging: vt6656: Cleanup of the vnt_get_frame_time function Oscar Carter
@ 2020-04-07 16:29 ` Oscar Carter
2020-04-07 16:29 ` [PATCH 2/2] staging: vt6656: Remove unnecessary local variable initialization Oscar Carter
2020-04-07 16:44 ` [PATCH v2 0/2] staging: vt6656: Cleanup of the vnt_get_frame_time function Oscar Carter
2 siblings, 0 replies; 5+ messages in thread
From: Oscar Carter @ 2020-04-07 16:29 UTC (permalink / raw)
To: Forest Bond, Greg Kroah-Hartman
Cc: Oscar Carter, Malcolm Priestley, Dan Carpenter,
Quentin Deslandes, Amir Mahdi Ghorbanian, devel, linux-kernel
Use the define RATE_11M present in the file "device.h" instead of the
magic number 3. So the code is more clear.
Reviewed-by: Dan Carpenter <dan.carpenter@oracle.com>
Signed-off-by: Oscar Carter <oscar.carter@gmx.com>
---
drivers/staging/vt6656/baseband.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/drivers/staging/vt6656/baseband.c b/drivers/staging/vt6656/baseband.c
index a19a563d8bcc..092e56668a09 100644
--- a/drivers/staging/vt6656/baseband.c
+++ b/drivers/staging/vt6656/baseband.c
@@ -24,6 +24,7 @@
#include <linux/bits.h>
#include <linux/kernel.h>
+#include "device.h"
#include "mac.h"
#include "baseband.h"
#include "rf.h"
@@ -141,7 +142,7 @@ unsigned int vnt_get_frame_time(u8 preamble_type, u8 pkt_type,
rate = (unsigned int)vnt_frame_time[tx_rate];
- if (tx_rate <= 3) {
+ if (tx_rate <= RATE_11M) {
if (preamble_type == 1)
preamble = 96;
else
--
2.20.1
^ permalink raw reply [flat|nested] 5+ messages in thread* [PATCH 2/2] staging: vt6656: Remove unnecessary local variable initialization
2020-04-07 16:29 [PATCH v2 0/2] staging: vt6656: Cleanup of the vnt_get_frame_time function Oscar Carter
2020-04-07 16:29 ` [PATCH 1/2] staging: vt6656: Use define instead of magic number for tx_rate Oscar Carter
@ 2020-04-07 16:29 ` Oscar Carter
2020-04-07 16:44 ` [PATCH v2 0/2] staging: vt6656: Cleanup of the vnt_get_frame_time function Oscar Carter
2 siblings, 0 replies; 5+ messages in thread
From: Oscar Carter @ 2020-04-07 16:29 UTC (permalink / raw)
To: Forest Bond, Greg Kroah-Hartman
Cc: Oscar Carter, Malcolm Priestley, Dan Carpenter,
Quentin Deslandes, Amir Mahdi Ghorbanian, devel, linux-kernel
Don't initialize the rate variable as it is set a few lines later.
Reviewed-by: Dan Carpenter <dan.carpenter@oracle.com>
Signed-off-by: Oscar Carter <oscar.carter@gmx.com>
---
drivers/staging/vt6656/baseband.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/vt6656/baseband.c b/drivers/staging/vt6656/baseband.c
index 092e56668a09..5d9bc97916a5 100644
--- a/drivers/staging/vt6656/baseband.c
+++ b/drivers/staging/vt6656/baseband.c
@@ -135,7 +135,7 @@ unsigned int vnt_get_frame_time(u8 preamble_type, u8 pkt_type,
{
unsigned int frame_time;
unsigned int preamble;
- unsigned int rate = 0;
+ unsigned int rate;
if (tx_rate > RATE_54M)
return 0;
--
2.20.1
^ permalink raw reply [flat|nested] 5+ messages in thread* Re: [PATCH v2 0/2] staging: vt6656: Cleanup of the vnt_get_frame_time function
2020-04-07 16:29 [PATCH v2 0/2] staging: vt6656: Cleanup of the vnt_get_frame_time function Oscar Carter
2020-04-07 16:29 ` [PATCH 1/2] staging: vt6656: Use define instead of magic number for tx_rate Oscar Carter
2020-04-07 16:29 ` [PATCH 2/2] staging: vt6656: Remove unnecessary local variable initialization Oscar Carter
@ 2020-04-07 16:44 ` Oscar Carter
2 siblings, 0 replies; 5+ messages in thread
From: Oscar Carter @ 2020-04-07 16:44 UTC (permalink / raw)
To: Forest Bond, Greg Kroah-Hartman
Cc: Oscar Carter, Malcolm Priestley, Dan Carpenter,
Quentin Deslandes, Amir Mahdi Ghorbanian, devel, linux-kernel
On Tue, Apr 07, 2020 at 06:29:57PM +0200, Oscar Carter wrote:
> This patch series makes a cleanup of the vnt_get_frame_time function.
>
> The first patch makes use of the define RATE_11M instead of a magic
> number. The second patch remove unnecessary local variable initialization.
>
> Changelog v1 -> v2
> - Not use the ARRAY_SIZE macro to compare against the tx_rate variable.
>
> Oscar Carter (2):
> staging: vt6656: Use define instead of magic number for tx_rate
> staging: vt6656: Remove unnecessary local variable initialization
>
> drivers/staging/vt6656/baseband.c | 5 +++--
> 1 file changed, 3 insertions(+), 2 deletions(-)
>
> --
> 2.20.1
>
Don't review this patch series as I have sent a new version. Sorry.
Thanks
Oscar Carter
^ permalink raw reply [flat|nested] 5+ messages in thread
* [PATCH 0/2] staging: vt6656: Refactor the vnt_vt3184_init function
@ 2020-04-11 12:51 Oscar Carter
2020-04-11 12:51 ` [PATCH 2/2] staging: vt6656: Remove unnecessary local variable initialization Oscar Carter
0 siblings, 1 reply; 5+ messages in thread
From: Oscar Carter @ 2020-04-11 12:51 UTC (permalink / raw)
To: Forest Bond, Greg Kroah-Hartman
Cc: Oscar Carter, Malcolm Priestley, Quentin Deslandes,
Amir Mahdi Ghorbanian, devel, linux-kernel
This patch series makes a refactor of the vnt_vt3184_init function through
two patches.
The first one removes duplicate code in the if statements because
different branches are almost the same.
The second patch remove unnecessary local variable initialization.
Oscar Carter (2):
staging: vt6656: Remove duplicate code in vnt_vt3184_init function
staging: vt6656: Remove unnecessary local variable initialization
drivers/staging/vt6656/baseband.c | 54 ++++++++-----------------------
1 file changed, 13 insertions(+), 41 deletions(-)
--
2.20.1
^ permalink raw reply [flat|nested] 5+ messages in thread
* [PATCH 2/2] staging: vt6656: Remove unnecessary local variable initialization
2020-04-11 12:51 [PATCH 0/2] staging: vt6656: Refactor the vnt_vt3184_init function Oscar Carter
@ 2020-04-11 12:51 ` Oscar Carter
0 siblings, 0 replies; 5+ messages in thread
From: Oscar Carter @ 2020-04-11 12:51 UTC (permalink / raw)
To: Forest Bond, Greg Kroah-Hartman
Cc: Oscar Carter, Malcolm Priestley, Quentin Deslandes,
Amir Mahdi Ghorbanian, devel, linux-kernel
Don't initialize the ret variable as it is set a few lines later.
Signed-off-by: Oscar Carter <oscar.carter@gmx.com>
---
drivers/staging/vt6656/baseband.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/vt6656/baseband.c b/drivers/staging/vt6656/baseband.c
index 276210a7284e..10d1f2cbb3d9 100644
--- a/drivers/staging/vt6656/baseband.c
+++ b/drivers/staging/vt6656/baseband.c
@@ -352,7 +352,7 @@ int vnt_set_antenna_mode(struct vnt_private *priv, u8 antenna_mode)
int vnt_vt3184_init(struct vnt_private *priv)
{
- int ret = 0;
+ int ret;
u16 length;
u8 *addr;
u8 data;
--
2.20.1
^ permalink raw reply [flat|nested] 5+ messages in thread
end of thread, other threads:[~2020-04-11 12:52 UTC | newest]
Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-04-07 16:29 [PATCH v2 0/2] staging: vt6656: Cleanup of the vnt_get_frame_time function Oscar Carter
2020-04-07 16:29 ` [PATCH 1/2] staging: vt6656: Use define instead of magic number for tx_rate Oscar Carter
2020-04-07 16:29 ` [PATCH 2/2] staging: vt6656: Remove unnecessary local variable initialization Oscar Carter
2020-04-07 16:44 ` [PATCH v2 0/2] staging: vt6656: Cleanup of the vnt_get_frame_time function Oscar Carter
2020-04-11 12:51 [PATCH 0/2] staging: vt6656: Refactor the vnt_vt3184_init function Oscar Carter
2020-04-11 12:51 ` [PATCH 2/2] staging: vt6656: Remove unnecessary local variable initialization Oscar Carter
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®