mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH 0/5] staging: vt6656: Rebase all rejected patches
@ 2020-04-14 15:38 Oscar Carter
  2020-04-14 15:38 ` [PATCH 1/5] staging: vt6656: Return error code in vnt_rf_write_embedded function Oscar Carter
                   ` (4 more replies)
  0 siblings, 5 replies; 6+ messages in thread
From: Oscar Carter @ 2020-04-14 15:38 UTC (permalink / raw)
  To: Forest Bond, Greg Kroah-Hartman
  Cc: Oscar Carter, Quentin Deslandes, Malcolm Priestley,
	Dan Carpenter, Amir Mahdi Ghorbanian, John B. Wyatt IV,
	Colin Ian King, devel, linux-kernel

This patch series makes a "rebase" of all the patches that were
previously rejected because they did not apply.

The first patch uses the error code returned by the vnt_control_out
function as the returned value of the vnt_rf_write_embedded function
instead of a boolean value. This way, the return value is an error code.
Also, fix all the vnt_rf_write_embedded calls accordingly.

The second patch uses the BIT() macro instead of the bit left shift
operator.

The third patch use the define RATE_11M present in the file "device.h"
instead of the magic number 3.

The fourth patch creates a constant array with the values of the
"phy->signal" variable for every rate and makes a refactor of the
assignment of this variable.

The fifth path takes out the "phy->service" assignment from the if-else
statement due to it's the same for the two branches.

Oscar Carter (5):
  staging: vt6656: Return error code in vnt_rf_write_embedded function
  staging: vt6656: Use BIT() macro instead of bit shift operator
  staging: vt6656: Use define instead of magic number for tx_rate
  staging: vt6656: Refactor the assignment of the phy->signal variable
  staging: vt6656: Remove duplicate code for the phy->service assignment

 drivers/staging/vt6656/baseband.c | 111 ++++++++----------------------
 drivers/staging/vt6656/card.c     |   4 +-
 drivers/staging/vt6656/rf.c       |  99 ++++++++++++++++----------
 3 files changed, 95 insertions(+), 119 deletions(-)

--
2.20.1


^ permalink raw reply	[flat|nested] 6+ messages in thread

end of thread, other threads:[~2020-04-14 15:41 UTC | newest]

Thread overview: 6+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-04-14 15:38 [PATCH 0/5] staging: vt6656: Rebase all rejected patches Oscar Carter
2020-04-14 15:38 ` [PATCH 1/5] staging: vt6656: Return error code in vnt_rf_write_embedded function Oscar Carter
2020-04-14 15:38 ` [PATCH 2/5] staging: vt6656: Use BIT() macro instead of bit shift operator Oscar Carter
2020-04-14 15:38 ` [PATCH 3/5] staging: vt6656: Use define instead of magic number for tx_rate Oscar Carter
2020-04-14 15:38 ` [PATCH 4/5] staging: vt6656: Refactor the assignment of the phy->signal variable Oscar Carter
2020-04-14 15:38 ` [PATCH 5/5] staging: vt6656: Remove duplicate code for the phy->service assignment Oscar Carter

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®