From: Sean V Kelley <sean.v.kelley@intel.com>
To: bhelgaas@google.com, Jonathan.Cameron@huawei.com,
xerces.zhao@gmail.com, rafael.j.wysocki@intel.com,
ashok.raj@intel.com, tony.luck@intel.com,
sathyanarayanan.kuppuswamy@intel.com, qiuxu.zhuo@intel.com
Cc: linux-pci@vger.kernel.org, linux-kernel@vger.kernel.org,
Sean V Kelley <sean.v.kelley@intel.com>
Subject: [PATCH v10 07/16] PCI/ERR: Simplify by computing pci_pcie_type() once
Date: Thu, 5 Nov 2020 16:14:35 -0800 [thread overview]
Message-ID: <20201106001444.667232-8-sean.v.kelley@intel.com> (raw)
In-Reply-To: <20201106001444.667232-1-sean.v.kelley@intel.com>
Instead of calling pci_pcie_type(dev) twice, call it once and save the
result. No functional change intended.
[bhelgaas: split to separate patch]
Link: https://lore.kernel.org/r/20201002184735.1229220-6-seanvk.dev@oregontracks.org
Signed-off-by: Sean V Kelley <sean.v.kelley@intel.com>
Signed-off-by: Bjorn Helgaas <bhelgaas@google.com>
Acked-by: Jonathan Cameron <Jonathan.Cameron@huawei.com>
---
drivers/pci/pcie/err.c | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
diff --git a/drivers/pci/pcie/err.c b/drivers/pci/pcie/err.c
index 05f61da5ed9d..7a5af873d8bc 100644
--- a/drivers/pci/pcie/err.c
+++ b/drivers/pci/pcie/err.c
@@ -150,6 +150,7 @@ pci_ers_result_t pcie_do_recovery(struct pci_dev *dev,
pci_channel_state_t state,
pci_ers_result_t (*reset_subordinates)(struct pci_dev *pdev))
{
+ int type = pci_pcie_type(dev);
pci_ers_result_t status = PCI_ERS_RESULT_CAN_RECOVER;
struct pci_bus *bus;
@@ -157,8 +158,8 @@ pci_ers_result_t pcie_do_recovery(struct pci_dev *dev,
* Error recovery runs on all subordinates of the first downstream port.
* If the downstream port detected the error, it is cleared at the end.
*/
- if (!(pci_pcie_type(dev) == PCI_EXP_TYPE_ROOT_PORT ||
- pci_pcie_type(dev) == PCI_EXP_TYPE_DOWNSTREAM))
+ if (!(type == PCI_EXP_TYPE_ROOT_PORT ||
+ type == PCI_EXP_TYPE_DOWNSTREAM))
dev = pci_upstream_bridge(dev);
bus = dev->subordinate;
--
2.29.2
next prev parent reply other threads:[~2020-11-06 0:15 UTC|newest]
Thread overview: 18+ messages / expand[flat|nested] mbox.gz Atom feed top
2020-11-06 0:14 [PATCH v10 00/16] Add RCEC handling to PCI/AER Sean V Kelley
2020-11-06 0:14 ` [PATCH v10 01/16] AER: aer_root_reset() non-native handling Sean V Kelley
2020-11-06 0:14 ` [PATCH v10 02/16] PCI/RCEC: Add RCEC class code and extended capability Sean V Kelley
2020-11-06 0:14 ` [PATCH v10 03/16] PCI/RCEC: Bind RCEC devices to the Root Port driver Sean V Kelley
2020-11-06 0:14 ` [PATCH v10 04/16] PCI/RCEC: Cache RCEC capabilities in pci_init_capabilities() Sean V Kelley
2020-11-06 0:14 ` [PATCH v10 05/16] PCI/ERR: Rename reset_link() to reset_subordinates() Sean V Kelley
2020-11-06 0:14 ` [PATCH v10 06/16] PCI/ERR: Simplify by using pci_upstream_bridge() Sean V Kelley
2020-11-06 0:14 ` Sean V Kelley [this message]
2020-11-06 0:14 ` [PATCH v10 08/16] PCI/ERR: Use "bridge" for clarity in pcie_do_recovery() Sean V Kelley
2020-11-06 0:14 ` [PATCH v10 09/16] PCI/ERR: Avoid negated conditional for clarity Sean V Kelley
2020-11-06 0:14 ` [PATCH v10 10/16] PCI/ERR: Add pci_walk_bridge() to pcie_do_recovery() Sean V Kelley
2020-11-06 0:14 ` [PATCH v10 11/16] PCI/ERR: Limit AER resets in pcie_do_recovery() Sean V Kelley
2020-11-06 0:14 ` [PATCH v10 12/16] PCI/RCEC: Add pcie_link_rcec() to associate RCiEPs Sean V Kelley
2020-11-06 0:14 ` [PATCH v10 13/16] PCI/RCEC: Add RCiEP's linked RCEC to AER/ERR Sean V Kelley
2020-11-06 0:40 ` Sean V Kelley
2020-11-06 0:14 ` [PATCH v10 14/16] PCI/AER: Add pcie_walk_rcec() to RCEC AER handling Sean V Kelley
2020-11-06 0:14 ` [PATCH v10 15/16] PCI/PME: Add pcie_walk_rcec() to RCEC PME handling Sean V Kelley
2020-11-06 0:14 ` [PATCH v10 16/16] PCI/AER: Add RCEC AER error injection support Sean V Kelley
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20201106001444.667232-8-sean.v.kelley@intel.com \
--to=sean.v.kelley@intel.com \
--cc=Jonathan.Cameron@huawei.com \
--cc=ashok.raj@intel.com \
--cc=bhelgaas@google.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-pci@vger.kernel.org \
--cc=qiuxu.zhuo@intel.com \
--cc=rafael.j.wysocki@intel.com \
--cc=sathyanarayanan.kuppuswamy@intel.com \
--cc=tony.luck@intel.com \
--cc=xerces.zhao@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®