* [PATCH 1/2] ASoC: amd: ps: update macros with ps platform naming convention
@ 2022-11-16 10:59 Syed Saba Kareem
2022-11-16 10:59 ` [PATCH 2/2] ASoC: amd: ps: Move acp63_dev_data strcture from PCI driver Syed Saba Kareem
2022-11-16 14:45 ` [PATCH 1/2] ASoC: amd: ps: update macros with ps platform naming convention Mark Brown
0 siblings, 2 replies; 3+ messages in thread
From: Syed Saba Kareem @ 2022-11-16 10:59 UTC (permalink / raw)
To: broonie, alsa-devel
Cc: Vijendar.Mukunda, Basavaraj.Hiregoudar, Sunil-kumar.Dommati,
mario.limonciello, Syed Saba Kareem, Liam Girdwood,
Jaroslav Kysela, Takashi Iwai, open list
Update macros using ps platform naming convention.
Signed-off-by: Syed Saba Kareem <Syed.SabaKareem@amd.com>
---
sound/soc/amd/ps/acp63.h | 8 ++++----
sound/soc/amd/ps/pci-ps.c | 14 +++++++-------
2 files changed, 11 insertions(+), 11 deletions(-)
diff --git a/sound/soc/amd/ps/acp63.h b/sound/soc/amd/ps/acp63.h
index 85f869c2229f..a90ba3b20dc7 100644
--- a/sound/soc/amd/ps/acp63.h
+++ b/sound/soc/amd/ps/acp63.h
@@ -8,10 +8,10 @@
#include <sound/acp63_chip_offset_byte.h>
#define ACP_DEVICE_ID 0x15E2
-#define ACP6x_REG_START 0x1240000
-#define ACP6x_REG_END 0x1250200
-#define ACP6x_DEVS 3
-#define ACP6x_PDM_MODE 1
+#define ACP63_REG_START 0x1240000
+#define ACP63_REG_END 0x1250200
+#define ACP63_DEVS 3
+#define ACP63_PDM_MODE 1
#define ACP_SOFT_RESET_SOFTRESET_AUDDONE_MASK 0x00010001
#define ACP_PGFSM_CNTL_POWER_ON_MASK 1
diff --git a/sound/soc/amd/ps/pci-ps.c b/sound/soc/amd/ps/pci-ps.c
index 08c4b9bef055..98dddd1a0cf4 100644
--- a/sound/soc/amd/ps/pci-ps.c
+++ b/sound/soc/amd/ps/pci-ps.c
@@ -21,7 +21,7 @@ struct acp63_dev_data {
void __iomem *acp63_base;
struct resource *res;
bool acp63_audio_mode;
- struct platform_device *pdev[ACP6x_DEVS];
+ struct platform_device *pdev[ACP63_DEVS];
};
static int acp63_power_on(void __iomem *acp_base)
@@ -143,7 +143,7 @@ static int snd_acp63_probe(struct pci_dev *pci,
const struct pci_device_id *pci_id)
{
struct acp63_dev_data *adata;
- struct platform_device_info pdevinfo[ACP6x_DEVS];
+ struct platform_device_info pdevinfo[ACP63_DEVS];
int index, ret;
int val = 0x00;
struct acpi_device *adev;
@@ -219,8 +219,8 @@ static int snd_acp63_probe(struct pci_dev *pci,
adata->res->name = "acp_iomem";
adata->res->flags = IORESOURCE_MEM;
adata->res->start = addr;
- adata->res->end = addr + (ACP6x_REG_END - ACP6x_REG_START);
- adata->acp63_audio_mode = ACP6x_PDM_MODE;
+ adata->res->end = addr + (ACP63_REG_END - ACP63_REG_START);
+ adata->acp63_audio_mode = ACP63_PDM_MODE;
memset(&pdevinfo, 0, sizeof(pdevinfo));
pdevinfo[0].name = "acp_ps_pdm_dma";
@@ -237,7 +237,7 @@ static int snd_acp63_probe(struct pci_dev *pci,
pdevinfo[2].id = 0;
pdevinfo[2].parent = &pci->dev;
- for (index = 0; index < ACP6x_DEVS; index++) {
+ for (index = 0; index < ACP63_DEVS; index++) {
adata->pdev[index] =
platform_device_register_full(&pdevinfo[index]);
@@ -312,8 +312,8 @@ static void snd_acp63_remove(struct pci_dev *pci)
int ret, index;
adata = pci_get_drvdata(pci);
- if (adata->acp63_audio_mode == ACP6x_PDM_MODE) {
- for (index = 0; index < ACP6x_DEVS; index++)
+ if (adata->acp63_audio_mode == ACP63_PDM_MODE) {
+ for (index = 0; index < ACP63_DEVS; index++)
platform_device_unregister(adata->pdev[index]);
}
ret = acp63_deinit(adata->acp63_base, &pci->dev);
--
2.25.1
^ permalink raw reply [flat|nested] 3+ messages in thread
* [PATCH 2/2] ASoC: amd: ps: Move acp63_dev_data strcture from PCI driver
2022-11-16 10:59 [PATCH 1/2] ASoC: amd: ps: update macros with ps platform naming convention Syed Saba Kareem
@ 2022-11-16 10:59 ` Syed Saba Kareem
2022-11-16 14:45 ` [PATCH 1/2] ASoC: amd: ps: update macros with ps platform naming convention Mark Brown
1 sibling, 0 replies; 3+ messages in thread
From: Syed Saba Kareem @ 2022-11-16 10:59 UTC (permalink / raw)
To: broonie, alsa-devel
Cc: Vijendar.Mukunda, Basavaraj.Hiregoudar, Sunil-kumar.Dommati,
mario.limonciello, Syed Saba Kareem, Liam Girdwood,
Jaroslav Kysela, Takashi Iwai, open list
Move acp63_dev_data structure from PCI driver to acp header file.
Signed-off-by: Syed Saba Kareem <Syed.SabaKareem@amd.com>
---
sound/soc/amd/ps/acp63.h | 7 +++++++
sound/soc/amd/ps/pci-ps.c | 7 -------
2 files changed, 7 insertions(+), 7 deletions(-)
diff --git a/sound/soc/amd/ps/acp63.h b/sound/soc/amd/ps/acp63.h
index a90ba3b20dc7..5e7f9c1c1b0e 100644
--- a/sound/soc/amd/ps/acp63.h
+++ b/sound/soc/amd/ps/acp63.h
@@ -96,3 +96,10 @@ static inline void acp63_writel(u32 val, void __iomem *base_addr)
{
writel(val, base_addr);
}
+
+struct acp63_dev_data {
+ void __iomem *acp63_base;
+ struct resource *res;
+ bool acp63_audio_mode;
+ struct platform_device *pdev[ACP63_DEVS];
+};
diff --git a/sound/soc/amd/ps/pci-ps.c b/sound/soc/amd/ps/pci-ps.c
index 98dddd1a0cf4..489f01a20699 100644
--- a/sound/soc/amd/ps/pci-ps.c
+++ b/sound/soc/amd/ps/pci-ps.c
@@ -17,13 +17,6 @@
#include "acp63.h"
-struct acp63_dev_data {
- void __iomem *acp63_base;
- struct resource *res;
- bool acp63_audio_mode;
- struct platform_device *pdev[ACP63_DEVS];
-};
-
static int acp63_power_on(void __iomem *acp_base)
{
u32 val;
--
2.25.1
^ permalink raw reply [flat|nested] 3+ messages in thread
* Re: [PATCH 1/2] ASoC: amd: ps: update macros with ps platform naming convention
2022-11-16 10:59 [PATCH 1/2] ASoC: amd: ps: update macros with ps platform naming convention Syed Saba Kareem
2022-11-16 10:59 ` [PATCH 2/2] ASoC: amd: ps: Move acp63_dev_data strcture from PCI driver Syed Saba Kareem
@ 2022-11-16 14:45 ` Mark Brown
1 sibling, 0 replies; 3+ messages in thread
From: Mark Brown @ 2022-11-16 14:45 UTC (permalink / raw)
To: alsa-devel, Syed Saba Kareem
Cc: Liam Girdwood, open list, Sunil-kumar.Dommati, mario.limonciello,
Vijendar.Mukunda, Jaroslav Kysela, Takashi Iwai,
Basavaraj.Hiregoudar
On Wed, 16 Nov 2022 16:29:22 +0530, Syed Saba Kareem wrote:
> Update macros using ps platform naming convention.
>
>
Applied to
broonie/sound.git for-next
Thanks!
[1/2] ASoC: amd: ps: update macros with ps platform naming convention
commit: d25ec74c6c5419f834bab506f251bc760bdfb858
[2/2] ASoC: amd: ps: Move acp63_dev_data strcture from PCI driver
commit: 7d95977533e14738e8193c14a7efac369288aeee
All being well this means that it will be integrated into the linux-next
tree (usually sometime in the next 24 hours) and sent to Linus during
the next merge window (or sooner if it is a bug fix), however if
problems are discovered then the patch may be dropped or reverted.
You may get further e-mails resulting from automated or manual testing
and review of the tree, please engage with people reporting problems and
send followup patches addressing any issues that are reported if needed.
If any updates are required or you are submitting further changes they
should be sent as incremental updates against current git, existing
patches will not be replaced.
Please add any relevant lists and maintainers to the CCs when replying
to this mail.
Thanks,
Mark
^ permalink raw reply [flat|nested] 3+ messages in thread
end of thread, other threads:[~2022-11-16 14:46 UTC | newest]
Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2022-11-16 10:59 [PATCH 1/2] ASoC: amd: ps: update macros with ps platform naming convention Syed Saba Kareem
2022-11-16 10:59 ` [PATCH 2/2] ASoC: amd: ps: Move acp63_dev_data strcture from PCI driver Syed Saba Kareem
2022-11-16 14:45 ` [PATCH 1/2] ASoC: amd: ps: update macros with ps platform naming convention Mark Brown
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®