From: Juergen Gross <jgross@suse.com>
To: linux-kernel@vger.kernel.org, x86@kernel.org
Cc: Juergen Gross <jgross@suse.com>,
Thomas Gleixner <tglx@linutronix.de>,
Ingo Molnar <mingo@redhat.com>, Borislav Petkov <bp@alien8.de>,
Dave Hansen <dave.hansen@linux.intel.com>,
"H. Peter Anvin" <hpa@zytor.com>,
Michael Kelley <mikelley@microsoft.com>
Subject: [PATCH v5 02/15] x86/mtrr: optimize mtrr_calc_physbits()
Date: Sat, 1 Apr 2023 08:36:39 +0200 [thread overview]
Message-ID: <20230401063652.23522-3-jgross@suse.com> (raw)
In-Reply-To: <20230401063652.23522-1-jgross@suse.com>
Optimize mtrr_calc_physbits() for better readability.
Drop a stale comment, as reality has made it obsolete.
[ bp:
- s/mtrr/MTRR/
- s/boot_cpu_has/cpu_feature_enabled/
- use GENMASK_ULL
- simplify. ]
Signed-off-by: Juergen Gross <jgross@suse.com>
Signed-off-by: Borislav Petkov (AMD) <bp@alien8.de>
Tested-by: Michael Kelley <mikelley@microsoft.com>
---
V3:
- new patch, split off from previous patch (Boris Petkov)
V5:
- add some modifications by Boris Petkov
---
arch/x86/kernel/cpu/mtrr/mtrr.c | 27 +++++++--------------------
1 file changed, 7 insertions(+), 20 deletions(-)
diff --git a/arch/x86/kernel/cpu/mtrr/mtrr.c b/arch/x86/kernel/cpu/mtrr/mtrr.c
index 8310bdb111d0..ce0b82209ad3 100644
--- a/arch/x86/kernel/cpu/mtrr/mtrr.c
+++ b/arch/x86/kernel/cpu/mtrr/mtrr.c
@@ -619,8 +619,6 @@ static struct syscore_ops mtrr_syscore_ops = {
int __initdata changed_by_mtrr_cleanup;
-#define SIZE_OR_MASK_BITS(n) (~((1ULL << ((n) - PAGE_SHIFT)) - 1))
-
static unsigned int __init mtrr_calc_physbits(bool generic)
{
unsigned int phys_addr;
@@ -628,15 +626,8 @@ static unsigned int __init mtrr_calc_physbits(bool generic)
phys_addr = 32;
if (generic) {
- size_or_mask = SIZE_OR_MASK_BITS(36);
- size_and_mask = 0x00f00000;
phys_addr = 36;
- /*
- * This is an AMD specific MSR, but we assume(hope?) that
- * Intel will implement it too when they extend the address
- * bus of the Xeon.
- */
if (cpuid_eax(0x80000000) >= 0x80000008) {
phys_addr = cpuid_eax(0x80000008) & 0xff;
/* CPUID workaround for Intel 0F33/0F34 CPU */
@@ -647,41 +638,37 @@ static unsigned int __init mtrr_calc_physbits(bool generic)
boot_cpu_data.x86_stepping == 0x4))
phys_addr = 36;
- size_or_mask = SIZE_OR_MASK_BITS(phys_addr);
- size_and_mask = ~size_or_mask & 0xfffff00000ULL;
} else if (boot_cpu_data.x86_vendor == X86_VENDOR_CENTAUR &&
boot_cpu_data.x86 == 6) {
/*
* VIA C* family have Intel style MTRRs,
* but don't support PAE
*/
- size_or_mask = SIZE_OR_MASK_BITS(32);
- size_and_mask = 0;
phys_addr = 32;
}
- } else {
- size_or_mask = SIZE_OR_MASK_BITS(32);
- size_and_mask = 0;
}
+ size_or_mask = ~GENMASK_ULL(phys_addr - PAGE_SHIFT - 1, 0);
+ size_and_mask = ~size_or_mask & GENMASK_ULL(39, 20);
+
return phys_addr;
}
/**
- * mtrr_bp_init - initialize mtrrs on the boot CPU
+ * mtrr_bp_init - initialize MTRRs on the boot CPU
*
* This needs to be called early; before any of the other CPUs are
* initialized (i.e. before smp_init()).
- *
*/
void __init mtrr_bp_init(void)
{
+ bool generic_mtrrs = cpu_feature_enabled(X86_FEATURE_MTRR);
const char *why = "(not available)";
unsigned int phys_addr;
- phys_addr = mtrr_calc_physbits(boot_cpu_has(X86_FEATURE_MTRR));
+ phys_addr = mtrr_calc_physbits(generic_mtrrs);
- if (boot_cpu_has(X86_FEATURE_MTRR)) {
+ if (generic_mtrrs) {
mtrr_if = &generic_mtrr_ops;
} else {
switch (boot_cpu_data.x86_vendor) {
--
2.35.3
next prev parent reply other threads:[~2023-04-01 6:37 UTC|newest]
Thread overview: 53+ messages / expand[flat|nested] mbox.gz Atom feed top
2023-04-01 6:36 [PATCH v5 00/15] x86/mtrr: fix handling with PAT but without MTRR Juergen Gross
2023-04-01 6:36 ` [PATCH v5 01/15] x86/mtrr: split off physical address size calculation Juergen Gross
2023-04-01 6:36 ` Juergen Gross [this message]
2023-04-01 6:36 ` [PATCH v5 03/15] x86/mtrr: replace some constants with defines Juergen Gross
2023-04-03 16:03 ` Borislav Petkov
2023-04-05 7:55 ` Juergen Gross
2023-04-05 20:26 ` Borislav Petkov
2023-04-11 13:32 ` Juergen Gross
2023-04-01 6:36 ` [PATCH v5 04/15] x86/mtrr: support setting MTRR state for software defined MTRRs Juergen Gross
2023-04-03 2:25 ` Huang, Kai
2023-04-03 7:10 ` Juergen Gross
2023-04-03 9:27 ` Huang, Kai
2023-04-03 9:35 ` Juergen Gross
2023-04-03 9:44 ` Huang, Kai
2023-04-03 9:43 ` Huang, Kai
2023-04-11 13:20 ` Borislav Petkov
2023-04-11 13:31 ` Juergen Gross
2023-04-11 17:14 ` Borislav Petkov
2023-04-11 13:59 ` Michael Kelley (LINUX)
2023-04-11 14:04 ` Juergen Gross
2023-04-11 14:26 ` Borislav Petkov
2023-04-11 15:57 ` Juergen Gross
2023-04-11 17:15 ` Borislav Petkov
2023-04-12 8:30 ` Juergen Gross
2023-04-11 14:25 ` Borislav Petkov
2023-04-01 6:36 ` [PATCH v5 05/15] x86/hyperv: set MTRR state when running as SEV-SNP Hyper-V guest Juergen Gross
2023-04-02 2:36 ` Michael Kelley (LINUX)
2023-04-01 6:36 ` [PATCH v5 06/15] x86/xen: set MTRR state when running as Xen PV initial domain Juergen Gross
2023-04-01 6:36 ` [PATCH v5 07/15] x86/mtrr: replace vendor tests in MTRR code Juergen Gross
2023-04-12 8:45 ` Borislav Petkov
2023-04-12 10:25 ` Juergen Gross
2023-04-01 6:36 ` [PATCH v5 08/15] x86/mtrr: have only one set_mtrr() variant Juergen Gross
2023-04-12 12:30 ` Borislav Petkov
2023-04-12 12:56 ` Juergen Gross
2023-04-12 20:09 ` Borislav Petkov
2023-04-01 6:36 ` [PATCH v5 09/15] x86/mtrr: allocate mtrr_value array dynamically Juergen Gross
2023-04-12 21:11 ` Borislav Petkov
2023-04-13 10:07 ` Juergen Gross
2023-04-01 6:36 ` [PATCH v5 10/15] x86/mtrr: add get_effective_type() service function Juergen Gross
2023-04-01 6:36 ` [PATCH v5 11/15] x86/mtrr: construct a memory map with cache modes Juergen Gross
2023-04-20 12:15 ` Borislav Petkov
2023-04-20 12:30 ` Juergen Gross
2023-04-20 12:30 ` Juergen Gross
2023-04-20 13:01 ` Borislav Petkov
2023-04-20 13:57 ` Juergen Gross
2023-04-20 14:54 ` Borislav Petkov
2023-04-20 15:10 ` Juergen Gross
2023-04-21 11:23 ` Borislav Petkov
2023-04-21 14:35 ` Juergen Gross
2023-04-01 6:36 ` [PATCH v5 12/15] x86/mtrr: use new cache_map in mtrr_type_lookup() Juergen Gross
2023-04-01 6:36 ` [PATCH v5 13/15] x86/mtrr: don't let mtrr_type_lookup() return MTRR_TYPE_INVALID Juergen Gross
2023-04-01 6:36 ` [PATCH v5 14/15] x86/mm: only check uniform after calling mtrr_type_lookup() Juergen Gross
2023-04-01 6:36 ` [PATCH v5 15/15] x86/mtrr: remove unused code Juergen Gross
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20230401063652.23522-3-jgross@suse.com \
--to=jgross@suse.com \
--cc=bp@alien8.de \
--cc=dave.hansen@linux.intel.com \
--cc=hpa@zytor.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mikelley@microsoft.com \
--cc=mingo@redhat.com \
--cc=tglx@linutronix.de \
--cc=x86@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®