mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH v6 0/5] erofs: cleanup of xattr handling
@ 2023-06-08 11:30 Jingbo Xu
  2023-06-08 11:30 ` [PATCH v6 1/5] erofs: use absolute position in xattr iterator Jingbo Xu
                   ` (4 more replies)
  0 siblings, 5 replies; 8+ messages in thread
From: Jingbo Xu @ 2023-06-08 11:30 UTC (permalink / raw)
  To: hsiangkao, chao, huyue2, linux-erofs; +Cc: linux-kernel

changes since v5:
- patch 1: newly added into this series, in preparation for the
  following cleanup
- patch 5: rename erofs_xattr_body() to erofs_xattr_handle_string()

changes since v4:
- patch 1: make conversions from erofs_read_metabuf() in xattr.c
  to "erofs_init_metabuf() + erofs_bread()" a separate patch
- patch 6: add "bool copy" function parameter to erofs_xattr_body(), and
  thus make erofs_xattr_namematch() and erofs_xattr_copy() inlined
  inside erofs_xattr_body()

changes since v3:
- patch 1: make a unified erofs_xattr_iter_fixup() API with newly
  introduced "bool nospan" argument; call erofs_init_metabuf() and
  erofs_bread() separately instead of erofs_read_metabuf()
- patch 2: avoid duplicated strlen() calculation in erofs_getxattr(); no
  need zeroing other fields when initializing 'struct erofs_xattr_iter'
- patch 4: don't explode 'struct erofs_xattr_iter' with inode/getxattr
  fields; instead pass inode/getxattr parameters through function
  parameters of erofs_iter_[inline|shared]_xattr()
- patch 5: don't explode 'struct erofs_xattr_iter' with remaining field;
  instead  calculate and check the remaining inside
  erofs_iter_inline_xattr()

changes since v2:
- rebase to v6.4-rc2
- passes xattr tests (erofs/019,020,021) of erofs-utils [1]

[1] https://git.kernel.org/pub/scm/linux/kernel/git/xiang/erofs-utils.git/log/?h=experimental-tests

v5: https://lore.kernel.org/all/20230601024347.108469-1-jefflexu@linux.alibaba.com/
v4: https://lore.kernel.org/all/20230531031330.3504-1-jefflexu@linux.alibaba.com/
v3: https://lore.kernel.org/lkml/20230518024551.123990-1-jefflexu@linux.alibaba.com/
v2: https://lore.kernel.org/all/20230330082910.125374-1-jefflexu@linux.alibaba.com/
v1: https://lore.kernel.org/all/20230323000949.57608-1-jefflexu@linux.alibaba.com/


Jingbo Xu (5):
  erofs: use absolute position in xattr iterator
  erofs: unify xattr_iter structures
  erofs: make the size of read data stored in buffer_ofs
  erofs: unify inline/share xattr iterators for listxattr/getxattr
  erofs: use separate xattr parsers for listxattr/getxattr

 fs/erofs/xattr.c | 652 +++++++++++++++++------------------------------
 1 file changed, 227 insertions(+), 425 deletions(-)

-- 
2.19.1.6.gb485710b


^ permalink raw reply	[flat|nested] 8+ messages in thread

end of thread, other threads:[~2023-06-12  3:01 UTC | newest]

Thread overview: 8+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2023-06-08 11:30 [PATCH v6 0/5] erofs: cleanup of xattr handling Jingbo Xu
2023-06-08 11:30 ` [PATCH v6 1/5] erofs: use absolute position in xattr iterator Jingbo Xu
2023-06-09  3:31   ` Gao Xiang
2023-06-08 11:30 ` [PATCH v6 2/5] erofs: unify xattr_iter structures Jingbo Xu
2023-06-08 11:30 ` [PATCH v6 3/5] erofs: make the size of read data stored in buffer_ofs Jingbo Xu
2023-06-08 11:30 ` [PATCH v6 4/5] erofs: unify inline/share xattr iterators for listxattr/getxattr Jingbo Xu
2023-06-12  3:01   ` Gao Xiang
2023-06-08 11:30 ` [PATCH v6 5/5] erofs: use separate xattr parsers " Jingbo Xu

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®