mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH] crypto: qat - use kcalloc_node() instead of kzalloc_node()
@ 2024-01-21 16:40 Erick Archer
  2024-01-22 17:55 ` Gustavo A. R. Silva
                   ` (2 more replies)
  0 siblings, 3 replies; 4+ messages in thread
From: Erick Archer @ 2024-01-21 16:40 UTC (permalink / raw)
  To: Giovanni Cabiddu, Herbert Xu, David S. Miller, Erick Archer,
	Tero Kristo, Andy Shevchenko, Damian Muszynski, Shashank Gupta,
	Tom Zanussi, Gustavo A. R. Silva
  Cc: qat-linux, linux-crypto, linux-kernel, linux-hardening

As noted in the "Deprecated Interfaces, Language Features, Attributes,
and Conventions" documentation [1], size calculations (especially
multiplication) should not be performed in memory allocator (or similar)
function arguments due to the risk of them overflowing. This could lead
to values wrapping around and a smaller allocation being made than the
caller was expecting. Using those allocations could lead to linear
overflows of heap memory and other misbehaviors.

So, use the purpose specific kcalloc_node() function instead of the
argument count * size in the kzalloc_node() function.

Link: https://www.kernel.org/doc/html/next/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments [1]
Link: https://github.com/KSPP/linux/issues/162
Signed-off-by: Erick Archer <erick.archer@gmx.com>
---
 drivers/crypto/intel/qat/qat_common/adf_isr.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/crypto/intel/qat/qat_common/adf_isr.c b/drivers/crypto/intel/qat/qat_common/adf_isr.c
index 3557a0d6dea2..a13d9885d60f 100644
--- a/drivers/crypto/intel/qat/qat_common/adf_isr.c
+++ b/drivers/crypto/intel/qat/qat_common/adf_isr.c
@@ -272,7 +272,7 @@ static int adf_isr_alloc_msix_vectors_data(struct adf_accel_dev *accel_dev)
 	if (!accel_dev->pf.vf_info)
 		msix_num_entries += hw_data->num_banks;

-	irqs = kzalloc_node(msix_num_entries * sizeof(*irqs),
+	irqs = kcalloc_node(msix_num_entries, sizeof(*irqs),
 			    GFP_KERNEL, dev_to_node(&GET_DEV(accel_dev)));
 	if (!irqs)
 		return -ENOMEM;
--
2.25.1


^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCH] crypto: qat - use kcalloc_node() instead of kzalloc_node()
  2024-01-21 16:40 [PATCH] crypto: qat - use kcalloc_node() instead of kzalloc_node() Erick Archer
@ 2024-01-22 17:55 ` Gustavo A. R. Silva
  2024-01-23 12:16 ` Cabiddu, Giovanni
  2024-01-26  9:06 ` Herbert Xu
  2 siblings, 0 replies; 4+ messages in thread
From: Gustavo A. R. Silva @ 2024-01-22 17:55 UTC (permalink / raw)
  To: Erick Archer, Giovanni Cabiddu, Herbert Xu, David S. Miller,
	Tero Kristo, Andy Shevchenko, Damian Muszynski, Shashank Gupta,
	Tom Zanussi, Gustavo A. R. Silva
  Cc: qat-linux, linux-crypto, linux-kernel, linux-hardening



On 1/21/24 10:40, Erick Archer wrote:
> As noted in the "Deprecated Interfaces, Language Features, Attributes,
> and Conventions" documentation [1], size calculations (especially
> multiplication) should not be performed in memory allocator (or similar)
> function arguments due to the risk of them overflowing. This could lead
> to values wrapping around and a smaller allocation being made than the
> caller was expecting. Using those allocations could lead to linear
> overflows of heap memory and other misbehaviors.
> 
> So, use the purpose specific kcalloc_node() function instead of the
> argument count * size in the kzalloc_node() function.
> 
> Link: https://www.kernel.org/doc/html/next/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments [1]
> Link: https://github.com/KSPP/linux/issues/162
> Signed-off-by: Erick Archer <erick.archer@gmx.com>

Reviewed-by: Gustavo A. R. Silva <gustavoars@kernel.org>

Thanks!
-- 
Gustavo

> ---
>   drivers/crypto/intel/qat/qat_common/adf_isr.c | 2 +-
>   1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/drivers/crypto/intel/qat/qat_common/adf_isr.c b/drivers/crypto/intel/qat/qat_common/adf_isr.c
> index 3557a0d6dea2..a13d9885d60f 100644
> --- a/drivers/crypto/intel/qat/qat_common/adf_isr.c
> +++ b/drivers/crypto/intel/qat/qat_common/adf_isr.c
> @@ -272,7 +272,7 @@ static int adf_isr_alloc_msix_vectors_data(struct adf_accel_dev *accel_dev)
>   	if (!accel_dev->pf.vf_info)
>   		msix_num_entries += hw_data->num_banks;
> 
> -	irqs = kzalloc_node(msix_num_entries * sizeof(*irqs),
> +	irqs = kcalloc_node(msix_num_entries, sizeof(*irqs),
>   			    GFP_KERNEL, dev_to_node(&GET_DEV(accel_dev)));
>   	if (!irqs)
>   		return -ENOMEM;
> --
> 2.25.1
> 

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCH] crypto: qat - use kcalloc_node() instead of kzalloc_node()
  2024-01-21 16:40 [PATCH] crypto: qat - use kcalloc_node() instead of kzalloc_node() Erick Archer
  2024-01-22 17:55 ` Gustavo A. R. Silva
@ 2024-01-23 12:16 ` Cabiddu, Giovanni
  2024-01-26  9:06 ` Herbert Xu
  2 siblings, 0 replies; 4+ messages in thread
From: Cabiddu, Giovanni @ 2024-01-23 12:16 UTC (permalink / raw)
  To: Erick Archer
  Cc: Herbert Xu, David S. Miller, Tero Kristo, Andy Shevchenko,
	Damian Muszynski, Shashank Gupta, Tom Zanussi,
	Gustavo A. R. Silva, qat-linux, linux-crypto, linux-kernel,
	linux-hardening

On Sun, Jan 21, 2024 at 05:40:43PM +0100, Erick Archer wrote:
> As noted in the "Deprecated Interfaces, Language Features, Attributes,
> and Conventions" documentation [1], size calculations (especially
> multiplication) should not be performed in memory allocator (or similar)
> function arguments due to the risk of them overflowing. This could lead
> to values wrapping around and a smaller allocation being made than the
> caller was expecting. Using those allocations could lead to linear
> overflows of heap memory and other misbehaviors.
> 
> So, use the purpose specific kcalloc_node() function instead of the
> argument count * size in the kzalloc_node() function.
> 
> Link: https://www.kernel.org/doc/html/next/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments [1]
> Link: https://github.com/KSPP/linux/issues/162
> Signed-off-by: Erick Archer <erick.archer@gmx.com>
Acked-by: Giovanni Cabiddu <giovanni.cabiddu@intel.com>

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCH] crypto: qat - use kcalloc_node() instead of kzalloc_node()
  2024-01-21 16:40 [PATCH] crypto: qat - use kcalloc_node() instead of kzalloc_node() Erick Archer
  2024-01-22 17:55 ` Gustavo A. R. Silva
  2024-01-23 12:16 ` Cabiddu, Giovanni
@ 2024-01-26  9:06 ` Herbert Xu
  2 siblings, 0 replies; 4+ messages in thread
From: Herbert Xu @ 2024-01-26  9:06 UTC (permalink / raw)
  To: Erick Archer
  Cc: Giovanni Cabiddu, David S. Miller, Tero Kristo, Andy Shevchenko,
	Damian Muszynski, Shashank Gupta, Tom Zanussi,
	Gustavo A. R. Silva, qat-linux, linux-crypto, linux-kernel,
	linux-hardening

On Sun, Jan 21, 2024 at 05:40:43PM +0100, Erick Archer wrote:
> As noted in the "Deprecated Interfaces, Language Features, Attributes,
> and Conventions" documentation [1], size calculations (especially
> multiplication) should not be performed in memory allocator (or similar)
> function arguments due to the risk of them overflowing. This could lead
> to values wrapping around and a smaller allocation being made than the
> caller was expecting. Using those allocations could lead to linear
> overflows of heap memory and other misbehaviors.
> 
> So, use the purpose specific kcalloc_node() function instead of the
> argument count * size in the kzalloc_node() function.
> 
> Link: https://www.kernel.org/doc/html/next/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments [1]
> Link: https://github.com/KSPP/linux/issues/162
> Signed-off-by: Erick Archer <erick.archer@gmx.com>
> ---
>  drivers/crypto/intel/qat/qat_common/adf_isr.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)

Patch applied.  Thanks.
-- 
Email: Herbert Xu <herbert@gondor.apana.org.au>
Home Page: http://gondor.apana.org.au/~herbert/
PGP Key: http://gondor.apana.org.au/~herbert/pubkey.txt

^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2024-01-26  9:06 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2024-01-21 16:40 [PATCH] crypto: qat - use kcalloc_node() instead of kzalloc_node() Erick Archer
2024-01-22 17:55 ` Gustavo A. R. Silva
2024-01-23 12:16 ` Cabiddu, Giovanni
2024-01-26  9:06 ` Herbert Xu

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®