mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: James Morse <james.morse@arm.com>
To: x86@kernel.org, linux-kernel@vger.kernel.org
Cc: Reinette Chatre <reinette.chatre@intel.com>,
	Thomas Gleixner <tglx@linutronix.de>,
	Ingo Molnar <mingo@redhat.com>, Borislav Petkov <bp@alien8.de>,
	H Peter Anvin <hpa@zytor.com>, Babu Moger <Babu.Moger@amd.com>,
	James Morse <james.morse@arm.com>,
	shameerali.kolothum.thodi@huawei.com,
	D Scott Phillips OS <scott@os.amperecomputing.com>,
	carl@os.amperecomputing.com, lcherian@marvell.com,
	bobo.shaobowang@huawei.com, tan.shaopeng@fujitsu.com,
	baolin.wang@linux.alibaba.com,
	Jamie Iles <quic_jiles@quicinc.com>,
	Xin Hao <xhao@linux.alibaba.com>,
	peternewman@google.com, dfustini@baylibre.com,
	amitsinght@marvell.com, David Hildenbrand <david@redhat.com>,
	Rex Nie <rex.nie@jaguarmicro.com>,
	Dave Martin <dave.martin@arm.com>, Koba Ko <kobak@nvidia.com>,
	Shanker Donthineni <sdonthineni@nvidia.com>,
	fenghuay@nvidia.com, Shaopeng Tan <tan.shaopeng@jp.fujitsu.com>,
	Tony Luck <tony.luck@intel.com>
Subject: [PATCH v7 26/49] x86/resctrl: Make resctrl_arch_pseudo_lock_fn() take a plr
Date: Fri, 28 Feb 2025 19:58:50 +0000	[thread overview]
Message-ID: <20250228195913.24895-27-james.morse@arm.com> (raw)
In-Reply-To: <20250228195913.24895-1-james.morse@arm.com>

resctrl_arch_pseudo_lock_fn() has architecture specific behaviour,
and takes a struct rdtgroup as an argument.

After the filesystem code moves to /fs/, the definition of struct
rdtgroup will not be available to the architecture code.

The only reason resctrl_arch_pseudo_lock_fn() wants the rdtgroup is
for the CLOSID. Embed that in the pseudo_lock_region as a closid,
and move the definition of struct pseudo_lock_region to resctrl.h.

Signed-off-by: James Morse <james.morse@arm.com>
Tested-by: Carl Worth <carl@os.amperecomputing.com> # arm64
Tested-by: Shaopeng Tan <tan.shaopeng@jp.fujitsu.com>
Reviewed-by: Shaopeng Tan <tan.shaopeng@jp.fujitsu.com>
Reviewed-by: Tony Luck <tony.luck@intel.com>
Reviewed-by: Reinette Chatre <reinette.chatre@intel.com>
---
Change since v1:
 * [Commit message only] Typo fix:
   s/hw_closid/closid/g
---
 arch/x86/include/asm/resctrl.h            |  2 +-
 arch/x86/kernel/cpu/resctrl/internal.h    | 37 ---------------------
 arch/x86/kernel/cpu/resctrl/pseudo_lock.c | 12 +++----
 include/linux/resctrl.h                   | 39 +++++++++++++++++++++++
 4 files changed, 46 insertions(+), 44 deletions(-)

diff --git a/arch/x86/include/asm/resctrl.h b/arch/x86/include/asm/resctrl.h
index 86407dbde583..011bf67a1866 100644
--- a/arch/x86/include/asm/resctrl.h
+++ b/arch/x86/include/asm/resctrl.h
@@ -204,7 +204,7 @@ static inline void resctrl_arch_mon_ctx_free(struct rdt_resource *r, int evtid,
 					     void *ctx) { };
 
 u64 resctrl_arch_get_prefetch_disable_bits(void);
-int resctrl_arch_pseudo_lock_fn(void *_rdtgrp);
+int resctrl_arch_pseudo_lock_fn(void *_plr);
 int resctrl_arch_measure_cycles_lat_fn(void *_plr);
 int resctrl_arch_measure_l2_residency(void *_plr);
 int resctrl_arch_measure_l3_residency(void *_plr);
diff --git a/arch/x86/kernel/cpu/resctrl/internal.h b/arch/x86/kernel/cpu/resctrl/internal.h
index 8d35bb423aad..0d13006e920b 100644
--- a/arch/x86/kernel/cpu/resctrl/internal.h
+++ b/arch/x86/kernel/cpu/resctrl/internal.h
@@ -208,43 +208,6 @@ struct mongroup {
 	u32			rmid;
 };
 
-/**
- * struct pseudo_lock_region - pseudo-lock region information
- * @s:			Resctrl schema for the resource to which this
- *			pseudo-locked region belongs
- * @d:			RDT domain to which this pseudo-locked region
- *			belongs
- * @cbm:		bitmask of the pseudo-locked region
- * @lock_thread_wq:	waitqueue used to wait on the pseudo-locking thread
- *			completion
- * @thread_done:	variable used by waitqueue to test if pseudo-locking
- *			thread completed
- * @cpu:		core associated with the cache on which the setup code
- *			will be run
- * @line_size:		size of the cache lines
- * @size:		size of pseudo-locked region in bytes
- * @kmem:		the kernel memory associated with pseudo-locked region
- * @minor:		minor number of character device associated with this
- *			region
- * @debugfs_dir:	pointer to this region's directory in the debugfs
- *			filesystem
- * @pm_reqs:		Power management QoS requests related to this region
- */
-struct pseudo_lock_region {
-	struct resctrl_schema	*s;
-	struct rdt_ctrl_domain	*d;
-	u32			cbm;
-	wait_queue_head_t	lock_thread_wq;
-	int			thread_done;
-	int			cpu;
-	unsigned int		line_size;
-	unsigned int		size;
-	void			*kmem;
-	unsigned int		minor;
-	struct dentry		*debugfs_dir;
-	struct list_head	pm_reqs;
-};
-
 /**
  * struct rdtgroup - store rdtgroup's data in resctrl file system.
  * @kn:				kernfs node
diff --git a/arch/x86/kernel/cpu/resctrl/pseudo_lock.c b/arch/x86/kernel/cpu/resctrl/pseudo_lock.c
index 90044a01d000..01fa7890b43f 100644
--- a/arch/x86/kernel/cpu/resctrl/pseudo_lock.c
+++ b/arch/x86/kernel/cpu/resctrl/pseudo_lock.c
@@ -414,7 +414,7 @@ static void pseudo_lock_free(struct rdtgroup *rdtgrp)
 
 /**
  * resctrl_arch_pseudo_lock_fn - Load kernel memory into cache
- * @_rdtgrp: resource group to which pseudo-lock region belongs
+ * @_plr: the pseudo-lock region descriptor
  *
  * This is the core pseudo-locking flow.
  *
@@ -431,10 +431,9 @@ static void pseudo_lock_free(struct rdtgroup *rdtgrp)
  *
  * Return: 0. Waiter on waitqueue will be woken on completion.
  */
-int resctrl_arch_pseudo_lock_fn(void *_rdtgrp)
+int resctrl_arch_pseudo_lock_fn(void *_plr)
 {
-	struct rdtgroup *rdtgrp = _rdtgrp;
-	struct pseudo_lock_region *plr = rdtgrp->plr;
+	struct pseudo_lock_region *plr = _plr;
 	u32 rmid_p, closid_p;
 	unsigned long i;
 	u64 saved_msr;
@@ -494,7 +493,8 @@ int resctrl_arch_pseudo_lock_fn(void *_rdtgrp)
 	 * pseudo-locked followed by reading of kernel memory to load it
 	 * into the cache.
 	 */
-	__wrmsr(MSR_IA32_PQR_ASSOC, rmid_p, rdtgrp->closid);
+	__wrmsr(MSR_IA32_PQR_ASSOC, rmid_p, plr->closid);
+
 	/*
 	 * Cache was flushed earlier. Now access kernel memory to read it
 	 * into cache region associated with just activated plr->closid.
@@ -1312,7 +1312,7 @@ int rdtgroup_pseudo_lock_create(struct rdtgroup *rdtgrp)
 
 	plr->thread_done = 0;
 
-	thread = kthread_run_on_cpu(resctrl_arch_pseudo_lock_fn, rdtgrp,
+	thread = kthread_run_on_cpu(resctrl_arch_pseudo_lock_fn, plr,
 				    plr->cpu, "pseudo_lock/%u");
 	if (IS_ERR(thread)) {
 		ret = PTR_ERR(thread);
diff --git a/include/linux/resctrl.h b/include/linux/resctrl.h
index 914df24ffe48..226cc5c0d765 100644
--- a/include/linux/resctrl.h
+++ b/include/linux/resctrl.h
@@ -58,6 +58,45 @@ enum resctrl_conf_type {
 
 #define CDP_NUM_TYPES	(CDP_DATA + 1)
 
+/*
+ * struct pseudo_lock_region - pseudo-lock region information
+ * @s:			Resctrl schema for the resource to which this
+ *			pseudo-locked region belongs
+ * @closid:		The closid that this pseudo-locked region uses
+ * @d:			RDT domain to which this pseudo-locked region
+ *			belongs
+ * @cbm:		bitmask of the pseudo-locked region
+ * @lock_thread_wq:	waitqueue used to wait on the pseudo-locking thread
+ *			completion
+ * @thread_done:	variable used by waitqueue to test if pseudo-locking
+ *			thread completed
+ * @cpu:		core associated with the cache on which the setup code
+ *			will be run
+ * @line_size:		size of the cache lines
+ * @size:		size of pseudo-locked region in bytes
+ * @kmem:		the kernel memory associated with pseudo-locked region
+ * @minor:		minor number of character device associated with this
+ *			region
+ * @debugfs_dir:	pointer to this region's directory in the debugfs
+ *			filesystem
+ * @pm_reqs:		Power management QoS requests related to this region
+ */
+struct pseudo_lock_region {
+	struct resctrl_schema	*s;
+	u32			closid;
+	struct rdt_ctrl_domain	*d;
+	u32			cbm;
+	wait_queue_head_t	lock_thread_wq;
+	int			thread_done;
+	int			cpu;
+	unsigned int		line_size;
+	unsigned int		size;
+	void			*kmem;
+	unsigned int		minor;
+	struct dentry		*debugfs_dir;
+	struct list_head	pm_reqs;
+};
+
 /**
  * struct resctrl_staged_config - parsed configuration to be applied
  * @new_ctrl:		new ctrl value to be loaded
-- 
2.39.5


  parent reply	other threads:[~2025-02-28 20:01 UTC|newest]

Thread overview: 149+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-02-28 19:58 [PATCH v7 00/49] x86/resctrl: Move the resctrl filesystem code to /fs/resctrl James Morse
2025-02-28 19:58 ` [PATCH v7 01/49] x86/resctrl: Fix allocation of cleanest CLOSID on platforms with no monitors James Morse
2025-03-06 20:56   ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 02/49] x86/resctrl: Add a helper to avoid reaching into the arch code resource list James Morse
2025-03-06 20:58   ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 03/49] x86/resctrl: Remove fflags from struct rdt_resource James Morse
2025-03-06 21:00   ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 04/49] x86/resctrl: Use schema type to determine how to parse schema values James Morse
2025-03-06 21:00   ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 05/49] x86/resctrl: Use schema type to determine the schema format string James Morse
2025-03-06 21:01   ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 06/49] x86/resctrl: Remove data_width and the tabular format James Morse
2025-03-06 21:02   ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 07/49] x86/resctrl: Add max_bw to struct resctrl_membw James Morse
2025-03-06 21:02   ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 08/49] x86/resctrl: Generate default_ctrl instead of sharing it James Morse
2025-03-06 21:04   ` Fenghua Yu
2025-03-07  4:33   ` Reinette Chatre
2025-03-07 18:08     ` James Morse
2025-02-28 19:58 ` [PATCH v7 09/49] x86/resctrl: Add helper for setting CPU default properties James Morse
2025-03-06 21:04   ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 10/49] x86/resctrl: Remove rdtgroup from update_cpu_closid_rmid() James Morse
2025-03-06 21:04   ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 11/49] x86/resctrl: Expose resctrl fs's init function to the rest of the kernel James Morse
2025-03-06 21:05   ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 12/49] x86/resctrl: Move rdt_find_domain() to be visible to arch and fs code James Morse
2025-03-06 21:08   ` Fenghua Yu
2025-03-07  4:34   ` Reinette Chatre
2025-03-07 19:35     ` James Morse
2025-02-28 19:58 ` [PATCH v7 13/49] x86/resctrl: Move resctrl types to a separate header James Morse
2025-03-06 21:09   ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 14/49] x86/resctrl: Add an arch helper to reset one resource James Morse
2025-03-06 21:10   ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 15/49] x86/resctrl: Move monitor exit work to a resctrl exit call James Morse
2025-03-06 21:28   ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 16/49] x86/resctrl: Move monitor init work to a resctrl init call James Morse
2025-03-06 21:29   ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 17/49] x86/resctrl: Rewrite and move the for_each_*_rdt_resource() walkers James Morse
2025-03-06 21:29   ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 18/49] x86/resctrl: Move the is_mbm_*_enabled() helpers to asm/resctrl.h James Morse
2025-03-06 21:30   ` Fenghua Yu
2025-03-07  4:35   ` Reinette Chatre
2025-02-28 19:58 ` [PATCH v7 19/49] x86/resctrl: Add resctrl_arch_is_evt_configurable() to abstract BMEC James Morse
2025-03-06 21:32   ` Fenghua Yu
2025-03-07  4:37   ` Reinette Chatre
2025-03-10 12:26     ` James Morse
2025-02-28 19:58 ` [PATCH v7 20/49] x86/resctrl: Change mon_event_config_{read,write}() to be arch helpers James Morse
2025-03-06 21:32   ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 21/49] x86/resctrl: Move mba_mbps_default_event init to filesystem code James Morse
2025-03-06 21:33   ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 22/49] x86/resctrl: Move mbm_cfg_mask to struct rdt_resource James Morse
2025-03-06 21:34   ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 23/49] x86/resctrl: Add resctrl_arch_ prefix to pseudo lock functions James Morse
2025-03-06 21:34   ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 24/49] x86/resctrl: Allow an architecture to disable pseudo lock James Morse
2025-03-06 21:35   ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 25/49] x86/resctrl: Make prefetch_disable_bits belong to the arch code James Morse
2025-03-06 21:36   ` Fenghua Yu
2025-02-28 19:58 ` James Morse [this message]
2025-03-06 21:36   ` [PATCH v7 26/49] x86/resctrl: Make resctrl_arch_pseudo_lock_fn() take a plr Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 27/49] x86/resctrl: Move RFTYPE flags to be managed by resctrl James Morse
2025-03-06 21:37   ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 28/49] x86/resctrl: Handle throttle_mode for SMBA resources James Morse
2025-03-06 21:37   ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 29/49] x86/resctrl: Move get_config_index() to a header James Morse
2025-03-06 22:00   ` Fenghua Yu
2025-03-07  4:37   ` Reinette Chatre
2025-02-28 19:58 ` [PATCH v7 30/49] x86/resctrl: Move get_{mon,ctrl}_domain_from_cpu() to live with their callers James Morse
2025-03-06 22:08   ` Fenghua Yu
2025-03-07  4:38   ` Reinette Chatre
2025-02-28 19:58 ` [PATCH v7 31/49] x86/resctrl: Remove the limit on the number of CLOSID James Morse
2025-03-06 22:11   ` Fenghua Yu
2025-03-07  4:40   ` Reinette Chatre
2025-03-10 14:20     ` James Morse
2025-02-28 19:58 ` [PATCH v7 32/49] x86/resctrl: Rename resctrl_sched_in() to begin with "resctrl_arch_" James Morse
2025-03-06 22:11   ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 33/49] x86/resctrl: resctrl_exit() teardown resctrl but leave the mount point James Morse
2025-03-07  4:45   ` Reinette Chatre
2025-03-07 17:54     ` James Morse
2025-03-07 19:04       ` Reinette Chatre
2025-03-10 18:15         ` James Morse
2025-02-28 19:58 ` [PATCH v7 34/49] x86/resctrl: Drop __init/__exit on assorted symbols James Morse
2025-03-06 22:30   ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 35/49] x86/resctrl: Move is_mba_sc() out of core.c James Morse
2025-03-06 22:31   ` Fenghua Yu
2025-02-28 19:59 ` [PATCH v7 36/49] x86/resctrl: Add end-marker to the resctrl_event_id enum James Morse
2025-03-06 22:31   ` Fenghua Yu
2025-02-28 19:59 ` [PATCH v7 37/49] x86/resctrl: Expand the width of dom_id by replacing mon_data_bits James Morse
2025-03-07  5:03   ` Reinette Chatre
2025-03-12 18:04     ` James Morse
2025-03-13 15:25       ` Reinette Chatre
2025-03-25  0:52         ` Luck, Tony
2025-04-03 19:16           ` Luck, Tony
2025-04-04 16:53             ` James Morse
2025-03-07 10:17   ` Amit Singh Tomar
2025-03-12 18:04     ` James Morse
2025-02-28 19:59 ` [PATCH v7 38/49] x86/resctrl: Remove a newline to avoid confusing the code move script James Morse
2025-03-06 22:41   ` Fenghua Yu
2025-02-28 19:59 ` [PATCH v7 39/49] x86/resctrl: Split trace.h James Morse
2025-03-07  5:04   ` Reinette Chatre
2025-02-28 19:59 ` [PATCH v7 40/49] fs/resctrl: Add boiler plate for external resctrl code James Morse
2025-03-07  2:16   ` Fenghua Yu
2025-03-14 12:01     ` James Morse
2025-03-07  5:05   ` Reinette Chatre
2025-02-28 19:59 ` [PATCH v7 41/49] x86/resctrl: Move the filesystem bits to headers visible to fs/resctrl James Morse
2025-03-07  2:19   ` Fenghua Yu
2025-03-07  5:05   ` Reinette Chatre
2025-02-28 19:59 ` [PATCH v7 42/49] x86/resctrl: Squelch whitespace anomalies in resctrl core code James Morse
2025-03-07  2:20   ` Fenghua Yu
2025-03-07  5:06   ` Reinette Chatre
2025-02-28 19:59 ` [PATCH v7 43/49] x86/resctrl: Prefer alloc(sizeof(*foo)) idiom in rdt_init_fs_context() James Morse
2025-03-07  2:23   ` Fenghua Yu
2025-03-07  5:06   ` Reinette Chatre
2025-02-28 19:59 ` [PATCH v7 44/49] x86/resctrl: Relax some asm #includes James Morse
2025-03-07  2:51   ` Fenghua Yu
     [not found]   ` <d4bba1b8-2faa-4d9b-becf-f10011351652@nvidia.com>
2025-03-14 12:00     ` James Morse
2025-02-28 19:59 ` [PATCH v7 45/49] x86,fs/resctrl: Move the resctrl filesystem code to live in /fs/resctrl James Morse
2025-03-06 20:35   ` Fenghua Yu
2025-03-14 17:42     ` James Morse
2025-03-06 20:45   ` Fenghua Yu
2025-02-28 19:59 ` [PATCH v7 46/49] x86,fs/resctrl: Remove duplicated trace header files James Morse
2025-03-07  2:32   ` Fenghua Yu
2025-03-14 17:42     ` James Morse
2025-02-28 19:59 ` [PATCH v7 47/49] fs/resctrl: Remove unnecessary includes James Morse
2025-03-07  2:37   ` Fenghua Yu
2025-03-14 17:42     ` James Morse
2025-03-07  5:07   ` Reinette Chatre
2025-02-28 19:59 ` [PATCH v7 48/49] fs/resctrl: Change internal.h's header guard macros James Morse
2025-03-07  2:44   ` Fenghua Yu
2025-02-28 19:59 ` [PATCH v7 49/49] x86,fs/resctrl: Move resctrl.rst to live under Documentation/filesystems James Morse
2025-03-07  2:45   ` Fenghua Yu
2025-03-03 10:14 ` [PATCH v7 00/49] x86/resctrl: Move the resctrl filesystem code to /fs/resctrl Peter Newman
2025-03-11 12:16   ` James Morse
2025-03-04 21:47 ` Luck, Tony
2025-03-05 16:35   ` Reinette Chatre
2025-03-05 20:47     ` Moger, Babu
2025-03-06 11:47 ` Shaopeng Tan (Fujitsu)
2025-03-11 12:26   ` James Morse
2025-03-07 10:27 ` Amit Singh Tomar
2025-03-07 13:50   ` Amit Singh Tomar
2025-03-07 16:38     ` Shanker Donthineni
2025-03-07 16:50       ` Shanker Donthineni
2025-03-11 18:33         ` James Morse
2025-03-11 18:33     ` James Morse
2025-03-10 14:07 ` Moger, Babu
2025-03-11 16:18   ` James Morse
2025-03-10 19:09 ` Borislav Petkov
2025-03-11 18:38   ` James Morse
2025-03-11 20:06     ` Borislav Petkov

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20250228195913.24895-27-james.morse@arm.com \
    --to=james.morse@arm.com \
    --cc=Babu.Moger@amd.com \
    --cc=amitsinght@marvell.com \
    --cc=baolin.wang@linux.alibaba.com \
    --cc=bobo.shaobowang@huawei.com \
    --cc=bp@alien8.de \
    --cc=carl@os.amperecomputing.com \
    --cc=dave.martin@arm.com \
    --cc=david@redhat.com \
    --cc=dfustini@baylibre.com \
    --cc=fenghuay@nvidia.com \
    --cc=hpa@zytor.com \
    --cc=kobak@nvidia.com \
    --cc=lcherian@marvell.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@redhat.com \
    --cc=peternewman@google.com \
    --cc=quic_jiles@quicinc.com \
    --cc=reinette.chatre@intel.com \
    --cc=rex.nie@jaguarmicro.com \
    --cc=scott@os.amperecomputing.com \
    --cc=sdonthineni@nvidia.com \
    --cc=shameerali.kolothum.thodi@huawei.com \
    --cc=tan.shaopeng@fujitsu.com \
    --cc=tan.shaopeng@jp.fujitsu.com \
    --cc=tglx@linutronix.de \
    --cc=tony.luck@intel.com \
    --cc=x86@kernel.org \
    --cc=xhao@linux.alibaba.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®