mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: James Morse <james.morse@arm.com>
To: Amit Singh Tomar <amitsinght@marvell.com>,
	x86@kernel.org, linux-kernel@vger.kernel.org
Cc: Reinette Chatre <reinette.chatre@intel.com>,
	Thomas Gleixner <tglx@linutronix.de>,
	Ingo Molnar <mingo@redhat.com>, Borislav Petkov <bp@alien8.de>,
	H Peter Anvin <hpa@zytor.com>, Babu Moger <Babu.Moger@amd.com>,
	shameerali.kolothum.thodi@huawei.com,
	D Scott Phillips OS <scott@os.amperecomputing.com>,
	carl@os.amperecomputing.com, lcherian@marvell.com,
	bobo.shaobowang@huawei.com, tan.shaopeng@fujitsu.com,
	baolin.wang@linux.alibaba.com,
	Jamie Iles <quic_jiles@quicinc.com>,
	Xin Hao <xhao@linux.alibaba.com>,
	peternewman@google.com, dfustini@baylibre.com,
	David Hildenbrand <david@redhat.com>,
	Rex Nie <rex.nie@jaguarmicro.com>,
	Dave Martin <dave.martin@arm.com>, Koba Ko <kobak@nvidia.com>,
	Shanker Donthineni <sdonthineni@nvidia.com>,
	fenghuay@nvidia.com
Subject: Re: [PATCH v7 37/49] x86/resctrl: Expand the width of dom_id by replacing mon_data_bits
Date: Wed, 12 Mar 2025 18:04:31 +0000	[thread overview]
Message-ID: <75244728-bc16-4657-9cab-9e931399e766@arm.com> (raw)
In-Reply-To: <072e82c2-97c2-429f-a0e3-10eb0bd00b1e@marvell.com>

Hi Amit,

On 07/03/2025 10:17, Amit Singh Tomar wrote:
>> MPAM platforms retrieve the cache-id property from the ACPI PPTT table.
>> The cache-id field is 32 bits wide. Under resctrl, the cache-id becomes
>> the domain-id, and is packed into the mon_data_bits union bitfield.
>> The width of cache-id in this field is 14 bits.
>>
>> Expanding the union would break 32bit x86 platforms as this union is
>> stored as the kernfs kn->priv pointer. This saved allocating memory
>> for the priv data storage.
>>
>> The firmware on MPAM platforms have used the PPTT cache-id field to
>> expose the interconnect's id for the cache, which is sparse and uses
>> more than 14 bits. Use of this id is to enable PCIe direct cache
>> injection hints. Using this feature with VFIO means the value provided
>> by the ACPI table should be exposed to user-space.
>>
>> To support cache-id values greater than 14 bits, convert the
>> mon_data_bits union to a structure. This is allocated for the default
>> control group when the kernfs event files are created, and free'd when
>> the monitor directory is rmdir'd when the domain goes offline.
>> All other control and monitor groups lookup the struct mon_data allocated
>> for the default control group, and use this.
>> This simplifies the lifecycle of this structure as the default control
>> group cannot be rmdir()d by user-space, so only needs to consider
>> domain-offline, which removes all the event files corresponding to a
>> domain while holding rdtgroup_mutex - which prevents concurrent
>> readers. mkdir_mondata_subdir_allrdtgrp() must special case the default
>> control group to ensure it is created first.


>> diff --git a/arch/x86/kernel/cpu/resctrl/rdtgroup.c b/arch/x86/kernel/cpu/resctrl/
>> rdtgroup.c
>> index aecd3fa734cd..443635d195f0 100644
>> --- a/arch/x86/kernel/cpu/resctrl/rdtgroup.c
>> +++ b/arch/x86/kernel/cpu/resctrl/rdtgroup.c
>> @@ -3114,6 +3114,110 @@ static struct file_system_type rdt_fs_type = {
>>       .kill_sb        = rdt_kill_sb,
>>   };
>>   +/**
>> + * mon_get_default_kn_priv() - Get the mon_data priv data for this event from
>> + *                             the default control group.
>> + * Called when monitor event files are created for a domain.
>> + * When called with the default control group, the structure will be allocated.
>> + * This happens at mount time, before other control or monitor groups are
>> + * created.
>> + * This simplifies the lifetime management for rmdir() versus domain-offline
>> + * as the default control group lives forever, and only one group needs to be
>> + * special cased.
>> + *
>> + * @r:      The resource for the event type being created.
>> + * @d:        The domain for the event type being created.
>> + * @mevt:   The event type being created.
>> + * @rdtgrp: The rdtgroup for which the monitor file is being created,
>> + *          used to determine if this is the default control group.
>> + * @do_sum: Whether the SNC sub-numa node monitors are being created.
>> + */
>> +static struct mon_data *mon_get_default_kn_priv(struct rdt_resource *r,
>> +                        struct rdt_mon_domain *d,
>> +                        struct mon_evt *mevt,
>> +                        struct rdtgroup *rdtgrp,
>> +                        bool do_sum)
>> +{
>> +    struct kernfs_node *kn_dom, *kn_evt;
>> +    struct mon_data *priv;
>> +    bool snc_mode;
>> +    char name[32];
>> +
>> +    lockdep_assert_held(&rdtgroup_mutex);
>> +
>> +    snc_mode = r->mon_scope == RESCTRL_L3_NODE;
>> +    if (!do_sum)
>> +        sprintf(name, "mon_%s_%02d", r->name, snc_mode ? d->ci->id : d->hdr.id);

> This change triggered a minor report during compilation.
> 
> fs/resctrl/rdtgroup.c: In function ‘mon_get_default_kn_priv’:
> fs/resctrl/rdtgroup.c:2931:28: warning: format ‘%d’ expects argument of type ‘int’, but
> argument 4 has type ‘long unsigned int’ [-Wformat=]
>  2931 |   sprintf(name, "mon_%s_%02d", r->name, snc_mode ? d->ci->id : d->hdr.id);
>       |                         ~~~^ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
>       | |                                 |
>       | int                               long unsigned int
>       |                         %02ld

Heh, not yet its not! You must have rebased the MPAM tree on-top, its a patch in there
that causes this:
This is because of the device-tree folk want to make cache-id an unsigned long so they can
use the arm CPU's affinity id as a cache-id. That patch already has to cleanup this
pattern elsewhere in resctrl, I need to add this one to it.

That thing is a discussion for the DT folk to drive ... I think they could just as easily
use the CPU number - only it wouldn't be a hardware-derived value. (the upshot is
cache-ids could change over a firmware update - which I think is fine)


Thanks,

James

  reply	other threads:[~2025-03-12 18:04 UTC|newest]

Thread overview: 149+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-02-28 19:58 [PATCH v7 00/49] x86/resctrl: Move the resctrl filesystem code to /fs/resctrl James Morse
2025-02-28 19:58 ` [PATCH v7 01/49] x86/resctrl: Fix allocation of cleanest CLOSID on platforms with no monitors James Morse
2025-03-06 20:56   ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 02/49] x86/resctrl: Add a helper to avoid reaching into the arch code resource list James Morse
2025-03-06 20:58   ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 03/49] x86/resctrl: Remove fflags from struct rdt_resource James Morse
2025-03-06 21:00   ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 04/49] x86/resctrl: Use schema type to determine how to parse schema values James Morse
2025-03-06 21:00   ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 05/49] x86/resctrl: Use schema type to determine the schema format string James Morse
2025-03-06 21:01   ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 06/49] x86/resctrl: Remove data_width and the tabular format James Morse
2025-03-06 21:02   ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 07/49] x86/resctrl: Add max_bw to struct resctrl_membw James Morse
2025-03-06 21:02   ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 08/49] x86/resctrl: Generate default_ctrl instead of sharing it James Morse
2025-03-06 21:04   ` Fenghua Yu
2025-03-07  4:33   ` Reinette Chatre
2025-03-07 18:08     ` James Morse
2025-02-28 19:58 ` [PATCH v7 09/49] x86/resctrl: Add helper for setting CPU default properties James Morse
2025-03-06 21:04   ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 10/49] x86/resctrl: Remove rdtgroup from update_cpu_closid_rmid() James Morse
2025-03-06 21:04   ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 11/49] x86/resctrl: Expose resctrl fs's init function to the rest of the kernel James Morse
2025-03-06 21:05   ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 12/49] x86/resctrl: Move rdt_find_domain() to be visible to arch and fs code James Morse
2025-03-06 21:08   ` Fenghua Yu
2025-03-07  4:34   ` Reinette Chatre
2025-03-07 19:35     ` James Morse
2025-02-28 19:58 ` [PATCH v7 13/49] x86/resctrl: Move resctrl types to a separate header James Morse
2025-03-06 21:09   ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 14/49] x86/resctrl: Add an arch helper to reset one resource James Morse
2025-03-06 21:10   ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 15/49] x86/resctrl: Move monitor exit work to a resctrl exit call James Morse
2025-03-06 21:28   ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 16/49] x86/resctrl: Move monitor init work to a resctrl init call James Morse
2025-03-06 21:29   ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 17/49] x86/resctrl: Rewrite and move the for_each_*_rdt_resource() walkers James Morse
2025-03-06 21:29   ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 18/49] x86/resctrl: Move the is_mbm_*_enabled() helpers to asm/resctrl.h James Morse
2025-03-06 21:30   ` Fenghua Yu
2025-03-07  4:35   ` Reinette Chatre
2025-02-28 19:58 ` [PATCH v7 19/49] x86/resctrl: Add resctrl_arch_is_evt_configurable() to abstract BMEC James Morse
2025-03-06 21:32   ` Fenghua Yu
2025-03-07  4:37   ` Reinette Chatre
2025-03-10 12:26     ` James Morse
2025-02-28 19:58 ` [PATCH v7 20/49] x86/resctrl: Change mon_event_config_{read,write}() to be arch helpers James Morse
2025-03-06 21:32   ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 21/49] x86/resctrl: Move mba_mbps_default_event init to filesystem code James Morse
2025-03-06 21:33   ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 22/49] x86/resctrl: Move mbm_cfg_mask to struct rdt_resource James Morse
2025-03-06 21:34   ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 23/49] x86/resctrl: Add resctrl_arch_ prefix to pseudo lock functions James Morse
2025-03-06 21:34   ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 24/49] x86/resctrl: Allow an architecture to disable pseudo lock James Morse
2025-03-06 21:35   ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 25/49] x86/resctrl: Make prefetch_disable_bits belong to the arch code James Morse
2025-03-06 21:36   ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 26/49] x86/resctrl: Make resctrl_arch_pseudo_lock_fn() take a plr James Morse
2025-03-06 21:36   ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 27/49] x86/resctrl: Move RFTYPE flags to be managed by resctrl James Morse
2025-03-06 21:37   ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 28/49] x86/resctrl: Handle throttle_mode for SMBA resources James Morse
2025-03-06 21:37   ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 29/49] x86/resctrl: Move get_config_index() to a header James Morse
2025-03-06 22:00   ` Fenghua Yu
2025-03-07  4:37   ` Reinette Chatre
2025-02-28 19:58 ` [PATCH v7 30/49] x86/resctrl: Move get_{mon,ctrl}_domain_from_cpu() to live with their callers James Morse
2025-03-06 22:08   ` Fenghua Yu
2025-03-07  4:38   ` Reinette Chatre
2025-02-28 19:58 ` [PATCH v7 31/49] x86/resctrl: Remove the limit on the number of CLOSID James Morse
2025-03-06 22:11   ` Fenghua Yu
2025-03-07  4:40   ` Reinette Chatre
2025-03-10 14:20     ` James Morse
2025-02-28 19:58 ` [PATCH v7 32/49] x86/resctrl: Rename resctrl_sched_in() to begin with "resctrl_arch_" James Morse
2025-03-06 22:11   ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 33/49] x86/resctrl: resctrl_exit() teardown resctrl but leave the mount point James Morse
2025-03-07  4:45   ` Reinette Chatre
2025-03-07 17:54     ` James Morse
2025-03-07 19:04       ` Reinette Chatre
2025-03-10 18:15         ` James Morse
2025-02-28 19:58 ` [PATCH v7 34/49] x86/resctrl: Drop __init/__exit on assorted symbols James Morse
2025-03-06 22:30   ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 35/49] x86/resctrl: Move is_mba_sc() out of core.c James Morse
2025-03-06 22:31   ` Fenghua Yu
2025-02-28 19:59 ` [PATCH v7 36/49] x86/resctrl: Add end-marker to the resctrl_event_id enum James Morse
2025-03-06 22:31   ` Fenghua Yu
2025-02-28 19:59 ` [PATCH v7 37/49] x86/resctrl: Expand the width of dom_id by replacing mon_data_bits James Morse
2025-03-07  5:03   ` Reinette Chatre
2025-03-12 18:04     ` James Morse
2025-03-13 15:25       ` Reinette Chatre
2025-03-25  0:52         ` Luck, Tony
2025-04-03 19:16           ` Luck, Tony
2025-04-04 16:53             ` James Morse
2025-03-07 10:17   ` Amit Singh Tomar
2025-03-12 18:04     ` James Morse [this message]
2025-02-28 19:59 ` [PATCH v7 38/49] x86/resctrl: Remove a newline to avoid confusing the code move script James Morse
2025-03-06 22:41   ` Fenghua Yu
2025-02-28 19:59 ` [PATCH v7 39/49] x86/resctrl: Split trace.h James Morse
2025-03-07  5:04   ` Reinette Chatre
2025-02-28 19:59 ` [PATCH v7 40/49] fs/resctrl: Add boiler plate for external resctrl code James Morse
2025-03-07  2:16   ` Fenghua Yu
2025-03-14 12:01     ` James Morse
2025-03-07  5:05   ` Reinette Chatre
2025-02-28 19:59 ` [PATCH v7 41/49] x86/resctrl: Move the filesystem bits to headers visible to fs/resctrl James Morse
2025-03-07  2:19   ` Fenghua Yu
2025-03-07  5:05   ` Reinette Chatre
2025-02-28 19:59 ` [PATCH v7 42/49] x86/resctrl: Squelch whitespace anomalies in resctrl core code James Morse
2025-03-07  2:20   ` Fenghua Yu
2025-03-07  5:06   ` Reinette Chatre
2025-02-28 19:59 ` [PATCH v7 43/49] x86/resctrl: Prefer alloc(sizeof(*foo)) idiom in rdt_init_fs_context() James Morse
2025-03-07  2:23   ` Fenghua Yu
2025-03-07  5:06   ` Reinette Chatre
2025-02-28 19:59 ` [PATCH v7 44/49] x86/resctrl: Relax some asm #includes James Morse
2025-03-07  2:51   ` Fenghua Yu
     [not found]   ` <d4bba1b8-2faa-4d9b-becf-f10011351652@nvidia.com>
2025-03-14 12:00     ` James Morse
2025-02-28 19:59 ` [PATCH v7 45/49] x86,fs/resctrl: Move the resctrl filesystem code to live in /fs/resctrl James Morse
2025-03-06 20:35   ` Fenghua Yu
2025-03-14 17:42     ` James Morse
2025-03-06 20:45   ` Fenghua Yu
2025-02-28 19:59 ` [PATCH v7 46/49] x86,fs/resctrl: Remove duplicated trace header files James Morse
2025-03-07  2:32   ` Fenghua Yu
2025-03-14 17:42     ` James Morse
2025-02-28 19:59 ` [PATCH v7 47/49] fs/resctrl: Remove unnecessary includes James Morse
2025-03-07  2:37   ` Fenghua Yu
2025-03-14 17:42     ` James Morse
2025-03-07  5:07   ` Reinette Chatre
2025-02-28 19:59 ` [PATCH v7 48/49] fs/resctrl: Change internal.h's header guard macros James Morse
2025-03-07  2:44   ` Fenghua Yu
2025-02-28 19:59 ` [PATCH v7 49/49] x86,fs/resctrl: Move resctrl.rst to live under Documentation/filesystems James Morse
2025-03-07  2:45   ` Fenghua Yu
2025-03-03 10:14 ` [PATCH v7 00/49] x86/resctrl: Move the resctrl filesystem code to /fs/resctrl Peter Newman
2025-03-11 12:16   ` James Morse
2025-03-04 21:47 ` Luck, Tony
2025-03-05 16:35   ` Reinette Chatre
2025-03-05 20:47     ` Moger, Babu
2025-03-06 11:47 ` Shaopeng Tan (Fujitsu)
2025-03-11 12:26   ` James Morse
2025-03-07 10:27 ` Amit Singh Tomar
2025-03-07 13:50   ` Amit Singh Tomar
2025-03-07 16:38     ` Shanker Donthineni
2025-03-07 16:50       ` Shanker Donthineni
2025-03-11 18:33         ` James Morse
2025-03-11 18:33     ` James Morse
2025-03-10 14:07 ` Moger, Babu
2025-03-11 16:18   ` James Morse
2025-03-10 19:09 ` Borislav Petkov
2025-03-11 18:38   ` James Morse
2025-03-11 20:06     ` Borislav Petkov

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=75244728-bc16-4657-9cab-9e931399e766@arm.com \
    --to=james.morse@arm.com \
    --cc=Babu.Moger@amd.com \
    --cc=amitsinght@marvell.com \
    --cc=baolin.wang@linux.alibaba.com \
    --cc=bobo.shaobowang@huawei.com \
    --cc=bp@alien8.de \
    --cc=carl@os.amperecomputing.com \
    --cc=dave.martin@arm.com \
    --cc=david@redhat.com \
    --cc=dfustini@baylibre.com \
    --cc=fenghuay@nvidia.com \
    --cc=hpa@zytor.com \
    --cc=kobak@nvidia.com \
    --cc=lcherian@marvell.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@redhat.com \
    --cc=peternewman@google.com \
    --cc=quic_jiles@quicinc.com \
    --cc=reinette.chatre@intel.com \
    --cc=rex.nie@jaguarmicro.com \
    --cc=scott@os.amperecomputing.com \
    --cc=sdonthineni@nvidia.com \
    --cc=shameerali.kolothum.thodi@huawei.com \
    --cc=tan.shaopeng@fujitsu.com \
    --cc=tglx@linutronix.de \
    --cc=x86@kernel.org \
    --cc=xhao@linux.alibaba.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®