From: James Morse <james.morse@arm.com>
To: x86@kernel.org, linux-kernel@vger.kernel.org
Cc: Reinette Chatre <reinette.chatre@intel.com>,
Thomas Gleixner <tglx@linutronix.de>,
Ingo Molnar <mingo@redhat.com>, Borislav Petkov <bp@alien8.de>,
H Peter Anvin <hpa@zytor.com>, Babu Moger <Babu.Moger@amd.com>,
James Morse <james.morse@arm.com>,
shameerali.kolothum.thodi@huawei.com,
D Scott Phillips OS <scott@os.amperecomputing.com>,
carl@os.amperecomputing.com, lcherian@marvell.com,
bobo.shaobowang@huawei.com, tan.shaopeng@fujitsu.com,
baolin.wang@linux.alibaba.com,
Jamie Iles <quic_jiles@quicinc.com>,
Xin Hao <xhao@linux.alibaba.com>,
peternewman@google.com, dfustini@baylibre.com,
amitsinght@marvell.com, David Hildenbrand <david@redhat.com>,
Rex Nie <rex.nie@jaguarmicro.com>,
Dave Martin <dave.martin@arm.com>, Koba Ko <kobak@nvidia.com>,
Shanker Donthineni <sdonthineni@nvidia.com>,
fenghuay@nvidia.com, Dave Martin <Dave.Martin@arm.com>,
Shaopeng Tan <tan.shaopeng@jp.fujitsu.com>,
Tony Luck <tony.luck@intel.com>
Subject: [PATCH v7 29/49] x86/resctrl: Move get_config_index() to a header
Date: Fri, 28 Feb 2025 19:58:53 +0000 [thread overview]
Message-ID: <20250228195913.24895-30-james.morse@arm.com> (raw)
In-Reply-To: <20250228195913.24895-1-james.morse@arm.com>
get_config_index() is used by the architecture specific code to map a
CLOSID+type pair to an index in the configuration arrays.
MPAM needs to do this too to preserve the ABI to user-space, there is
no reason to do it differently.
Move the helper to a header file to allow all architectures that either
use or emulate CDP to use the same pattern of CLOSID values. Moving
this to a header file means it must be marked inline, which matches
the existing compiler choice for this static function.
Co-developed-by: Dave Martin <Dave.Martin@arm.com>
Signed-off-by: Dave Martin <Dave.Martin@arm.com>
Signed-off-by: James Morse <james.morse@arm.com>
Tested-by: Carl Worth <carl@os.amperecomputing.com> # arm64
Tested-by: Shaopeng Tan <tan.shaopeng@jp.fujitsu.com>
Reviewed-by: Shaopeng Tan <tan.shaopeng@jp.fujitsu.com>
Reviewed-by: Tony Luck <tony.luck@intel.com>
---
Changes since v6:
* Expanded the last paragraph of the commit message.
Changes since v1:
* Reindent resctrl_get_config_index() as per coding-style.rst rules.
---
arch/x86/kernel/cpu/resctrl/ctrlmondata.c | 19 +++----------------
include/linux/resctrl.h | 15 +++++++++++++++
2 files changed, 18 insertions(+), 16 deletions(-)
diff --git a/arch/x86/kernel/cpu/resctrl/ctrlmondata.c b/arch/x86/kernel/cpu/resctrl/ctrlmondata.c
index 1ecc93282b7d..0a0ac5f6112e 100644
--- a/arch/x86/kernel/cpu/resctrl/ctrlmondata.c
+++ b/arch/x86/kernel/cpu/resctrl/ctrlmondata.c
@@ -287,25 +287,12 @@ static int parse_line(char *line, struct resctrl_schema *s,
return -EINVAL;
}
-static u32 get_config_index(u32 closid, enum resctrl_conf_type type)
-{
- switch (type) {
- default:
- case CDP_NONE:
- return closid;
- case CDP_CODE:
- return closid * 2 + 1;
- case CDP_DATA:
- return closid * 2;
- }
-}
-
int resctrl_arch_update_one(struct rdt_resource *r, struct rdt_ctrl_domain *d,
u32 closid, enum resctrl_conf_type t, u32 cfg_val)
{
struct rdt_hw_ctrl_domain *hw_dom = resctrl_to_arch_ctrl_dom(d);
struct rdt_hw_resource *hw_res = resctrl_to_arch_res(r);
- u32 idx = get_config_index(closid, t);
+ u32 idx = resctrl_get_config_index(closid, t);
struct msr_param msr_param;
if (!cpumask_test_cpu(smp_processor_id(), &d->hdr.cpu_mask))
@@ -342,7 +329,7 @@ int resctrl_arch_update_domains(struct rdt_resource *r, u32 closid)
if (!cfg->have_new_ctrl)
continue;
- idx = get_config_index(closid, t);
+ idx = resctrl_get_config_index(closid, t);
if (cfg->new_ctrl == hw_dom->ctrl_val[idx])
continue;
hw_dom->ctrl_val[idx] = cfg->new_ctrl;
@@ -462,7 +449,7 @@ u32 resctrl_arch_get_config(struct rdt_resource *r, struct rdt_ctrl_domain *d,
u32 closid, enum resctrl_conf_type type)
{
struct rdt_hw_ctrl_domain *hw_dom = resctrl_to_arch_ctrl_dom(d);
- u32 idx = get_config_index(closid, type);
+ u32 idx = resctrl_get_config_index(closid, type);
return hw_dom->ctrl_val[idx];
}
diff --git a/include/linux/resctrl.h b/include/linux/resctrl.h
index 226cc5c0d765..880351ca3dfc 100644
--- a/include/linux/resctrl.h
+++ b/include/linux/resctrl.h
@@ -384,6 +384,21 @@ void resctrl_arch_mon_event_config_write(void *config_info);
*/
void resctrl_arch_mon_event_config_read(void *config_info);
+/* For use by arch code to remap resctrl's smaller CDP CLOSID range */
+static inline u32 resctrl_get_config_index(u32 closid,
+ enum resctrl_conf_type type)
+{
+ switch (type) {
+ default:
+ case CDP_NONE:
+ return closid;
+ case CDP_CODE:
+ return closid * 2 + 1;
+ case CDP_DATA:
+ return closid * 2;
+ }
+}
+
/*
* Update the ctrl_val and apply this config right now.
* Must be called on one of the domain's CPUs.
--
2.39.5
next prev parent reply other threads:[~2025-02-28 20:01 UTC|newest]
Thread overview: 149+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-02-28 19:58 [PATCH v7 00/49] x86/resctrl: Move the resctrl filesystem code to /fs/resctrl James Morse
2025-02-28 19:58 ` [PATCH v7 01/49] x86/resctrl: Fix allocation of cleanest CLOSID on platforms with no monitors James Morse
2025-03-06 20:56 ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 02/49] x86/resctrl: Add a helper to avoid reaching into the arch code resource list James Morse
2025-03-06 20:58 ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 03/49] x86/resctrl: Remove fflags from struct rdt_resource James Morse
2025-03-06 21:00 ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 04/49] x86/resctrl: Use schema type to determine how to parse schema values James Morse
2025-03-06 21:00 ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 05/49] x86/resctrl: Use schema type to determine the schema format string James Morse
2025-03-06 21:01 ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 06/49] x86/resctrl: Remove data_width and the tabular format James Morse
2025-03-06 21:02 ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 07/49] x86/resctrl: Add max_bw to struct resctrl_membw James Morse
2025-03-06 21:02 ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 08/49] x86/resctrl: Generate default_ctrl instead of sharing it James Morse
2025-03-06 21:04 ` Fenghua Yu
2025-03-07 4:33 ` Reinette Chatre
2025-03-07 18:08 ` James Morse
2025-02-28 19:58 ` [PATCH v7 09/49] x86/resctrl: Add helper for setting CPU default properties James Morse
2025-03-06 21:04 ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 10/49] x86/resctrl: Remove rdtgroup from update_cpu_closid_rmid() James Morse
2025-03-06 21:04 ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 11/49] x86/resctrl: Expose resctrl fs's init function to the rest of the kernel James Morse
2025-03-06 21:05 ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 12/49] x86/resctrl: Move rdt_find_domain() to be visible to arch and fs code James Morse
2025-03-06 21:08 ` Fenghua Yu
2025-03-07 4:34 ` Reinette Chatre
2025-03-07 19:35 ` James Morse
2025-02-28 19:58 ` [PATCH v7 13/49] x86/resctrl: Move resctrl types to a separate header James Morse
2025-03-06 21:09 ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 14/49] x86/resctrl: Add an arch helper to reset one resource James Morse
2025-03-06 21:10 ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 15/49] x86/resctrl: Move monitor exit work to a resctrl exit call James Morse
2025-03-06 21:28 ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 16/49] x86/resctrl: Move monitor init work to a resctrl init call James Morse
2025-03-06 21:29 ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 17/49] x86/resctrl: Rewrite and move the for_each_*_rdt_resource() walkers James Morse
2025-03-06 21:29 ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 18/49] x86/resctrl: Move the is_mbm_*_enabled() helpers to asm/resctrl.h James Morse
2025-03-06 21:30 ` Fenghua Yu
2025-03-07 4:35 ` Reinette Chatre
2025-02-28 19:58 ` [PATCH v7 19/49] x86/resctrl: Add resctrl_arch_is_evt_configurable() to abstract BMEC James Morse
2025-03-06 21:32 ` Fenghua Yu
2025-03-07 4:37 ` Reinette Chatre
2025-03-10 12:26 ` James Morse
2025-02-28 19:58 ` [PATCH v7 20/49] x86/resctrl: Change mon_event_config_{read,write}() to be arch helpers James Morse
2025-03-06 21:32 ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 21/49] x86/resctrl: Move mba_mbps_default_event init to filesystem code James Morse
2025-03-06 21:33 ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 22/49] x86/resctrl: Move mbm_cfg_mask to struct rdt_resource James Morse
2025-03-06 21:34 ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 23/49] x86/resctrl: Add resctrl_arch_ prefix to pseudo lock functions James Morse
2025-03-06 21:34 ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 24/49] x86/resctrl: Allow an architecture to disable pseudo lock James Morse
2025-03-06 21:35 ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 25/49] x86/resctrl: Make prefetch_disable_bits belong to the arch code James Morse
2025-03-06 21:36 ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 26/49] x86/resctrl: Make resctrl_arch_pseudo_lock_fn() take a plr James Morse
2025-03-06 21:36 ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 27/49] x86/resctrl: Move RFTYPE flags to be managed by resctrl James Morse
2025-03-06 21:37 ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 28/49] x86/resctrl: Handle throttle_mode for SMBA resources James Morse
2025-03-06 21:37 ` Fenghua Yu
2025-02-28 19:58 ` James Morse [this message]
2025-03-06 22:00 ` [PATCH v7 29/49] x86/resctrl: Move get_config_index() to a header Fenghua Yu
2025-03-07 4:37 ` Reinette Chatre
2025-02-28 19:58 ` [PATCH v7 30/49] x86/resctrl: Move get_{mon,ctrl}_domain_from_cpu() to live with their callers James Morse
2025-03-06 22:08 ` Fenghua Yu
2025-03-07 4:38 ` Reinette Chatre
2025-02-28 19:58 ` [PATCH v7 31/49] x86/resctrl: Remove the limit on the number of CLOSID James Morse
2025-03-06 22:11 ` Fenghua Yu
2025-03-07 4:40 ` Reinette Chatre
2025-03-10 14:20 ` James Morse
2025-02-28 19:58 ` [PATCH v7 32/49] x86/resctrl: Rename resctrl_sched_in() to begin with "resctrl_arch_" James Morse
2025-03-06 22:11 ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 33/49] x86/resctrl: resctrl_exit() teardown resctrl but leave the mount point James Morse
2025-03-07 4:45 ` Reinette Chatre
2025-03-07 17:54 ` James Morse
2025-03-07 19:04 ` Reinette Chatre
2025-03-10 18:15 ` James Morse
2025-02-28 19:58 ` [PATCH v7 34/49] x86/resctrl: Drop __init/__exit on assorted symbols James Morse
2025-03-06 22:30 ` Fenghua Yu
2025-02-28 19:58 ` [PATCH v7 35/49] x86/resctrl: Move is_mba_sc() out of core.c James Morse
2025-03-06 22:31 ` Fenghua Yu
2025-02-28 19:59 ` [PATCH v7 36/49] x86/resctrl: Add end-marker to the resctrl_event_id enum James Morse
2025-03-06 22:31 ` Fenghua Yu
2025-02-28 19:59 ` [PATCH v7 37/49] x86/resctrl: Expand the width of dom_id by replacing mon_data_bits James Morse
2025-03-07 5:03 ` Reinette Chatre
2025-03-12 18:04 ` James Morse
2025-03-13 15:25 ` Reinette Chatre
2025-03-25 0:52 ` Luck, Tony
2025-04-03 19:16 ` Luck, Tony
2025-04-04 16:53 ` James Morse
2025-03-07 10:17 ` Amit Singh Tomar
2025-03-12 18:04 ` James Morse
2025-02-28 19:59 ` [PATCH v7 38/49] x86/resctrl: Remove a newline to avoid confusing the code move script James Morse
2025-03-06 22:41 ` Fenghua Yu
2025-02-28 19:59 ` [PATCH v7 39/49] x86/resctrl: Split trace.h James Morse
2025-03-07 5:04 ` Reinette Chatre
2025-02-28 19:59 ` [PATCH v7 40/49] fs/resctrl: Add boiler plate for external resctrl code James Morse
2025-03-07 2:16 ` Fenghua Yu
2025-03-14 12:01 ` James Morse
2025-03-07 5:05 ` Reinette Chatre
2025-02-28 19:59 ` [PATCH v7 41/49] x86/resctrl: Move the filesystem bits to headers visible to fs/resctrl James Morse
2025-03-07 2:19 ` Fenghua Yu
2025-03-07 5:05 ` Reinette Chatre
2025-02-28 19:59 ` [PATCH v7 42/49] x86/resctrl: Squelch whitespace anomalies in resctrl core code James Morse
2025-03-07 2:20 ` Fenghua Yu
2025-03-07 5:06 ` Reinette Chatre
2025-02-28 19:59 ` [PATCH v7 43/49] x86/resctrl: Prefer alloc(sizeof(*foo)) idiom in rdt_init_fs_context() James Morse
2025-03-07 2:23 ` Fenghua Yu
2025-03-07 5:06 ` Reinette Chatre
2025-02-28 19:59 ` [PATCH v7 44/49] x86/resctrl: Relax some asm #includes James Morse
2025-03-07 2:51 ` Fenghua Yu
[not found] ` <d4bba1b8-2faa-4d9b-becf-f10011351652@nvidia.com>
2025-03-14 12:00 ` James Morse
2025-02-28 19:59 ` [PATCH v7 45/49] x86,fs/resctrl: Move the resctrl filesystem code to live in /fs/resctrl James Morse
2025-03-06 20:35 ` Fenghua Yu
2025-03-14 17:42 ` James Morse
2025-03-06 20:45 ` Fenghua Yu
2025-02-28 19:59 ` [PATCH v7 46/49] x86,fs/resctrl: Remove duplicated trace header files James Morse
2025-03-07 2:32 ` Fenghua Yu
2025-03-14 17:42 ` James Morse
2025-02-28 19:59 ` [PATCH v7 47/49] fs/resctrl: Remove unnecessary includes James Morse
2025-03-07 2:37 ` Fenghua Yu
2025-03-14 17:42 ` James Morse
2025-03-07 5:07 ` Reinette Chatre
2025-02-28 19:59 ` [PATCH v7 48/49] fs/resctrl: Change internal.h's header guard macros James Morse
2025-03-07 2:44 ` Fenghua Yu
2025-02-28 19:59 ` [PATCH v7 49/49] x86,fs/resctrl: Move resctrl.rst to live under Documentation/filesystems James Morse
2025-03-07 2:45 ` Fenghua Yu
2025-03-03 10:14 ` [PATCH v7 00/49] x86/resctrl: Move the resctrl filesystem code to /fs/resctrl Peter Newman
2025-03-11 12:16 ` James Morse
2025-03-04 21:47 ` Luck, Tony
2025-03-05 16:35 ` Reinette Chatre
2025-03-05 20:47 ` Moger, Babu
2025-03-06 11:47 ` Shaopeng Tan (Fujitsu)
2025-03-11 12:26 ` James Morse
2025-03-07 10:27 ` Amit Singh Tomar
2025-03-07 13:50 ` Amit Singh Tomar
2025-03-07 16:38 ` Shanker Donthineni
2025-03-07 16:50 ` Shanker Donthineni
2025-03-11 18:33 ` James Morse
2025-03-11 18:33 ` James Morse
2025-03-10 14:07 ` Moger, Babu
2025-03-11 16:18 ` James Morse
2025-03-10 19:09 ` Borislav Petkov
2025-03-11 18:38 ` James Morse
2025-03-11 20:06 ` Borislav Petkov
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20250228195913.24895-30-james.morse@arm.com \
--to=james.morse@arm.com \
--cc=Babu.Moger@amd.com \
--cc=amitsinght@marvell.com \
--cc=baolin.wang@linux.alibaba.com \
--cc=bobo.shaobowang@huawei.com \
--cc=bp@alien8.de \
--cc=carl@os.amperecomputing.com \
--cc=dave.martin@arm.com \
--cc=david@redhat.com \
--cc=dfustini@baylibre.com \
--cc=fenghuay@nvidia.com \
--cc=hpa@zytor.com \
--cc=kobak@nvidia.com \
--cc=lcherian@marvell.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@redhat.com \
--cc=peternewman@google.com \
--cc=quic_jiles@quicinc.com \
--cc=reinette.chatre@intel.com \
--cc=rex.nie@jaguarmicro.com \
--cc=scott@os.amperecomputing.com \
--cc=sdonthineni@nvidia.com \
--cc=shameerali.kolothum.thodi@huawei.com \
--cc=tan.shaopeng@fujitsu.com \
--cc=tan.shaopeng@jp.fujitsu.com \
--cc=tglx@linutronix.de \
--cc=tony.luck@intel.com \
--cc=x86@kernel.org \
--cc=xhao@linux.alibaba.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®