mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH 0/2] rename system_wq and system_unbound_wq
@ 2025-10-31 10:48 Marco Crivellari
  2025-10-31 10:48 ` [PATCH 1/2] drm/rockchip: replace use of system_unbound_wq with system_dfl_wq Marco Crivellari
                   ` (3 more replies)
  0 siblings, 4 replies; 6+ messages in thread
From: Marco Crivellari @ 2025-10-31 10:48 UTC (permalink / raw)
  To: linux-kernel, dri-devel, linux-arm-kernel, linux-rockchip
  Cc: Tejun Heo, Lai Jiangshan, Frederic Weisbecker,
	Sebastian Andrzej Siewior, Marco Crivellari, Michal Hocko,
	Sandy Huang, Heiko Stübner, Andy Yan, Maarten Lankhorst,
	Thomas Zimmermann, David Airlie, Simona Vetter

Hi,

=== Current situation: problems ===

Let's consider a nohz_full system with isolated CPUs: wq_unbound_cpumask is
set to the housekeeping CPUs, for !WQ_UNBOUND the local CPU is selected.

This leads to different scenarios if a work item is scheduled on an
isolated CPU where "delay" value is 0 or greater then 0:
        schedule_delayed_work(, 0);

This will be handled by __queue_work() that will queue the work item on the
current local (isolated) CPU, while:

        schedule_delayed_work(, 1);

Will move the timer on an housekeeping CPU, and schedule the work there.

Currently if a user enqueue a work item using schedule_delayed_work() the
used wq is "system_wq" (per-cpu wq) while queue_delayed_work() use
WORK_CPU_UNBOUND (used when a cpu is not specified). The same applies to
schedule_work() that is using system_wq and queue_work(), that makes use
again of WORK_CPU_UNBOUND.

This lack of consistency cannot be addressed without refactoring the API.

=== Recent changes to the WQ API ===

The following, address the recent changes in the Workqueue API:

- commit 128ea9f6ccfb ("workqueue: Add system_percpu_wq and system_dfl_wq")
- commit 930c2ea566af ("workqueue: Add new WQ_PERCPU flag")

The old workqueues will be removed in a future release cycle.

=== Introduced Changes by this series ===

1) [P 1-2]  Replace uses of system_wq and system_unbound_wq

    system_wq is a per-CPU workqueue, but his name is not clear.
    system_unbound_wq is to be used when locality is not required.

    Because of that, system_wq has been replaced with system_percpu_wq, and
    system_unbound_wq has been replaced with system_dfl_wq.

	The new wq(s) keep the same old behavior.


Thanks!


Marco Crivellari (2):
  drm/rockchip: replace use of system_unbound_wq with system_dfl_wq
  drm/rockchip: replace use of system_wq with system_percpu_wq

 drivers/gpu/drm/rockchip/dw_hdmi_qp-rockchip.c | 4 ++--
 drivers/gpu/drm/rockchip/rockchip_drm_vop.c    | 2 +-
 2 files changed, 3 insertions(+), 3 deletions(-)

-- 
2.51.0


^ permalink raw reply	[flat|nested] 6+ messages in thread

* [PATCH 1/2] drm/rockchip: replace use of system_unbound_wq with system_dfl_wq
  2025-10-31 10:48 [PATCH 0/2] rename system_wq and system_unbound_wq Marco Crivellari
@ 2025-10-31 10:48 ` Marco Crivellari
  2025-10-31 10:48 ` [PATCH 2/2] drm/rockchip: replace use of system_wq with system_percpu_wq Marco Crivellari
                   ` (2 subsequent siblings)
  3 siblings, 0 replies; 6+ messages in thread
From: Marco Crivellari @ 2025-10-31 10:48 UTC (permalink / raw)
  To: linux-kernel, dri-devel, linux-arm-kernel, linux-rockchip
  Cc: Tejun Heo, Lai Jiangshan, Frederic Weisbecker,
	Sebastian Andrzej Siewior, Marco Crivellari, Michal Hocko,
	Sandy Huang, Heiko Stübner, Andy Yan, Maarten Lankhorst,
	Thomas Zimmermann, David Airlie, Simona Vetter

Currently if a user enqueue a work item using schedule_delayed_work() the
used wq is "system_wq" (per-cpu wq) while queue_delayed_work() use
WORK_CPU_UNBOUND (used when a cpu is not specified). The same applies to
schedule_work() that is using system_wq and queue_work(), that makes use
again of WORK_CPU_UNBOUND.

This lack of consistency cannot be addressed without refactoring the API.

system_unbound_wq should be the default workqueue so as not to enforce
locality constraints for random work whenever it's not required.

Adding system_dfl_wq to encourage its use when unbound work should be used.

The old system_unbound_wq will be kept for a few release cycles.

Suggested-by: Tejun Heo <tj@kernel.org>
Signed-off-by: Marco Crivellari <marco.crivellari@suse.com>
---
 drivers/gpu/drm/rockchip/rockchip_drm_vop.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/gpu/drm/rockchip/rockchip_drm_vop.c b/drivers/gpu/drm/rockchip/rockchip_drm_vop.c
index ba6b0528d1e5..18393c8671eb 100644
--- a/drivers/gpu/drm/rockchip/rockchip_drm_vop.c
+++ b/drivers/gpu/drm/rockchip/rockchip_drm_vop.c
@@ -1770,7 +1770,7 @@ static void vop_handle_vblank(struct vop *vop)
 	spin_unlock(&drm->event_lock);
 
 	if (test_and_clear_bit(VOP_PENDING_FB_UNREF, &vop->pending))
-		drm_flip_work_commit(&vop->fb_unref_work, system_unbound_wq);
+		drm_flip_work_commit(&vop->fb_unref_work, system_dfl_wq);
 }
 
 static irqreturn_t vop_isr(int irq, void *data)
-- 
2.51.0


^ permalink raw reply	[flat|nested] 6+ messages in thread

* [PATCH 2/2] drm/rockchip: replace use of system_wq with system_percpu_wq
  2025-10-31 10:48 [PATCH 0/2] rename system_wq and system_unbound_wq Marco Crivellari
  2025-10-31 10:48 ` [PATCH 1/2] drm/rockchip: replace use of system_unbound_wq with system_dfl_wq Marco Crivellari
@ 2025-10-31 10:48 ` Marco Crivellari
  2025-12-02 13:18 ` [PATCH 0/2] rename system_wq and system_unbound_wq Marco Crivellari
  2026-01-09 19:25 ` Heiko Stuebner
  3 siblings, 0 replies; 6+ messages in thread
From: Marco Crivellari @ 2025-10-31 10:48 UTC (permalink / raw)
  To: linux-kernel, dri-devel, linux-arm-kernel, linux-rockchip
  Cc: Tejun Heo, Lai Jiangshan, Frederic Weisbecker,
	Sebastian Andrzej Siewior, Marco Crivellari, Michal Hocko,
	Sandy Huang, Heiko Stübner, Andy Yan, Maarten Lankhorst,
	Thomas Zimmermann, David Airlie, Simona Vetter

Currently if a user enqueue a work item using schedule_delayed_work() the
used wq is "system_wq" (per-cpu wq) while queue_delayed_work() use
WORK_CPU_UNBOUND (used when a cpu is not specified). The same applies to
schedule_work() that is using system_wq and queue_work(), that makes use
again of WORK_CPU_UNBOUND.

This lack of consistency cannot be addressed without refactoring the API.

system_wq should be the per-cpu workqueue, yet in this name nothing makes
that clear, so replace system_wq with system_percpu_wq.

The old wq (system_wq) will be kept for a few release cycles.

Suggested-by: Tejun Heo <tj@kernel.org>
Signed-off-by: Marco Crivellari <marco.crivellari@suse.com>
---
 drivers/gpu/drm/rockchip/dw_hdmi_qp-rockchip.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/gpu/drm/rockchip/dw_hdmi_qp-rockchip.c b/drivers/gpu/drm/rockchip/dw_hdmi_qp-rockchip.c
index ed6e8f036f4b..deeeface0b63 100644
--- a/drivers/gpu/drm/rockchip/dw_hdmi_qp-rockchip.c
+++ b/drivers/gpu/drm/rockchip/dw_hdmi_qp-rockchip.c
@@ -276,7 +276,7 @@ static irqreturn_t dw_hdmi_qp_rk3576_irq(int irq, void *dev_id)
 
 	val = FIELD_PREP_WM16(RK3576_HDMI_HPD_INT_CLR, 1);
 	regmap_write(hdmi->regmap, RK3576_IOC_MISC_CON0, val);
-	mod_delayed_work(system_wq, &hdmi->hpd_work,
+	mod_delayed_work(system_percpu_wq, &hdmi->hpd_work,
 			 msecs_to_jiffies(HOTPLUG_DEBOUNCE_MS));
 
 	val = FIELD_PREP_WM16(RK3576_HDMI_HPD_INT_MSK, 0);
@@ -319,7 +319,7 @@ static irqreturn_t dw_hdmi_qp_rk3588_irq(int irq, void *dev_id)
 		val = FIELD_PREP_WM16(RK3588_HDMI0_HPD_INT_CLR, 1);
 	regmap_write(hdmi->regmap, RK3588_GRF_SOC_CON2, val);
 
-	mod_delayed_work(system_wq, &hdmi->hpd_work,
+	mod_delayed_work(system_percpu_wq, &hdmi->hpd_work,
 			 msecs_to_jiffies(HOTPLUG_DEBOUNCE_MS));
 
 	if (hdmi->port_id)
-- 
2.51.0


^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [PATCH 0/2] rename system_wq and system_unbound_wq
  2025-10-31 10:48 [PATCH 0/2] rename system_wq and system_unbound_wq Marco Crivellari
  2025-10-31 10:48 ` [PATCH 1/2] drm/rockchip: replace use of system_unbound_wq with system_dfl_wq Marco Crivellari
  2025-10-31 10:48 ` [PATCH 2/2] drm/rockchip: replace use of system_wq with system_percpu_wq Marco Crivellari
@ 2025-12-02 13:18 ` Marco Crivellari
  2026-01-09 19:25 ` Heiko Stuebner
  3 siblings, 0 replies; 6+ messages in thread
From: Marco Crivellari @ 2025-12-02 13:18 UTC (permalink / raw)
  To: linux-kernel, dri-devel, linux-arm-kernel, linux-rockchip
  Cc: Tejun Heo, Lai Jiangshan, Frederic Weisbecker,
	Sebastian Andrzej Siewior, Michal Hocko, Sandy Huang,
	Heiko Stübner, Andy Yan, Maarten Lankhorst,
	Thomas Zimmermann, David Airlie, Simona Vetter

Hi,

On Fri, Oct 31, 2025 at 11:48 AM Marco Crivellari
<marco.crivellari@suse.com> wrote:
> Marco Crivellari (2):
>   drm/rockchip: replace use of system_unbound_wq with system_dfl_wq
>   drm/rockchip: replace use of system_wq with system_percpu_wq
>
>  drivers/gpu/drm/rockchip/dw_hdmi_qp-rockchip.c | 4 ++--
>  drivers/gpu/drm/rockchip/rockchip_drm_vop.c    | 2 +-
>  2 files changed, 3 insertions(+), 3 deletions(-)

Gentle ping about this.

Thanks!

-- 

Marco Crivellari

L3 Support Engineer, Technology & Product

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [PATCH 0/2] rename system_wq and system_unbound_wq
  2025-10-31 10:48 [PATCH 0/2] rename system_wq and system_unbound_wq Marco Crivellari
                   ` (2 preceding siblings ...)
  2025-12-02 13:18 ` [PATCH 0/2] rename system_wq and system_unbound_wq Marco Crivellari
@ 2026-01-09 19:25 ` Heiko Stuebner
  2026-01-12  8:23   ` Marco Crivellari
  3 siblings, 1 reply; 6+ messages in thread
From: Heiko Stuebner @ 2026-01-09 19:25 UTC (permalink / raw)
  To: linux-kernel, dri-devel, linux-arm-kernel, linux-rockchip,
	Marco Crivellari
  Cc: Heiko Stuebner, Tejun Heo, Lai Jiangshan, Frederic Weisbecker,
	Sebastian Andrzej Siewior, Michal Hocko, Sandy Huang, Andy Yan,
	Maarten Lankhorst, Thomas Zimmermann, David Airlie,
	Simona Vetter


On Fri, 31 Oct 2025 11:48:44 +0100, Marco Crivellari wrote:
> === Current situation: problems ===
> 
> Let's consider a nohz_full system with isolated CPUs: wq_unbound_cpumask is
> set to the housekeeping CPUs, for !WQ_UNBOUND the local CPU is selected.
> 
> This leads to different scenarios if a work item is scheduled on an
> isolated CPU where "delay" value is 0 or greater then 0:
>         schedule_delayed_work(, 0);
> 
> [...]

Applied, thanks!

[1/2] drm/rockchip: replace use of system_unbound_wq with system_dfl_wq
      commit: 0650f4909af2bafe49322c91dd8dd0f68abfdf4f
[2/2] drm/rockchip: replace use of system_wq with system_percpu_wq
      commit: ab8559d44de5750e03778c42311aec8dd41a61f5

Best regards,
-- 
Heiko Stuebner <heiko@sntech.de>

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [PATCH 0/2] rename system_wq and system_unbound_wq
  2026-01-09 19:25 ` Heiko Stuebner
@ 2026-01-12  8:23   ` Marco Crivellari
  0 siblings, 0 replies; 6+ messages in thread
From: Marco Crivellari @ 2026-01-12  8:23 UTC (permalink / raw)
  To: Heiko Stuebner
  Cc: linux-kernel, dri-devel, linux-arm-kernel, linux-rockchip,
	Tejun Heo, Lai Jiangshan, Frederic Weisbecker,
	Sebastian Andrzej Siewior, Michal Hocko, Sandy Huang, Andy Yan,
	Maarten Lankhorst, Thomas Zimmermann, David Airlie,
	Simona Vetter

On Fri, Jan 9, 2026 at 8:25 PM Heiko Stuebner <heiko@sntech.de> wrote:
> [...]
>
> Applied, thanks!
>
> [1/2] drm/rockchip: replace use of system_unbound_wq with system_dfl_wq
>       commit: 0650f4909af2bafe49322c91dd8dd0f68abfdf4f
> [2/2] drm/rockchip: replace use of system_wq with system_percpu_wq
>       commit: ab8559d44de5750e03778c42311aec8dd41a61f5

Thank you!

-- 

Marco Crivellari

L3 Support Engineer

^ permalink raw reply	[flat|nested] 6+ messages in thread

end of thread, other threads:[~2026-01-12  8:23 UTC | newest]

Thread overview: 6+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2025-10-31 10:48 [PATCH 0/2] rename system_wq and system_unbound_wq Marco Crivellari
2025-10-31 10:48 ` [PATCH 1/2] drm/rockchip: replace use of system_unbound_wq with system_dfl_wq Marco Crivellari
2025-10-31 10:48 ` [PATCH 2/2] drm/rockchip: replace use of system_wq with system_percpu_wq Marco Crivellari
2025-12-02 13:18 ` [PATCH 0/2] rename system_wq and system_unbound_wq Marco Crivellari
2026-01-09 19:25 ` Heiko Stuebner
2026-01-12  8:23   ` Marco Crivellari

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®