mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH 0/8] hrtimer: Untangle base definitions from hrtimer.h
@ 2026-07-02  9:41 Thomas Weißschuh (Schneider Electric)
  2026-07-02  9:41 ` [PATCH 1/8] hrtimer: Rename hrtimer_defs.h to hrtimer_bases.h Thomas Weißschuh (Schneider Electric)
                   ` (7 more replies)
  0 siblings, 8 replies; 17+ messages in thread
From: Thomas Weißschuh (Schneider Electric) @ 2026-07-02  9:41 UTC (permalink / raw)
  To: Anna-Maria Behnsen, Frederic Weisbecker, Thomas Gleixner
  Cc: linux-kernel, Thomas Weißschuh (Schneider Electric)

Currently the hrtimer base structure definitions are included from the
widely used linux/hrtimer.h header.
Any change to the base structures will trigger a nearly full rebuild.

That inclusion is not really necessary as nearly no user needs the base
bits anyways.

Signed-off-by: Thomas Weißschuh (Schneider Electric) <thomas.weissschuh@linutronix.de>
---
Thomas Weißschuh (Schneider Electric) (8):
      hrtimer: Rename hrtimer_defs.h to hrtimer_bases.h
      hrtimer: Move hrtimer_callback_running() to hrtimer_bases.h
      hrtimer: Move hrtimer_update_function() to hrtimer.c
      tick: Explicitly include linux/hrtimer_bases.h
      hrtimer: Explicitly include linux/hrtimer_bases.h
      hrtimer: Explicitly include some necessary headers in hrtimer_rearm.h
      x86/speculation: Explicitly include linux/types.h
      hrtimer: Remove inclusion of hrtimer_bases.h remove from hrtimer.h

 arch/x86/include/asm/nospec-branch.h              |  1 +
 include/linux/hrtimer.h                           | 34 ++---------------------
 include/linux/{hrtimer_defs.h => hrtimer_bases.h} | 14 ++++++++--
 include/linux/hrtimer_rearm.h                     |  5 ++++
 kernel/sched/fair.c                               |  2 ++
 kernel/time/hrtimer.c                             | 25 +++++++++++++++++
 kernel/time/tick-internal.h                       |  1 +
 sound/drivers/dummy.c                             |  1 +
 8 files changed, 49 insertions(+), 34 deletions(-)
---
base-commit: dc59e4fea9d83f03bad6bddf3fa2e52491777482
change-id: 20260626-hrtimer-header-dependencies-5a7d2ddff43f

Best regards,
--  
Thomas Weißschuh <thomas.weissschuh@linutronix.de>


^ permalink raw reply	[flat|nested] 17+ messages in thread

end of thread, other threads:[~2026-07-07 21:49 UTC | newest]

Thread overview: 17+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2026-07-02  9:41 [PATCH 0/8] hrtimer: Untangle base definitions from hrtimer.h Thomas Weißschuh (Schneider Electric)
2026-07-02  9:41 ` [PATCH 1/8] hrtimer: Rename hrtimer_defs.h to hrtimer_bases.h Thomas Weißschuh (Schneider Electric)
2026-07-07 21:49   ` [tip: timers/core] " tip-bot2 for Thomas Weißschuh (Schneider Electric)
2026-07-02  9:41 ` [PATCH 2/8] hrtimer: Move hrtimer_callback_running() " Thomas Weißschuh (Schneider Electric)
2026-07-07 21:49   ` [tip: timers/core] " tip-bot2 for Thomas Weißschuh (Schneider Electric)
2026-07-02  9:42 ` [PATCH 3/8] hrtimer: Move hrtimer_update_function() to hrtimer.c Thomas Weißschuh (Schneider Electric)
2026-07-07 21:49   ` [tip: timers/core] " tip-bot2 for Thomas Weißschuh (Schneider Electric)
2026-07-02  9:42 ` [PATCH 4/8] tick: Explicitly include linux/hrtimer_bases.h Thomas Weißschuh (Schneider Electric)
2026-07-07 21:49   ` [tip: timers/core] " tip-bot2 for Thomas Weißschuh (Schneider Electric)
2026-07-02  9:42 ` [PATCH 5/8] hrtimer: " Thomas Weißschuh (Schneider Electric)
2026-07-07 21:49   ` [tip: timers/core] " tip-bot2 for Thomas Weißschuh (Schneider Electric)
2026-07-02  9:42 ` [PATCH 6/8] hrtimer: Explicitly include some necessary headers in hrtimer_rearm.h Thomas Weißschuh (Schneider Electric)
2026-07-07 21:49   ` [tip: timers/core] " tip-bot2 for Thomas Weißschuh (Schneider Electric)
2026-07-02  9:42 ` [PATCH 7/8] x86/speculation: Explicitly include linux/types.h Thomas Weißschuh (Schneider Electric)
2026-07-07 21:49   ` [tip: timers/core] " tip-bot2 for Thomas Weißschuh (Schneider Electric)
2026-07-02  9:42 ` [PATCH 8/8] hrtimer: Remove inclusion of hrtimer_bases.h remove from hrtimer.h Thomas Weißschuh (Schneider Electric)
2026-07-07 21:49   ` [tip: timers/core] " tip-bot2 for Thomas Weißschuh (Schneider Electric)

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®