From: Maxim Levitsky <mlevitsk@redhat.com>
To: Sean Christopherson <seanjc@google.com>,
Paolo Bonzini <pbonzini@redhat.com>,
Vitaly Kuznetsov <vkuznets@redhat.com>
Cc: kvm@vger.kernel.org, linux-kernel@vger.kernel.org,
Hou Wenlong <houwenlong.hwl@antgroup.com>,
Kechen Lu <kechenl@nvidia.com>,
Oliver Upton <oliver.upton@linux.dev>,
Binbin Wu <binbin.wu@linux.intel.com>,
Yang Weijiang <weijiang.yang@intel.com>,
Robert Hoo <robert.hoo.linux@gmail.com>
Subject: Re: [PATCH v2 26/49] KVM: x86: Add a macro to init CPUID features that KVM emulates in software
Date: Thu, 04 Jul 2024 21:59:20 -0400 [thread overview]
Message-ID: <2e0f3fb63c810dd924907bccf9256f6f193b02ec.camel@redhat.com> (raw)
In-Reply-To: <20240517173926.965351-27-seanjc@google.com>
On Fri, 2024-05-17 at 10:39 -0700, Sean Christopherson wrote:
> Now that kvm_cpu_cap_init() is a macro with its own scope, add EMUL_F() to
> OR-in features that KVM emulates in software, i.e. that don't depend on
> the feature being available in hardware. The contained scope
> of kvm_cpu_cap_init() allows using a local variable to track the set of
> emulated leaves, which in addition to avoiding confusing and/or
> unnecessary variables, helps prevent misuse of EMUL_F().
>
> Signed-off-by: Sean Christopherson <seanjc@google.com>
> ---
> arch/x86/kvm/cpuid.c | 36 +++++++++++++++++++++---------------
> 1 file changed, 21 insertions(+), 15 deletions(-)
>
> diff --git a/arch/x86/kvm/cpuid.c b/arch/x86/kvm/cpuid.c
> index 1064e4d68718..33e3e77de1b7 100644
> --- a/arch/x86/kvm/cpuid.c
> +++ b/arch/x86/kvm/cpuid.c
> @@ -94,6 +94,16 @@ u32 xstate_required_size(u64 xstate_bv, bool compacted)
> F(name); \
> })
>
> +/*
> + * Emulated Feature - For features that KVM emulates in software irrespective
> + * of host CPU/kernel support.
> + */
> +#define EMUL_F(name) \
> +({ \
> + kvm_cpu_cap_emulated |= F(name); \
> + F(name); \
> +})
To me it feels more and more that this patch series doesn't go into the right direction.
How about we just abandon the whole concept of masks and instead just have a list of statements
Pretty much the opposite of the patch series I confess:
#define CAP_PASSTHOUGH 0x01
#define CAP_EMULATED 0x02
#define CAP_AMD_ALIASED 0x04 // for AMD aliased features
#define CAP_SCATTERED 0x08
#define CAP_X86_64 0x10 // supported only on 64 bit hypervisors
...
/* CPUID_1_ECX*/
/* TMA is not passed though because: xyz*/
kvm_cpu_cap_init(TMA, 0);
kvm_cpu_cap_init(SSSE3, CAP_PASSTHOUGH);
/* CNXT_ID is not passed though because: xyz*/
kvm_cpu_cap_init(CNXT_ID, 0);
kvm_cpu_cap_init(RESERVED, 0);
kvm_cpu_cap_init(FMA, CAP_PASSTHOUGH);
...
/* KVM always emulates TSC_ADJUST */
kvm_cpu_cap_init(TSC_ADJUST, CAP_EMULATED | CAP_SCATTERED);
...
/* CPUID_D_1_EAX*/
/* XFD is disabled on 32 bit systems because: xyz*/
kvm_cpu_cap_init(XFD, CAP_PASSTHOUGH | CAP_X86_64)
'kvm_cpu_cap_init' can be a macro if needed to have the compile checks.
There are several advantages to this:
- more readability, plus if needed each statement can be amended with a comment.
- No weird hacks in 'F*' macros, which additionally eventually evaluate into a bit, which is confusing.
In fact no need to even have them at all.
- No need to verify that bitmask belongs to a feature word.
- Merge friendly - each capability has its own line.
Disadvantages:
- Longer list - IMHO not a problem, since it is very easy to read / search
and can have as much comments as needed.
For example this is how the kernel lists the CPUID features and this list IMHO
is very manageable.
- Slower - kvm_set_cpu_caps is called exactly once per KVM module load, thus
performance is the last thing I would care about in this function.
Another note about this patch: It is somewhat confusing that EMUL_F just forces a feature in kvm caps,
regardless of CPU support, because KVM also has KVM_GET_EMULATED_CPUID and it has a different meaning.
Users can easily confuse the EMUL_F for something that sets a feature bit in the KVM_GET_EMULATED_CPUID.
Best regards,
Maxim Levitsky
> +
> /*
> * Aliased Features - For features in 0x8000_0001.EDX that are duplicates of
> * identical 0x1.EDX features, and thus are aliased from 0x1 to 0x8000_0001.
> @@ -649,6 +659,7 @@ do { \
> do { \
> const struct cpuid_reg cpuid = x86_feature_cpuid(leaf * 32); \
> const u32 __maybe_unused kvm_cpu_cap_init_in_progress = leaf; \
> + u32 kvm_cpu_cap_emulated = 0; \
> \
> if (leaf < NCAPINTS) \
> kvm_cpu_caps[leaf] &= (mask); \
> @@ -656,6 +667,7 @@ do { \
> kvm_cpu_caps[leaf] = (mask); \
> \
> kvm_cpu_caps[leaf] &= raw_cpuid_get(cpuid); \
> + kvm_cpu_caps[leaf] |= kvm_cpu_cap_emulated; \
> } while (0)
>
> /*
> @@ -684,12 +696,10 @@ void kvm_set_cpu_caps(void)
> 0 /* TM2 */ | F(SSSE3) | 0 /* CNXT-ID */ | 0 /* Reserved */ |
> F(FMA) | F(CX16) | 0 /* xTPR Update */ | F(PDCM) |
> F(PCID) | 0 /* Reserved, DCA */ | F(XMM4_1) |
> - F(XMM4_2) | F(X2APIC) | F(MOVBE) | F(POPCNT) |
> + F(XMM4_2) | EMUL_F(X2APIC) | F(MOVBE) | F(POPCNT) |
> 0 /* Reserved*/ | F(AES) | F(XSAVE) | 0 /* OSXSAVE */ | F(AVX) |
> F(F16C) | F(RDRAND)
> );
> - /* KVM emulates x2apic in software irrespective of host support. */
> - kvm_cpu_cap_set(X86_FEATURE_X2APIC);
>
> kvm_cpu_cap_init(CPUID_1_EDX,
> F(FPU) | F(VME) | F(DE) | F(PSE) |
> @@ -703,13 +713,13 @@ void kvm_set_cpu_caps(void)
> );
>
> kvm_cpu_cap_init(CPUID_7_0_EBX,
> - F(FSGSBASE) | F(SGX) | F(BMI1) | F(HLE) | F(AVX2) |
> - F(FDP_EXCPTN_ONLY) | F(SMEP) | F(BMI2) | F(ERMS) | F(INVPCID) |
> - F(RTM) | F(ZERO_FCS_FDS) | 0 /*MPX*/ | F(AVX512F) |
> - F(AVX512DQ) | F(RDSEED) | F(ADX) | F(SMAP) | F(AVX512IFMA) |
> - F(CLFLUSHOPT) | F(CLWB) | 0 /*INTEL_PT*/ | F(AVX512PF) |
> - F(AVX512ER) | F(AVX512CD) | F(SHA_NI) | F(AVX512BW) |
> - F(AVX512VL));
> + F(FSGSBASE) | EMUL_F(TSC_ADJUST) | F(SGX) | F(BMI1) | F(HLE) |
> + F(AVX2) | F(FDP_EXCPTN_ONLY) | F(SMEP) | F(BMI2) | F(ERMS) |
> + F(INVPCID) | F(RTM) | F(ZERO_FCS_FDS) | 0 /*MPX*/ |
> + F(AVX512F) | F(AVX512DQ) | F(RDSEED) | F(ADX) | F(SMAP) |
> + F(AVX512IFMA) | F(CLFLUSHOPT) | F(CLWB) | 0 /*INTEL_PT*/ |
> + F(AVX512PF) | F(AVX512ER) | F(AVX512CD) | F(SHA_NI) |
> + F(AVX512BW) | F(AVX512VL));
>
> kvm_cpu_cap_init(CPUID_7_ECX,
> F(AVX512VBMI) | RAW_F(LA57) | F(PKU) | 0 /*OSPKE*/ | F(RDPID) |
> @@ -728,16 +738,12 @@ void kvm_set_cpu_caps(void)
>
> kvm_cpu_cap_init(CPUID_7_EDX,
> F(AVX512_4VNNIW) | F(AVX512_4FMAPS) | F(SPEC_CTRL) |
> - F(SPEC_CTRL_SSBD) | F(ARCH_CAPABILITIES) | F(INTEL_STIBP) |
> + F(SPEC_CTRL_SSBD) | EMUL_F(ARCH_CAPABILITIES) | F(INTEL_STIBP) |
> F(MD_CLEAR) | F(AVX512_VP2INTERSECT) | F(FSRM) |
> F(SERIALIZE) | F(TSXLDTRK) | F(AVX512_FP16) |
> F(AMX_TILE) | F(AMX_INT8) | F(AMX_BF16) | F(FLUSH_L1D)
> );
>
> - /* TSC_ADJUST and ARCH_CAPABILITIES are emulated in software. */
> - kvm_cpu_cap_set(X86_FEATURE_TSC_ADJUST);
> - kvm_cpu_cap_set(X86_FEATURE_ARCH_CAPABILITIES);
> -
> if (boot_cpu_has(X86_FEATURE_IBPB) && boot_cpu_has(X86_FEATURE_IBRS))
> kvm_cpu_cap_set(X86_FEATURE_SPEC_CTRL);
> if (boot_cpu_has(X86_FEATURE_STIBP))
next prev parent reply other threads:[~2024-07-05 1:59 UTC|newest]
Thread overview: 185+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-05-17 17:38 [PATCH v2 00/49] KVM: x86: CPUID overhaul, fixes, and caching Sean Christopherson
2024-05-17 17:38 ` [PATCH v2 01/49] KVM: x86: Do all post-set CPUID processing during vCPU creation Sean Christopherson
2024-07-05 0:48 ` Maxim Levitsky
2024-07-08 18:46 ` Sean Christopherson
2024-07-24 17:24 ` Maxim Levitsky
2024-05-17 17:38 ` [PATCH v2 02/49] KVM: x86: Explicitly do runtime CPUID updates "after" initial setup Sean Christopherson
2024-07-05 0:51 ` Maxim Levitsky
2024-07-09 19:46 ` Sean Christopherson
2024-07-24 17:24 ` Maxim Levitsky
2024-05-17 17:38 ` [PATCH v2 03/49] KVM: x86: Account for KVM-reserved CR4 bits when passing through CR4 on VMX Sean Christopherson
2024-07-05 0:55 ` Maxim Levitsky
2024-07-09 19:58 ` Sean Christopherson
2024-07-24 17:28 ` Maxim Levitsky
2024-05-17 17:38 ` [PATCH v2 04/49] KVM: selftests: Update x86's set_sregs_test to match KVM's CPUID enforcement Sean Christopherson
2024-07-05 0:55 ` Maxim Levitsky
2024-05-17 17:38 ` [PATCH v2 05/49] KVM: selftests: Assert that the @cpuid passed to get_cpuid_entry() is non-NULL Sean Christopherson
2024-07-05 0:58 ` Maxim Levitsky
2024-07-08 19:33 ` Sean Christopherson
2024-07-24 17:28 ` Maxim Levitsky
2024-11-21 18:57 ` Sean Christopherson
2024-05-17 17:38 ` [PATCH v2 06/49] KVM: selftests: Refresh vCPU CPUID cache in __vcpu_get_cpuid_entry() Sean Christopherson
2024-07-05 0:59 ` Maxim Levitsky
2024-05-17 17:38 ` [PATCH v2 07/49] KVM: selftests: Verify KVM stuffs runtime CPUID OS bits on CR4 writes Sean Christopherson
2024-07-05 1:02 ` Maxim Levitsky
2024-07-08 19:39 ` Sean Christopherson
2024-05-17 17:38 ` [PATCH v2 08/49] KVM: x86: Move __kvm_is_valid_cr4() definition to x86.h Sean Christopherson
2024-07-05 1:02 ` Maxim Levitsky
2024-05-17 17:38 ` [PATCH v2 09/49] KVM: x86/pmu: Drop now-redundant refresh() during init() Sean Christopherson
2024-07-05 1:02 ` Maxim Levitsky
2024-05-17 17:38 ` [PATCH v2 10/49] KVM: x86: Drop now-redundant MAXPHYADDR and GPA rsvd bits from vCPU creation Sean Christopherson
2024-07-05 1:13 ` Maxim Levitsky
2024-07-08 19:53 ` Sean Christopherson
2024-07-24 17:30 ` Maxim Levitsky
2024-05-17 17:38 ` [PATCH v2 11/49] KVM: x86: Disallow KVM_CAP_X86_DISABLE_EXITS after " Sean Christopherson
2024-07-05 1:17 ` Maxim Levitsky
2024-07-08 19:43 ` Sean Christopherson
2024-07-24 17:31 ` Maxim Levitsky
2024-07-25 18:07 ` Sean Christopherson
2024-07-12 7:42 ` Xiaoyao Li
2024-05-17 17:38 ` [PATCH v2 12/49] KVM: x86: Reject disabling of MWAIT/HLT interception when not allowed Sean Christopherson
2024-05-22 5:09 ` Binbin Wu
2024-05-28 18:56 ` Sean Christopherson
2024-07-05 1:17 ` Maxim Levitsky
2024-07-12 7:51 ` Xiaoyao Li
2024-07-12 13:31 ` Sean Christopherson
2024-05-17 17:38 ` [PATCH v2 13/49] KVM: selftests: Fix a bad TEST_REQUIRE() in x86's KVM PV test Sean Christopherson
2024-07-05 1:17 ` Maxim Levitsky
2024-05-17 17:38 ` [PATCH v2 14/49] KVM: selftests: Update x86's KVM PV test to match KVM's disabling exits behavior Sean Christopherson
2024-07-05 1:17 ` Maxim Levitsky
2024-05-17 17:38 ` [PATCH v2 15/49] KVM: x86: Zero out PV features cache when the CPUID leaf is not present Sean Christopherson
2024-07-05 1:17 ` Maxim Levitsky
2024-05-17 17:38 ` [PATCH v2 16/49] KVM: x86: Don't update PV features caches when enabling enforcement capability Sean Christopherson
2024-07-05 1:17 ` Maxim Levitsky
2024-05-17 17:38 ` [PATCH v2 17/49] KVM: x86: Do reverse CPUID sanity checks in __feature_leaf() Sean Christopherson
2024-07-05 1:17 ` Maxim Levitsky
2024-05-17 17:38 ` [PATCH v2 18/49] KVM: x86: Account for max supported CPUID leaf when getting raw host CPUID Sean Christopherson
2024-06-19 6:17 ` Yang, Weijiang
2024-06-19 8:07 ` Yang, Weijiang
2024-07-05 1:17 ` Maxim Levitsky
2024-05-17 17:38 ` [PATCH v2 19/49] KVM: x86: Add a macro to init CPUID features that ignore host kernel support Sean Christopherson
2024-07-05 1:21 ` Maxim Levitsky
2024-07-08 20:53 ` Sean Christopherson
2024-07-24 17:39 ` Maxim Levitsky
2024-07-08 22:36 ` Sean Christopherson
2024-07-24 17:40 ` Maxim Levitsky
2024-05-17 17:38 ` [PATCH v2 20/49] KVM: x86: Rename kvm_cpu_cap_mask() to kvm_cpu_cap_init() Sean Christopherson
2024-05-22 6:23 ` Binbin Wu
2024-05-28 18:54 ` Sean Christopherson
2024-07-05 1:24 ` Maxim Levitsky
2024-05-17 17:38 ` [PATCH v2 21/49] KVM: x86: Add a macro to init CPUID features that are 64-bit only Sean Christopherson
2024-07-05 1:24 ` Maxim Levitsky
2024-07-17 13:31 ` Xiaoyao Li
2024-05-17 17:38 ` [PATCH v2 22/49] KVM: x86: Add a macro to precisely handle aliased 0x1.EDX CPUID features Sean Christopherson
2024-07-05 1:25 ` Maxim Levitsky
2024-07-08 21:08 ` Sean Christopherson
2024-07-24 17:46 ` Maxim Levitsky
2024-07-25 18:39 ` Sean Christopherson
2024-08-05 11:06 ` mlevitsk
2024-08-05 22:00 ` Sean Christopherson
2024-09-10 20:37 ` Maxim Levitsky
2024-09-11 15:37 ` Sean Christopherson
2024-11-22 3:17 ` Maxim Levitsky
2024-11-27 14:38 ` Sean Christopherson
2024-05-17 17:39 ` [PATCH v2 23/49] KVM: x86: Handle kernel- and KVM-defined CPUID words in a single helper Sean Christopherson
2024-07-05 1:28 ` Maxim Levitsky
2024-07-08 21:18 ` Sean Christopherson
2024-07-17 14:00 ` Xiaoyao Li
2024-07-24 17:51 ` Maxim Levitsky
2024-07-25 19:18 ` Sean Christopherson
2024-08-05 11:07 ` mlevitsk
2024-05-17 17:39 ` [PATCH v2 24/49] KVM: x86: #undef SPEC_CTRL_SSBD in cpuid.c to avoid macro collisions Sean Christopherson
2024-07-05 1:30 ` Maxim Levitsky
2024-07-08 21:29 ` Sean Christopherson
2024-07-24 17:54 ` Maxim Levitsky
2024-07-26 23:34 ` Sean Christopherson
2024-08-05 11:11 ` mlevitsk
2024-08-05 21:35 ` Sean Christopherson
2024-09-10 20:37 ` Maxim Levitsky
2024-05-17 17:39 ` [PATCH v2 25/49] KVM: x86: Harden CPU capabilities processing against out-of-scope features Sean Christopherson
2024-07-05 1:31 ` Maxim Levitsky
2024-07-09 18:11 ` Sean Christopherson
2024-07-24 17:55 ` Maxim Levitsky
2024-05-17 17:39 ` [PATCH v2 26/49] KVM: x86: Add a macro to init CPUID features that KVM emulates in software Sean Christopherson
2024-07-05 1:59 ` Maxim Levitsky [this message]
2024-07-08 22:30 ` Sean Christopherson
2024-07-24 17:58 ` Maxim Levitsky
2024-07-27 0:06 ` Sean Christopherson
2024-08-05 11:16 ` mlevitsk
2024-08-05 19:59 ` Sean Christopherson
2024-09-10 20:41 ` Maxim Levitsky
2024-09-11 16:03 ` Sean Christopherson
2024-11-22 3:28 ` Maxim Levitsky
2024-05-17 17:39 ` [PATCH v2 27/49] KVM: x86: Swap incoming guest CPUID into vCPU before massaging in KVM_SET_CPUID2 Sean Christopherson
2024-07-05 1:32 ` Maxim Levitsky
2024-07-08 21:37 ` Sean Christopherson
2024-05-17 17:39 ` [PATCH v2 28/49] KVM: x86: Clear PV_UNHALT for !HLT-exiting only when userspace sets CPUID Sean Christopherson
2024-07-05 1:32 ` Maxim Levitsky
2024-05-17 17:39 ` [PATCH v2 29/49] KVM: x86: Remove unnecessary caching of KVM's PV CPUID base Sean Christopherson
2024-07-05 1:51 ` Maxim Levitsky
2024-07-09 19:00 ` Sean Christopherson
2024-07-24 17:59 ` Maxim Levitsky
2024-05-17 17:39 ` [PATCH v2 30/49] KVM: x86: Always operate on kvm_vcpu data in cpuid_entry2_find() Sean Christopherson
2024-07-05 1:51 ` Maxim Levitsky
2024-05-17 17:39 ` [PATCH v2 31/49] KVM: x86: Move kvm_find_cpuid_entry{,_index}() up near cpuid_entry2_find() Sean Christopherson
2024-07-05 1:51 ` Maxim Levitsky
2024-05-17 17:39 ` [PATCH v2 32/49] KVM: x86: Remove all direct usage of cpuid_entry2_find() Sean Christopherson
2024-07-05 1:52 ` Maxim Levitsky
2024-05-17 17:39 ` [PATCH v2 33/49] KVM: x86: Advertise TSC_DEADLINE_TIMER in KVM_GET_SUPPORTED_CPUID Sean Christopherson
2024-05-22 9:11 ` Binbin Wu
2024-05-28 15:21 ` Sean Christopherson
2024-07-05 2:04 ` Maxim Levitsky
2024-07-09 19:28 ` Sean Christopherson
2024-07-24 18:00 ` Maxim Levitsky
2024-05-17 17:39 ` [PATCH v2 34/49] KVM: x86: Advertise HYPERVISOR " Sean Christopherson
2024-07-05 2:04 ` Maxim Levitsky
2024-05-17 17:39 ` [PATCH v2 35/49] KVM: x86: Add a macro to handle features that are fully VMM controlled Sean Christopherson
2024-07-05 2:08 ` Maxim Levitsky
2024-05-17 17:39 ` [PATCH v2 36/49] KVM: x86: Rename "governed features" helpers to use "guest_cpu_cap" Sean Christopherson
2024-05-22 14:23 ` Binbin Wu
2024-05-17 17:39 ` [PATCH v2 37/49] KVM: x86: Replace guts of "governed" features with comprehensive cpu_caps Sean Christopherson
2024-06-20 2:20 ` Yang, Weijiang
2024-07-05 2:10 ` Maxim Levitsky
2024-07-09 18:30 ` Sean Christopherson
2024-07-24 18:00 ` Maxim Levitsky
2024-05-17 17:39 ` [PATCH v2 38/49] KVM: x86: Initialize guest cpu_caps based on guest CPUID Sean Christopherson
2024-06-20 2:24 ` Yang, Weijiang
2024-07-05 2:13 ` Maxim Levitsky
2024-05-17 17:39 ` [PATCH v2 39/49] KVM: x86: Extract code for generating per-entry emulated CPUID information Sean Christopherson
2024-07-05 2:18 ` Maxim Levitsky
2024-07-09 0:13 ` Sean Christopherson
2024-07-24 18:00 ` Maxim Levitsky
2024-05-17 17:39 ` [PATCH v2 40/49] KVM: x86: Initialize guest cpu_caps based on KVM support Sean Christopherson
2024-07-05 2:22 ` Maxim Levitsky
2024-07-09 0:10 ` Sean Christopherson
2024-07-24 18:01 ` Maxim Levitsky
2024-07-29 15:34 ` Sean Christopherson
2024-08-05 11:16 ` mlevitsk
2024-05-17 17:39 ` [PATCH v2 41/49] KVM: x86: Avoid double CPUID lookup when updating MWAIT at runtime Sean Christopherson
2024-07-05 2:22 ` Maxim Levitsky
2024-05-17 17:39 ` [PATCH v2 42/49] KVM: x86: Drop unnecessary check that cpuid_entry2_find() returns right leaf Sean Christopherson
2024-07-05 2:22 ` Maxim Levitsky
2024-05-17 17:39 ` [PATCH v2 43/49] KVM: x86: Update OS{XSAVE,PKE} bits in guest CPUID irrespective of host support Sean Christopherson
2024-07-05 2:22 ` Maxim Levitsky
2024-05-17 17:39 ` [PATCH v2 44/49] KVM: x86: Update guest cpu_caps at runtime for dynamic CPUID-based features Sean Christopherson
2024-07-05 2:26 ` Maxim Levitsky
2024-07-09 0:24 ` Sean Christopherson
2024-09-10 20:41 ` Maxim Levitsky
2024-09-11 15:41 ` Sean Christopherson
2024-11-22 2:11 ` Maxim Levitsky
2024-05-17 17:39 ` [PATCH v2 45/49] KVM: x86: Shuffle code to prepare for dropping guest_cpuid_has() Sean Christopherson
2024-07-05 2:26 ` Maxim Levitsky
2024-05-17 17:39 ` [PATCH v2 46/49] KVM: x86: Replace (almost) all guest CPUID feature queries with cpu_caps Sean Christopherson
2024-07-05 2:34 ` Maxim Levitsky
2024-07-09 19:20 ` Sean Christopherson
2024-07-24 18:01 ` Maxim Levitsky
2024-05-17 17:39 ` [PATCH v2 47/49] KVM: x86: Drop superfluous host XSAVE check when adjusting guest XSAVES caps Sean Christopherson
2024-07-05 2:36 ` Maxim Levitsky
2024-07-09 19:15 ` Sean Christopherson
2024-07-24 18:02 ` Maxim Levitsky
2024-05-17 17:39 ` [PATCH v2 48/49] KVM: x86: Add a macro for features that are synthesized into boot_cpu_data Sean Christopherson
2024-07-05 2:43 ` Maxim Levitsky
2024-07-09 21:13 ` Sean Christopherson
2024-07-24 18:04 ` Maxim Levitsky
2024-05-17 17:39 ` [PATCH v2 49/49] *** DO NOT APPLY *** KVM: x86: Verify KVM initializes all consumed guest caps Sean Christopherson
2024-05-17 17:54 ` [PATCH v2 00/49] KVM: x86: CPUID overhaul, fixes, and caching Paolo Bonzini
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=2e0f3fb63c810dd924907bccf9256f6f193b02ec.camel@redhat.com \
--to=mlevitsk@redhat.com \
--cc=binbin.wu@linux.intel.com \
--cc=houwenlong.hwl@antgroup.com \
--cc=kechenl@nvidia.com \
--cc=kvm@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=oliver.upton@linux.dev \
--cc=pbonzini@redhat.com \
--cc=robert.hoo.linux@gmail.com \
--cc=seanjc@google.com \
--cc=vkuznets@redhat.com \
--cc=weijiang.yang@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome