From: Sibi Sankar <quic_sibis@quicinc.com>
To: Srinivasa Rao Mandadapu <quic_srivasam@quicinc.com>,
<linux-remoteproc@vger.kernel.org>, <agross@kernel.org>,
<bjorn.andersson@linaro.org>, <lgirdwood@gmail.com>,
<broonie@kernel.org>, <robh+dt@kernel.org>,
<quic_plai@quicinc.com>, <bgoswami@quicinc.com>, <perex@perex.cz>,
<tiwai@suse.com>, <srinivas.kandagatla@linaro.org>,
<quic_rohkumar@quicinc.com>, <linux-arm-msm@vger.kernel.org>,
<linux-kernel@vger.kernel.org>, <swboyd@chromium.org>,
<judyhsiao@chromium.org>, <devicetree@vger.kernel.org>
Subject: Re: [PATCH v6 7/8] remoteproc: qcom: Add support for memory sandbox
Date: Wed, 14 Sep 2022 15:40:33 +0530 [thread overview]
Message-ID: <3c951582-070c-675f-14c7-ca033ca347b6@quicinc.com> (raw)
In-Reply-To: <1662643422-14909-8-git-send-email-quic_srivasam@quicinc.com>
On 9/8/22 6:53 PM, Srinivasa Rao Mandadapu wrote:
> Update pil driver with SMMU mapping for allowing authorised
> memory access to ADSP firmware, by carveout reserved adsp memory
> region from device tree file.
>
> Signed-off-by: Srinivasa Rao Mandadapu <quic_srivasam@quicinc.com>
> ---
> Changes since V5:
> -- Remove adsp_rproc_unmap_smmu, adsp_of_unmap_smmu, adsp_of_map_smmu and
> adsp_rproc_map_smmu functions.
> -- Remove find_loaded_rsc_table call back initialization.
> -- Rename adsp_sandbox_needed to has_iommu.
> Changes since V4:
> -- Split the code and add appropriate APIs for resource allocation and free.
> -- Update adsp_unmap_smmu with missing free ops call.
> -- Update normalizing length value in adsp_of_unmap_smmu.
> Changes since V3:
> -- Rename is_adsp_sb_needed to adsp_sandbox_needed.
> -- Add smmu unmapping in error case and in adsp stop.
> Changes since V2:
> -- Replace platform_bus_type with adsp->dev->bus.
> -- Use API of_parse_phandle_with_args() instead of of_parse_phandle_with_fixed_args().
> -- Replace adsp->is_wpss with adsp->is_adsp.
> -- Update error handling in adsp_start().
>
> drivers/remoteproc/qcom_q6v5_adsp.c | 55 ++++++++++++++++++++++++++++++++++++-
> 1 file changed, 54 insertions(+), 1 deletion(-)
>
> diff --git a/drivers/remoteproc/qcom_q6v5_adsp.c b/drivers/remoteproc/qcom_q6v5_adsp.c
> index ccb5592..e55d593 100644
> --- a/drivers/remoteproc/qcom_q6v5_adsp.c
> +++ b/drivers/remoteproc/qcom_q6v5_adsp.c
> @@ -9,6 +9,7 @@
> #include <linux/firmware.h>
> #include <linux/interrupt.h>
> #include <linux/io.h>
> +#include <linux/iommu.h>
> #include <linux/iopoll.h>
> #include <linux/kernel.h>
> #include <linux/mfd/syscon.h>
> @@ -48,6 +49,8 @@
> #define LPASS_PWR_ON_REG 0x10
> #define LPASS_HALTREQ_REG 0x0
>
> +#define SID_MASK_DEFAULT 0xF
> +
> #define QDSP6SS_XO_CBCR 0x38
> #define QDSP6SS_CORE_CBCR 0x20
> #define QDSP6SS_SLEEP_CBCR 0x3c
> @@ -333,6 +336,42 @@ static int adsp_load(struct rproc *rproc, const struct firmware *fw)
> return 0;
> }
>
> +static void adsp_unmap_smmu(struct rproc *rproc)
> +{
> + struct qcom_adsp *adsp = (struct qcom_adsp *)rproc->priv;
> +
> + iommu_unmap(rproc->domain, adsp->mem_phys, adsp->mem_size);
> +}
> +
> +static int adsp_map_smmu(struct qcom_adsp *adsp, struct rproc *rproc)
you could perhaps name the func to adsp_map_carveout/adsp_unmap_carveout
> +{
> + struct of_phandle_args args;
> + long long sid;
> + unsigned long iova;
> + int ret;
> +
> + if (!rproc->domain)
> + return -EINVAL;
> +
> + ret = of_parse_phandle_with_args(adsp->dev->of_node, "iommus", "#iommu-cells", 0, &args);
> + if (ret < 0)
> + return ret;
> +
> + sid = args.args[0] & SID_MASK_DEFAULT;
> +
> + /* Add SID configuration for ADSP Firmware to SMMU */
> + iova = adsp->mem_phys | (sid << 32);
> +
> + ret = iommu_map(rproc->domain, iova, adsp->mem_phys,
> + adsp->mem_size, IOMMU_READ | IOMMU_WRITE);
> + if (ret) {
> + dev_err(adsp->dev, "Unable to map ADSP Physical Memory\n");
> + return ret;
> + }
> +
> + return 0;
> +}
> +
> static int adsp_start(struct rproc *rproc)
> {
> struct qcom_adsp *adsp = (struct qcom_adsp *)rproc->priv;
> @@ -343,9 +382,17 @@ static int adsp_start(struct rproc *rproc)
> if (ret)
> return ret;
>
> + if (adsp->has_iommu) {
> + ret = adsp_map_smmu(adsp, rproc);
> + if (ret) {
> + dev_err(adsp->dev, "ADSP smmu mapping failed\n");
> + goto disable_irqs;
> + }
> + }
> +
> ret = clk_prepare_enable(adsp->xo);
> if (ret)
> - goto disable_irqs;
> + goto adsp_smmu_unmap;
>
> ret = qcom_rproc_pds_enable(adsp, adsp->proxy_pds,
> adsp->proxy_pd_count);
> @@ -401,6 +448,9 @@ static int adsp_start(struct rproc *rproc)
> qcom_rproc_pds_disable(adsp, adsp->proxy_pds, adsp->proxy_pd_count);
> disable_xo_clk:
> clk_disable_unprepare(adsp->xo);
> +adsp_smmu_unmap:
> + if (adsp->has_iommu)
> + adsp_unmap_smmu(rproc);
> disable_irqs:
> qcom_q6v5_unprepare(&adsp->q6v5);
>
> @@ -429,6 +479,9 @@ static int adsp_stop(struct rproc *rproc)
> if (ret)
> dev_err(adsp->dev, "failed to shutdown: %d\n", ret);
>
> + if (adsp->has_iommu)
> + adsp_unmap_smmu(rproc);
> +
> handover = qcom_q6v5_unprepare(&adsp->q6v5);
> if (handover)
> qcom_adsp_pil_handover(&adsp->q6v5);
>
next prev parent reply other threads:[~2022-09-14 10:11 UTC|newest]
Thread overview: 30+ messages / expand[flat|nested] mbox.gz Atom feed top
2022-09-08 13:23 [PATCH v6 0/8] Update ADSP pil loader for SC7280 platform Srinivasa Rao Mandadapu
2022-09-08 13:23 ` [PATCH v6 1/8] dt-bindings: remoteproc: qcom: Add SC7280 ADSP support Srinivasa Rao Mandadapu
2022-09-11 22:52 ` Stephen Boyd
2022-09-14 8:58 ` Sibi Sankar
2022-09-19 14:04 ` Srinivasa Rao Mandadapu
2022-09-08 13:23 ` [PATCH v6 2/8] remoteproc: qcom: Add flag in adsp private data structure Srinivasa Rao Mandadapu
2022-09-14 9:06 ` Sibi Sankar
2022-09-19 14:05 ` Srinivasa Rao Mandadapu
2022-09-08 13:23 ` [PATCH v6 3/8] remoteproc: qcom: Add compatible name for SC7280 ADSP Srinivasa Rao Mandadapu
2022-09-11 22:53 ` Stephen Boyd
2022-09-14 9:22 ` Sibi Sankar
2022-09-19 14:11 ` Srinivasa Rao Mandadapu
2022-09-08 13:23 ` [PATCH v6 4/8] remoteproc: qcom: Update rproc parse firmware callback Srinivasa Rao Mandadapu
2022-09-11 22:55 ` Stephen Boyd
2022-09-19 13:57 ` Srinivasa Rao Mandadapu
2022-09-14 9:35 ` Sibi Sankar
2022-09-19 14:15 ` Srinivasa Rao Mandadapu
2022-09-08 13:23 ` [PATCH v6 5/8] remoteproc: qcom: Replace hard coded values with macros Srinivasa Rao Mandadapu
2022-09-14 9:37 ` Sibi Sankar
2022-09-08 13:23 ` [PATCH v6 6/8] remoteproc: qcom: Add efuse evb selection control Srinivasa Rao Mandadapu
2022-09-11 22:57 ` Stephen Boyd
2022-09-14 9:42 ` Sibi Sankar
2022-09-08 13:23 ` [PATCH v6 7/8] remoteproc: qcom: Add support for memory sandbox Srinivasa Rao Mandadapu
2022-09-11 23:01 ` Stephen Boyd
2022-09-19 13:59 ` Srinivasa Rao Mandadapu
2022-09-14 10:10 ` Sibi Sankar [this message]
2022-09-19 14:19 ` Srinivasa Rao Mandadapu
2022-09-08 13:23 ` [PATCH v6 8/8] remoteproc: qcom: Update QDSP6 out-of-reset timeout value Srinivasa Rao Mandadapu
2022-09-14 9:45 ` Sibi Sankar
2022-09-19 14:20 ` Srinivasa Rao Mandadapu
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=3c951582-070c-675f-14c7-ca033ca347b6@quicinc.com \
--to=quic_sibis@quicinc.com \
--cc=agross@kernel.org \
--cc=bgoswami@quicinc.com \
--cc=bjorn.andersson@linaro.org \
--cc=broonie@kernel.org \
--cc=devicetree@vger.kernel.org \
--cc=judyhsiao@chromium.org \
--cc=lgirdwood@gmail.com \
--cc=linux-arm-msm@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-remoteproc@vger.kernel.org \
--cc=perex@perex.cz \
--cc=quic_plai@quicinc.com \
--cc=quic_rohkumar@quicinc.com \
--cc=quic_srivasam@quicinc.com \
--cc=robh+dt@kernel.org \
--cc=srinivas.kandagatla@linaro.org \
--cc=swboyd@chromium.org \
--cc=tiwai@suse.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®