mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH v3 bpf] bpf, test_run: fix &xdp_frame misplacement for LIVE_FRAMES
@ 2023-02-15 15:21 Alexander Lobakin
  2023-02-15 18:04 ` Martin KaFai Lau
  0 siblings, 1 reply; 3+ messages in thread
From: Alexander Lobakin @ 2023-02-15 15:21 UTC (permalink / raw)
  To: Alexei Starovoitov, Daniel Borkmann, Andrii Nakryiko
  Cc: Alexander Lobakin, Toke Høiland-Jørgensen,
	Martin KaFai Lau, Song Liu, Jesper Dangaard Brouer,
	Jakub Kicinski, bpf, netdev, linux-kernel

&xdp_buff and &xdp_frame are bound in a way that

xdp_buff->data_hard_start == xdp_frame

It's always the case and e.g. xdp_convert_buff_to_frame() relies on
this.
IOW, the following:

	for (u32 i = 0; i < 0xdead; i++) {
		xdpf = xdp_convert_buff_to_frame(&xdp);
		xdp_convert_frame_to_buff(xdpf, &xdp);
	}

shouldn't ever modify @xdpf's contents or the pointer itself.
However, "live packet" code wrongly treats &xdp_frame as part of its
context placed *before* the data_hard_start. With such flow,
data_hard_start is sizeof(*xdpf) off to the right and no longer points
to the XDP frame.

Instead of replacing `sizeof(ctx)` with `offsetof(ctx, xdpf)` in several
places and praying that there are no more miscalcs left somewhere in the
code, unionize ::frm with ::data in a flex array, so that both starts
pointing to the actual data_hard_start and the XDP frame actually starts
being a part of it, i.e. a part of the headroom, not the context.
A nice side effect is that the maximum frame size for this mode gets
increased by 40 bytes, as xdp_buff::frame_sz includes everything from
data_hard_start (-> includes xdpf already) to the end of XDP/skb shared
info.
Also update %MAX_PKT_SIZE accordingly in the selftests code. Leave it
hardcoded for 64 bit && 64-byte cacheline && 4k pages, it can be made
more flexible later on.

Minor: align `&head->data` with how `head->frm` is assigned for
consistency.
Minor #2: rename 'frm' to 'frame' in &xdp_page_head while at it for
clarity.

(was found while testing XDP traffic generator on ice, which calls
 xdp_convert_frame_to_buff() for each XDP frame)

Fixes: b530e9e1063e ("bpf: Add "live packet" mode for XDP in BPF_PROG_RUN")
Acked-by: Toke Høiland-Jørgensen <toke@redhat.com>
Signed-off-by: Alexander Lobakin <aleksander.lobakin@intel.com>
---
From v2[0]:
- update %MAX_PKT_SIZE in the selftests (Daniel, CI bots);
- add conditional static assert to avoid facing the same issue in future;
- pick one Acked-by (Toke).

From v1[1]:
- align `&head->data` with how `head->frm` is assigned for consistency
  (Toke);
- rename 'frm' to 'frame' in &xdp_page_head (Jakub);
- no functional changes.

[0] https://lore.kernel.org/bpf/20230213142747.3225479-1-alexandr.lobakin@intel.com
[1] https://lore.kernel.org/bpf/20230209172827.874728-1-alexandr.lobakin@intel.com
---
 net/bpf/test_run.c                            | 23 ++++++++++++++-----
 .../bpf/prog_tests/xdp_do_redirect.c          |  4 ++--
 2 files changed, 19 insertions(+), 8 deletions(-)

diff --git a/net/bpf/test_run.c b/net/bpf/test_run.c
index 2723623429ac..b9e77ab94b03 100644
--- a/net/bpf/test_run.c
+++ b/net/bpf/test_run.c
@@ -97,8 +97,11 @@ static bool bpf_test_timer_continue(struct bpf_test_timer *t, int iterations,
 struct xdp_page_head {
 	struct xdp_buff orig_ctx;
 	struct xdp_buff ctx;
-	struct xdp_frame frm;
-	u8 data[];
+	union {
+		/* ::data_hard_start starts here */
+		DECLARE_FLEX_ARRAY(struct xdp_frame, frame);
+		DECLARE_FLEX_ARRAY(u8, data);
+	};
 };
 
 struct xdp_test_data {
@@ -116,6 +119,14 @@ struct xdp_test_data {
 #define TEST_XDP_FRAME_SIZE (PAGE_SIZE - sizeof(struct xdp_page_head))
 #define TEST_XDP_MAX_BATCH 256
 
+#if BITS_PER_LONG == 64 && SMP_CACHE_BYTES == 64 && PAGE_SIZE == SZ_4K
+/* tools/testing/selftests/bpf/prog_tests/xdp_do_redirect.c:%MAX_PKT_SIZE
+ * must be updated accordingly when any of these changes.
+ */
+static_assert(TEST_XDP_FRAME_SIZE - XDP_PACKET_HEADROOM -
+	      SKB_DATA_ALIGN(sizeof(struct skb_shared_info)) == 3408);
+#endif
+
 static void xdp_test_run_init_page(struct page *page, void *arg)
 {
 	struct xdp_page_head *head = phys_to_virt(page_to_phys(page));
@@ -132,8 +143,8 @@ static void xdp_test_run_init_page(struct page *page, void *arg)
 	headroom -= meta_len;
 
 	new_ctx = &head->ctx;
-	frm = &head->frm;
-	data = &head->data;
+	frm = head->frame;
+	data = head->data;
 	memcpy(data + headroom, orig_ctx->data_meta, frm_len);
 
 	xdp_init_buff(new_ctx, TEST_XDP_FRAME_SIZE, &xdp->rxq);
@@ -223,7 +234,7 @@ static void reset_ctx(struct xdp_page_head *head)
 	head->ctx.data = head->orig_ctx.data;
 	head->ctx.data_meta = head->orig_ctx.data_meta;
 	head->ctx.data_end = head->orig_ctx.data_end;
-	xdp_update_frame_from_buff(&head->ctx, &head->frm);
+	xdp_update_frame_from_buff(&head->ctx, head->frame);
 }
 
 static int xdp_recv_frames(struct xdp_frame **frames, int nframes,
@@ -285,7 +296,7 @@ static int xdp_test_run_batch(struct xdp_test_data *xdp, struct bpf_prog *prog,
 		head = phys_to_virt(page_to_phys(page));
 		reset_ctx(head);
 		ctx = &head->ctx;
-		frm = &head->frm;
+		frm = head->frame;
 		xdp->frame_cnt++;
 
 		act = bpf_prog_run_xdp(prog, ctx);
diff --git a/tools/testing/selftests/bpf/prog_tests/xdp_do_redirect.c b/tools/testing/selftests/bpf/prog_tests/xdp_do_redirect.c
index a50971c6cf4a..0253070138b1 100644
--- a/tools/testing/selftests/bpf/prog_tests/xdp_do_redirect.c
+++ b/tools/testing/selftests/bpf/prog_tests/xdp_do_redirect.c
@@ -63,9 +63,9 @@ static int attach_tc_prog(struct bpf_tc_hook *hook, int fd)
 }
 
 /* The maximum permissible size is: PAGE_SIZE - sizeof(struct xdp_page_head) -
- * sizeof(struct skb_shared_info) - XDP_PACKET_HEADROOM = 3368 bytes
+ * sizeof(struct skb_shared_info) - XDP_PACKET_HEADROOM = 3408 bytes
  */
-#define MAX_PKT_SIZE 3368
+#define MAX_PKT_SIZE 3408
 static void test_max_pkt_size(int fd)
 {
 	char data[MAX_PKT_SIZE + 1] = {};
-- 
2.39.1


^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: [PATCH v3 bpf] bpf, test_run: fix &xdp_frame misplacement for LIVE_FRAMES
  2023-02-15 15:21 [PATCH v3 bpf] bpf, test_run: fix &xdp_frame misplacement for LIVE_FRAMES Alexander Lobakin
@ 2023-02-15 18:04 ` Martin KaFai Lau
  2023-02-15 18:11   ` Alexander Lobakin
  0 siblings, 1 reply; 3+ messages in thread
From: Martin KaFai Lau @ 2023-02-15 18:04 UTC (permalink / raw)
  To: Alexander Lobakin, Alexei Starovoitov, Daniel Borkmann, Andrii Nakryiko
  Cc: Toke Høiland-Jørgensen, Song Liu,
	Jesper Dangaard Brouer, Jakub Kicinski, bpf, netdev,
	linux-kernel

On 2/15/23 7:21 AM, Alexander Lobakin wrote:
>   /* The maximum permissible size is: PAGE_SIZE - sizeof(struct xdp_page_head) -
> - * sizeof(struct skb_shared_info) - XDP_PACKET_HEADROOM = 3368 bytes
> + * sizeof(struct skb_shared_info) - XDP_PACKET_HEADROOM = 3408 bytes
>    */
> -#define MAX_PKT_SIZE 3368
> +#define MAX_PKT_SIZE 3408

s390 has a different cache line size:

https://lore.kernel.org/all/20230128000650.1516334-11-iii@linux.ibm.com/

The above s390 fix is in bpf-next. It is better to target this patch for 
bpf-next also such that the CI can test it in s390.


^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: [PATCH v3 bpf] bpf, test_run: fix &xdp_frame misplacement for LIVE_FRAMES
  2023-02-15 18:04 ` Martin KaFai Lau
@ 2023-02-15 18:11   ` Alexander Lobakin
  0 siblings, 0 replies; 3+ messages in thread
From: Alexander Lobakin @ 2023-02-15 18:11 UTC (permalink / raw)
  To: Martin KaFai Lau
  Cc: Alexei Starovoitov, Daniel Borkmann, Andrii Nakryiko,
	Toke Høiland-Jørgensen, Song Liu,
	Jesper Dangaard Brouer, Jakub Kicinski, bpf, netdev,
	linux-kernel

From: Martin Kafai Lau <martin.lau@linux.dev>
Date: Wed, 15 Feb 2023 10:04:51 -0800

> On 2/15/23 7:21 AM, Alexander Lobakin wrote:
>>   /* The maximum permissible size is: PAGE_SIZE - sizeof(struct
>> xdp_page_head) -
>> - * sizeof(struct skb_shared_info) - XDP_PACKET_HEADROOM = 3368 bytes
>> + * sizeof(struct skb_shared_info) - XDP_PACKET_HEADROOM = 3408 bytes
>>    */
>> -#define MAX_PKT_SIZE 3368
>> +#define MAX_PKT_SIZE 3408
> 
> s390 has a different cache line size:
> 
> https://lore.kernel.org/all/20230128000650.1516334-11-iii@linux.ibm.com/
> 
> The above s390 fix is in bpf-next. It is better to target this patch for
> bpf-next also such that the CI can test it in s390.
> 

Oh, thanks for letting me know! Will do in a bit.

Thanks,
Olek

^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2023-02-15 18:19 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2023-02-15 15:21 [PATCH v3 bpf] bpf, test_run: fix &xdp_frame misplacement for LIVE_FRAMES Alexander Lobakin
2023-02-15 18:04 ` Martin KaFai Lau
2023-02-15 18:11   ` Alexander Lobakin

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®