From: Tejun Heo <tj@kernel.org>
To: Andy Walls <awalls@radix.net>
Cc: torvalds@linux-foundation.org, mingo@elte.hu,
peterz@infradead.org, linux-kernel@vger.kernel.org,
jeff@garzik.org, akpm@linux-foundation.org,
jens.axboe@oracle.com, rusty@rustcorp.com.au,
cl@linux-foundation.org, dhowells@redhat.com,
arjan@linux.intel.com, avi@redhat.com, johannes@sipsolutions.net,
andi@firstfloor.org
Subject: Re: [PATCH 30/40] workqueue: implement work_busy()
Date: Mon, 18 Jan 2010 14:41:42 +0900 [thread overview]
Message-ID: <4B53F496.8050105@kernel.org> (raw)
In-Reply-To: <1263783156.5220.66.camel@palomino.walls.org>
Hello, Andy.
On 01/18/2010 11:52 AM, Andy Walls wrote:
>>From a driver writer's perspective, this function not useful since it is
> unreliable (false positives only?) and I have no way of
>
> "ensuring the workqueue @work was last queued on stays valid until this
> function returns."
>
> I don't quite know how to check and enfore a workqueue's continuing
> validity across the function call. (Maybe you could clarify?)
I don't really think that would be possible without tinkering with
workqueue internal locking.
> 2. Just schedule the work object and check the return value to see if
> the submission suceeded. If it did, the work was "not pending". This
> method can't check for "running" of course.
For workqueue, the above combined with proper subsystem locking would
be the best way to do it, I think.
> Is there some specific use case where this function is very useful
> despite being unreliable? I just think it's asking for abuse by someone
> who would think "mostly reliable" is good enough, when it actually may
> not be.
I mostly just wanted to keep the fscache debug printout which
indicates whether a fscache object has work pending or running. It's
a debug printout so it doesn't need to be reliable. If the debug
printout can be removed, this patch can go too.
Thanks.
--
tejun
next prev parent reply other threads:[~2010-01-18 5:37 UTC|newest]
Thread overview: 102+ messages / expand[flat|nested] mbox.gz Atom feed top
2010-01-18 0:57 [PATCHSET] concurrency managed workqueue, take#3 Tejun Heo
2010-01-18 0:57 ` [PATCH 01/40] sched: consult online mask instead of active in select_fallback_rq() Tejun Heo
2010-01-18 10:13 ` Peter Zijlstra
2010-01-18 11:26 ` Tejun Heo
2010-01-18 0:57 ` [PATCH 02/40] sched: rename preempt_notifiers to sched_notifiers and refactor implementation Tejun Heo
2010-01-18 0:57 ` [PATCH 03/40] sched: refactor try_to_wake_up() Tejun Heo
2010-01-18 0:57 ` [PATCH 04/40] sched: implement __set_cpus_allowed() Tejun Heo
2010-01-18 9:56 ` Peter Zijlstra
2010-01-18 11:22 ` Tejun Heo
2010-01-18 11:41 ` Peter Zijlstra
2010-01-19 1:07 ` Tejun Heo
2010-01-19 8:37 ` Peter Zijlstra
2010-01-20 8:35 ` Tejun Heo
2010-01-20 8:50 ` Peter Zijlstra
2010-01-20 9:00 ` Tejun Heo
2010-01-20 8:59 ` Peter Zijlstra
2010-01-24 8:18 ` Tejun Heo
2010-01-18 0:57 ` [PATCH 05/40] sched: make sched_notifiers unconditional Tejun Heo
2010-01-18 0:57 ` [PATCH 06/40] sched: add wakeup/sleep sched_notifiers and allow NULL notifier ops Tejun Heo
2010-01-18 9:57 ` Peter Zijlstra
2010-01-18 11:31 ` Tejun Heo
2010-01-18 12:49 ` Peter Zijlstra
2010-01-19 1:04 ` Tejun Heo
2010-01-19 8:28 ` Tejun Heo
2010-01-19 8:55 ` Peter Zijlstra
2010-01-20 8:47 ` Tejun Heo
2010-01-18 0:57 ` [PATCH 07/40] sched: implement try_to_wake_up_local() Tejun Heo
2010-01-18 0:57 ` [PATCH 08/40] acpi: use queue_work_on() instead of binding workqueue worker to cpu0 Tejun Heo
2010-01-18 0:57 ` [PATCH 09/40] stop_machine: reimplement without using workqueue Tejun Heo
2010-01-18 0:57 ` [PATCH 10/40] workqueue: misc/cosmetic updates Tejun Heo
2010-01-18 0:57 ` [PATCH 11/40] workqueue: merge feature parameters into flags Tejun Heo
2010-01-18 0:57 ` [PATCH 12/40] workqueue: define both bit position and mask for work flags Tejun Heo
2010-01-18 0:57 ` [PATCH 13/40] workqueue: separate out process_one_work() Tejun Heo
2010-01-18 0:57 ` [PATCH 14/40] workqueue: temporarily disable workqueue tracing Tejun Heo
2010-01-18 0:57 ` [PATCH 15/40] workqueue: kill cpu_populated_map Tejun Heo
2010-01-18 0:57 ` [PATCH 16/40] workqueue: update cwq alignement Tejun Heo
2010-01-18 0:57 ` [PATCH 17/40] workqueue: reimplement workqueue flushing using color coded works Tejun Heo
2010-01-18 0:57 ` [PATCH 18/40] workqueue: introduce worker Tejun Heo
2010-01-18 0:57 ` [PATCH 19/40] workqueue: reimplement work flushing using linked works Tejun Heo
2010-01-18 0:57 ` [PATCH 20/40] workqueue: implement per-cwq active work limit Tejun Heo
2010-01-18 0:57 ` [PATCH 21/40] workqueue: reimplement workqueue freeze using max_active Tejun Heo
2010-01-18 0:57 ` [PATCH 22/40] workqueue: introduce global cwq and unify cwq locks Tejun Heo
2010-01-18 0:57 ` [PATCH 23/40] workqueue: implement worker states Tejun Heo
2010-01-18 0:57 ` [PATCH 24/40] workqueue: reimplement CPU hotplugging support using trustee Tejun Heo
2010-01-18 0:57 ` [PATCH 25/40] workqueue: make single thread workqueue shared worker pool friendly Tejun Heo
2010-01-18 0:57 ` [PATCH 26/40] workqueue: use shared worklist and pool all workers per cpu Tejun Heo
2010-01-18 0:57 ` [PATCH 27/40] workqueue: implement concurrency managed dynamic worker pool Tejun Heo
2010-01-18 0:57 ` [PATCH 28/40] workqueue: increase max_active of keventd and kill current_is_keventd() Tejun Heo
2010-01-18 0:57 ` [PATCH 29/40] workqueue: add system_wq and system_single_wq Tejun Heo
2010-01-18 0:57 ` [PATCH 30/40] workqueue: implement work_busy() Tejun Heo
2010-01-18 2:52 ` Andy Walls
2010-01-18 5:41 ` Tejun Heo [this message]
2010-01-18 0:57 ` [PATCH 31/40] libata: take advantage of cmwq and remove concurrency limitations Tejun Heo
2010-01-18 15:48 ` Stefan Richter
2010-01-19 0:49 ` Tejun Heo
2010-01-18 0:57 ` [PATCH 32/40] async: introduce workqueue based alternative implementation Tejun Heo
2010-01-18 6:01 ` Arjan van de Ven
2010-01-18 8:49 ` Tejun Heo
2010-01-18 15:25 ` Arjan van de Ven
2010-01-19 0:57 ` Tejun Heo
2010-01-19 0:57 ` Arjan van de Ven
2010-01-19 7:56 ` Tejun Heo
2010-01-19 14:37 ` Arjan van de Ven
2010-01-20 0:19 ` Tejun Heo
2010-01-20 0:31 ` Arjan van de Ven
2010-01-20 2:08 ` Tejun Heo
2010-01-20 6:03 ` Arjan van de Ven
2010-01-20 8:24 ` Tejun Heo
2010-01-22 10:59 ` [PATCH] async: use workqueue for worker pool Tejun Heo
2010-01-18 0:57 ` [PATCH 33/40] async: convert async users to use the new implementation Tejun Heo
2010-01-18 0:57 ` [PATCH 34/40] async: kill original implementation Tejun Heo
2010-01-18 0:57 ` [PATCH 35/40] fscache: convert object to use workqueue instead of slow-work Tejun Heo
2010-01-18 0:57 ` [PATCH 36/40] fscache: convert operation " Tejun Heo
2010-01-18 0:57 ` [PATCH 37/40] fscache: drop references to slow-work Tejun Heo
2010-01-18 0:57 ` [PATCH 38/40] cifs: use workqueue instead of slow-work Tejun Heo
2010-01-19 12:20 ` Jeff Layton
2010-01-20 0:15 ` Tejun Heo
2010-01-20 0:56 ` Jeff Layton
2010-01-20 1:23 ` Tejun Heo
2010-01-22 11:14 ` [PATCH UPDATED " Tejun Heo
2010-01-22 11:45 ` Jeff Layton
2010-01-24 8:25 ` Tejun Heo
2010-01-24 12:13 ` Jeff Layton
2010-01-25 15:25 ` Tejun Heo
2010-01-18 0:57 ` [PATCH 39/40] gfs2: " Tejun Heo
2010-01-18 9:45 ` Steven Whitehouse
2010-01-18 11:24 ` Tejun Heo
2010-01-18 12:07 ` Steven Whitehouse
2010-01-19 1:00 ` Tejun Heo
2010-01-19 8:46 ` [PATCH UPDATED " Tejun Heo
2010-01-18 0:57 ` [PATCH 40/40] slow-work: kill it Tejun Heo
2010-01-18 1:03 ` perf-wq.c used to generate synthetic workload Tejun Heo
2010-01-18 16:13 ` [PATCHSET] concurrency managed workqueue, take#3 Stefan Richter
2010-02-12 18:03 ` [PATCH 35/40] fscache: convert object to use workqueue instead of slow-work David Howells
2010-02-13 5:43 ` Tejun Heo
2010-02-15 15:04 ` David Howells
2010-02-16 3:40 ` Tejun Heo
2010-02-16 3:59 ` Tejun Heo
2010-02-16 18:05 ` David Howells
2010-02-16 23:50 ` Tejun Heo
2010-02-18 11:50 ` David Howells
2010-02-18 12:33 ` Tejun Heo
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=4B53F496.8050105@kernel.org \
--to=tj@kernel.org \
--cc=akpm@linux-foundation.org \
--cc=andi@firstfloor.org \
--cc=arjan@linux.intel.com \
--cc=avi@redhat.com \
--cc=awalls@radix.net \
--cc=cl@linux-foundation.org \
--cc=dhowells@redhat.com \
--cc=jeff@garzik.org \
--cc=jens.axboe@oracle.com \
--cc=johannes@sipsolutions.net \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@elte.hu \
--cc=peterz@infradead.org \
--cc=rusty@rustcorp.com.au \
--cc=torvalds@linux-foundation.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome