mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [RESEND PATCH v2 0/2] sched_ext: rename var for slice refill event and add helper
@ 2025-05-07  1:16 Honglei Wang
  2025-05-07  1:16 ` [RESEND PATCH v2 1/2] sched_ext: change the variable name for slice refill event Honglei Wang
                   ` (3 more replies)
  0 siblings, 4 replies; 6+ messages in thread
From: Honglei Wang @ 2025-05-07  1:16 UTC (permalink / raw)
  To: tj, void, arighi, changwoo
  Cc: mingo, peterz, juri.lelli, vincent.guittot, dietmar.eggemann,
	rostedt, bsegall, mgorman, vschneid, joshdon, brho, linux-kernel,
	bpf, jameshongleiwang

SCX_EV_ENQ_SLICE_DFL gives the impression that the event only occurs
when the tasks were enqueued, which seems not accurate. So rename the
variable to SCX_EV_REFILL_SLICE_DFL.

The slice refilling with default slice always come with event
statistics together, add a helper routine to make it cleaner.

Changes in v2:
Refine the comments base on Andrea's suggestion.

Honglei Wang (2):
  sched_ext: change the variable name for slice refill event
  sched_ext: add helper for refill task with default slice

 kernel/sched/ext.c             | 36 +++++++++++++++++-----------------
 tools/sched_ext/scx_qmap.bpf.c |  4 ++--
 2 files changed, 20 insertions(+), 20 deletions(-)

-- 
2.45.2


^ permalink raw reply	[flat|nested] 6+ messages in thread

* [RESEND PATCH v2 1/2] sched_ext: change the variable name for slice refill event
  2025-05-07  1:16 [RESEND PATCH v2 0/2] sched_ext: rename var for slice refill event and add helper Honglei Wang
@ 2025-05-07  1:16 ` Honglei Wang
  2025-05-07  1:16 ` [RESEND PATCH v2 2/2] sched_ext: add helper for refill task with default slice Honglei Wang
                   ` (2 subsequent siblings)
  3 siblings, 0 replies; 6+ messages in thread
From: Honglei Wang @ 2025-05-07  1:16 UTC (permalink / raw)
  To: tj, void, arighi, changwoo
  Cc: mingo, peterz, juri.lelli, vincent.guittot, dietmar.eggemann,
	rostedt, bsegall, mgorman, vschneid, joshdon, brho, linux-kernel,
	bpf, jameshongleiwang

SCX_EV_ENQ_SLICE_DFL gives the impression that the event only occurs
when the tasks were enqueued, which seems not accurate. What it actually
means is the refilling with defalt slice, and this can occur either when
enqueue or pick_task. Let's change the variable to
SCX_EV_REFILL_SLICE_DFL.

Signed-off-by: Honglei Wang <jameshongleiwang@126.com>
---
v2:
- refine the comments base on Andrea's suggestion.
---
 kernel/sched/ext.c             | 22 +++++++++++-----------
 tools/sched_ext/scx_qmap.bpf.c |  4 ++--
 2 files changed, 13 insertions(+), 13 deletions(-)

diff --git a/kernel/sched/ext.c b/kernel/sched/ext.c
index 66bcd40a28ca..2a091ea23328 100644
--- a/kernel/sched/ext.c
+++ b/kernel/sched/ext.c
@@ -1517,10 +1517,10 @@ struct scx_event_stats {
 	s64		SCX_EV_ENQ_SKIP_MIGRATION_DISABLED;
 
 	/*
-	 * The total number of tasks enqueued (or pick_task-ed) with a
-	 * default time slice (SCX_SLICE_DFL).
+	 * Total number of times a task's time slice was refilled with the
+	 * default value (SCX_SLICE_DFL).
 	 */
-	s64		SCX_EV_ENQ_SLICE_DFL;
+	s64		SCX_EV_REFILL_SLICE_DFL;
 
 	/*
 	 * The total duration of bypass modes in nanoseconds.
@@ -2197,7 +2197,7 @@ static void do_enqueue_task(struct rq *rq, struct task_struct *p, u64 enq_flags,
 	 */
 	touch_core_sched(rq, p);
 	p->scx.slice = SCX_SLICE_DFL;
-	__scx_add_event(SCX_EV_ENQ_SLICE_DFL, 1);
+	__scx_add_event(SCX_EV_REFILL_SLICE_DFL, 1);
 local_norefill:
 	dispatch_enqueue(&rq->scx.local_dsq, p, enq_flags);
 	return;
@@ -2205,7 +2205,7 @@ static void do_enqueue_task(struct rq *rq, struct task_struct *p, u64 enq_flags,
 global:
 	touch_core_sched(rq, p);	/* see the comment in local: */
 	p->scx.slice = SCX_SLICE_DFL;
-	__scx_add_event(SCX_EV_ENQ_SLICE_DFL, 1);
+	__scx_add_event(SCX_EV_REFILL_SLICE_DFL, 1);
 	dispatch_enqueue(find_global_dsq(p), p, enq_flags);
 }
 
@@ -3296,7 +3296,7 @@ static struct task_struct *pick_task_scx(struct rq *rq)
 		p = prev;
 		if (!p->scx.slice) {
 			p->scx.slice = SCX_SLICE_DFL;
-			__scx_add_event(SCX_EV_ENQ_SLICE_DFL, 1);
+			__scx_add_event(SCX_EV_REFILL_SLICE_DFL, 1);
 		}
 	} else {
 		p = first_local_task(rq);
@@ -3313,7 +3313,7 @@ static struct task_struct *pick_task_scx(struct rq *rq)
 				scx_warned_zero_slice = true;
 			}
 			p->scx.slice = SCX_SLICE_DFL;
-			__scx_add_event(SCX_EV_ENQ_SLICE_DFL, 1);
+			__scx_add_event(SCX_EV_REFILL_SLICE_DFL, 1);
 		}
 	}
 
@@ -3399,7 +3399,7 @@ static int select_task_rq_scx(struct task_struct *p, int prev_cpu, int wake_flag
 		if (cpu >= 0) {
 			p->scx.slice = SCX_SLICE_DFL;
 			p->scx.ddsp_dsq_id = SCX_DSQ_LOCAL;
-			__scx_add_event(SCX_EV_ENQ_SLICE_DFL, 1);
+			__scx_add_event(SCX_EV_REFILL_SLICE_DFL, 1);
 		} else {
 			cpu = prev_cpu;
 		}
@@ -4413,7 +4413,7 @@ static ssize_t scx_attr_events_show(struct kobject *kobj,
 	at += scx_attr_event_show(buf, at, &events, SCX_EV_DISPATCH_KEEP_LAST);
 	at += scx_attr_event_show(buf, at, &events, SCX_EV_ENQ_SKIP_EXITING);
 	at += scx_attr_event_show(buf, at, &events, SCX_EV_ENQ_SKIP_MIGRATION_DISABLED);
-	at += scx_attr_event_show(buf, at, &events, SCX_EV_ENQ_SLICE_DFL);
+	at += scx_attr_event_show(buf, at, &events, SCX_EV_REFILL_SLICE_DFL);
 	at += scx_attr_event_show(buf, at, &events, SCX_EV_BYPASS_DURATION);
 	at += scx_attr_event_show(buf, at, &events, SCX_EV_BYPASS_DISPATCH);
 	at += scx_attr_event_show(buf, at, &events, SCX_EV_BYPASS_ACTIVATE);
@@ -5148,7 +5148,7 @@ static void scx_dump_state(struct scx_exit_info *ei, size_t dump_len)
 	scx_dump_event(s, &events, SCX_EV_DISPATCH_KEEP_LAST);
 	scx_dump_event(s, &events, SCX_EV_ENQ_SKIP_EXITING);
 	scx_dump_event(s, &events, SCX_EV_ENQ_SKIP_MIGRATION_DISABLED);
-	scx_dump_event(s, &events, SCX_EV_ENQ_SLICE_DFL);
+	scx_dump_event(s, &events, SCX_EV_REFILL_SLICE_DFL);
 	scx_dump_event(s, &events, SCX_EV_BYPASS_DURATION);
 	scx_dump_event(s, &events, SCX_EV_BYPASS_DISPATCH);
 	scx_dump_event(s, &events, SCX_EV_BYPASS_ACTIVATE);
@@ -7313,7 +7313,7 @@ __bpf_kfunc void scx_bpf_events(struct scx_event_stats *events,
 		scx_agg_event(&e_sys, e_cpu, SCX_EV_DISPATCH_KEEP_LAST);
 		scx_agg_event(&e_sys, e_cpu, SCX_EV_ENQ_SKIP_EXITING);
 		scx_agg_event(&e_sys, e_cpu, SCX_EV_ENQ_SKIP_MIGRATION_DISABLED);
-		scx_agg_event(&e_sys, e_cpu, SCX_EV_ENQ_SLICE_DFL);
+		scx_agg_event(&e_sys, e_cpu, SCX_EV_REFILL_SLICE_DFL);
 		scx_agg_event(&e_sys, e_cpu, SCX_EV_BYPASS_DURATION);
 		scx_agg_event(&e_sys, e_cpu, SCX_EV_BYPASS_DISPATCH);
 		scx_agg_event(&e_sys, e_cpu, SCX_EV_BYPASS_ACTIVATE);
diff --git a/tools/sched_ext/scx_qmap.bpf.c b/tools/sched_ext/scx_qmap.bpf.c
index 26c40ca4f36c..c3cd9a17d48e 100644
--- a/tools/sched_ext/scx_qmap.bpf.c
+++ b/tools/sched_ext/scx_qmap.bpf.c
@@ -784,8 +784,8 @@ static int monitor_timerfn(void *map, int *key, struct bpf_timer *timer)
 		   scx_read_event(&events, SCX_EV_DISPATCH_KEEP_LAST));
 	bpf_printk("%35s: %lld", "SCX_EV_ENQ_SKIP_EXITING",
 		   scx_read_event(&events, SCX_EV_ENQ_SKIP_EXITING));
-	bpf_printk("%35s: %lld", "SCX_EV_ENQ_SLICE_DFL",
-		   scx_read_event(&events, SCX_EV_ENQ_SLICE_DFL));
+	bpf_printk("%35s: %lld", "SCX_EV_REFILL_SLICE_DFL",
+		   scx_read_event(&events, SCX_EV_REFILL_SLICE_DFL));
 	bpf_printk("%35s: %lld", "SCX_EV_BYPASS_DURATION",
 		   scx_read_event(&events, SCX_EV_BYPASS_DURATION));
 	bpf_printk("%35s: %lld", "SCX_EV_BYPASS_DISPATCH",
-- 
2.45.2


^ permalink raw reply	[flat|nested] 6+ messages in thread

* [RESEND PATCH v2 2/2] sched_ext: add helper for refill task with default slice
  2025-05-07  1:16 [RESEND PATCH v2 0/2] sched_ext: rename var for slice refill event and add helper Honglei Wang
  2025-05-07  1:16 ` [RESEND PATCH v2 1/2] sched_ext: change the variable name for slice refill event Honglei Wang
@ 2025-05-07  1:16 ` Honglei Wang
  2025-05-07  2:05 ` [RESEND PATCH v2 0/2] sched_ext: rename var for slice refill event and add helper Changwoo Min
  2025-05-07 16:59 ` Tejun Heo
  3 siblings, 0 replies; 6+ messages in thread
From: Honglei Wang @ 2025-05-07  1:16 UTC (permalink / raw)
  To: tj, void, arighi, changwoo
  Cc: mingo, peterz, juri.lelli, vincent.guittot, dietmar.eggemann,
	rostedt, bsegall, mgorman, vschneid, joshdon, brho, linux-kernel,
	bpf, jameshongleiwang

Add helper for refilling task with default slice and event
statistics accordingly.

Signed-off-by: Honglei Wang <jameshongleiwang@126.com>
---
 kernel/sched/ext.c | 24 ++++++++++++------------
 1 file changed, 12 insertions(+), 12 deletions(-)

diff --git a/kernel/sched/ext.c b/kernel/sched/ext.c
index 2a091ea23328..579dc0e9443a 100644
--- a/kernel/sched/ext.c
+++ b/kernel/sched/ext.c
@@ -1815,6 +1815,12 @@ static void dsq_mod_nr(struct scx_dispatch_q *dsq, s32 delta)
 	WRITE_ONCE(dsq->nr, dsq->nr + delta);
 }
 
+static void refill_task_slice_dfl(struct task_struct *p)
+{
+	p->scx.slice = SCX_SLICE_DFL;
+	__scx_add_event(SCX_EV_REFILL_SLICE_DFL, 1);
+}
+
 static void dispatch_enqueue(struct scx_dispatch_q *dsq, struct task_struct *p,
 			     u64 enq_flags)
 {
@@ -2196,16 +2202,14 @@ static void do_enqueue_task(struct rq *rq, struct task_struct *p, u64 enq_flags,
 	 * higher priority it becomes from scx_prio_less()'s POV.
 	 */
 	touch_core_sched(rq, p);
-	p->scx.slice = SCX_SLICE_DFL;
-	__scx_add_event(SCX_EV_REFILL_SLICE_DFL, 1);
+	refill_task_slice_dfl(p);
 local_norefill:
 	dispatch_enqueue(&rq->scx.local_dsq, p, enq_flags);
 	return;
 
 global:
 	touch_core_sched(rq, p);	/* see the comment in local: */
-	p->scx.slice = SCX_SLICE_DFL;
-	__scx_add_event(SCX_EV_REFILL_SLICE_DFL, 1);
+	refill_task_slice_dfl(p);
 	dispatch_enqueue(find_global_dsq(p), p, enq_flags);
 }
 
@@ -3294,10 +3298,8 @@ static struct task_struct *pick_task_scx(struct rq *rq)
 	 */
 	if (keep_prev) {
 		p = prev;
-		if (!p->scx.slice) {
-			p->scx.slice = SCX_SLICE_DFL;
-			__scx_add_event(SCX_EV_REFILL_SLICE_DFL, 1);
-		}
+		if (!p->scx.slice)
+			refill_task_slice_dfl(p);
 	} else {
 		p = first_local_task(rq);
 		if (!p) {
@@ -3312,8 +3314,7 @@ static struct task_struct *pick_task_scx(struct rq *rq)
 						p->comm, p->pid, __func__);
 				scx_warned_zero_slice = true;
 			}
-			p->scx.slice = SCX_SLICE_DFL;
-			__scx_add_event(SCX_EV_REFILL_SLICE_DFL, 1);
+			refill_task_slice_dfl(p);
 		}
 	}
 
@@ -3397,9 +3398,8 @@ static int select_task_rq_scx(struct task_struct *p, int prev_cpu, int wake_flag
 
 		cpu = scx_select_cpu_dfl(p, prev_cpu, wake_flags, 0);
 		if (cpu >= 0) {
-			p->scx.slice = SCX_SLICE_DFL;
+			refill_task_slice_dfl(p);
 			p->scx.ddsp_dsq_id = SCX_DSQ_LOCAL;
-			__scx_add_event(SCX_EV_REFILL_SLICE_DFL, 1);
 		} else {
 			cpu = prev_cpu;
 		}
-- 
2.45.2


^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [RESEND PATCH v2 0/2] sched_ext: rename var for slice refill event and add helper
  2025-05-07  1:16 [RESEND PATCH v2 0/2] sched_ext: rename var for slice refill event and add helper Honglei Wang
  2025-05-07  1:16 ` [RESEND PATCH v2 1/2] sched_ext: change the variable name for slice refill event Honglei Wang
  2025-05-07  1:16 ` [RESEND PATCH v2 2/2] sched_ext: add helper for refill task with default slice Honglei Wang
@ 2025-05-07  2:05 ` Changwoo Min
  2025-05-07 16:59 ` Tejun Heo
  3 siblings, 0 replies; 6+ messages in thread
From: Changwoo Min @ 2025-05-07  2:05 UTC (permalink / raw)
  To: Honglei Wang, tj, void, arighi
  Cc: mingo, peterz, juri.lelli, vincent.guittot, dietmar.eggemann,
	rostedt, bsegall, mgorman, vschneid, joshdon, brho, linux-kernel,
	bpf

Hi Honglei,

Looks good to me.

Acked-by: Changwoo Min <changwoo@igalia.com>

On 5/7/25 10:16, Honglei Wang wrote:
> SCX_EV_ENQ_SLICE_DFL gives the impression that the event only occurs
> when the tasks were enqueued, which seems not accurate. So rename the
> variable to SCX_EV_REFILL_SLICE_DFL.
> 
> The slice refilling with default slice always come with event
> statistics together, add a helper routine to make it cleaner.
> 
> Changes in v2:
> Refine the comments base on Andrea's suggestion.
> 
> Honglei Wang (2):
>    sched_ext: change the variable name for slice refill event
>    sched_ext: add helper for refill task with default slice
> 
>   kernel/sched/ext.c             | 36 +++++++++++++++++-----------------
>   tools/sched_ext/scx_qmap.bpf.c |  4 ++--
>   2 files changed, 20 insertions(+), 20 deletions(-)
> 


^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [RESEND PATCH v2 0/2] sched_ext: rename var for slice refill event and add helper
  2025-05-07  1:16 [RESEND PATCH v2 0/2] sched_ext: rename var for slice refill event and add helper Honglei Wang
                   ` (2 preceding siblings ...)
  2025-05-07  2:05 ` [RESEND PATCH v2 0/2] sched_ext: rename var for slice refill event and add helper Changwoo Min
@ 2025-05-07 16:59 ` Tejun Heo
  2025-05-08  2:09   ` Honglei Wang
  3 siblings, 1 reply; 6+ messages in thread
From: Tejun Heo @ 2025-05-07 16:59 UTC (permalink / raw)
  To: Honglei Wang
  Cc: void, arighi, changwoo, mingo, peterz, juri.lelli,
	vincent.guittot, dietmar.eggemann, rostedt, bsegall, mgorman,
	vschneid, joshdon, brho, linux-kernel, bpf

On Wed, May 07, 2025 at 09:16:35AM +0800, Honglei Wang wrote:
> SCX_EV_ENQ_SLICE_DFL gives the impression that the event only occurs
> when the tasks were enqueued, which seems not accurate. So rename the
> variable to SCX_EV_REFILL_SLICE_DFL.
> 
> The slice refilling with default slice always come with event
> statistics together, add a helper routine to make it cleaner.
> 
> Changes in v2:
> Refine the comments base on Andrea's suggestion.
> 
> Honglei Wang (2):
>   sched_ext: change the variable name for slice refill event
>   sched_ext: add helper for refill task with default slice
> 
>  kernel/sched/ext.c             | 36 +++++++++++++++++-----------------
>  tools/sched_ext/scx_qmap.bpf.c |  4 ++--
>  2 files changed, 20 insertions(+), 20 deletions(-)

These patches already had been applied back in mid April. If there are
updates to be made, please send incremental patches.

Thanks.

-- 
tejun

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [RESEND PATCH v2 0/2] sched_ext: rename var for slice refill event and add helper
  2025-05-07 16:59 ` Tejun Heo
@ 2025-05-08  2:09   ` Honglei Wang
  0 siblings, 0 replies; 6+ messages in thread
From: Honglei Wang @ 2025-05-08  2:09 UTC (permalink / raw)
  To: Tejun Heo
  Cc: void, arighi, changwoo, mingo, peterz, juri.lelli,
	vincent.guittot, dietmar.eggemann, rostedt, bsegall, mgorman,
	vschneid, joshdon, brho, linux-kernel, bpf

Hi Tejun,

On 2025/5/8 00:59, Tejun Heo wrote:
> On Wed, May 07, 2025 at 09:16:35AM +0800, Honglei Wang wrote:
>> SCX_EV_ENQ_SLICE_DFL gives the impression that the event only occurs
>> when the tasks were enqueued, which seems not accurate. So rename the
>> variable to SCX_EV_REFILL_SLICE_DFL.
>>
>> The slice refilling with default slice always come with event
>> statistics together, add a helper routine to make it cleaner.
>>
>> Changes in v2:
>> Refine the comments base on Andrea's suggestion.
>>
>> Honglei Wang (2):
>>   sched_ext: change the variable name for slice refill event
>>   sched_ext: add helper for refill task with default slice
>>
>>  kernel/sched/ext.c             | 36 +++++++++++++++++-----------------
>>  tools/sched_ext/scx_qmap.bpf.c |  4 ++--
>>  2 files changed, 20 insertions(+), 20 deletions(-)
> 
> These patches already had been applied back in mid April. If there are
> updates to be made, please send incremental patches.
> 

Seems I missed the applied message in the mail series... Sorry for
bothering, I'll be careful next time.

Thanks,
Honglei

> Thanks.
> 


^ permalink raw reply	[flat|nested] 6+ messages in thread

end of thread, other threads:[~2025-05-08  2:13 UTC | newest]

Thread overview: 6+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2025-05-07  1:16 [RESEND PATCH v2 0/2] sched_ext: rename var for slice refill event and add helper Honglei Wang
2025-05-07  1:16 ` [RESEND PATCH v2 1/2] sched_ext: change the variable name for slice refill event Honglei Wang
2025-05-07  1:16 ` [RESEND PATCH v2 2/2] sched_ext: add helper for refill task with default slice Honglei Wang
2025-05-07  2:05 ` [RESEND PATCH v2 0/2] sched_ext: rename var for slice refill event and add helper Changwoo Min
2025-05-07 16:59 ` Tejun Heo
2025-05-08  2:09   ` Honglei Wang

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®