mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [RESEND PATCH v2 0/2] sched_ext: rename var for slice refill event and add helper
@ 2025-05-07  1:16 Honglei Wang
  2025-05-07  1:16 ` [RESEND PATCH v2 1/2] sched_ext: change the variable name for slice refill event Honglei Wang
                   ` (3 more replies)
  0 siblings, 4 replies; 6+ messages in thread
From: Honglei Wang @ 2025-05-07  1:16 UTC (permalink / raw)
  To: tj, void, arighi, changwoo
  Cc: mingo, peterz, juri.lelli, vincent.guittot, dietmar.eggemann,
	rostedt, bsegall, mgorman, vschneid, joshdon, brho, linux-kernel,
	bpf, jameshongleiwang

SCX_EV_ENQ_SLICE_DFL gives the impression that the event only occurs
when the tasks were enqueued, which seems not accurate. So rename the
variable to SCX_EV_REFILL_SLICE_DFL.

The slice refilling with default slice always come with event
statistics together, add a helper routine to make it cleaner.

Changes in v2:
Refine the comments base on Andrea's suggestion.

Honglei Wang (2):
  sched_ext: change the variable name for slice refill event
  sched_ext: add helper for refill task with default slice

 kernel/sched/ext.c             | 36 +++++++++++++++++-----------------
 tools/sched_ext/scx_qmap.bpf.c |  4 ++--
 2 files changed, 20 insertions(+), 20 deletions(-)

-- 
2.45.2


^ permalink raw reply	[flat|nested] 6+ messages in thread

end of thread, other threads:[~2025-05-08  2:13 UTC | newest]

Thread overview: 6+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2025-05-07  1:16 [RESEND PATCH v2 0/2] sched_ext: rename var for slice refill event and add helper Honglei Wang
2025-05-07  1:16 ` [RESEND PATCH v2 1/2] sched_ext: change the variable name for slice refill event Honglei Wang
2025-05-07  1:16 ` [RESEND PATCH v2 2/2] sched_ext: add helper for refill task with default slice Honglei Wang
2025-05-07  2:05 ` [RESEND PATCH v2 0/2] sched_ext: rename var for slice refill event and add helper Changwoo Min
2025-05-07 16:59 ` Tejun Heo
2025-05-08  2:09   ` Honglei Wang

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®