From: Eduardo Valentin <eduardo.valentin@ti.com>
To: amit daniel kachhap <amit.daniel@samsung.com>
Cc: Eduardo Valentin <eduardo.valentin@ti.com>,
<linux-pm@vger.kernel.org>, Zhang Rui <rui.zhang@intel.com>,
<linux-samsung-soc@vger.kernel.org>,
<linux-kernel@vger.kernel.org>,
Kukjin Kim <kgene.kim@samsung.com>, <jonghwa3.lee@samsung.com>
Subject: Re: [PATCH V6 08/30] thermal: exynos: Add missing definations and code cleanup
Date: Fri, 21 Jun 2013 10:31:16 -0400 [thread overview]
Message-ID: <51C463B4.9070506@ti.com> (raw)
In-Reply-To: <CADGdYn6FHXd2YELP1z9zbqnf3Yd0PG0svaz7V6w9NYO3xSW8PQ@mail.gmail.com>
[-- Attachment #1: Type: text/plain, Size: 6957 bytes --]
On 20-06-2013 22:01, amit daniel kachhap wrote:
> Hi Eduardo,
>
> On Thu, Jun 20, 2013 at 1:25 AM, Eduardo Valentin
> <eduardo.valentin@ti.com> wrote:
>> On 17-06-2013 02:46, Amit Daniel Kachhap wrote:
>>> This patch adds some extra register bitfield definations and cleans
>>> up the code to prepare for moving register macros and definations inside
>>> the TMU data section.
>>>
>>> Acked-by: Kukjin Kim <kgene.kim@samsung.com>
>>> Acked-by: Jonghwa Lee <jonghwa3.lee@samsung.com>
>>> Signed-off-by: Amit Daniel Kachhap <amit.daniel@samsung.com>
>>> ---
>>> drivers/thermal/samsung/exynos_tmu.c | 62 +++++++++++++++++++++++++---------
>>> 1 files changed, 46 insertions(+), 16 deletions(-)
>>>
>>> diff --git a/drivers/thermal/samsung/exynos_tmu.c b/drivers/thermal/samsung/exynos_tmu.c
>>> index 5df04a1..fa33a48 100644
>>> --- a/drivers/thermal/samsung/exynos_tmu.c
>>> +++ b/drivers/thermal/samsung/exynos_tmu.c
>>> @@ -43,9 +43,12 @@
>>>
>>> #define EXYNOS_TMU_TRIM_TEMP_MASK 0xff
>>> #define EXYNOS_TMU_GAIN_SHIFT 8
>>> +#define EXYNOS_TMU_GAIN_MASK 0xf
>>> #define EXYNOS_TMU_REF_VOLTAGE_SHIFT 24
>>> -#define EXYNOS_TMU_CORE_ON 3
>>> -#define EXYNOS_TMU_CORE_OFF 2
>>> +#define EXYNOS_TMU_REF_VOLTAGE_MASK 0x1f
>>> +#define EXYNOS_TMU_BUF_SLOPE_SEL_MASK 0xf
>>> +#define EXYNOS_TMU_BUF_SLOPE_SEL_SHIFT 8
>>> +#define EXYNOS_TMU_CORE_EN_SHIFT 0
>>> #define EXYNOS_TMU_DEF_CODE_TO_TEMP_OFFSET 50
>>>
>>> /* Exynos4210 specific registers */
>>> @@ -63,6 +66,7 @@
>>> #define EXYNOS4210_TMU_TRIG_LEVEL1_MASK 0x10
>>> #define EXYNOS4210_TMU_TRIG_LEVEL2_MASK 0x100
>>> #define EXYNOS4210_TMU_TRIG_LEVEL3_MASK 0x1000
>>> +#define EXYNOS4210_TMU_TRIG_LEVEL_MASK 0x1111
>>> #define EXYNOS4210_TMU_INTCLEAR_VAL 0x1111
>>>
>>> /* Exynos5250 and Exynos4412 specific registers */
>>> @@ -72,17 +76,30 @@
>>> #define EXYNOS_EMUL_CON 0x80
>>>
>>> #define EXYNOS_TRIMINFO_RELOAD 0x1
>>> +#define EXYNOS_TRIMINFO_SHIFT 0x0
>>> +#define EXYNOS_TMU_RISE_INT_MASK 0x111
>>> +#define EXYNOS_TMU_RISE_INT_SHIFT 0
>>> +#define EXYNOS_TMU_FALL_INT_MASK 0x111
>>> +#define EXYNOS_TMU_FALL_INT_SHIFT 12
>>> #define EXYNOS_TMU_CLEAR_RISE_INT 0x111
>>> #define EXYNOS_TMU_CLEAR_FALL_INT (0x111 << 12)
>>> -#define EXYNOS_MUX_ADDR_VALUE 6
>>> -#define EXYNOS_MUX_ADDR_SHIFT 20
>>> #define EXYNOS_TMU_TRIP_MODE_SHIFT 13
>>> +#define EXYNOS_TMU_TRIP_MODE_MASK 0x7
>>> +
>>> +#define EXYNOS_TMU_INTEN_RISE0_SHIFT 0
>>> +#define EXYNOS_TMU_INTEN_RISE1_SHIFT 4
>>> +#define EXYNOS_TMU_INTEN_RISE2_SHIFT 8
>>> +#define EXYNOS_TMU_INTEN_RISE3_SHIFT 12
>>> +#define EXYNOS_TMU_INTEN_FALL0_SHIFT 16
>>> +#define EXYNOS_TMU_INTEN_FALL1_SHIFT 20
>>> +#define EXYNOS_TMU_INTEN_FALL2_SHIFT 24
>>>
>>> #define EFUSE_MIN_VALUE 40
>>> #define EFUSE_MAX_VALUE 100
>>>
>>> #ifdef CONFIG_THERMAL_EMULATION
>>> #define EXYNOS_EMUL_TIME 0x57F0
>>> +#define EXYNOS_EMUL_TIME_MASK 0xffff
>>> #define EXYNOS_EMUL_TIME_SHIFT 16
>>> #define EXYNOS_EMUL_DATA_SHIFT 8
>>> #define EXYNOS_EMUL_DATA_MASK 0xFF
>>> @@ -261,24 +278,37 @@ static void exynos_tmu_control(struct platform_device *pdev, bool on)
>>> mutex_lock(&data->lock);
>>> clk_enable(data->clk);
>>>
>>> - con = pdata->reference_voltage << EXYNOS_TMU_REF_VOLTAGE_SHIFT |
>>> - pdata->gain << EXYNOS_TMU_GAIN_SHIFT;
>>> + con = readl(data->base + EXYNOS_TMU_REG_CONTROL);
>>>
>>> - if (data->soc == SOC_ARCH_EXYNOS) {
>>> - con |= pdata->noise_cancel_mode << EXYNOS_TMU_TRIP_MODE_SHIFT;
>>> - con |= (EXYNOS_MUX_ADDR_VALUE << EXYNOS_MUX_ADDR_SHIFT);
>>> + if (pdata->reference_voltage) {
>>> + con &= ~(EXYNOS_TMU_REF_VOLTAGE_MASK <<
>>> + EXYNOS_TMU_REF_VOLTAGE_SHIFT);
>>> + con |= pdata->reference_voltage << EXYNOS_TMU_REF_VOLTAGE_SHIFT;
>>> + }
>>> +
>>> + if (pdata->gain) {
>>> + con &= ~(EXYNOS_TMU_GAIN_MASK << EXYNOS_TMU_GAIN_SHIFT);
>>> + con |= (pdata->gain << EXYNOS_TMU_GAIN_SHIFT);
>>> + }
>>> +
>>> + if (pdata->noise_cancel_mode) {
>>> + con &= ~(EXYNOS_TMU_TRIP_MODE_MASK <<
>>> + EXYNOS_TMU_TRIP_MODE_SHIFT);
>>> + con |= (pdata->noise_cancel_mode << EXYNOS_TMU_TRIP_MODE_SHIFT);
>>> }
>>>
>>> if (on) {
>>> - con |= EXYNOS_TMU_CORE_ON;
>>
>>
>>
>> Before, in order to turn core on you had:
>> con = con | 3;
>>
>> now you do:
>> con = con | (1 << 0);
>>
>> To me, before you would set bit 1 and 0, now you set bit 0.
>>
>>
>>> - interrupt_en = pdata->trigger_level3_en << 12 |
>>> - pdata->trigger_level2_en << 8 |
>>> - pdata->trigger_level1_en << 4 |
>>> - pdata->trigger_level0_en;
>>> + con |= (1 << EXYNOS_TMU_CORE_EN_SHIFT);
>>> + interrupt_en =
>>> + pdata->trigger_level3_en << EXYNOS_TMU_INTEN_RISE3_SHIFT |
>>> + pdata->trigger_level2_en << EXYNOS_TMU_INTEN_RISE2_SHIFT |
>>> + pdata->trigger_level1_en << EXYNOS_TMU_INTEN_RISE1_SHIFT |
>>> + pdata->trigger_level0_en << EXYNOS_TMU_INTEN_RISE0_SHIFT;
>>> if (pdata->threshold_falling)
>>> - interrupt_en |= interrupt_en << 16;
>>> + interrupt_en |=
>>> + interrupt_en << EXYNOS_TMU_INTEN_FALL0_SHIFT;
>>> } else {
>>> - con |= EXYNOS_TMU_CORE_OFF;
>>> + con &= ~(1 << EXYNOS_TMU_CORE_EN_SHIFT);
>>
>>
>> Before, in order to turno core off you had:
>> con = con | 2;
>>
>> now you do:
>> con = con & ~(1 << 0);
>>
>> To me, before you would set bit 2, now you clear bit 0.
>>
>> Using the approach on this patch looks correct to me if you have 1 bit
>> core_en for instance.
>>
>> so, Is this a fix?
>>
>> Just to be clear, is this what you want ?
> Yes you are right. Bit 0 is the actual enable bit. Bit 1 is the
> reserve bit and its default value is 1. Earlier both bits are used to
> turn on/off the controller which was wrong so this patch rectifies it.
Care to mention this in your patch description? It is good for code history.
>
> Thanks,
> Amit
>>
>>> interrupt_en = 0; /* Disable all interrupts */
>>> }
>>> writel(interrupt_en, data->base + EXYNOS_TMU_REG_INTEN);
>>>
>>
>>
>> --
>> You have got to be excited about what you are doing. (L. Lamport)
>>
>> Eduardo Valentin
>>
>
>
--
You have got to be excited about what you are doing. (L. Lamport)
Eduardo Valentin
[-- Attachment #2: OpenPGP digital signature --]
[-- Type: application/pgp-signature, Size: 295 bytes --]
next prev parent reply other threads:[~2013-06-21 14:31 UTC|newest]
Thread overview: 86+ messages / expand[flat|nested] mbox.gz Atom feed top
2013-06-17 6:46 [PATCH V6 00/30] thermal: exynos: Re-structure driver and add support for exynos5440 Amit Daniel Kachhap
2013-06-17 6:46 ` [PATCH V6 01/30] thermal: exynos: Moving exynos thermal files into samsung directory Amit Daniel Kachhap
2013-06-19 18:46 ` Eduardo Valentin
2013-06-17 6:46 ` [PATCH V6 02/30] thermal: exynos: Use ARCH_HAS_BANDGAP config to know the supported soc's Amit Daniel Kachhap
2013-06-19 18:46 ` Eduardo Valentin
2013-06-17 6:46 ` [PATCH V6 03/30] thermal: exynos: Remove un-necessary CPU_THERMAL dependency Amit Daniel Kachhap
2013-06-19 18:48 ` Eduardo Valentin
2013-06-17 6:46 ` [PATCH V6 04/30] thermal: exynos: Bifurcate exynos thermal common and tmu controller code Amit Daniel Kachhap
2013-06-19 18:45 ` Eduardo Valentin
2013-06-21 1:50 ` amit daniel kachhap
2013-06-21 14:30 ` Eduardo Valentin
2013-06-19 19:01 ` Eduardo Valentin
2013-06-21 2:48 ` amit daniel kachhap
2013-06-21 14:23 ` Eduardo Valentin
2013-06-17 6:46 ` [PATCH V6 05/30] thermal: exynos: Rename exynos_thermal.c to exynos_tmu.c Amit Daniel Kachhap
2013-06-17 6:46 ` [PATCH V6 06/30] thermal: exynos: Move exynos_thermal.h from include/* to driver/* folder Amit Daniel Kachhap
2013-06-19 19:18 ` Eduardo Valentin
2013-06-19 19:20 ` Eduardo Valentin
2013-06-21 4:34 ` amit daniel kachhap
2013-06-21 4:33 ` amit daniel kachhap
2013-06-17 6:46 ` [PATCH V6 07/30] thermal: exynos: Bifurcate exynos tmu driver and configuration data Amit Daniel Kachhap
2013-06-19 19:35 ` Eduardo Valentin
2013-06-19 19:43 ` Eduardo Valentin
2013-06-21 5:06 ` amit daniel kachhap
2013-06-17 6:46 ` [PATCH V6 08/30] thermal: exynos: Add missing definations and code cleanup Amit Daniel Kachhap
2013-06-19 19:55 ` Eduardo Valentin
2013-06-21 2:01 ` amit daniel kachhap
2013-06-21 14:31 ` Eduardo Valentin [this message]
2013-06-24 3:57 ` amit daniel kachhap
2013-06-17 6:46 ` [PATCH V6 09/30] thermal: exynos: Add extra entries in the tmu platform data Amit Daniel Kachhap
2013-06-19 20:19 ` Eduardo Valentin
2013-06-19 20:52 ` Eduardo Valentin
2013-06-21 8:50 ` amit daniel kachhap
2013-06-21 14:26 ` Eduardo Valentin
2013-06-21 6:39 ` amit daniel kachhap
2013-06-17 6:46 ` [PATCH V6 10/30] thermal: exynos: Move register definitions from driver to data file Amit Daniel Kachhap
2013-06-19 21:02 ` Eduardo Valentin
2013-06-17 6:46 ` [PATCH V6 11/30] thermal: exynos: Support thermal tripping Amit Daniel Kachhap
2013-06-19 22:23 ` Eduardo Valentin
2013-06-17 6:46 ` [PATCH V6 12/30] thermal: exynos: Fix to clear only the generated interrupts Amit Daniel Kachhap
2013-06-19 22:26 ` Eduardo Valentin
2013-06-17 6:46 ` [PATCH V6 13/30] thermal: exynos: Add support for instance based register/unregister Amit Daniel Kachhap
2013-06-19 22:40 ` Eduardo Valentin
2013-06-17 6:46 ` [PATCH V6 14/30] thermal: exynos: Modify private_data to appropriate name driver_data Amit Daniel Kachhap
2013-06-19 22:44 ` Eduardo Valentin
2013-06-17 6:46 ` [PATCH V6 15/30] thermal: exynos: Return success even if no cooling data supplied Amit Daniel Kachhap
2013-06-19 22:54 ` Eduardo Valentin
2013-06-19 23:04 ` Eduardo Valentin
2013-06-17 6:46 ` [PATCH V6 16/30] thermal: exynos: Make the zone handling use trip information Amit Daniel Kachhap
2013-06-19 23:03 ` Eduardo Valentin
2013-06-21 12:30 ` amit daniel kachhap
2013-06-21 14:35 ` Eduardo Valentin
2013-06-17 6:46 ` [PATCH V6 17/30] thermal: exynos: Remove non DT based support Amit Daniel Kachhap
2013-06-19 23:09 ` Eduardo Valentin
2013-06-17 6:46 ` [PATCH V6 18/30] thermal: exynos: Add support to handle many instances of TMU Amit Daniel Kachhap
2013-06-19 23:27 ` Eduardo Valentin
2013-06-21 12:46 ` amit daniel kachhap
2013-06-21 14:28 ` Eduardo Valentin
2013-06-17 6:46 ` [PATCH V6 19/30] thermal: exynos: Add TMU features to check instead of using SOC type Amit Daniel Kachhap
2013-06-19 23:35 ` Eduardo Valentin
2013-06-17 6:46 ` [PATCH V6 20/30] thermal: exynos: use device resource management infrastructure Amit Daniel Kachhap
2013-06-19 23:42 ` Eduardo Valentin
2013-06-17 6:46 ` [PATCH V6 21/30] ARM: dts: thermal: exynos4: Add documentation for Exynos SoC thermal bindings Amit Daniel Kachhap
2013-06-19 23:45 ` Eduardo Valentin
2013-06-21 14:34 ` amit daniel kachhap
2013-06-17 6:46 ` [PATCH V6 22/30] thermal: exynos: Add support to access common register for multistance Amit Daniel Kachhap
2013-06-19 23:53 ` Eduardo Valentin
2013-06-17 6:46 ` [PATCH V6 23/30] thermal: exynos: Add driver support for exynos5440 TMU sensor Amit Daniel Kachhap
2013-06-20 2:06 ` Eduardo Valentin
2013-06-21 15:17 ` amit daniel kachhap
2013-06-17 6:46 ` [PATCH V6 24/30] thermal: exynos: Add thermal configuration data " Amit Daniel Kachhap
2013-06-20 2:18 ` Eduardo Valentin
2013-06-21 15:19 ` amit daniel kachhap
2013-06-21 15:21 ` amit daniel kachhap
2013-06-17 6:46 ` [PATCH V6 25/30] thermal: exynos: Fix to set the second point correction value Amit Daniel Kachhap
2013-06-20 2:22 ` Eduardo Valentin
2013-06-17 6:46 ` [PATCH V6 26/30] thermal: exynos: Add hardware mode thermal calibration support Amit Daniel Kachhap
2013-06-20 2:30 ` Eduardo Valentin
2013-06-17 6:46 ` [PATCH V6 27/30] Documentation: thermal: Explain the exynos thermal driver model Amit Daniel Kachhap
2013-06-20 2:32 ` Eduardo Valentin
2013-06-17 6:46 ` [PATCH V6 28/30] thermal: exynos: Support for TMU regulator defined at device tree Amit Daniel Kachhap
2013-06-20 2:33 ` Eduardo Valentin
2013-06-17 6:46 ` [PATCH V6 29/30] ARM: dts: Add device tree node for exynos5440 TMU controller Amit Daniel Kachhap
2013-06-20 2:37 ` Eduardo Valentin
2013-06-17 6:46 ` [PATCH V6 30/30] arm: exynos: enable ARCH_HAS_BANDGAP Amit Daniel Kachhap
2013-06-19 18:47 ` Eduardo Valentin
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=51C463B4.9070506@ti.com \
--to=eduardo.valentin@ti.com \
--cc=amit.daniel@samsung.com \
--cc=jonghwa3.lee@samsung.com \
--cc=kgene.kim@samsung.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-pm@vger.kernel.org \
--cc=linux-samsung-soc@vger.kernel.org \
--cc=rui.zhang@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome