mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Philipp Hortmann <philipp.g.hortmann@gmail.com>
To: Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	linux-staging@lists.linux.dev, linux-kernel@vger.kernel.org
Cc: Philipp Hortmann <philipp.g.hortmann@gmail.com>
Subject: [PATCH 02/16] staging: rtl8723bs: Remove function pointer EfuseGetCurrentSize
Date: Wed,  6 Nov 2024 19:33:31 +0100	[thread overview]
Message-ID: <58a991eeda12ccb69fe8b81ef1bb2fe3c5aa364b.1730916582.git.philipp.g.hortmann@gmail.com> (raw)
In-Reply-To: <cover.1730916582.git.philipp.g.hortmann@gmail.com>

Remove function pointer EfuseGetCurrentSize and use
Hal_EfuseGetCurrentSize directly to increase readability.

Signed-off-by: Philipp Hortmann <philipp.g.hortmann@gmail.com>
---
 drivers/staging/rtl8723bs/core/rtw_efuse.c        | 3 +--
 drivers/staging/rtl8723bs/hal/rtl8723b_hal_init.c | 3 +--
 drivers/staging/rtl8723bs/include/hal_intf.h      | 2 +-
 3 files changed, 3 insertions(+), 5 deletions(-)

diff --git a/drivers/staging/rtl8723bs/core/rtw_efuse.c b/drivers/staging/rtl8723bs/core/rtw_efuse.c
index b8023e9d7631..8e6c294c168e 100644
--- a/drivers/staging/rtl8723bs/core/rtw_efuse.c
+++ b/drivers/staging/rtl8723bs/core/rtw_efuse.c
@@ -102,8 +102,7 @@ Efuse_GetCurrentSize(
 	u8	efuseType,
 	bool		bPseudoTest)
 {
-	return padapter->HalFunc.EfuseGetCurrentSize(padapter, efuseType,
-						     bPseudoTest);
+	return Hal_EfuseGetCurrentSize(padapter, efuseType, bPseudoTest);
 }
 
 /*  11/16/2008 MH Add description. Get current efuse area enabled word!!. */
diff --git a/drivers/staging/rtl8723bs/hal/rtl8723b_hal_init.c b/drivers/staging/rtl8723bs/hal/rtl8723b_hal_init.c
index 8a4ebe645786..11969a90a5e5 100644
--- a/drivers/staging/rtl8723bs/hal/rtl8723b_hal_init.c
+++ b/drivers/staging/rtl8723bs/hal/rtl8723b_hal_init.c
@@ -1072,7 +1072,7 @@ static u16 hal_EfuseGetCurrentSize_BT(struct adapter *padapter, u8 bPseudoTest)
 	return retU2;
 }
 
-static u16 Hal_EfuseGetCurrentSize(
+u16 Hal_EfuseGetCurrentSize(
 	struct adapter *padapter, u8 efuseType, bool bPseudoTest
 )
 {
@@ -1745,7 +1745,6 @@ void UpdateHalRAMask8723B(struct adapter *padapter, u32 mac_id, u8 rssi_level)
 void rtl8723b_set_hal_ops(struct hal_ops *pHalFunc)
 {
 	/*  Efuse related function */
-	pHalFunc->EfuseGetCurrentSize = &Hal_EfuseGetCurrentSize;
 	pHalFunc->Efuse_PgPacketRead = &Hal_EfusePgPacketRead;
 	pHalFunc->Efuse_PgPacketWrite = &Hal_EfusePgPacketWrite;
 	pHalFunc->Efuse_WordEnableDataWrite = &Hal_EfuseWordEnableDataWrite;
diff --git a/drivers/staging/rtl8723bs/include/hal_intf.h b/drivers/staging/rtl8723bs/include/hal_intf.h
index a513721e763b..48305cbf9929 100644
--- a/drivers/staging/rtl8723bs/include/hal_intf.h
+++ b/drivers/staging/rtl8723bs/include/hal_intf.h
@@ -164,7 +164,6 @@ typedef s32 (*c2h_id_filter)(u8 *c2h_evt);
 struct hal_ops {
 	void (*SetHalODMVarHandler)(struct adapter *padapter, enum hal_odm_variable eVariable, void *pValue1, bool bSet);
 
-	u16 (*EfuseGetCurrentSize)(struct adapter *padapter, u8 efuseType, bool bPseudoTest);
 	int	(*Efuse_PgPacketRead)(struct adapter *padapter, u8 offset, u8 *data, bool bPseudoTest);
 	int	(*Efuse_PgPacketWrite)(struct adapter *padapter, u8 offset, u8 word_en, u8 *data, bool bPseudoTest);
 	u8 (*Efuse_WordEnableDataWrite)(struct adapter *padapter, u16 efuse_addr, u8 word_en, u8 *data, bool bPseudoTest);
@@ -291,4 +290,5 @@ void Hal_ReadEFuse(struct adapter *padapter, u8 efuseType, u16 _offset,
 		   u16 _size_byte, u8 *pbuf, bool bPseudoTest);
 void Hal_GetEfuseDefinition(struct adapter *padapter, u8 efuseType, u8 type,
 			    void *pOut, bool bPseudoTest);
+u16 Hal_EfuseGetCurrentSize(struct adapter *padapter, u8 efuseType, bool bPseudoTest);
 #endif /* __HAL_INTF_H__ */
-- 
2.43.0


  parent reply	other threads:[~2024-11-06 18:33 UTC|newest]

Thread overview: 17+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2024-11-06 18:33 [PATCH 00/16] staging: rtl8723bs: Replace function pointers starting with EFUSEGetEfuseDefinition Philipp Hortmann
2024-11-06 18:33 ` [PATCH 01/16] staging: rtl8723bs: Remove function pointer EFUSEGetEfuseDefinition Philipp Hortmann
2024-11-06 18:33 ` Philipp Hortmann [this message]
2024-11-06 18:33 ` [PATCH 03/16] staging: rtl8723bs: Remove unused function Efuse_PgPacketRead Philipp Hortmann
2024-11-06 18:33 ` [PATCH 04/16] staging: rtl8723bs: Remove unused function Hal_EfusePgPacketRead Philipp Hortmann
2024-11-06 18:33 ` [PATCH 05/16] staging: rtl8723bs: Remove unused function Efuse_PgPacketWrite Philipp Hortmann
2024-11-06 18:33 ` [PATCH 06/16] staging: rtl8723bs: Remove unused function Hal_EfusePgPacketWrite Philipp Hortmann
2024-11-06 18:33 ` [PATCH 07/16] staging: rtl8723bs: Remove unused function Hal_EfusePgPacketWrite_BT Philipp Hortmann
2024-11-06 18:33 ` [PATCH 08/16] staging: rtl8723bs: Remove unused function hal_EfusePgPacketWriteData Philipp Hortmann
2024-11-06 18:33 ` [PATCH 09/16] staging: rtl8723bs: Remove unused function hal_EfusePgPacketWriteHeader Philipp Hortmann
2024-11-06 18:33 ` [PATCH 10/16] staging: rtl8723bs: Remove unused function hal_EfusePartialWriteCheck Philipp Hortmann
2024-11-06 18:33 ` [PATCH 11/16] staging: rtl8723bs: Remove unused function hal_EfuseConstructPGPkt Philipp Hortmann
2024-11-06 18:33 ` [PATCH 12/16] staging: rtl8723bs: Remove unused function hal_EfusePgCheckAvailableAddr Philipp Hortmann
2024-11-06 18:33 ` [PATCH 13/16] staging: rtl8723bs: Remove function hal_EfusePgPacketWrite2ByteHeader Philipp Hortmann
2024-11-06 18:33 ` [PATCH 14/16] staging: rtl8723bs: Remove function hal_EfusePgPacketWrite1ByteHeader Philipp Hortmann
2024-11-06 18:33 ` [PATCH 15/16] staging: rtl8723bs: Remove unused function efuse_WordEnableDataRead Philipp Hortmann
2024-11-06 18:33 ` [PATCH 16/16] staging: rtl8723bs: Remove unused function Efuse_GetCurrentSize Philipp Hortmann

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=58a991eeda12ccb69fe8b81ef1bb2fe3c5aa364b.1730916582.git.philipp.g.hortmann@gmail.com \
    --to=philipp.g.hortmann@gmail.com \
    --cc=gregkh@linuxfoundation.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-staging@lists.linux.dev \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®