From: Jinjie Ruan <ruanjinjie@huawei.com>
To: <catalin.marinas@arm.com>, <will@kernel.org>,
<mark.rutland@arm.com>, <oleg@redhat.com>, <kees@kernel.org>,
<luto@amacapital.net>, <wad@chromium.org>, <peterz@infradead.org>,
<ada.coupriediaz@arm.com>, <linusw@kernel.org>,
<kevin.brodsky@arm.com>, <yeoreum.yun@arm.com>,
<thuth@redhat.com>, <james.morse@arm.com>,
<vladimir.murzin@arm.com>, <broonie@kernel.org>,
<pengcan@kylinos.cn>, <liqiang01@kylinos.cn>,
<ryan.roberts@arm.com>, <linux-arm-kernel@lists.infradead.org>,
<linux-kernel@vger.kernel.org>
Subject: Re: [PATCH v18 00/14] arm64: entry: Convert to Generic Entry
Date: Tue, 15 Sep 2026 21:03:58 +0800 [thread overview]
Message-ID: <5cdfdfb6-c46e-4260-a89b-ac02528d46d7@huawei.com> (raw)
In-Reply-To: <20260902095537.602517-1-ruanjinjie@huawei.com>
在 2026/9/2 17:55, Jinjie Ruan 写道:
> This series converts arm64 to the generic entry infrastructure.
>
> Currently, architectures such as x86, RISC-V, LoongArch, Powerprc
> and S390 use generic entry, which significantly reduces maintenance
> burden and improves code elegance. arm64 already adopted generic IRQ
> entry in commit b3cf07851b6c ("arm64: entry: Switch to generic IRQ entry"),
> making it the right time to complete the conversion.
>
> This work brings arm64 in line with other major architectures,
> reducing duplicated code and enabling future improvements like
> Syscall User Dispatch and rseq time slice extension optimizations.
>
> The series is rebased on v7.3-rc1 and has been tested on Kunpeng HIP09
> with stress-ng, hackbench, kselftests (ptrace, breakpoints, arm64/abi,
> arm64/fp, vDSO), ptrace stress test, and Pseudo-NMI load test.
>
> Changes in v18:
> - Rebased on v7.3-rc1.
> - Drop the SUD patch as Mark suggeted.
> - Update the commit message.
> - Add Reviewed-by.
> - Link to v17: https://lore.kernel.org/all/20260721081858.1169276-1-ruanjinjie@huawei.com/
Hi Mark,
Thanks for your continuous and detailed guidance through the previous
iterations of this series.
Please let me know if there are any further review comments or code
modifications required from my side, or if this looks good to be queued
for the upcoming 7.4 cycle?
Thanks,
Jinjie
>
> For changes in v7 to v16, please refer to the individual patch threads:
> - v16: https://lore.kernel.org/all/20260629130616.642022-1-ruanjinjie@huawei.com/
> - v15: https://lore.kernel.org/all/20260511092103.1974980-1-ruanjinjie@huawei.com/
> - v14: https://lore.kernel.org/all/20260320102620.1336796-1-ruanjinjie@huawei.com/
> - v13: https://lore.kernel.org/all/20260317082020.737779-1-ruanjinjie@huawei.com/
> - v12: https://lore.kernel.org/all/20260203133728.848283-1-ruanjinjie@huawei.com/
> - v11: https://lore.kernel.org/all/20260128031934.3906955-1-ruanjinjie@huawei.com/
> - v10: https://lore.kernel.org/all/20251222114737.1334364-1-ruanjinjie@huawei.com/
> - v9: https://lore.kernel.org/all/20251204082123.2792067-1-ruanjinjie@huawei.com/
> - v8: https://lore.kernel.org/all/20251126071446.3234218-1-ruanjinjie@huawei.com/
> - v7: https://lore.kernel.org/all/20251117133048.53182-1-ruanjinjie@huawei.com/
>
> Jinjie Ruan (14):
> arm64: ptrace: Fix redundant syscall exit stop for
> PTRACE_SYSEMU_SINGLESTEP
> arm64: ptrace: Rework audit_syscall_entry()
> arm64: ptrace: Open-code seccomp check in syscall_trace_enter()
> arm64: ptrace: Rename and clean up syscall_trace_enter()
> arm64: ptrace: Protect rseq_syscall() from tracer PC modifications
> arm64: syscall: Rework the syscall exit path in el0_svc_common()
> arm64: ptrace: Pass thread flags to trace enter/exit
> arm64: ptrace: Extract arm64_syscall_exit_to_user_mode_work() helper
> arm64: ptrace: Align syscall exit work semantics with generic entry
> arm64: syscall: Use exit-specific flags check in el0_svc_common()
> arm64: syscall: Simplify el0_svc_common() syscall exit path
> arm64: ptrace: Make return type of arm64_syscall_trace_enter() bool
> arm64: entry: Convert to generic entry
> arm64: Inline el0_svc_common()
>
> arch/arm64/Kconfig | 2 +-
> arch/arm64/include/asm/entry-common.h | 77 +++++++++++++++++
> arch/arm64/include/asm/syscall.h | 5 +-
> arch/arm64/include/asm/thread_info.h | 16 +---
> arch/arm64/kernel/debug-monitors.c | 8 ++
> arch/arm64/kernel/entry-common.c | 2 +-
> arch/arm64/kernel/ptrace.c | 115 --------------------------
> arch/arm64/kernel/signal.c | 2 +-
> arch/arm64/kernel/syscall.c | 34 +++-----
> 9 files changed, 102 insertions(+), 159 deletions(-)
>
prev parent reply other threads:[~2026-09-15 13:04 UTC|newest]
Thread overview: 18+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-09-02 9:55 Jinjie Ruan
2026-09-02 9:55 ` [PATCH v18 01/14] arm64: ptrace: Fix redundant syscall exit stop for PTRACE_SYSEMU_SINGLESTEP Jinjie Ruan
2026-09-02 9:55 ` [PATCH v18 02/14] arm64: ptrace: Rework audit_syscall_entry() Jinjie Ruan
2026-09-19 16:43 ` Karl Mehltretter
2026-09-20 1:24 ` Jinjie Ruan
2026-09-02 9:55 ` [PATCH v18 03/14] arm64: ptrace: Open-code seccomp check in syscall_trace_enter() Jinjie Ruan
2026-09-02 9:55 ` [PATCH v18 04/14] arm64: ptrace: Rename and clean up syscall_trace_enter() Jinjie Ruan
2026-09-02 9:55 ` [PATCH v18 05/14] arm64: ptrace: Protect rseq_syscall() from tracer PC modifications Jinjie Ruan
2026-09-02 9:55 ` [PATCH v18 06/14] arm64: syscall: Rework the syscall exit path in el0_svc_common() Jinjie Ruan
2026-09-02 9:55 ` [PATCH v18 07/14] arm64: ptrace: Pass thread flags to trace enter/exit Jinjie Ruan
2026-09-02 9:55 ` [PATCH v18 08/14] arm64: ptrace: Extract arm64_syscall_exit_to_user_mode_work() helper Jinjie Ruan
2026-09-02 9:55 ` [PATCH v18 09/14] arm64: ptrace: Align syscall exit work semantics with generic entry Jinjie Ruan
2026-09-02 9:55 ` [PATCH v18 10/14] arm64: syscall: Use exit-specific flags check in el0_svc_common() Jinjie Ruan
2026-09-02 9:55 ` [PATCH v18 11/14] arm64: syscall: Simplify el0_svc_common() syscall exit path Jinjie Ruan
2026-09-02 9:55 ` [PATCH v18 12/14] arm64: ptrace: Make return type of arm64_syscall_trace_enter() bool Jinjie Ruan
2026-09-02 9:55 ` [PATCH v18 13/14] arm64: entry: Convert to generic entry Jinjie Ruan
2026-09-02 9:55 ` [PATCH v18 14/14] arm64: Inline el0_svc_common() Jinjie Ruan
2026-09-15 13:03 ` Jinjie Ruan [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=5cdfdfb6-c46e-4260-a89b-ac02528d46d7@huawei.com \
--to=ruanjinjie@huawei.com \
--cc=ada.coupriediaz@arm.com \
--cc=broonie@kernel.org \
--cc=catalin.marinas@arm.com \
--cc=james.morse@arm.com \
--cc=kees@kernel.org \
--cc=kevin.brodsky@arm.com \
--cc=linusw@kernel.org \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=liqiang01@kylinos.cn \
--cc=luto@amacapital.net \
--cc=mark.rutland@arm.com \
--cc=oleg@redhat.com \
--cc=pengcan@kylinos.cn \
--cc=peterz@infradead.org \
--cc=ryan.roberts@arm.com \
--cc=thuth@redhat.com \
--cc=vladimir.murzin@arm.com \
--cc=wad@chromium.org \
--cc=will@kernel.org \
--cc=yeoreum.yun@arm.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®