mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Devarsh Thakkar <devarsht@ti.com>
To: Tomi Valkeinen <tomi.valkeinen@ideasonboard.com>
Cc: <praneeth@ti.com>, <vigneshr@ti.com>, <aradhya.bhatia@linux.dev>,
	<s-jain1@ti.com>, <r-donadkar@ti.com>, <j-choudhary@ti.com>,
	<h-shenoy@ti.com>, <jyri.sarha@iki.fi>, <airlied@gmail.com>,
	<maarten.lankhorst@linux.intel.com>, <mripard@kernel.org>,
	<tzimmermann@suse.de>, <dri-devel@lists.freedesktop.org>,
	<simona@ffwll.ch>, <linux-kernel@vger.kernel.org>,
	<devicetree@vger.kernel.org>, <robh@kernel.org>,
	<krzk+dt@kernel.org>, <conor+dt@kernel.org>
Subject: Re: [PATCH v5 2/3] drm/tidss: Update infrastructure to support K3 DSS cut-down versions
Date: Mon, 5 May 2025 13:19:17 +0530	[thread overview]
Message-ID: <5fd14448-27d9-43e6-8526-fd93483b94cb@ti.com> (raw)
In-Reply-To: <d4daa87f-3556-4b46-a0e0-d90f9d14a097@ideasonboard.com>

Hi Tomi

On 03/05/25 14:14, Tomi Valkeinen wrote:
> On 02/05/2025 14:52, Devarsh Thakkar wrote:

>> Hi,
>>
>>
<snip>
>> Ok I see what you mean to say.....although functionally it is working
>> fine but from readability point of view it is confusing since both
>> functions use same argument name i.e hw_plane in two different contexts.
>> In that case, I would propose to use hw_id as arg name for all
>> dispc_k3_vid* functions, will that be okay ?
> 
> I'd prefer to have all the dispc functions take the same kind of index.
> 

Why? Even all dispc functions are not named with same prefix.
1) dispc_vid* functions act on VID* base directly and here plane
indexing would be w.r.t which VID* base we are using e.g VID vs VIDL
2) dispc_k3_vid* functions act on common region bits which are related
to VID pipelines and plane indexing would signify vid base w.r.t common
register space i.e. COMMON_VID_IRQ0 vs COMMON_VID_IRQ1.

As they both act on different register base and refer it in different
contexts (VID* base vs COMMON_VID* base)  and have also been named
differently anyway, I feel it is okay and legitimate to use hw_id for
dispc_k3_vid* functions (which would signify vid* indexing w.r.t common
region) and hw_plane for dispc_vid* functions (which would signify vid*
base w.r.t VID* regions mapped in device-tree).

Regards
Devarsh

>  Tomi
> 


  reply	other threads:[~2025-05-05  7:50 UTC|newest]

Thread overview: 15+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-04-29 14:36 [PATCH v5 0/3] Add support for AM62L DSS Devarsh Thakkar
2025-04-29 14:36 ` [PATCH v5 1/3] dt-bindings: display: ti,am65x-dss: " Devarsh Thakkar
2025-04-29 14:36 ` [PATCH v5 2/3] drm/tidss: Update infrastructure to support K3 DSS cut-down versions Devarsh Thakkar
2025-04-30 13:14   ` Tomi Valkeinen
2025-04-30 16:37     ` Devarsh Thakkar
2025-04-30 17:42       ` Tomi Valkeinen
2025-05-02  7:06         ` Devarsh Thakkar
2025-05-02  8:07           ` Tomi Valkeinen
2025-05-02 10:47             ` Devarsh Thakkar
2025-05-02 10:55               ` Tomi Valkeinen
2025-05-02 11:52                 ` Devarsh Thakkar
2025-05-03  8:44                   ` Tomi Valkeinen
2025-05-05  7:49                     ` Devarsh Thakkar [this message]
2025-05-05  8:06                       ` Tomi Valkeinen
2025-04-29 14:36 ` [PATCH v5 3/3] drm/tidss: Add support for AM62L display subsystem Devarsh Thakkar

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=5fd14448-27d9-43e6-8526-fd93483b94cb@ti.com \
    --to=devarsht@ti.com \
    --cc=airlied@gmail.com \
    --cc=aradhya.bhatia@linux.dev \
    --cc=conor+dt@kernel.org \
    --cc=devicetree@vger.kernel.org \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=h-shenoy@ti.com \
    --cc=j-choudhary@ti.com \
    --cc=jyri.sarha@iki.fi \
    --cc=krzk+dt@kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=maarten.lankhorst@linux.intel.com \
    --cc=mripard@kernel.org \
    --cc=praneeth@ti.com \
    --cc=r-donadkar@ti.com \
    --cc=robh@kernel.org \
    --cc=s-jain1@ti.com \
    --cc=simona@ffwll.ch \
    --cc=tomi.valkeinen@ideasonboard.com \
    --cc=tzimmermann@suse.de \
    --cc=vigneshr@ti.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®