From: Tomi Valkeinen <tomi.valkeinen@ideasonboard.com>
To: Devarsh Thakkar <devarsht@ti.com>
Cc: praneeth@ti.com, vigneshr@ti.com, aradhya.bhatia@linux.dev,
s-jain1@ti.com, r-donadkar@ti.com, j-choudhary@ti.com,
h-shenoy@ti.com, jyri.sarha@iki.fi, airlied@gmail.com,
maarten.lankhorst@linux.intel.com, mripard@kernel.org,
tzimmermann@suse.de, dri-devel@lists.freedesktop.org,
simona@ffwll.ch, linux-kernel@vger.kernel.org,
devicetree@vger.kernel.org, robh@kernel.org, krzk+dt@kernel.org,
conor+dt@kernel.org
Subject: Re: [PATCH v5 2/3] drm/tidss: Update infrastructure to support K3 DSS cut-down versions
Date: Sat, 3 May 2025 11:44:12 +0300 [thread overview]
Message-ID: <d4daa87f-3556-4b46-a0e0-d90f9d14a097@ideasonboard.com> (raw)
In-Reply-To: <ead31912-d1e5-4813-99a7-5cd2754672ef@ti.com>
On 02/05/2025 14:52, Devarsh Thakkar wrote:
> Hi,
>
> <snip>
>>> It uses hw_id i.e. 1 for all vid irqstatus related registers since it is
>>> accessing am65x common region register space which has vid on idx0 which
>>> we want to skip for am62l.
>>>
>>> For dispc_plane_enable(), the caller uses
>>>> 0, for dispc_k3_vid_write_irqstatus(), the caller uses 1...
>>>
>>> Yes above is correct, and I think that's how it is supposed to be.
>>
>> No it's not. Both functions have "hw_plane" parameter, yet they require
>> a different value to be used even when referring to the same plane.
>>
>>>> With a quick look at the code, changing the callers to pass the "old
>>>> style" hw_plane as the parameter to those irq functions, and the
>>>> functions internally get the hw_id, would solve most of the problems.
>>>
>>> I don't follow above, hw_plane has 0 so it should not be used for
>>> programming irq related functions which expect idx 1 as explained above.
>>
>> We have various functions in tidss_dispc.c that have hw_plane as a
>> parameter. But the caller is supposed to know that for some functions
>> hw_plane is a plane index from 0, and for some it's the hw_id from
>> vid_info[].
>>
>>> There's still dispc_k3_set_irqenable() which manages 'main_disable' and
>>>> needs the hw_id, but maybe that's fine, even if a bit confusing.
>>>>
>>>
>>> I still feel there is no inherent bug here, but let me know if you want
>>> me to put some debug prints or get register dump so that we can double
>>> confirm.
>>
>> I'm not saying there's a bug. I'm saying it's bad code and will cause
>> confusion and bugs in the future.
>>
>
> Ok I see what you mean to say.....although functionally it is working
> fine but from readability point of view it is confusing since both
> functions use same argument name i.e hw_plane in two different contexts.
> In that case, I would propose to use hw_id as arg name for all
> dispc_k3_vid* functions, will that be okay ?
I'd prefer to have all the dispc functions take the same kind of index.
Tomi
next prev parent reply other threads:[~2025-05-03 8:44 UTC|newest]
Thread overview: 15+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-04-29 14:36 [PATCH v5 0/3] Add support for AM62L DSS Devarsh Thakkar
2025-04-29 14:36 ` [PATCH v5 1/3] dt-bindings: display: ti,am65x-dss: " Devarsh Thakkar
2025-04-29 14:36 ` [PATCH v5 2/3] drm/tidss: Update infrastructure to support K3 DSS cut-down versions Devarsh Thakkar
2025-04-30 13:14 ` Tomi Valkeinen
2025-04-30 16:37 ` Devarsh Thakkar
2025-04-30 17:42 ` Tomi Valkeinen
2025-05-02 7:06 ` Devarsh Thakkar
2025-05-02 8:07 ` Tomi Valkeinen
2025-05-02 10:47 ` Devarsh Thakkar
2025-05-02 10:55 ` Tomi Valkeinen
2025-05-02 11:52 ` Devarsh Thakkar
2025-05-03 8:44 ` Tomi Valkeinen [this message]
2025-05-05 7:49 ` Devarsh Thakkar
2025-05-05 8:06 ` Tomi Valkeinen
2025-04-29 14:36 ` [PATCH v5 3/3] drm/tidss: Add support for AM62L display subsystem Devarsh Thakkar
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=d4daa87f-3556-4b46-a0e0-d90f9d14a097@ideasonboard.com \
--to=tomi.valkeinen@ideasonboard.com \
--cc=airlied@gmail.com \
--cc=aradhya.bhatia@linux.dev \
--cc=conor+dt@kernel.org \
--cc=devarsht@ti.com \
--cc=devicetree@vger.kernel.org \
--cc=dri-devel@lists.freedesktop.org \
--cc=h-shenoy@ti.com \
--cc=j-choudhary@ti.com \
--cc=jyri.sarha@iki.fi \
--cc=krzk+dt@kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=maarten.lankhorst@linux.intel.com \
--cc=mripard@kernel.org \
--cc=praneeth@ti.com \
--cc=r-donadkar@ti.com \
--cc=robh@kernel.org \
--cc=s-jain1@ti.com \
--cc=simona@ffwll.ch \
--cc=tzimmermann@suse.de \
--cc=vigneshr@ti.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®