mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: "Huang, Kai" <kai.huang@intel.com>
To: "kirill.shutemov@linux.intel.com"
	<kirill.shutemov@linux.intel.com>,
	"peterz@infradead.org" <peterz@infradead.org>,
	"nik.borisov@suse.com" <nik.borisov@suse.com>,
	"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>
Cc: "Hansen, Dave" <dave.hansen@intel.com>, "Christopherson,,
	Sean" <seanjc@google.com>, "bp@alien8.de" <bp@alien8.de>,
	"x86@kernel.org" <x86@kernel.org>,
	"hpa@zytor.com" <hpa@zytor.com>,
	"mingo@redhat.com" <mingo@redhat.com>,
	"tglx@linutronix.de" <tglx@linutronix.de>,
	"pbonzini@redhat.com" <pbonzini@redhat.com>,
	"kvm@vger.kernel.org" <kvm@vger.kernel.org>,
	"Yamahata, Isaku" <isaku.yamahata@intel.com>,
	"sathyanarayanan.kuppuswamy@linux.intel.com" 
	<sathyanarayanan.kuppuswamy@linux.intel.com>
Subject: Re: [PATCH 04/10] x86/tdx: Make macros of TDCALLs consistent with the spec
Date: Mon, 17 Jul 2023 00:57:39 +0000	[thread overview]
Message-ID: <61e70e0cb895663f5d28b260f1aa779fae0b1182.camel@intel.com> (raw)
In-Reply-To: <574a6b44-38bf-85ce-1dd0-2414fa389c48@suse.com>

On Fri, 2023-07-14 at 15:28 +0300, Nikolay Borisov wrote:
> 
> On 12.07.23 г. 11:55 ч., Kai Huang wrote:
> > The TDX spec names all TDCALLs with prefix "TDG".  Currently, the kernel
> > doesn't follow such convention for the macros of those TDCALLs but uses
> > prefix "TDX_" for all of them.  Although it's arguable whether the TDX
> > spec names those TDCALLs properly, it's better for the kernel to follow
> > the spec when naming those macros.
> > 
> > Change all macros of TDCALLs to make them consistent with the spec.  As
> > a bonus, they get distinguished easily from the host-side SEAMCALLs,
> > which all have prefix "TDH".
> > 
> > No functional change intended.
> > 
> > Signed-off-by: Kai Huang <kai.huang@intel.com>
> > ---
> >   arch/x86/coco/tdx/tdx.c | 22 +++++++++++-----------
> >   1 file changed, 11 insertions(+), 11 deletions(-)
> > 
> > diff --git a/arch/x86/coco/tdx/tdx.c b/arch/x86/coco/tdx/tdx.c
> > index 5b8056f6c83f..de021df92009 100644
> > --- a/arch/x86/coco/tdx/tdx.c
> > +++ b/arch/x86/coco/tdx/tdx.c
> > @@ -15,11 +15,11 @@
> >   #include <asm/pgtable.h>
> >   
> >   /* TDX module Call Leaf IDs */
> > -#define TDX_GET_INFO			1
> > -#define TDX_GET_VEINFO			3
> > -#define TDX_GET_REPORT			4
> > -#define TDX_ACCEPT_PAGE			6
> > -#define TDX_WR				8
> > +#define TDG_VP_INFO			1
> > +#define TDG_VP_VEINFO_GET		3
> > +#define TDG_MR_REPORT			4
> > +#define TDG_MEM_PAGE_ACCEPT		6
> > +#define TDG_VM_WR			8
> >   
> What branch is this patch set based off? Because the existing TDX_GET_* 
> defines are in arch/x86/include/asm/shared/tdx.h due to ff40b5769a50f ?
> 

It was based on tip/x86/tdx, which didn't have above patch.  I'll rebase to the
Linus's tree for the next round since it now has all TDX patches anyway.

  reply	other threads:[~2023-07-17  0:57 UTC|newest]

Thread overview: 58+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2023-07-12  8:55 [PATCH 00/10] Unify TDCALL/SEAMCALL and TDVMCALL assembly Kai Huang
2023-07-12  8:55 ` [PATCH 01/10] x86/tdx: Zero out the missing RSI in TDX_HYPERCALL macro Kai Huang
2023-07-12 19:19   ` Sathyanarayanan Kuppuswamy
2023-07-12  8:55 ` [PATCH 02/10] x86/tdx: Use cmovc to save a label in TDX_MODULE_CALL asm Kai Huang
2023-07-12 19:27   ` Sathyanarayanan Kuppuswamy
2023-07-13 10:32     ` Huang, Kai
2023-07-12  8:55 ` [PATCH 03/10] x86/tdx: Move FRAME_BEGIN/END to TDX_MODULE_CALL asm macro Kai Huang
2023-07-12 19:57   ` Sathyanarayanan Kuppuswamy
2023-07-12 22:05   ` Isaku Yamahata
2023-07-12  8:55 ` [PATCH 04/10] x86/tdx: Make macros of TDCALLs consistent with the spec Kai Huang
2023-07-14 12:28   ` Nikolay Borisov
2023-07-14 12:28   ` Nikolay Borisov
2023-07-17  0:57     ` Huang, Kai [this message]
2023-07-12  8:55 ` [PATCH 05/10] x86/tdx: Rename __tdx_module_call() to __tdcall() Kai Huang
2023-07-12  8:55 ` [PATCH 06/10] x86/tdx: Pass TDCALL/SEAMCALL input/output registers via a structure Kai Huang
2023-07-12  8:55 ` [PATCH 07/10] x86/tdx: Extend TDX_MODULE_CALL to support more TDCALL/SEAMCALL leafs Kai Huang
2023-07-12 16:53   ` Peter Zijlstra
2023-07-12 16:59     ` Peter Zijlstra
2023-07-13  8:02       ` Huang, Kai
2023-07-13  8:43         ` Peter Zijlstra
2023-07-13 10:19           ` Huang, Kai
2023-07-13 10:24             ` Huang, Kai
2023-07-13 10:39               ` Peter Zijlstra
2023-07-13 10:37             ` Peter Zijlstra
2023-07-13 10:47               ` Huang, Kai
2023-07-13 11:22                 ` Andrew Cooper
2023-07-13 11:40                   ` Huang, Kai
2023-07-13  7:48     ` Huang, Kai
2023-07-13  8:46       ` Peter Zijlstra
2023-07-13  9:34         ` Huang, Kai
2023-07-13  9:40           ` Peter Zijlstra
2023-07-12 17:11   ` Peter Zijlstra
2023-07-13  8:09     ` Huang, Kai
2023-07-13  9:01       ` Peter Zijlstra
2023-07-13  9:15         ` Huang, Kai
2023-07-13  9:25           ` Peter Zijlstra
2023-07-13 10:01             ` Huang, Kai
2023-07-12  8:55 ` [PATCH 08/10] x86/tdx: Unify TDX_HYPERCALL and TDX_MODULE_CALL assembly Kai Huang
2023-07-15 10:05   ` Nikolay Borisov
2023-07-17  6:35     ` Huang, Kai
2023-07-17  7:02       ` Nikolay Borisov
2023-07-17  7:58         ` Huang, Kai
2023-07-18 10:32           ` Huang, Kai
2023-07-12  8:55 ` [PATCH 09/10] x86/virt/tdx: Wire up basic SEAMCALL functions Kai Huang
2023-07-12 22:15   ` Isaku Yamahata
2023-07-13  3:46     ` Huang, Kai
2023-07-13  7:42       ` Peter Zijlstra
2023-07-13  8:18         ` Huang, Kai
2023-07-13  9:03           ` Peter Zijlstra
2023-07-13  9:20             ` Huang, Kai
2023-07-13 14:51           ` Sean Christopherson
2023-07-17  3:52             ` Huang, Kai
2023-07-13 18:44       ` Isaku Yamahata
2023-08-08  9:16         ` Yuan Yao
2023-08-14 20:37           ` Isaku Yamahata
2023-07-12  8:55 ` [PATCH 10/10] x86/virt/tdx: Allow SEAMCALL to handle #UD and #GP Kai Huang
2023-07-13  8:07   ` Peter Zijlstra
2023-07-13  9:58     ` Huang, Kai

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=61e70e0cb895663f5d28b260f1aa779fae0b1182.camel@intel.com \
    --to=kai.huang@intel.com \
    --cc=bp@alien8.de \
    --cc=dave.hansen@intel.com \
    --cc=hpa@zytor.com \
    --cc=isaku.yamahata@intel.com \
    --cc=kirill.shutemov@linux.intel.com \
    --cc=kvm@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@redhat.com \
    --cc=nik.borisov@suse.com \
    --cc=pbonzini@redhat.com \
    --cc=peterz@infradead.org \
    --cc=sathyanarayanan.kuppuswamy@linux.intel.com \
    --cc=seanjc@google.com \
    --cc=tglx@linutronix.de \
    --cc=x86@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®