From: "Moger, Babu" <babu.moger@amd.com>
To: Reinette Chatre <reinette.chatre@intel.com>,
corbet@lwn.net, tony.luck@intel.com, Dave.Martin@arm.com,
james.morse@arm.com, tglx@linutronix.de, mingo@redhat.com,
bp@alien8.de, dave.hansen@linux.intel.com
Cc: x86@kernel.org, hpa@zytor.com, akpm@linux-foundation.org,
rostedt@goodmis.org, paulmck@kernel.org, thuth@redhat.com,
ardb@kernel.org, gregkh@linuxfoundation.org, seanjc@google.com,
thomas.lendacky@amd.com, pawan.kumar.gupta@linux.intel.com,
manali.shukla@amd.com, perry.yuan@amd.com, kai.huang@intel.com,
peterz@infradead.org, xiaoyao.li@intel.com,
kan.liang@linux.intel.com, mario.limonciello@amd.com,
xin3.li@intel.com, gautham.shenoy@amd.com, xin@zytor.com,
chang.seok.bae@intel.com, fenghuay@nvidia.com,
peternewman@google.com, maciej.wieczor-retman@intel.com,
eranian@google.com, linux-doc@vger.kernel.org,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH v14 27/32] x86,fs/resctrl: Auto assign/unassign counters on mkdir
Date: Tue, 1 Jul 2025 14:06:54 -0500 [thread overview]
Message-ID: <6485fc52-15cc-4a6f-93cd-72d953cf7858@amd.com> (raw)
In-Reply-To: <c5d040fa-1e27-4edd-a808-0ef9811c2e9a@intel.com>
Hi Reinette,
On 6/25/25 18:25, Reinette Chatre wrote:
> Hi Babu,
>
> On 6/13/25 2:05 PM, Babu Moger wrote:
>> Resctrl provides a user-configurable option mbm_assign_on_mkdir that
>> determines if a counter will automatically be assigned to an RMID, event
>> pair when its associated monitor group is created via mkdir.
>>
>> Enable mbm_assign_on_mkdir by default and automatically assign or unassignq
>> counters when a resctrl group is created or deleted.
>
> This is a bit confusing since I do not think mbm_assign_on_mkdir has *anything*
> to do with unassign of counters. Counters are always (irrespective of mbm_assign_on_mkdir)
> unassigned when a resctrl group is deleted, no?
Yes. That is correct. Changed the text now.
>
> The subject also does not seem accurate since there is no unassign on
> mkdir.
Changed the subject to:
x86,fs/resctrl: Auto assign counters on mkdir and clean up on group removal
>
>>
>> By default, each group requires two counters: one for the MBM total event
>> and one for the MBM local event.
>>
>> If the counters are exhausted, the kernel will log the error message
>> "Unable to allocate counter in domain" in
>> /sys/fs/resctrl/info/last_cmd_status when a new group is created and the
>> counter assignment will fail. However, the creation of a group should not
>> fail due to assignment failures. Users have the flexibility to modify the
>> assignments at a later time.
>>
>> Signed-off-by: Babu Moger <babu.moger@amd.com>
>> ---
>
> ...
>
>> ---
>> arch/x86/kernel/cpu/resctrl/monitor.c | 1 +
>> fs/resctrl/rdtgroup.c | 71 ++++++++++++++++++++++++++-
>> 2 files changed, 70 insertions(+), 2 deletions(-)
>>
>> diff --git a/arch/x86/kernel/cpu/resctrl/monitor.c b/arch/x86/kernel/cpu/resctrl/monitor.c
>> index ee0aa741cf6c..053f516a8e67 100644
>> --- a/arch/x86/kernel/cpu/resctrl/monitor.c
>> +++ b/arch/x86/kernel/cpu/resctrl/monitor.c
>> @@ -429,6 +429,7 @@ int __init rdt_get_mon_l3_config(struct rdt_resource *r)
>> r->mon.mbm_cntr_assignable = true;
>> cpuid_count(0x80000020, 5, &eax, &ebx, &ecx, &edx);
>> r->mon.num_mbm_cntrs = (ebx & GENMASK(15, 0)) + 1;
>> + r->mon.mbm_assign_on_mkdir = true;
>> }
>>
>> r->mon_capable = true;
>> diff --git a/fs/resctrl/rdtgroup.c b/fs/resctrl/rdtgroup.c
>> index bf5fd46bd455..128a9db339f3 100644
>> --- a/fs/resctrl/rdtgroup.c
>> +++ b/fs/resctrl/rdtgroup.c
>> @@ -2945,6 +2945,55 @@ static void schemata_list_destroy(void)
>> }
>> }
>>
>> +/**
>> + * rdtgroup_assign_cntrs() - Assign counters to MBM events. Called when
>> + * a new group is created.
>> + * If "mbm_event" mode is enabled, counters are automatically assigned.
>
> "counters are automatically assigned" -> "counters should be automatically assigned
> if the "mbm_assign_on_mkdir" is set"?
Sure.
>
>> + * Each group can accommodate two counters: one for the total event and
>> + * one for the local event. Assignments may fail due to the limited number
>> + * of counters. However, it is not necessary to fail the group creation
>> + * and thus no failure is returned. Users have the option to modify the
>> + * counter assignments after the group has been created.
>> + */
>> +static void rdtgroup_assign_cntrs(struct rdtgroup *rdtgrp)
>> +{
>> + struct rdt_resource *r = resctrl_arch_get_resource(RDT_RESOURCE_L3);
>> +
>> + if (!r->mon_capable)
>> + return;
>> +
>> + if (resctrl_arch_mbm_cntr_assign_enabled(r) && !r->mon.mbm_assign_on_mkdir)
>> + return;
>
> This check is not clear to me. It looks to me as though counter assignment
> will be attempted if !resctrl_arch_mbm_cntr_assign_enabled(r)? Perhaps
> something like:
> if (!r->mon_capable || !resctrl_arch_mbm_cntr_assign_enabled(r) ||
> !r->mon.mbm_assign_on_mkdir)
> return;
>
Yes. Good catch.
>> +
>> + if (resctrl_is_mon_event_enabled(QOS_L3_MBM_TOTAL_EVENT_ID))
>> + resctrl_assign_cntr_event(r, NULL, rdtgrp,
>> + &mon_event_all[QOS_L3_MBM_TOTAL_EVENT_ID]);
>
> Switching the namespace like this is confusing to me. rdtgroup_assign_cntrs()
> has prefix rdtgroup_ to indicate it operates on a resource group. It is confusing
> when it switches namespace to call resctrl_assign_cntr_event() that actually assigns
> a specific event to a resource group. I think this will be easier to follow if:
> resctrl_assign_cntr_event() -> rdtgroup_assign_cntr_event()
Sure.
>
>> +
>> + if (resctrl_is_mon_event_enabled(QOS_L3_MBM_LOCAL_EVENT_ID))
>> + resctrl_assign_cntr_event(r, NULL, rdtgrp,
>> + &mon_event_all[QOS_L3_MBM_LOCAL_EVENT_ID]);
>> +}
>> +
>> +/*
>> + * rdtgroup_unassign_cntrs() - Unassign the counters associated with MBM events.
>> + * Called when a group is deleted.
>> + */
>> +static void rdtgroup_unassign_cntrs(struct rdtgroup *rdtgrp)
>> +{
>> + struct rdt_resource *r = resctrl_arch_get_resource(RDT_RESOURCE_L3);
>> +
>> + if (!r->mon_capable || !resctrl_arch_mbm_cntr_assign_enabled(r))
>> + return;
>> +
>> + if (resctrl_is_mon_event_enabled(QOS_L3_MBM_TOTAL_EVENT_ID))
>> + resctrl_unassign_cntr_event(r, NULL, rdtgrp,
>> + &mon_event_all[QOS_L3_MBM_TOTAL_EVENT_ID]);
>
> same here, I think this will be easier to follow when namespace is
> consistent:
> resctrl_unassign_cntr_event() -> rdtgroup_unassign_cntr_event()
>
Sure.
>
> Also, the struct rdt_resource parameter should not be needed when
> struct mon_evt is provided and resource can be obtained from mon_evt::rid.
>
>> +
>> + if (resctrl_is_mon_event_enabled(QOS_L3_MBM_LOCAL_EVENT_ID))
>> + resctrl_unassign_cntr_event(r, NULL, rdtgrp,
>> + &mon_event_all[QOS_L3_MBM_LOCAL_EVENT_ID]);
>> +}
>> +
>> static int rdt_get_tree(struct fs_context *fc)
>> {
>> struct rdt_fs_context *ctx = rdt_fc2context(fc);
>
>
> Reinette
>
--
Thanks
Babu Moger
next prev parent reply other threads:[~2025-07-01 19:07 UTC|newest]
Thread overview: 114+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-06-13 21:04 [PATCH v14 00/32] fs,x86/resctrl: Support AMD Assignable Bandwidth Monitoring Counters (ABMC) Babu Moger
2025-06-13 21:04 ` [PATCH v14 01/32] x86,fs/resctrl: Remove unappropriate references to cacheinfo in the resctrl subsystem Babu Moger
2025-06-13 21:04 ` [PATCH v14 02/32] x86,fs/resctrl: Consolidate monitor event descriptions Babu Moger
2025-06-24 21:28 ` Reinette Chatre
2025-06-25 15:57 ` Moger, Babu
2025-06-25 17:55 ` Luck, Tony
2025-06-25 20:12 ` Luck, Tony
2025-06-25 22:31 ` Moger, Babu
2025-06-13 21:04 ` [PATCH v14 03/32] x86,fs/resctrl: Replace architecture event enabled checks Babu Moger
2025-06-13 21:04 ` [PATCH v14 04/32] x86/resctrl: Remove 'rdt_mon_features' global variable Babu Moger
2025-06-13 21:04 ` [PATCH v14 05/32] x86,fs/resctrl: Prepare for more monitor events Babu Moger
2025-06-24 21:30 ` Reinette Chatre
2025-06-13 21:04 ` [PATCH v14 06/32] x86/cpufeatures: Add support for Assignable Bandwidth Monitoring Counters (ABMC) Babu Moger
2025-06-24 21:31 ` Reinette Chatre
2025-06-25 16:28 ` Moger, Babu
2025-06-13 21:04 ` [PATCH v14 07/32] x86/resctrl: Add ABMC feature in the command line options Babu Moger
2025-06-13 21:04 ` [PATCH v14 08/32] x86,fs/resctrl: Consolidate monitoring related data from rdt_resource Babu Moger
2025-06-24 21:32 ` Reinette Chatre
2025-06-25 16:53 ` Moger, Babu
2025-06-13 21:04 ` [PATCH v14 09/32] x86/resctrl: Detect Assignable Bandwidth Monitoring feature details Babu Moger
2025-06-24 21:33 ` Reinette Chatre
2025-06-25 17:58 ` Moger, Babu
2025-06-13 21:04 ` [PATCH v14 10/32] x86/resctrl: Add support to enable/disable AMD ABMC feature Babu Moger
2025-06-24 22:37 ` Reinette Chatre
2025-06-25 19:50 ` Moger, Babu
2025-06-13 21:04 ` [PATCH v14 11/32] fs/resctrl: Introduce the interface to display monitoring modes Babu Moger
2025-06-24 22:47 ` Reinette Chatre
2025-06-25 20:14 ` Moger, Babu
2025-06-13 21:04 ` [PATCH v14 12/32] fs/resctrl: Introduce interface to display number of assignable counter IDs Babu Moger
2025-06-24 23:05 ` Reinette Chatre
2025-06-25 20:33 ` Moger, Babu
2025-06-13 21:04 ` [PATCH v14 13/32] fs/resctrl: Introduce mbm_cntr_cfg to track assignable counters per domain Babu Moger
2025-06-24 23:31 ` Reinette Chatre
2025-06-26 1:31 ` Moger, Babu
2025-06-26 15:05 ` Reinette Chatre
2025-06-26 15:46 ` Moger, Babu
2025-06-13 21:04 ` [PATCH v14 14/32] fs/resctrl: Introduce interface to display number of free MBM counters Babu Moger
2025-06-24 23:39 ` Reinette Chatre
2025-06-26 14:17 ` Moger, Babu
2025-06-24 23:41 ` Reinette Chatre
2025-06-26 14:19 ` Moger, Babu
2025-06-13 21:04 ` [PATCH v14 15/32] x86/resctrl: Add data structures and definitions for ABMC assignment Babu Moger
2025-06-13 21:05 ` [PATCH v14 16/32] x86,fs/resctrl: Introduce event configuration field in struct mon_evt Babu Moger
2025-06-24 23:51 ` Reinette Chatre
2025-06-26 16:47 ` Moger, Babu
2025-06-13 21:05 ` [PATCH v14 17/32] x86/resctrl: Implement resctrl_arch_config_cntr() to assign a counter with ABMC Babu Moger
2025-06-25 3:03 ` Reinette Chatre
2025-06-26 17:41 ` Moger, Babu
2025-06-26 18:02 ` Reinette Chatre
2025-06-26 18:35 ` Moger, Babu
2025-06-26 20:24 ` Reinette Chatre
2025-06-13 21:05 ` [PATCH v14 18/32] fs/resctrl: Add the functionality to assign MBM events Babu Moger
2025-06-25 3:32 ` Reinette Chatre
2025-06-26 19:31 ` Moger, Babu
2025-06-13 21:05 ` [PATCH v14 19/32] fs/resctrl: Add the functionality to unassign " Babu Moger
2025-06-25 3:38 ` Reinette Chatre
2025-06-26 21:12 ` Moger, Babu
2025-06-13 21:05 ` [PATCH v14 20/32] fs/resctrl: Report 'Unassigned' for MBM events in mbm_event mode Babu Moger
2025-06-25 4:14 ` Reinette Chatre
2025-06-27 1:34 ` Moger, Babu
2025-06-13 21:05 ` [PATCH v14 21/32] fs/resctrl: Pass entire struct rdtgroup rather than passing individual members Babu Moger
2025-06-25 4:18 ` Reinette Chatre
2025-06-30 13:57 ` Moger, Babu
2025-06-30 15:44 ` Reinette Chatre
2025-06-30 20:58 ` Moger, Babu
2025-06-30 21:59 ` Reinette Chatre
2025-06-30 22:47 ` Moger, Babu
2025-06-13 21:05 ` [PATCH v14 22/32] x86,fs/resctrl: Add the support for reading ABMC counters Babu Moger
2025-06-13 21:05 ` [PATCH v14 23/32] fs/resctrl: Add definitions for MBM event configuration Babu Moger
2025-06-25 4:32 ` Reinette Chatre
2025-06-30 17:20 ` Moger, Babu
2025-06-30 21:58 ` Reinette Chatre
2025-06-30 22:51 ` Moger, Babu
2025-06-13 21:05 ` [PATCH v14 24/32] fs/resctrl: Add event configuration directory under info/L3_MON/ Babu Moger
2025-06-25 23:23 ` Reinette Chatre
2025-06-30 19:06 ` Moger, Babu
2025-06-13 21:05 ` [PATCH v14 25/32] fs/resctrl: Provide interface to update the event configurations Babu Moger
2025-06-25 23:21 ` Reinette Chatre
2025-07-01 0:43 ` Moger, Babu
2025-07-01 1:33 ` Reinette Chatre
2025-07-01 16:14 ` Moger, Babu
2025-06-13 21:05 ` [PATCH v14 26/32] fs/resctrl: Introduce mbm_assign_on_mkdir to enable assignments on mkdir Babu Moger
2025-06-25 23:24 ` Reinette Chatre
2025-07-01 16:23 ` Moger, Babu
2025-07-01 16:37 ` Reinette Chatre
2025-06-13 21:05 ` [PATCH v14 27/32] x86,fs/resctrl: Auto assign/unassign counters " Babu Moger
2025-06-25 23:25 ` Reinette Chatre
2025-07-01 19:06 ` Moger, Babu [this message]
2025-06-13 21:05 ` [PATCH v14 28/32] fs/resctrl: Introduce mbm_L3_assignments to list assignments in a group Babu Moger
2025-06-25 23:27 ` Reinette Chatre
2025-07-01 19:48 ` Moger, Babu
2025-06-13 21:05 ` [PATCH v14 29/32] fs/resctrl: Introduce the interface to modify " Babu Moger
2025-06-25 23:38 ` Reinette Chatre
2025-07-02 2:18 ` Moger, Babu
2025-07-02 2:56 ` Reinette Chatre
2025-06-13 21:05 ` [PATCH v14 30/32] fs/resctrl: Hide the BMEC related files when mbm_event mode is enabled Babu Moger
2025-06-25 23:39 ` Reinette Chatre
2025-07-02 16:42 ` Moger, Babu
2025-07-02 17:21 ` Reinette Chatre
2025-07-02 19:04 ` Moger, Babu
2025-07-03 16:21 ` Reinette Chatre
2025-07-07 22:35 ` Moger, Babu
2025-07-08 13:27 ` Moger, Babu
2025-07-08 15:21 ` Reinette Chatre
2025-07-08 15:43 ` Moger, Babu
2025-06-13 21:05 ` [PATCH v14 31/32] fs/resctrl: Introduce the interface to switch between monitor modes Babu Moger
2025-06-25 23:40 ` Reinette Chatre
2025-07-02 17:39 ` Moger, Babu
2025-06-13 21:05 ` [PATCH v14 32/32] x86/resctrl: Configure mbm_event mode if supported Babu Moger
2025-06-25 23:40 ` Reinette Chatre
2025-07-02 17:45 ` Moger, Babu
2025-06-13 21:41 ` [PATCH v14 00/32] fs,x86/resctrl: Support AMD Assignable Bandwidth Monitoring Counters (ABMC) Luck, Tony
2025-06-16 14:47 ` Moger, Babu
2025-06-24 21:25 ` Reinette Chatre
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=6485fc52-15cc-4a6f-93cd-72d953cf7858@amd.com \
--to=babu.moger@amd.com \
--cc=Dave.Martin@arm.com \
--cc=akpm@linux-foundation.org \
--cc=ardb@kernel.org \
--cc=bp@alien8.de \
--cc=chang.seok.bae@intel.com \
--cc=corbet@lwn.net \
--cc=dave.hansen@linux.intel.com \
--cc=eranian@google.com \
--cc=fenghuay@nvidia.com \
--cc=gautham.shenoy@amd.com \
--cc=gregkh@linuxfoundation.org \
--cc=hpa@zytor.com \
--cc=james.morse@arm.com \
--cc=kai.huang@intel.com \
--cc=kan.liang@linux.intel.com \
--cc=linux-doc@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=maciej.wieczor-retman@intel.com \
--cc=manali.shukla@amd.com \
--cc=mario.limonciello@amd.com \
--cc=mingo@redhat.com \
--cc=paulmck@kernel.org \
--cc=pawan.kumar.gupta@linux.intel.com \
--cc=perry.yuan@amd.com \
--cc=peternewman@google.com \
--cc=peterz@infradead.org \
--cc=reinette.chatre@intel.com \
--cc=rostedt@goodmis.org \
--cc=seanjc@google.com \
--cc=tglx@linutronix.de \
--cc=thomas.lendacky@amd.com \
--cc=thuth@redhat.com \
--cc=tony.luck@intel.com \
--cc=x86@kernel.org \
--cc=xiaoyao.li@intel.com \
--cc=xin3.li@intel.com \
--cc=xin@zytor.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®