* [PATCH v1] tee: qcomtee: Drop unused assignment of platform_device_id driver data
@ 2026-06-16 14:38 Uwe Kleine-König (The Capable Hub)
2026-06-24 3:39 ` Amirreza Zarrabi
0 siblings, 1 reply; 4+ messages in thread
From: Uwe Kleine-König (The Capable Hub) @ 2026-06-16 14:38 UTC (permalink / raw)
To: Amirreza Zarrabi, Jens Wiklander
Cc: Sumit Garg, linux-arm-msm, op-tee, linux-kernel
The driver explicitly sets the .driver_data member of struct
platform_device_id to zero without relying on that value. Drop this
unused assignment.
While touching this array unify spacing and usage of commas and use
a named initializer for .name for improved readability.
Signed-off-by: Uwe Kleine-König (The Capable Hub) <u.kleine-koenig@baylibre.com>
---
Hello,
while this is a cleanup that can stand on its own, it is also a
preparation for a change to struct platform_device_id that requires that
.driver_data isn't assigned by a list initializer.
Best regards
Uwe
drivers/tee/qcomtee/call.c | 7 ++++++-
1 file changed, 6 insertions(+), 1 deletion(-)
diff --git a/drivers/tee/qcomtee/call.c b/drivers/tee/qcomtee/call.c
index 0efc5646242a..4a597eeaf174 100644
--- a/drivers/tee/qcomtee/call.c
+++ b/drivers/tee/qcomtee/call.c
@@ -798,7 +798,12 @@ static void qcomtee_remove(struct platform_device *pdev)
kfree(qcomtee);
}
-static const struct platform_device_id qcomtee_ids[] = { { "qcomtee", 0 }, {} };
+static const struct platform_device_id qcomtee_ids[] = {
+ {
+ .name = "qcomtee",
+ },
+ { }
+};
MODULE_DEVICE_TABLE(platform, qcomtee_ids);
static struct platform_driver qcomtee_platform_driver = {
base-commit: 8d6dbbbe3ba62de0a63e962ee004afb848c8e3ac
--
2.47.3
^ permalink raw reply [flat|nested] 4+ messages in thread
* Re: [PATCH v1] tee: qcomtee: Drop unused assignment of platform_device_id driver data
2026-06-16 14:38 [PATCH v1] tee: qcomtee: Drop unused assignment of platform_device_id driver data Uwe Kleine-König (The Capable Hub)
@ 2026-06-24 3:39 ` Amirreza Zarrabi
2026-06-29 8:52 ` Jens Wiklander
2026-09-16 9:15 ` Jens Wiklander
0 siblings, 2 replies; 4+ messages in thread
From: Amirreza Zarrabi @ 2026-06-24 3:39 UTC (permalink / raw)
To: Uwe Kleine-König (The Capable Hub), Jens Wiklander
Cc: Sumit Garg, linux-arm-msm, op-tee, linux-kernel
Hi,
On 6/17/2026 12:38 AM, Uwe Kleine-König (The Capable Hub) wrote:
> The driver explicitly sets the .driver_data member of struct
> platform_device_id to zero without relying on that value. Drop this
> unused assignment.
>
> While touching this array unify spacing and usage of commas and use
> a named initializer for .name for improved readability.
>
> Signed-off-by: Uwe Kleine-König (The Capable Hub) <u.kleine-koenig@baylibre.com>
> ---
> Hello,
>
> while this is a cleanup that can stand on its own, it is also a
> preparation for a change to struct platform_device_id that requires that
> .driver_data isn't assigned by a list initializer.
>
> Best regards
> Uwe
>
> drivers/tee/qcomtee/call.c | 7 ++++++-
> 1 file changed, 6 insertions(+), 1 deletion(-)
>
> diff --git a/drivers/tee/qcomtee/call.c b/drivers/tee/qcomtee/call.c
> index 0efc5646242a..4a597eeaf174 100644
> --- a/drivers/tee/qcomtee/call.c
> +++ b/drivers/tee/qcomtee/call.c
> @@ -798,7 +798,12 @@ static void qcomtee_remove(struct platform_device *pdev)
> kfree(qcomtee);
> }
>
> -static const struct platform_device_id qcomtee_ids[] = { { "qcomtee", 0 }, {} };
> +static const struct platform_device_id qcomtee_ids[] = {
> + {
> + .name = "qcomtee",
> + },
> + { }
> +};
> MODULE_DEVICE_TABLE(platform, qcomtee_ids);
>
Looks good to me, thanks.
Reviewed-by: Amirreza Zarrabi <amirreza.zarrabi@oss.qualcomm.com>
> static struct platform_driver qcomtee_platform_driver = {
>
> base-commit: 8d6dbbbe3ba62de0a63e962ee004afb848c8e3ac
^ permalink raw reply [flat|nested] 4+ messages in thread
* Re: [PATCH v1] tee: qcomtee: Drop unused assignment of platform_device_id driver data
2026-06-24 3:39 ` Amirreza Zarrabi
@ 2026-06-29 8:52 ` Jens Wiklander
2026-09-16 9:15 ` Jens Wiklander
1 sibling, 0 replies; 4+ messages in thread
From: Jens Wiklander @ 2026-06-29 8:52 UTC (permalink / raw)
To: Amirreza Zarrabi
Cc: Uwe Kleine-König (The Capable Hub),
Sumit Garg, linux-arm-msm, op-tee, linux-kernel
Hi,
On Wed, Jun 24, 2026 at 5:39 AM Amirreza Zarrabi
<amirreza.zarrabi@oss.qualcomm.com> wrote:
>
> Hi,
>
> On 6/17/2026 12:38 AM, Uwe Kleine-König (The Capable Hub) wrote:
> > The driver explicitly sets the .driver_data member of struct
> > platform_device_id to zero without relying on that value. Drop this
> > unused assignment.
> >
> > While touching this array unify spacing and usage of commas and use
> > a named initializer for .name for improved readability.
> >
> > Signed-off-by: Uwe Kleine-König (The Capable Hub) <u.kleine-koenig@baylibre.com>
> > ---
> > Hello,
> >
> > while this is a cleanup that can stand on its own, it is also a
> > preparation for a change to struct platform_device_id that requires that
> > .driver_data isn't assigned by a list initializer.
> >
> > Best regards
> > Uwe
> >
> > drivers/tee/qcomtee/call.c | 7 ++++++-
> > 1 file changed, 6 insertions(+), 1 deletion(-)
> >
> > diff --git a/drivers/tee/qcomtee/call.c b/drivers/tee/qcomtee/call.c
> > index 0efc5646242a..4a597eeaf174 100644
> > --- a/drivers/tee/qcomtee/call.c
> > +++ b/drivers/tee/qcomtee/call.c
> > @@ -798,7 +798,12 @@ static void qcomtee_remove(struct platform_device *pdev)
> > kfree(qcomtee);
> > }
> >
> > -static const struct platform_device_id qcomtee_ids[] = { { "qcomtee", 0 }, {} };
> > +static const struct platform_device_id qcomtee_ids[] = {
> > + {
> > + .name = "qcomtee",
> > + },
> > + { }
> > +};
> > MODULE_DEVICE_TABLE(platform, qcomtee_ids);
> >
>
> Looks good to me, thanks.
>
> Reviewed-by: Amirreza Zarrabi <amirreza.zarrabi@oss.qualcomm.com>
I'm picking up this.
Cheers,
Jens
^ permalink raw reply [flat|nested] 4+ messages in thread
* Re: [PATCH v1] tee: qcomtee: Drop unused assignment of platform_device_id driver data
2026-06-24 3:39 ` Amirreza Zarrabi
2026-06-29 8:52 ` Jens Wiklander
@ 2026-09-16 9:15 ` Jens Wiklander
1 sibling, 0 replies; 4+ messages in thread
From: Jens Wiklander @ 2026-09-16 9:15 UTC (permalink / raw)
To: Amirreza Zarrabi
Cc: Uwe Kleine-König (The Capable Hub),
Jens Wiklander, Sumit Garg, linux-arm-msm, op-tee, linux-kernel
Hi,
On Fri, Sep 11, 2026 at 9:36 AM Amirreza Zarrabi
<amirreza.zarrabi@oss.qualcomm.com> wrote:
>
> Hi,
>
> On 6/17/2026 12:38 AM, Uwe Kleine-König (The Capable Hub) wrote:
> > The driver explicitly sets the .driver_data member of struct
> > platform_device_id to zero without relying on that value. Drop this
> > unused assignment.
> >
> > While touching this array unify spacing and usage of commas and use
> > a named initializer for .name for improved readability.
> >
> > Signed-off-by: Uwe Kleine-König (The Capable Hub) <u.kleine-koenig@baylibre.com>
> > ---
> > Hello,
> >
> > while this is a cleanup that can stand on its own, it is also a
> > preparation for a change to struct platform_device_id that requires that
> > .driver_data isn't assigned by a list initializer.
> >
> > Best regards
> > Uwe
> >
> > drivers/tee/qcomtee/call.c | 7 ++++++-
> > 1 file changed, 6 insertions(+), 1 deletion(-)
> >
> > diff --git a/drivers/tee/qcomtee/call.c b/drivers/tee/qcomtee/call.c
> > index 0efc5646242a..4a597eeaf174 100644
> > --- a/drivers/tee/qcomtee/call.c
> > +++ b/drivers/tee/qcomtee/call.c
> > @@ -798,7 +798,12 @@ static void qcomtee_remove(struct platform_device *pdev)
> > kfree(qcomtee);
> > }
> >
> > -static const struct platform_device_id qcomtee_ids[] = { { "qcomtee", 0 }, {} };
> > +static const struct platform_device_id qcomtee_ids[] = {
> > + {
> > + .name = "qcomtee",
> > + },
> > + { }
> > +};
> > MODULE_DEVICE_TABLE(platform, qcomtee_ids);
> >
>
> Looks good to me, thanks.
>
> Reviewed-by: Amirreza Zarrabi <amirreza.zarrabi@oss.qualcomm.com>
I'm picking this up.
Thanks,
Jens
^ permalink raw reply [flat|nested] 4+ messages in thread
end of thread, other threads:[~2026-09-16 9:15 UTC | newest]
Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2026-06-16 14:38 [PATCH v1] tee: qcomtee: Drop unused assignment of platform_device_id driver data Uwe Kleine-König (The Capable Hub)
2026-06-24 3:39 ` Amirreza Zarrabi
2026-06-29 8:52 ` Jens Wiklander
2026-09-16 9:15 ` Jens Wiklander
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®