From: "Chen, Yu C" <yu.c.chen@intel.com>
To: "Luck, Tony" <tony.luck@intel.com>
Cc: <reinette.chatre@intel.com>, <x86@kernel.org>,
<linux-kernel@vger.kernel.org>, <tglx@kernel.org>,
<mingo@redhat.com>, <bp@alien8.de>, <dave.hansen@linux.intel.com>,
<hpa@zytor.com>, <Dave.Martin@arm.com>, <james.morse@arm.com>,
<babu.moger@amd.com>, <fenghuay@nvidia.com>
Subject: Re: [RFC PATCH 1/6] x86/resctrl: Parse ACPI ERDT table and map RMDD domains by L3 cache ID
Date: Fri, 29 May 2026 10:16:32 +0800 [thread overview]
Message-ID: <6a91c0bf-466a-4c1d-a3dc-f81653c62832@intel.com> (raw)
In-Reply-To: <ahij0uMU3NQGOwRB@agluck-desk3>
On 5/29/2026 4:21 AM, Luck, Tony wrote:
> On Wed, May 27, 2026 at 05:26:54PM +0800, Chen Yu wrote:
>> +static __init int get_l3_cache_id_from_cacd(struct acpi_erdt_cacd *cacd)
>> +{
>> + int num_ids, cpu, online_cpu = -1, cache_id = -1, tmp;
>> + struct cacheinfo *ci;
>> +
>> + if (cacd->header.length < sizeof(*cacd) + sizeof(cacd->X2APICIDS[0])) {
>> + pr_warn(FW_BUG "Invalid x2apicid CACD table\n");
>> + return -1;
>> + }
>> +
>> + num_ids = (cacd->header.length - sizeof(*cacd)) / sizeof(cacd->X2APICIDS[0]);
>> +
>> + guard(cpus_read_lock)();
>
> This file should #include <linux/cleanup.h> (maybe some other headers
> too) to follow the "include-what-you-use" best practice (which is only
> lightly enforced in the kernel - but saves pain when some refactor
> breaks your code because the implicit chain of includes is changed).
>
Thanks Tony, will fix this. Appreciate the guidance on IWYU.
thanks,
Chenyu
next prev parent reply other threads:[~2026-05-29 2:16 UTC|newest]
Thread overview: 9+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-05-27 9:25 [RFC PATCH 0/6] x86/resctrl: Introduce MMIO-based CMT access for Enhanced RDT Chen Yu
2026-05-27 9:26 ` [RFC PATCH 1/6] x86/resctrl: Parse ACPI ERDT table and map RMDD domains by L3 cache ID Chen Yu
2026-05-28 20:21 ` Luck, Tony
2026-05-29 2:16 ` Chen, Yu C [this message]
2026-05-27 9:27 ` [RFC PATCH 2/6] x86/resctrl: Parse ACPI CMRC table Chen Yu
2026-05-27 9:27 ` [RFC PATCH 3/6] x86/resctrl: Rename prev_msr to prev_mon_val Chen Yu
2026-05-27 9:27 ` [RFC PATCH 4/6] x86/resctrl: Refactor the monitor read function Chen Yu
2026-05-27 9:28 ` [RFC PATCH 5/6] fs/resctrl: Do not invoke smp_processor_id() in preemptible context Chen Yu
2026-05-27 9:28 ` [RFC PATCH 6/6] x86/resctrl: Add support for L3 occupancy monitoring via RMID MMIO read Chen Yu
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=6a91c0bf-466a-4c1d-a3dc-f81653c62832@intel.com \
--to=yu.c.chen@intel.com \
--cc=Dave.Martin@arm.com \
--cc=babu.moger@amd.com \
--cc=bp@alien8.de \
--cc=dave.hansen@linux.intel.com \
--cc=fenghuay@nvidia.com \
--cc=hpa@zytor.com \
--cc=james.morse@arm.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@redhat.com \
--cc=reinette.chatre@intel.com \
--cc=tglx@kernel.org \
--cc=tony.luck@intel.com \
--cc=x86@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®