From: Namhyung Kim <namhyung@kernel.org>
To: Steven Rostedt <rostedt@goodmis.org>
Cc: Arnaldo Carvalho de Melo <acme@ghostprotocols.net>,
Peter Zijlstra <a.p.zijlstra@chello.nl>,
Paul Mackerras <paulus@samba.org>, Ingo Molnar <mingo@kernel.org>,
Namhyung Kim <namhyung.kim@lge.com>,
LKML <linux-kernel@vger.kernel.org>,
Frederic Weisbecker <fweisbec@gmail.com>
Subject: Re: [PATCH 7/9] perf util: Get rid of read_or_die() in trace-event-read.c
Date: Wed, 20 Mar 2013 10:24:32 +0900 [thread overview]
Message-ID: <87a9pyj227.fsf@sejong.aot.lge.com> (raw)
In-Reply-To: <1363704867.5938.28.camel@gandalf.local.home> (Steven Rostedt's message of "Tue, 19 Mar 2013 10:54:27 -0400")
On Tue, 19 Mar 2013 10:54:27 -0400, Steven Rostedt wrote:
> On Tue, 2013-03-19 at 17:53 +0900, Namhyung Kim wrote:
>> From: Namhyung Kim <namhyung.kim@lge.com>
>>
>> Rename it to do_read and original do_read to __do_read, and check
>> their return value.
>>
>> Cc: Steven Rostedt <rostedt@goodmis.org>
>> Cc: Frederic Weisbecker <fweisbec@gmail.com>
>> Signed-off-by: Namhyung Kim <namhyung@kernel.org>
>> ---
>> tools/perf/util/trace-event-read.c | 80 +++++++++++++++++++++++++++-----------
>> 1 file changed, 57 insertions(+), 23 deletions(-)
>>
>> diff --git a/tools/perf/util/trace-event-read.c b/tools/perf/util/trace-event-read.c
>> index 62dd2168f4f5..87f0ccd54cdc 100644
>> --- a/tools/perf/util/trace-event-read.c
>> +++ b/tools/perf/util/trace-event-read.c
>> @@ -48,7 +48,7 @@ static int long_size;
>> static ssize_t calc_data_size;
>> static bool repipe;
>>
>> -static int do_read(int fd, void *buf, int size)
>> +static int __do_read(int fd, void *buf, int size)
>> {
>> int rsize = size;
>>
>> @@ -61,8 +61,10 @@ static int do_read(int fd, void *buf, int size)
>> if (repipe) {
>> int retw = write(STDOUT_FILENO, buf, ret);
>>
>> - if (retw <= 0 || retw != ret)
>> - die("repiping input file");
>> + if (retw <= 0 || retw != ret) {
>> + pr_debug("repiping input file");
>
> Again, why debug and not err?
Well, there's a pr_err() at the caller of top-level trace_report() in
case of error. So if we use pr_err() there'll be multiple error message
for one failure and I don't think it's so helpful to normal users. If
one really wants to know what happens inside, she will set -v to see
this low-level debug message.
Does that make sense?
>
>> + return -1;
>> + }
>> }
>>
>> size -= ret;
>> @@ -72,14 +74,16 @@ static int do_read(int fd, void *buf, int size)
>> return rsize;
>> }
>>
>> -static int read_or_die(void *data, int size)
>> +static int do_read(void *data, int size)
>> {
>> int r;
>>
>> - r = do_read(input_fd, data, size);
>> - if (r <= 0)
>> - die("reading input file (size expected=%d received=%d)",
>> - size, r);
>> + r = __do_read(input_fd, data, size);
>> + if (r <= 0) {
>> + pr_debug("reading input file (size expected=%d received=%d)",
>> + size, r);
>> + return -1;
>> + }
>>
>> if (calc_data_size)
>> calc_data_size += r;
>> @@ -95,7 +99,7 @@ static void skip(int size)
>>
>> while (size) {
>> r = size > BUFSIZ ? BUFSIZ : size;
>> - read_or_die(buf, r);
>> + do_read(buf, r);
>
> Shouldn't this check the result of do_read()?
I was not so sure about this, but I skipped the check since all it does
is to "skip" and comment said "If it fails, the next read will report
it". :-)
Thanks,
Namhyung
>
>> size -= r;
>> };
>> }
>
> -- Steve
next prev parent reply other threads:[~2013-03-20 1:24 UTC|newest]
Thread overview: 33+ messages / expand[flat|nested] mbox.gz Atom feed top
2013-03-19 8:53 [PATCHSET 0/9] perf util: Cleanup die() and its friends Namhyung Kim
2013-03-19 8:53 ` [PATCH 1/9] perf util: Let get_tracing_file() can return NULL Namhyung Kim
2013-03-19 13:54 ` Steven Rostedt
2013-03-20 0:53 ` Namhyung Kim
2013-03-19 8:53 ` [PATCH 2/9] perf util: Get rid of malloc_or_die() in trace-event-info.c Namhyung Kim
2013-03-19 8:53 ` [PATCH 3/9] perf util: Get rid of write_or_die() from trace-event-info.c Namhyung Kim
2013-03-19 14:35 ` Steven Rostedt
2013-03-19 14:49 ` Peter Zijlstra
2013-03-19 14:59 ` Steven Rostedt
2013-03-19 15:04 ` Peter Zijlstra
2013-03-20 0:57 ` Namhyung Kim
2013-03-19 8:53 ` [PATCH 4/9] perf util: Get rid of die() calls " Namhyung Kim
2013-03-19 8:53 ` [PATCH 5/9] perf util: Handle failure case in trace_report() Namhyung Kim
2013-03-19 14:47 ` Steven Rostedt
2013-03-20 1:12 ` Namhyung Kim
2013-03-20 1:54 ` Steven Rostedt
2013-03-19 8:53 ` [PATCH 6/9] perf util: Get rid of malloc_or_die() in trace-event-read.c Namhyung Kim
2013-03-19 14:50 ` Steven Rostedt
2013-03-20 1:14 ` Namhyung Kim
2013-03-20 1:55 ` Steven Rostedt
2013-03-20 3:00 ` Namhyung Kim
2013-03-20 3:13 ` Steven Rostedt
2013-03-20 13:04 ` Arnaldo Carvalho de Melo
2013-03-19 8:53 ` [PATCH 7/9] perf util: Get rid of read_or_die() " Namhyung Kim
2013-03-19 14:54 ` Steven Rostedt
2013-03-20 1:24 ` Namhyung Kim [this message]
2013-03-20 1:59 ` Steven Rostedt
2013-03-19 8:53 ` [PATCH 8/9] perf util: Get rid of die() calls in trace-data-read.c Namhyung Kim
2013-03-19 14:55 ` Steven Rostedt
2013-03-20 1:25 ` Namhyung Kim
2013-03-20 13:27 ` Arnaldo Carvalho de Melo
2013-03-19 8:53 ` [PATCH 9/9] perf util: Cleanup calc_data_size logic Namhyung Kim
2013-03-21 7:18 [PATCHSET 0/9] perf util: Cleanup die() and its friends (v2) Namhyung Kim
2013-03-21 7:18 ` [PATCH 7/9] perf util: Get rid of read_or_die() in trace-event-read.c Namhyung Kim
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=87a9pyj227.fsf@sejong.aot.lge.com \
--to=namhyung@kernel.org \
--cc=a.p.zijlstra@chello.nl \
--cc=acme@ghostprotocols.net \
--cc=fweisbec@gmail.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@kernel.org \
--cc=namhyung.kim@lge.com \
--cc=paulus@samba.org \
--cc=rostedt@goodmis.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome