mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH] potential parse error, drivers/serial/dz.h
@ 2007-07-16 15:02 Yoann Padioleau
  2007-07-16 22:04 ` Andrew Morton
  0 siblings, 1 reply; 3+ messages in thread
From: Yoann Padioleau @ 2007-07-16 15:02 UTC (permalink / raw)
  To: linux-janitors; +Cc: akpm, linux-kernel


potential parse error in declaration under a #ifdef.

Signed-off-by: Yoann Padioleau <padator@wanadoo.fr> 


diff --git a/drivers/serial/dz.h b/drivers/serial/dz.h
index 9674d4e..9141c37 100644
--- a/drivers/serial/dz.h
+++ b/drivers/serial/dz.h
@@ -125,8 +125,8 @@ #define DZ_XMIT_SIZE   4096             
 #define DZ_WAKEUP_CHARS   DZ_XMIT_SIZE/4
 
 #ifdef MODULE
-int init_module (void)
-void cleanup_module (void)
+int init_module (void);
+void cleanup_module (void);
 #endif
 
 #endif /* DZ_SERIAL_H */


^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: [PATCH] potential parse error, drivers/serial/dz.h
  2007-07-16 15:02 [PATCH] potential parse error, drivers/serial/dz.h Yoann Padioleau
@ 2007-07-16 22:04 ` Andrew Morton
  2007-07-16 22:14   ` Robert P. J. Day
  0 siblings, 1 reply; 3+ messages in thread
From: Andrew Morton @ 2007-07-16 22:04 UTC (permalink / raw)
  To: Yoann Padioleau; +Cc: linux-janitors, linux-kernel

On Mon, 16 Jul 2007 17:02:13 +0200
Yoann Padioleau <padator@wanadoo.fr> wrote:

> 
> potential parse error in declaration under a #ifdef.

A certain parse error, I'd say.  How come nobody is reporting it?
 
> Signed-off-by: Yoann Padioleau <padator@wanadoo.fr> 
> 
> 
> diff --git a/drivers/serial/dz.h b/drivers/serial/dz.h
> index 9674d4e..9141c37 100644
> --- a/drivers/serial/dz.h
> +++ b/drivers/serial/dz.h
> @@ -125,8 +125,8 @@ #define DZ_XMIT_SIZE   4096             
>  #define DZ_WAKEUP_CHARS   DZ_XMIT_SIZE/4
>  
>  #ifdef MODULE
> -int init_module (void)
> -void cleanup_module (void)
> +int init_module (void);
> +void cleanup_module (void);
>  #endif
>  
>  #endif /* DZ_SERIAL_H */

I don't think these symbols are actually implemented in anything which
uses this header.  If they _do_ exist then they are awfully named and
should be renamed ASAP.  Or they should be made static.

However I suspect they just don't exist, and this stuff should be simply
deleted.

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: [PATCH] potential parse error, drivers/serial/dz.h
  2007-07-16 22:04 ` Andrew Morton
@ 2007-07-16 22:14   ` Robert P. J. Day
  0 siblings, 0 replies; 3+ messages in thread
From: Robert P. J. Day @ 2007-07-16 22:14 UTC (permalink / raw)
  To: Andrew Morton; +Cc: Yoann Padioleau, linux-janitors, linux-kernel

On Mon, 16 Jul 2007, Andrew Morton wrote:

> On Mon, 16 Jul 2007 17:02:13 +0200
> Yoann Padioleau <padator@wanadoo.fr> wrote:
>
> >
> > potential parse error in declaration under a #ifdef.
>
> A certain parse error, I'd say.  How come nobody is reporting it?
>
> > Signed-off-by: Yoann Padioleau <padator@wanadoo.fr>
> >
> >
> > diff --git a/drivers/serial/dz.h b/drivers/serial/dz.h
> > index 9674d4e..9141c37 100644
> > --- a/drivers/serial/dz.h
> > +++ b/drivers/serial/dz.h
> > @@ -125,8 +125,8 @@ #define DZ_XMIT_SIZE   4096
> >  #define DZ_WAKEUP_CHARS   DZ_XMIT_SIZE/4
> >
> >  #ifdef MODULE
> > -int init_module (void)
> > -void cleanup_module (void)
> > +int init_module (void);
> > +void cleanup_module (void);
> >  #endif
> >
> >  #endif /* DZ_SERIAL_H */
>
> I don't think these symbols are actually implemented in anything
> which uses this header.  If they _do_ exist then they are awfully
> named and should be renamed ASAP.  Or they should be made static.
>
> However I suspect they just don't exist, and this stuff should be
> simply deleted.

that header file is included only by drivers/serial/dz.c, whose
Kconfig controlling setting is:

config SERIAL_DZ
        bool "DECstation DZ serial driver"
	...

so, since it's "bool," there's no way "#ifdef MODULE" can ever be
true, yes?

rday
-- 
========================================================================
Robert P. J. Day
Linux Consulting, Training and Annoying Kernel Pedantry
Waterloo, Ontario, CANADA

http://fsdev.net/wiki/index.php?title=Main_Page
========================================================================

^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2007-07-16 22:17 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2007-07-16 15:02 [PATCH] potential parse error, drivers/serial/dz.h Yoann Padioleau
2007-07-16 22:04 ` Andrew Morton
2007-07-16 22:14   ` Robert P. J. Day

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®