mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Geert Uytterhoeven <geert@linux-m68k.org>
To: Maxime Ripard <mripard@kernel.org>
Cc: Javier Martinez Canillas <javierm@redhat.com>,
	Thomas Zimmermann <tzimmermann@suse.de>,
	linux-kernel@vger.kernel.org, dri-devel@lists.freedesktop.org
Subject: Re: [PATCH] drm/ssd130x: Drop _helper prefix from struct drm_*_helper_funcs callbacks
Date: Thu, 21 Sep 2023 09:57:22 +0200	[thread overview]
Message-ID: <CAMuHMdUGVgj6V+N865QZaAusqD7O2f1askE544Z4MF0h4zBERg@mail.gmail.com> (raw)
In-Reply-To: <552hpgr7qzbjxuyei3n5m7rsn7ekwbdgzv25oe5vy6qb35gf23@q4etussk5jwl>

Hi Maxime,

On Thu, Sep 21, 2023 at 9:44 AM Maxime Ripard <mripard@kernel.org> wrote:
> On Mon, Sep 18, 2023 at 09:19:07AM +0200, Javier Martinez Canillas wrote:
> > Thomas Zimmermann <tzimmermann@suse.de> writes:
> > > Am 14.09.23 um 21:51 schrieb Javier Martinez Canillas:
> > >> The driver uses a naming convention where functions for struct drm_*_funcs
> > >> callbacks are named ssd130x_$object_$operation, while the callbacks for
> > >> struct drm_*_helper_funcs are named ssd130x_$object_helper_$operation.
> > >>
> > >> The idea is that this helper_ prefix in the function names denote that are
> > >> for struct drm_*_helper_funcs callbacks. This convention was copied from
> > >> other drivers, when ssd130x was written but Maxime pointed out that is the
> > >> exception rather than the norm.
> > >
> > > I guess you found this in my code. I want to point out that I use the
> > > _helper infix to signal that these are callback for
> > > drm_primary_plane_helper_funcs and *not* drm_primary_plane_funcs. The
> > > naming is intentional.
> >
> > Yes, that's what tried to say in the commit message and indeed I got the
> > convention from drivers in drivers/gpu/drm/tiny. In fact I believe these
> > function names are since first iteration of the driver, when was meant to
> > be a tiny driver.
> >
> > According to Maxime it's the exception rather than the rule and suggested
> > to change it, I don't really have a strong opinion on either naming TBH.
>
> Maybe that's just me, but the helper in the name indeed throws me off. In my
> mind, it's supposed to be used only for helpers, not functions implementing the
> helpers hooks.

With several callbacks using the same (field) name, it is very helpful
to name the actual implementation by combining the struct type name
and the field name.  Anything else confuses the casual reader.
Perhaps the real question is whether the structures should have "helper"
in their name in the first place?

Just my 2€c as a DRM novice...

Gr{oetje,eeting}s,

                        Geert

-- 
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@linux-m68k.org

In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
                                -- Linus Torvalds

  reply	other threads:[~2023-09-21 17:52 UTC|newest]

Thread overview: 17+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2023-09-14 19:51 Javier Martinez Canillas
2023-09-18  6:51 ` Thomas Zimmermann
2023-09-18  7:19   ` Javier Martinez Canillas
2023-09-21  7:44     ` Maxime Ripard
2023-09-21  7:57       ` Geert Uytterhoeven [this message]
2023-09-21  8:12         ` Maxime Ripard
2023-09-21  8:25           ` Javier Martinez Canillas
2023-09-21  8:46           ` Geert Uytterhoeven
2023-09-21  8:51             ` Maxime Ripard
2023-09-21  9:07               ` Geert Uytterhoeven
2023-09-21  8:55             ` Thomas Zimmermann
2023-09-21  8:23         ` Javier Martinez Canillas
2023-09-21  8:44           ` Thomas Zimmermann
2023-09-21  8:52       ` Thomas Zimmermann
2023-09-21 13:22         ` Maxime Ripard
2023-09-21 14:19 ` Maxime Ripard
2023-09-22  9:50   ` Javier Martinez Canillas

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=CAMuHMdUGVgj6V+N865QZaAusqD7O2f1askE544Z4MF0h4zBERg@mail.gmail.com \
    --to=geert@linux-m68k.org \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=javierm@redhat.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mripard@kernel.org \
    --cc=tzimmermann@suse.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®