mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Guennadi Liakhovetski <g.liakhovetski@gmx.de>
To: David Miller <davem@davemloft.net>
Cc: florian@openwrt.org, peter@holik.at, linux-kernel@vger.kernel.org
Subject: Re: [PATCH] usb driver for intellon based PLC like devolo dlan duo
Date: Sun, 19 Apr 2009 10:32:24 +0200 (CEST)	[thread overview]
Message-ID: <Pine.LNX.4.64.0904191025060.4369@axis700.grange> (raw)
In-Reply-To: <20090418.211503.13481677.davem@davemloft.net>

On Sat, 18 Apr 2009, David Miller wrote:

> From: Guennadi Liakhovetski <g.liakhovetski@gmx.de>
> Date: Sat, 18 Apr 2009 21:54:11 +0200 (CEST)
> 
> > If you are working with that file and see a call to reg_write() you
> > know where to look for it.
> 
> I would never use such a generic name for a driver local routine.
> 
> For example, in the tg3 driver we use "tr32()" and "tw32()" so that
> at least some inkling of the driver name, even if it is just one
> character, prefixes the name.
> 
> This extends to other driver's I've written.  The niu driver thus
> uses "tr64()" and "nw64()".

Ok, we currently have drivers for mt9m001, mt9m111, mt9t031, and mt9v022. 
Which letter would you take for them?:-) You'd have to take at least two 
characters like "m0", "m1", "t0", and "v0" but that wouldn't be very 
intuitive IMHO either. Take four characters like m001r16() and it looks 
pretty bad compared to all routines being called mt9m001_*.

> This is just common sense as far as I'm concerned.  It is just
> as straight forward as not using variable names like 'foo'.

I'd say that's subjective (not the latter, but the former):-)

Thanks
Guennadi
---
Guennadi Liakhovetski, Ph.D.
Freelance Open-Source Software Developer
http://www.open-technology.de/

  parent reply	other threads:[~2009-04-19  8:32 UTC|newest]

Thread overview: 17+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2009-04-17 14:10 Peter Holik
2009-04-17 14:32 ` Florian Fainelli
2009-04-17 19:07   ` Guennadi Liakhovetski
2009-04-18  8:55     ` David Miller
2009-04-18 19:54       ` Guennadi Liakhovetski
2009-04-19  4:15         ` David Miller
2009-04-19  4:24           ` David Miller
2009-04-19  8:32           ` Guennadi Liakhovetski [this message]
2009-04-19  8:35             ` David Miller
2009-04-18  6:48   ` Peter Holik
2009-04-18 10:22     ` Florian Fainelli
2009-04-18 13:42       ` Jon Smirl
2009-04-17 14:41 ` Oliver Neukum
2009-04-18  7:16   ` Peter Holik
2009-04-18  7:38     ` Oliver Neukum
2009-04-18  8:41       ` Peter Holik
2009-04-18  8:49         ` Oliver Neukum

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=Pine.LNX.4.64.0904191025060.4369@axis700.grange \
    --to=g.liakhovetski@gmx.de \
    --cc=davem@davemloft.net \
    --cc=florian@openwrt.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=peter@holik.at \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®