* [PATCH 3/5] drivers/scsi: Use DIV_ROUND_CLOSEST
@ 2009-08-01 19:49 Julia Lawall
2009-08-02 20:44 ` Guennadi Liakhovetski
0 siblings, 1 reply; 4+ messages in thread
From: Julia Lawall @ 2009-08-01 19:49 UTC (permalink / raw)
To: garloff, g.liakhovetski, linux-kernel, kernel-janitors
From: Julia Lawall <julia@diku.dk>
The kernel.h macro DIV_ROUND_CLOSEST performs the computation (x + d/2)/d
but is perhaps more readable.
The semantic patch that makes this change is as follows:
(http://www.emn.fr/x-info/coccinelle/)
// <smpl>
@haskernel@
@@
#include <linux/kernel.h>
@depends on haskernel@
expression x,__divisor;
@@
- (((x) + ((__divisor) / 2)) / (__divisor))
+ DIV_ROUND_CLOSEST(x,__divisor)
// </smpl>
Signed-off-by: Julia Lawall <julia@diku.dk>
---
drivers/scsi/tmscsim.c | 3 ++-
1 files changed, 2 insertions(+), 1 deletions(-)
Diff --git a/drivers/scsi/tmscsim.c b/drivers/scsi/tmscsim.c
index 9a42734..7322f30 100644
--- a/drivers/scsi/tmscsim.c
+++ b/drivers/scsi/tmscsim.c
@@ -1125,7 +1125,8 @@ dc390_MsgIn_set_sync (struct dc390_acb* pACB, struct dc390_srb* pSRB)
{
if (! (bval & FAST_SCSI)) wval1++;
printk (KERN_INFO "DC390: Target %i: Sync transfer %i.%1i MHz, Offset %i\n", pDCB->TargetID,
- 40/wval1, ((40%wval1)*10+wval1/2)/wval1, pDCB->SyncOffset & 0x0f);
+ 40/wval1, DIV_ROUND_CLOSEST((40 % wval1) * 10, wval1),
+ pDCB->SyncOffset & 0x0f);
}
dc390_reprog (pACB, pDCB);
^ permalink raw reply [flat|nested] 4+ messages in thread
* Re: [PATCH 3/5] drivers/scsi: Use DIV_ROUND_CLOSEST
2009-08-01 19:49 [PATCH 3/5] drivers/scsi: Use DIV_ROUND_CLOSEST Julia Lawall
@ 2009-08-02 20:44 ` Guennadi Liakhovetski
2009-08-03 9:21 ` Julia Lawall
2009-08-03 9:22 ` Julia Lawall
0 siblings, 2 replies; 4+ messages in thread
From: Guennadi Liakhovetski @ 2009-08-02 20:44 UTC (permalink / raw)
To: Julia Lawall; +Cc: Kurt Garloff, linux-kernel, kernel-janitors
On Sat, 1 Aug 2009, Julia Lawall wrote:
> From: Julia Lawall <julia@diku.dk>
>
> The kernel.h macro DIV_ROUND_CLOSEST performs the computation (x + d/2)/d
> but is perhaps more readable.
>
> The semantic patch that makes this change is as follows:
> (http://www.emn.fr/x-info/coccinelle/)
>
> // <smpl>
> @haskernel@
> @@
>
> #include <linux/kernel.h>
>
> @depends on haskernel@
> expression x,__divisor;
> @@
>
> - (((x) + ((__divisor) / 2)) / (__divisor))
> + DIV_ROUND_CLOSEST(x,__divisor)
> // </smpl>
>
> Signed-off-by: Julia Lawall <julia@diku.dk>
>
> ---
> drivers/scsi/tmscsim.c | 3 ++-
> 1 files changed, 2 insertions(+), 1 deletions(-)
>
> Diff --git a/drivers/scsi/tmscsim.c b/drivers/scsi/tmscsim.c
> index 9a42734..7322f30 100644
> --- a/drivers/scsi/tmscsim.c
> +++ b/drivers/scsi/tmscsim.c
> @@ -1125,7 +1125,8 @@ dc390_MsgIn_set_sync (struct dc390_acb* pACB, struct dc390_srb* pSRB)
> {
> if (! (bval & FAST_SCSI)) wval1++;
> printk (KERN_INFO "DC390: Target %i: Sync transfer %i.%1i MHz, Offset %i\n", pDCB->TargetID,
> - 40/wval1, ((40%wval1)*10+wval1/2)/wval1, pDCB->SyncOffset & 0x0f);
> + 40/wval1, DIV_ROUND_CLOSEST((40 % wval1) * 10, wval1),
> + pDCB->SyncOffset & 0x0f);
> }
>
> dc390_reprog (pACB, pDCB);
With all my respect to these scripted clean-up efforts, I am not sure this
really improves anything. I.e., I am not sure, that
z = DIV_ROUND_CLOSEST(x, y);
is better readable than
z = (x + y / 2) / y;
Besides, I do realise, that tmscsim.c indentation is dreadful (legacy
code...) but this patch changes it further from
printk("...",
x,
y);
to
printk("...",
x,
y);
which doesn't seem like an improvement to me either. That said, this does
compile, and I don't see why this shouldn't work, so, if we really want
this change here's the
Acked-by: Guennadi Liakhovetski <g.liakhovetski@gmx.de>
Thanks
Guennadi
---
Guennadi Liakhovetski, Ph.D.
Freelance Open-Source Software Developer
http://www.open-technology.de/
^ permalink raw reply [flat|nested] 4+ messages in thread
* Re: [PATCH 3/5] drivers/scsi: Use DIV_ROUND_CLOSEST
2009-08-02 20:44 ` Guennadi Liakhovetski
@ 2009-08-03 9:21 ` Julia Lawall
2009-08-03 9:22 ` Julia Lawall
1 sibling, 0 replies; 4+ messages in thread
From: Julia Lawall @ 2009-08-03 9:21 UTC (permalink / raw)
To: Guennadi Liakhovetski; +Cc: Kurt Garloff, linux-kernel, kernel-janitors
On Sun, 2 Aug 2009, Guennadi Liakhovetski wrote:
> On Sat, 1 Aug 2009, Julia Lawall wrote:
>
> > From: Julia Lawall <julia@diku.dk>
> >
> > The kernel.h macro DIV_ROUND_CLOSEST performs the computation (x + d/2)/d
> > but is perhaps more readable.
> >
> > The semantic patch that makes this change is as follows:
> > (http://www.emn.fr/x-info/coccinelle/)
> >
> > // <smpl>
> > @haskernel@
> > @@
> >
> > #include <linux/kernel.h>
> >
> > @depends on haskernel@
> > expression x,__divisor;
> > @@
> >
> > - (((x) + ((__divisor) / 2)) / (__divisor))
> > + DIV_ROUND_CLOSEST(x,__divisor)
> > // </smpl>
> >
> > Signed-off-by: Julia Lawall <julia@diku.dk>
> >
> > ---
> > drivers/scsi/tmscsim.c | 3 ++-
> > 1 files changed, 2 insertions(+), 1 deletions(-)
> >
> > Diff --git a/drivers/scsi/tmscsim.c b/drivers/scsi/tmscsim.c
> > index 9a42734..7322f30 100644
> > --- a/drivers/scsi/tmscsim.c
> > +++ b/drivers/scsi/tmscsim.c
> > @@ -1125,7 +1125,8 @@ dc390_MsgIn_set_sync (struct dc390_acb* pACB, struct dc390_srb* pSRB)
> > {
> > if (! (bval & FAST_SCSI)) wval1++;
> > printk (KERN_INFO "DC390: Target %i: Sync transfer %i.%1i MHz, Offset %i\n", pDCB->TargetID,
> > - 40/wval1, ((40%wval1)*10+wval1/2)/wval1, pDCB->SyncOffset & 0x0f);
> > + 40/wval1, DIV_ROUND_CLOSEST((40 % wval1) * 10, wval1),
> > + pDCB->SyncOffset & 0x0f);
> > }
> >
> > dc390_reprog (pACB, pDCB);
>
> With all my respect to these scripted clean-up efforts, I am not sure this
> really improves anything. I.e., I am not sure, that
>
> z = DIV_ROUND_CLOSEST(x, y);
>
> is better readable than
>
> z = (x + y / 2) / y;
>
> Besides, I do realise, that tmscsim.c indentation is dreadful (legacy
> code...) but this patch changes it further from
>
> printk("...",
> x,
> y);
>
> to
>
> printk("...",
> x,
> y);
>
> which doesn't seem like an improvement to me either. That said, this does
> compile, and I don't see why this shouldn't work, so, if we really want
> this change here's the
I will adjust the spacing in the argument to printk.
julia
^ permalink raw reply [flat|nested] 4+ messages in thread
* Re: [PATCH 3/5] drivers/scsi: Use DIV_ROUND_CLOSEST
2009-08-02 20:44 ` Guennadi Liakhovetski
2009-08-03 9:21 ` Julia Lawall
@ 2009-08-03 9:22 ` Julia Lawall
1 sibling, 0 replies; 4+ messages in thread
From: Julia Lawall @ 2009-08-03 9:22 UTC (permalink / raw)
To: Guennadi Liakhovetski; +Cc: Kurt Garloff, linux-kernel, kernel-janitors
From: Julia Lawall <julia@diku.dk>
The kernel.h macro DIV_ROUND_CLOSEST performs the computation (x + d/2)/d
but is perhaps more readable.
The semantic patch that makes this change is as follows:
(http://www.emn.fr/x-info/coccinelle/)
// <smpl>
@haskernel@
@@
#include <linux/kernel.h>
@depends on haskernel@
expression x,__divisor;
@@
- (((x) + ((__divisor) / 2)) / (__divisor))
+ DIV_ROUND_CLOSEST(x,__divisor)
// </smpl>
Signed-off-by: Julia Lawall <julia@diku.dk>
---
drivers/scsi/tmscsim.c | 3 ++-
1 files changed, 2 insertions(+), 1 deletions(-)
diff --git a/drivers/scsi/tmscsim.c b/drivers/scsi/tmscsim.c
index 9a42734..e580db5 100644
--- a/drivers/scsi/tmscsim.c
+++ b/drivers/scsi/tmscsim.c
@@ -1125,7 +1125,8 @@ dc390_MsgIn_set_sync (struct dc390_acb* pACB, struct dc390_srb* pSRB)
{
if (! (bval & FAST_SCSI)) wval1++;
printk (KERN_INFO "DC390: Target %i: Sync transfer %i.%1i MHz, Offset %i\n", pDCB->TargetID,
- 40/wval1, ((40%wval1)*10+wval1/2)/wval1, pDCB->SyncOffset & 0x0f);
+ 40/wval1, DIV_ROUND_CLOSEST((40%wval1)*10, wval1),
+ pDCB->SyncOffset & 0x0f);
}
dc390_reprog (pACB, pDCB);
^ permalink raw reply [flat|nested] 4+ messages in thread
end of thread, other threads:[~2009-08-03 9:22 UTC | newest]
Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2009-08-01 19:49 [PATCH 3/5] drivers/scsi: Use DIV_ROUND_CLOSEST Julia Lawall
2009-08-02 20:44 ` Guennadi Liakhovetski
2009-08-03 9:21 ` Julia Lawall
2009-08-03 9:22 ` Julia Lawall
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®